none
"setup is preparing your computer for first use" hangs during Windows 7 deployment

    Question

  • Hi Everyone

    I'm using SCCM 2007 R3 to deploy windows 7

    I'm able to run a bare-metal installation on all the models except one - lenovo 7440 desktop.

    during the deployment the computer hangs after the last restart on the known screen setup is preparing your computer for first use 

    the last tasks in the task sequences are installing hotfix KB977384 and then restart

    I tried installing with the inject driver task enable and disable and got stuck at the same step

    I also get it with 2 different task sequences. one win7 x32 and one win7 x64.

    tried to look at the log smsts.log but couldn't see anything suspicious

    the only thing I can do is restart but then the computers logs on without SCCM client!

    of course it happens on every lenovo 7440...

    has anyone else found a solution for this specific problem?

    thanks

    Monday, June 13, 2011 7:54 PM

All replies

  • Hi, it's better to install the hotfix during the Setup Windows and ConfigMgr step indeed of installing it at last task. This because during installation of this hotfix, the ConfigMgr and WMI service will be stopped and contact will be lost to finalize the task sequence. Have a look at this:

    Description of the prerequisite hotfix for System Center Configuration Manager 2007 R3: http://support.microsoft.com/kb/977384

    To install the KB977384 hotfix during a ConfigMgr 2007 OSD task sequence, use the PATCH= option that is described in the following Microsoft Knowledge Base article:

    907423 (http://support.microsoft.com/kb/907423/ ) How to include an update in the initial installation of Systems Management Server 2003 Advanced Client

    To install the KB977384 hotfix during a ConfigMgr 2007 OSD task sequence, follow these steps:

    1. Apply the hotfix on the site server.
    2. When the hotfix has been applied on the site server, the ConfigMgr 2007 client installation files will be updated to include the KB977384 hotfix in the directory \i386\hotfix\KB977384\ of the ConfigMgr 2007 client installation files. Because the ConfigMgr 2007 client installation files have been updated, make sure to update the distribution points where the ConfigMgr 2007 client installation package resides.
    3. Right-click the task sequence that you need to change, and then click Edit.
    4. Click Setup windows and ConfigMgr.
    5. In the Installation properties box, type the following:
      PATCH="%_SMSTSMDataPath%\OSD\<var><Package_ID></var>\i386\hotfix\KB977384\SCCM2007AC-SP2-KB977384-x86-enu.msp"

    My ConfigMgr blog: http://henkhoogendoorn.blogspot.com Follow me on Twitter: @henkhoogendoorn
    Monday, June 13, 2011 9:28 PM
  • Hi Tamirlevy,

    1- You said that the installation hangs when installing the KB977384. This is a QFE KB needed for SCCM R3 Power Management. Can you try to remove it from the installation TS ?

    2- Can you confirm that the installation hangs for all Lenovo 7440 computers or just for one ?


    Regards, Samir Farhat Infrastructure Consultant
    Monday, June 13, 2011 9:29 PM
  • Hi,

    You can't use "Install Software" task in task sequence to install hotfix, this will cause the ConfigMgr 2007 client service to stop which will cause the task sequence to fail.

    So as Henk said, you should apply this hotfix in the "Step Windows and ConfigMgr" task.

    Thanks

    Wednesday, June 15, 2011 7:33 AM
  • Hi everyone

    thanks for your replies

    as I mentioned before - I already tried to disable the hotfix installation step and got to the same position.

    and I can point out that with all the other models I have no issues during the installation. not with the hotfix and not with the deployment itself

    I'll try to install the hotfix in the same step with the configmgr as hank offered with the installation properties.
    I remember that the first time I tried it didn't work but I'll give it another shot

     

    thanks anyone

    Saturday, June 25, 2011 12:37 PM