none
SCCM 2007 SP2 Install Not Completing Successfully - Install Component Manager & Install Management Point = Unknown

    Question

  • Windows Server 2008 Standard SP2 64-bit running on VMware ESXi, SQL Server 2008 SP2 64-bit

    When trying to install System Center Configuration Manager 2007 SP2 on the above platform I consistently get the same issue. The server is being built using a template which was created by a previous admin and contains regeistry entries which increase security - I suspect that it's one of these entries or something else in the image causing this problem. I have installed from MS media as a test and do not get this issue.

    The problem I am experiencing is the installation is timing out and I get the following in the installer results summary:

    If I look in the ComponentSetup.log file I can see the following:

    When checking though the rest of the setup is appears corrupted and most notably the SMS_EXECUTIVE service has not been installed and the whole installation is corrupt.

    I have tried the following to fix the issue:

    • Running "lodctr.exe /r" to repair perfmon
    • Adding server computer account to domain admins during installation
    • ensuring the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation DWORD 0 is set (followed by a reboot)

    I am also seeing lots of 1016 and 1020 error messages for just about all components.

    Can anyone help me resolve this issue?


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP


    Friday, October 28, 2011 2:03 PM

Answers

  • I *guess* that this step restores the registry files that are located in the SiteServer folder of the ConfigMgr backup (SMSbkSiteRegNAL.dat and SMSbkSiteRegSMS.dat), but this might be completely wrong though.

    Torsten Meringer | http://www.mssccmfaq.de

    • Proposed as answer by TNJMAN Friday, March 09, 2012 11:30 PM
    • Marked as answer by Jonathan Conway Saturday, March 10, 2012 1:10 PM
    Thursday, March 08, 2012 2:58 PM
    Moderator
  • 3rd Rebuild of the server resolved the issue. Still none the wiser as to what caused this issue but case closed. Next...
    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Friday, November 11, 2011 1:56 PM

All replies

  • Hi,

     

    Did you run the Setup Prerequisite Checks?

     

    Also, please try to take the following suggestions to test:

     

    1. Disable UAC on 2008 server- Set to never notify

    2. Stop and disable antivirus services from services.msc

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 01, 2011 9:55 AM
  • The setup Prerequisite checks run fine ahead of install and I've done this install many times before so I know they are all installed.

    As stated in my initial question, I have run this same install on a test machine using Microsoft media and it works fine - the issue seems to be something contained within the corporate server build being used on the account.

    UAC and Windows Firewall are both disabled and there is no AV software running.


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Tuesday, November 01, 2011 10:06 AM
  • What about C:\ConfigMgrSetup.log and sitecomp.log?
    Torsten Meringer | http://www.mssccmfaq.de
    Tuesday, November 01, 2011 10:26 AM
    Moderator
  • Latter part of the ConfigMgrSetup.log:

    <11-01-2011 13:50:36> Precompiling (NGEN) D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI\bin\AdminUI.AuthorizedUpdates.dll
    <11-01-2011 13:50:36> Initiating compilation of NGEN QUEUE
    <11-01-2011 13:50:37> Initiating compilation of NGEN QUEUE
    <11-01-2011 13:50:45> Asset Intelligence component has been installed. Asset Intelligence data collection is disabled.                     See Administrator Console Help for more information about enabling or disabling Asset Intelligence                     data collection.
    <11-01-2011 13:50:46> Successfully created Status Reporting Control File 'D:\Program Files (x86)\Microsoft Configuration Manager\scripts\StatusReportingCtrl.ct0'.
    <11-01-2011 13:50:46> SMS Setup full version is 4.00.6487.2000
    <11-01-2011 13:50:46> Successfully set security on Setup registry key.
    <11-01-2011 13:50:46> Successfully set security on SQL Server registry key.
    <11-01-2011 13:50:46> Successfully set security on Identification registry key.
    <11-01-2011 13:50:46> Adding AssetAdvisor component registry key.
    <11-01-2011 13:50:46> Creating SMS Inbox Source registry key ...
    <11-01-2011 13:50:46> Installing SMS Site Component Manager ...
    <11-01-2011 13:50:46> Installing Site Component Manager under acct <NT AUTHORITY\SYSTEM> path <D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\sitecomp.exe>
    <11-01-2011 13:50:48> Started Site Component Manager service
    <11-01-2011 13:50:48> SMS Site Component Manager installation completed.
    <11-01-2011 13:50:48> Done with service installation
    <11-01-2011 13:50:48> Begin monitoring - SMS_SITE_COMPONENT_MANAGER.
    <11-01-2011 13:50:48> Starting WMI.
    <11-01-2011 13:50:48> Starting iphlpsvc.
    <11-01-2011 13:50:48> Starting VMUpgradeHelper.
    <11-01-2011 13:50:48> Using default Timeout value.
    <11-01-2011 13:50:48> Checking status of WinMgmt...
    <11-01-2011 13:50:49> Verified that WinMgmt is running.
    <11-01-2011 13:50:49> Checking status of VMUpgradeHelper...
    <11-01-2011 13:50:50> Verified that VMUpgradeHelper is running.
    <11-01-2011 13:50:50> Checking status of iphlpsvc...
    <11-01-2011 13:50:51> Verified that iphlpsvc is running.
    <11-01-2011 13:50:51> Adding Boot Image Packages...
    <11-01-2011 13:50:53> Attempting to export x86 boot image from WAIK installation source
    <11-01-2011 13:53:05> Attempting to create x86 default boot image from \\<SERVERNAME>\SMS_ENG\osd\boot\i386\boot.wim
    <11-01-2011 13:54:21> Successfuly created Boot image (x86)
    <11-01-2011 13:54:21> Attempting to export x64 boot image from WAIK installation source
    <11-01-2011 13:56:19> Attempting to create x64 default boot image from \\<SERVERNAME>\SMS_ENG\osd\boot\x64\boot.wim
    <11-01-2011 13:57:15> Successfully completed monitoring.
    <11-01-2011 13:57:15> End monitoring - SMS_SITE_COMPONENT_MANAGER.
    <11-01-2011 13:57:15> Begin monitoring - SMS_COMPONENT_MONITOR.
    <11-01-2011 13:57:15> Timed out monitoring.
    <11-01-2011 13:57:15> End monitoring - SMS_COMPONENT_MONITOR.
    <11-01-2011 13:57:15> Begin monitoring - SMS Management Point.
    <11-01-2011 13:57:15> Timed out monitoring.
    <11-01-2011 13:57:15> End monitoring - SMS Management Point.
    <11-01-2011 13:57:15> Completed monitoring installation of Configuration Manager services.
    <11-01-2011 13:57:15> All core services are available.
    <11-01-2011 13:57:15> Not enabling Next button.
    <11-01-2011 13:57:31> Successfuly created Boot image (x64)
    <11-01-2011 13:57:31> Attempting to delete legacy SMS program groups
    <11-01-2011 13:57:31> Failed to delete program group C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Systems Management Server with error 2
    <11-01-2011 13:57:31> Attempting to delete Configuration Manager 2007 sub-program group
    <11-01-2011 13:57:31> Failed to delete program group C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007 with error 3
    <11-01-2011 13:57:31> Attempting to delete Microsoft System Center program group
    <11-01-2011 13:57:31> Failed to delete program group C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center with error 2
    <11-01-2011 13:57:31> Creating directory C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center
    <11-01-2011 13:57:31> CreateDirectory for C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center returned: 1
    <11-01-2011 13:57:31> Creating directory C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007
    <11-01-2011 13:57:31> CreateDirectory for C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007 returned: 1
    <11-01-2011 13:57:31> Adding an icon for C:\Windows\help\SMSWRAPPER.CHM
    <11-01-2011 13:57:31> Adding an icon for D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI\bin\ADMINCONSOLE.MSC
    <11-01-2011 13:57:31> Adding an icon for D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI\bin\REPAIRWIZARD.EXE
    <11-01-2011 13:57:31> Adding an icon for D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\COURSEND.EXE
    <11-01-2011 13:57:31> AddItem(D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI\bin\ADMINCONSOLE.MSC, ConfigMgr Console)
    <11-01-2011 13:57:31> Shortcut string is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007\ConfigMgr Console.lnk
    <11-01-2011 13:57:31> AddItem(D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\SETUP.EXE, ConfigMgr Setup)
    <11-01-2011 13:57:31> Shortcut string is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007\ConfigMgr Setup.lnk
    <11-01-2011 13:57:31> AddItem(D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\COURSEND.EXE, ConfigMgr Courier Sender)
    <11-01-2011 13:57:31> Shortcut string is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007\ConfigMgr Courier Sender.lnk
    <11-01-2011 13:57:31> AddItem(D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI\bin\REPAIRWIZARD.EXE, ConfigMgr Site Repair Wizard)
    <11-01-2011 13:57:31> Shortcut string is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007\ConfigMgr Site Repair Wizard.lnk
    <11-01-2011 13:57:31> AddItem(C:\Windows\help\SMSWRAPPER.CHM, ConfigMgr Documentation)
    <11-01-2011 13:57:31> Shortcut string is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft System Center\Configuration Manager 2007\ConfigMgr Documentation.lnk
    <11-01-2011 13:57:31> Creating SMS_ADMIN_UI_PATH system environment variable ...
    <11-01-2011 13:57:31> Setting 6487 to Version
    <11-01-2011 13:57:31> Setting 4.00.6487.2000 to Full Version
    <11-01-2011 13:57:31> Setting D:\Program Files (x86)\Microsoft Configuration Manager to Installation Directory
    <11-01-2011 13:57:31> Setting <SERVERNAME> to Provider Location
    <11-01-2011 13:57:31> Setting PYHYP-XXXXX-XXXXX-XXXXX-XXXXX to Product ID
    <11-01-2011 13:57:31> Setting 455 to Phase
    <11-01-2011 13:57:31> Setting 1 to Type
    <11-01-2011 13:57:31> Setting 32 to Server Platforms
    <11-01-2011 13:57:31> Setting D:\Program Files (x86)\Microsoft Configuration Manager\AdminUI to UI Installation Directory
    <11-01-2011 13:57:31> Setting 6487 to UI Version
    <11-01-2011 13:57:31> Try to checking MUICache for user :.DEFAULT
    <11-01-2011 13:57:31> Try to checking MUICache for user :S-1-5-19
    <11-01-2011 13:57:31> Try to checking MUICache for user :S-1-5-20
    <11-01-2011 13:57:31> Try to checking MUICache for user :S-1-5-21-785592008-1861760626-313593124-121557
    <11-01-2011 13:57:31> Try to checking MUICache for user :S-1-5-21-785592008-1861760626-313593124-121557_Classes
    <11-01-2011 13:57:31> Try to checking MUICache for user :S-1-5-18
    <11-01-2011 13:57:31> Installation and configuring site are done.


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Tuesday, November 01, 2011 2:41 PM
  • Latter part of the sitecomp.log

          118976 bytes are required in the "C:\Windows" directory for this component's files.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.109 2011 GMT Standard Time><thread=4968 (0x1368)>
          All files installed.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.118 2011 GMT Standard Time><thread=4968 (0x1368)>
          Writing the SMS Performance Data Provider key to server <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.130 2011 GMT Standard Time><thread=4968 (0x1368)>
          The SMS Performance Data Provider key is already in the registry on server <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.130 2011 GMT Standard Time><thread=4968 (0x1368)>
          Cannot write to registry on server <SERVERNAME>; error = 1.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.131 2011 GMT Standard Time><thread=4968 (0x1368)>
          Starting bootstrap operations...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.132 2011 GMT Standard Time><thread=4968 (0x1368)>
            Installed service SMS_SERVER_BOOTSTRAP_<SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.168 2011 GMT Standard Time><thread=4968 (0x1368)>
            Starting service SMS_SERVER_BOOTSTRAP_<SERVERNAME> with command-line arguments "ENG D:\Program Files (x86)\Microsoft Configuration Manager /install D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\perfsetup.exe SMS_WSUS_SYNC_MANAGER"...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:56:59.168 2011 GMT Standard Time><thread=4968 (0x1368)>
              Execution of "D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\perfsetup.exe /install /siteserver:<SERVERNAME>" on server <SERVERNAME> failed: Child process exited with non-zero code 1000.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.233 2011 GMT Standard Time><thread=4968 (0x1368)>
            Bootstrap operation failed.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.234 2011 GMT Standard Time><thread=4968 (0x1368)>
            Deinstalled service SMS_SERVER_BOOTSTRAP_<SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.237 2011 GMT Standard Time><thread=4968 (0x1368)>
          Bootstrap operations aborted.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.237 2011 GMT Standard Time><thread=4968 (0x1368)>
        Installation failed and will be retried in the next polling cycle.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.237 2011 GMT Standard Time><thread=4968 (0x1368)>
    LogEvent(): Successfully logged Event to NT Event Log (1, 73, -1073740808, (null)).  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.238 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1075 SEV=I LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:56:59.109 2011 ISTR0="118976" ISTR1="C:\Windows" ISTR2="3396251648" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.239 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1079 SEV=I LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:56:59.114 2011 ISTR0="D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\system32\smsperf.dll" ISTR1="C:\Windows\system32\smsperf.dll" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.241 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1079 SEV=I LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:56:59.117 2011 ISTR0="D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\system32\perf_msg.dll" ISTR1="C:\Windows\system32\perf_msg.dll" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.242 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=578 SEV=E LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:56:59.131 2011 ISTR0="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\SMS Performance Data Provider\SMS_WSUS_SYNC_MANAGER" ISTR1="<SERVERNAME>" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.243 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=4905 SEV=E LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.233 2011 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.244 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1016 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.239 2011 ISTR0="60" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.246 2011 GMT Standard Time><thread=4968 (0x1368)>
        Installing component SMS_WSUS_SYNC_MANAGER...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.248 2011 GMT Standard Time><thread=4968 (0x1368)>
    LogEvent(): Successfully logged Event to NT Event Log (4, 73, 1073742838, (null)).  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.251 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1014 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.251 2011 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.252 2011 GMT Standard Time><thread=4968 (0x1368)>
          The server already contains some of the required files for this component.  A disk space check will not be made.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.254 2011 GMT Standard Time><thread=4968 (0x1368)>
          All files installed.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.263 2011 GMT Standard Time><thread=4968 (0x1368)>
          Writing the SMS Performance Data Provider key to server <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.265 2011 GMT Standard Time><thread=4968 (0x1368)>
          The SMS Performance Data Provider key is already in the registry on server <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.266 2011 GMT Standard Time><thread=4968 (0x1368)>
          Cannot write to registry on server <SERVERNAME>; error = 1.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.266 2011 GMT Standard Time><thread=4968 (0x1368)>
          Starting bootstrap operations...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.268 2011 GMT Standard Time><thread=4968 (0x1368)>
            Installed service SMS_SERVER_BOOTSTRAP_<SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.326 2011 GMT Standard Time><thread=4968 (0x1368)>
            Starting service SMS_SERVER_BOOTSTRAP_<SERVERNAME> with command-line arguments "ENG D:\Program Files (x86)\Microsoft Configuration Manager /install D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\perfsetup.exe SMS_WSUS_SYNC_MANAGER"...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:06.326 2011 GMT Standard Time><thread=4968 (0x1368)>
              Execution of "D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\perfsetup.exe /install /siteserver:<SERVERNAME>" on server <SERVERNAME> failed: Child process exited with non-zero code 1000.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.390 2011 GMT Standard Time><thread=4968 (0x1368)>
            Bootstrap operation failed.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.391 2011 GMT Standard Time><thread=4968 (0x1368)>
            Deinstalled service SMS_SERVER_BOOTSTRAP_<SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.395 2011 GMT Standard Time><thread=4968 (0x1368)>
          Bootstrap operations aborted.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.395 2011 GMT Standard Time><thread=4968 (0x1368)>
        Installation failed and will be retried in the next polling cycle.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.395 2011 GMT Standard Time><thread=4968 (0x1368)>
    LogEvent(): Successfully logged Event to NT Event Log (1, 73, -1073740808, (null)).  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.396 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1079 SEV=I LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.259 2011 ISTR0="D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\system32\smsperf.dll" ISTR1="C:\Windows\system32\smsperf.dll" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.397 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1079 SEV=I LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.262 2011 ISTR0="D:\Program Files (x86)\Microsoft Configuration Manager\bin\i386\system32\perf_msg.dll" ISTR1="C:\Windows\system32\perf_msg.dll" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.398 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=578 SEV=E LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:06.266 2011 ISTR0="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\SMS Performance Data Provider\SMS_WSUS_SYNC_MANAGER" ISTR1="<SERVERNAME>" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.401 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=4905 SEV=E LEV=D SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:13.391 2011 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.403 2011 GMT Standard Time><thread=4968 (0x1368)>
    STATMSG: ID=1016 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_WSUS_SYNC_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=4968 GMTDATE=Tue Nov 01 13:57:13.397 2011 ISTR0="60" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.404 2011 GMT Standard Time><thread=4968 (0x1368)>
        Updating Security settings on site system ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.405 2011 GMT Standard Time><thread=4968 (0x1368)>
        Getting Security configuration based on registry settings ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.406 2011 GMT Standard Time><thread=4968 (0x1368)>
        SSL Security settings are present.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.406 2011 GMT Standard Time><thread=4968 (0x1368)>
        Getting Security configuration for server based on its server roles ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.406 2011 GMT Standard Time><thread=4968 (0x1368)>
        SSL Security settings are required for server <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.407 2011 GMT Standard Time><thread=4968 (0x1368)>
        Updating DNS publishing settings on site system ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.407 2011 GMT Standard Time><thread=4968 (0x1368)>
      Finished polling server <SERVERNAME>...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.408 2011 GMT Standard Time><thread=4968 (0x1368)>
    Thread "SiteComp server polling Thread #0" id:4968 terminated normally  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.408 2011 GMT Standard Time><thread=4968 (0x1368)>
    CSiteCompThreadManager::ThreadTerminating - All threads have stopped running  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.409 2011 GMT Standard Time><thread=4968 (0x1368)>
    CSiteCompThreadManager::WaitForThreadsToFinish - All threads have stopped  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.409 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Finished polling all servers  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.410 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Publish Servers in Active Directory.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.411 2011 GMT Standard Time><thread=5036 (0x13AC)>
       DS Root:DC=CUSOTMER DOMAIN,DC=CUSOTMER DOMAIN,DC=CUSOTMER DOMAIN~  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.575 2011 GMT Standard Time><thread=5036 (0x13AC)>
       Searching for the System Management Container.~  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.575 2011 GMT Standard Time><thread=5036 (0x13AC)>
       LDAP://CN=System Management,CN=System,DC=CUSOTMER DOMAIN,DC=CUSOTMER DOMAIN,DC=CUSOTMER DOMAIN container exists.~  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.580 2011 GMT Standard Time><thread=5036 (0x13AC)>
       Site System <<SERVERNAME>> is the Default Management Point.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.614 2011 GMT Standard Time><thread=5036 (0x13AC)>
    ~No Fallback Status Point installed on the Site  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.615 2011 GMT Standard Time><thread=5036 (0x13AC)>
      Size of Signing Certificate: 0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.615 2011 GMT Standard Time><thread=5036 (0x13AC)>
      Signing Certificate:   $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.615 2011 GMT Standard Time><thread=5036 (0x13AC)>
      Checking configuration information for server: <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.615 2011 GMT Standard Time><thread=5036 (0x13AC)>
        <SERVERNAME> is the Default MP.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.626 2011 GMT Standard Time><thread=5036 (0x13AC)>
        MP Configuration for <SERVERNAME> is correct.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.626 2011 GMT Standard Time><thread=5036 (0x13AC)>
        Installing Security settings on site system ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.626 2011 GMT Standard Time><thread=5036 (0x13AC)>
        Security settings are up to date for <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.627 2011 GMT Standard Time><thread=5036 (0x13AC)>
        Installing DNS publishing settings on site system ...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.627 2011 GMT Standard Time><thread=5036 (0x13AC)>
        DNS publishing settings are up to date for <SERVERNAME>.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.627 2011 GMT Standard Time><thread=5036 (0x13AC)>
        Publishing <SERVERNAME>(<SERVERNAME>.CUSOTMER DOMAIN.CUSOTMER DOMAIN.CUSOTMER DOMAIN) as a Management Point into Active Directory.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:13.627 2011 GMT Standard Time><thread=5036 (0x13AC)>
    STATMSG: ID=4911 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_SITE_COMPONENT_MANAGER" SYS=<SERVERNAME> SITE=ENG PID=5024 TID=5036 GMTDATE=Tue Nov 01 13:57:14.805 2011 ISTR0="cn=SMS-MP-ENG-<SERVERNAME>" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.805 2011 GMT Standard Time><thread=5036 (0x13AC)>
        SMS-MP-ENG-<SERVERNAME> successfully created.~  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.808 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Wrote a delta site control file to the "Site Control Manager (Master Site Control File)" inbox.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.822 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Waiting for changes to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" or "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitecomp.box" directories, servers will be polled in 1 hour...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Detected a change to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" directory.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    A new master site control file was not available.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Waiting for changes to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" or "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitecomp.box" directories, servers will be polled in 1 hour...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Detected a change to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" directory.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    A new master site control file was not available.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Waiting for changes to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" or "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitecomp.box" directories, servers will be polled in 1 hour...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Detected a change to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Tracing registry key.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:14.824 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Waiting for changes to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" or "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitecomp.box" directories, servers will be polled in 59 minutes, 59 seconds...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:15.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Detected a change to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Tracing registry key.  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:15.823 2011 GMT Standard Time><thread=5036 (0x13AC)>
    Waiting for changes to the "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitectrl.box" or "D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\sitecomp.box" directories, servers will be polled in 59 minutes, 58 seconds...  $$<SMS_SITE_COMPONENT_MANAGER><Tue Nov 01 13:57:16.822 2011 GMT Standard Time><thread=5036 (0x13AC)>


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Tuesday, November 01, 2011 3:05 PM
  • I've noticed that there a few messages about components failing to install but most lead to the steps I've already taken - see the initial post at the top i.e. corrupt perfmon, 8dot3, etc.

    Anyone got any ideas?


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Tuesday, November 01, 2011 4:31 PM
  • Did you configure the server per TechNet: http://technet.microsoft.com/en-us/library/cc431377.aspx?
    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    Tuesday, November 01, 2011 7:19 PM
  • Yes.

    I've followed the same procedure using the same media to sucessfully install in a test environment - the only difference is in my test environment I have installed from Microsoft media, whereas on the failing install I am using the customers own Windows Server 2008 image which includes various security hardening aspects such as local GPO and registry settings.


    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Tuesday, November 01, 2011 7:55 PM
  • Well, if it quacks like a duck...

    I recommend starting clean and applying the settings in the policy one by one after you install ConfigMgr so that you know what breaks it.

    Here's a fabulous session I recommend you give to whomever created and/or endorsed this security posture: Unintended Consequences of Security Lockdowns (http://channel9.msdn.com/Events/TechEd/NorthAmerica/2011/SIM304).


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    Tuesday, November 01, 2011 8:24 PM
  • 3rd Rebuild of the server resolved the issue. Still none the wiser as to what caused this issue but case closed. Next...
    Jonathan Conway | MCITP: Enterprise Administrator • MCP • MCSE 2003 • MCTS System Center Configuration Manager 2007 • VCP
    Friday, November 11, 2011 1:56 PM
  • Update - in case it helps someone.

    The various blogs/notes/TechNet articles about SCCM migration/restore are lacking in some cirtical details.

    I have vaguely similar issue as above - but during my "site repair" from a (sccm 2007) 32-bit w2k3 to 64-bit w2k8 (r2) system, the restore succeeds up to the point of "Restore Registry Files" - at that point, it gives status of '"Failed."

    On my other thread about this issue, I have over 30 hits, and no comments yet.

    For one thing, I've seen several notes that say, "keep your install path the same;" i.e., c:\sms, and "all else will magically happen."

    One note also says, "Oh the DB location doesn't matter." WELL, IT DOES!

    On my old box, it was c:\smsdata

    On my new box, it is c:\sqldata

    And, lo and behold, there is an hklm "sms" key that points back to c:\smsdata - so, YES, IF YOU CHANGE DB LOCATION, IT MAKES A DIFFERENCE! :-)

    Also, I am AMAZED that nobody knows exactly what this "Restore Registry Files" step does - if we could at least have some insight into that, as well as more verbose output somewhere, it would help. For instance, I had no idea there were any logs apparently on the top of the C: drive, until reading this posting (thanks, btw - you would think this would be one of THE TOP things mentioned in 'troubleshooting' - but maybe I missed it).

    FYI, I do not appear to have a 'sitecomp.log', but i do have ConfigMgrSetup.log, ComponentSetup.log and ConfigMgrPrereq.log.

    My ConfigMgrSetup.log looks similar to the one above. So, if I modify the "DB path" in the SMS key and apply that to my new server, will it be happy - or, should I go to the trouble of moving the DB to the same path as it was in prevously?

    Note: AFTER the 'restore registy files' step, there is Start Services, Get Data from Database, and Checking for Permissions steps.

    Bottom line: If the "Site Repair Wizard" doesn't finish, due to a small glitch, then whomever wrote the Site Repair Wizard should give us enough insight that we could finish the task on our own.

    Example: Does the 'restore registry files' step restore MORE THAN ONE registry file? The only thing I know for sure is that there is an HKLM SMS key - fyi, my previous install was SCCM upgrade to 2007 from a prior 2003 SMS installation. Are there other keys that come into play? If I know what this "restore registry files step" does, then I could finish fixing it on my own.

    Thanks! Any insight(s) would be appreciated.


    tnjman

    Thursday, March 08, 2012 2:35 PM
  • I *guess* that this step restores the registry files that are located in the SiteServer folder of the ConfigMgr backup (SMSbkSiteRegNAL.dat and SMSbkSiteRegSMS.dat), but this might be completely wrong though.

    Torsten Meringer | http://www.mssccmfaq.de

    • Proposed as answer by TNJMAN Friday, March 09, 2012 11:30 PM
    • Marked as answer by Jonathan Conway Saturday, March 10, 2012 1:10 PM
    Thursday, March 08, 2012 2:58 PM
    Moderator
  • We had the exact same issue that Jonathan originally had.

    One of the SCCM prerequisite checker prerequisites that originally failed was that "Short file name (8.3) support" was not enabled (there was a security lockdowns/template that had disabled this).  But before this was found, there had already been something installed to "D:\Program Files (x86)".  Then we enabled "Short file name (8.3) support" with  fsutil.exe behavior set disable8dot3 0  command, and checked the registry key for NtfsDisable8dot3NameCreation  and it was 0.

    Then the SCCM prerequisite checker passed "Short file name (8.3) support", and the installation of SCCM started... but it failed when running the "D:\Program Files (x86)\MICROS~1\bin\i386\COMREG~1.EXE /install /siteserver:SCCM01"  command (and future commands).  Note that "D:\Program Files (x86)"  above is not truncated to "8.3 format", but the subfolder and command EXE are.

    So, the  "D:\Program Files (x86)"  folder had already been created without “8.3 support”… but the SCCM installation would see "Short file name (8.3) support" as enabled, would start OK, but fail.

    So our solution was to ensure to have "Short file name (8.3) support" enabled, uninstall everything that had already been installed to the "D:\Program Files (x86)" folder, delete "D:\Program Files (x86)", reboot, and then install SCCM... and it succeeded !!!

    For others that may see this, if you cannot uninstall everything from the  "Program Files (x86)"  folder where you will install SCCM... then ensure "Short file name (8.3) support" is enabled ... and install to some other folder, e.g. D:\SCCM    

    e.g.  the DIR /X /S   at the root of D:  shows below.  Note that Program Files (x86)  does not have a corresponding short file name.

    Directory of D:\
    28/03/2012  11:31 AM    <DIR>                       Program Files (x86)

    Directory of D:\Program Files (x86)
    21/03/2012  01:57 PM    <DIR>                       ConfigMgr 2007 Toolkit V2
    23/03/2012  02:56 PM    <DIR>          MICROS~1     Microsoft Configuration Manager

    I think this may be answer for Jonathan's original post; potentially on the "3rd rebuild of the server" that has been mentioned, nothing had already been installed to the "Program Files (x86)"   folder... and the next SCCM install was successful.

    • Proposed as answer by ShaneAlexander Thursday, April 05, 2012 10:18 PM
    Thursday, April 05, 2012 10:17 PM