none
Error (12700)

    Question

  • please help me with the following error while creating VM. I am running a script to create 40 VMs/hour

    Error (12700)

    VMM cannot complete the Hyper-V operation on the <host> server because of the error: 'vmm30-00-0008' failed to add device 'Microsoft Synthetic Ethernet Port'. (Virtual machine ID 9559DEFB-68CE-4C10-A354-D51F4B8154DE)

    The Virtual Machines configuration 9559DEFB-68CE-4C10-A354-D51F4B8154DE at 'E:\scvmmVM\vmm30-00-0008' is no longer accessible: The requested operation cannot be performed on a file with a user-mapped section open. (0x800704C8)

     (Unknown error (0x8000))

    Recommended Action

    Resolve the issue in Hyper-V and then try the operation again.

    Thursday, February 23, 2012 9:51 AM

Answers

  • try to disable the AV and restart the job again

    Mohamed Fawzi | http://fawzi.wordpress.com

    • Marked as answer by Geeta Gokhale Monday, March 19, 2012 9:49 AM
    Thursday, February 23, 2012 2:03 PM
    Moderator

All replies

  • try to disable the AV and restart the job again

    Mohamed Fawzi | http://fawzi.wordpress.com

    • Marked as answer by Geeta Gokhale Monday, March 19, 2012 9:49 AM
    Thursday, February 23, 2012 2:03 PM
    Moderator
  • Also, are you capturing your jobs and watching them to see that they are finished before you apply the next setting?

    When you provision at scale the system will give you an instant return but commonly the actual action is not complete.

    If you capture the output from your call into an object you should be able to query its status.

    The object has a few statuses that you can use.  For example  $vm = New-SCVirtualMachine

    $vm.MostRecentTask gives you the long running task object and you can go from there.

    The OP that I helped ended up doing this:

    ifelse { [string]($vm.MostRecentTask | select "Status") -match "Running" { 
      "Skip this VM, it is already running a job" 
    }
    


    Brian Ehlert (hopefully you have found this useful) http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, February 23, 2012 4:40 PM
    Moderator
  • try to disable the AV and restart the job again

    Mohamed Fawzi | http://fawzi.wordpress.com

    I can vouch that in our implementation we were receiving the same error and this was the solution to that issue.

    By disabling OfficeScan on the hosts, the creation job completed successfully.

    Thursday, February 23, 2012 10:29 PM
  • AV is not running
    Friday, February 24, 2012 5:30 AM
  • Please confirm that AV is not running on the Hyper-v host, Als have you tried to restart the job again ?

    Please check

    http://support.microsoft.com/kb/961804

    Mohamed Fawzi | http://fawzi.wordpress.com

    Monday, February 27, 2012 8:17 PM
    Moderator
  • I checked that all hosts have AV not running and restarted the service. I am still getting the error.
    Friday, March 02, 2012 6:26 AM
  • The error has gone away. looks like the AV was automatically getting ON in between. the error went away when disabled the AV services
    Monday, March 19, 2012 9:49 AM
  • Hi;

    I've had similar problems.

    The Legacy Network Adapter is the cause of the Problem.

    Thursday, October 03, 2013 7:42 PM