none
boot from winpe usb flash drive then can't access the usb drive

    Question

  • I created a bootable winpe 3.0 usb flash drive. However, after booting to winpe I can not see the usb drive. All I see is the X: drive and C: D: which are local HDD. I tried all remaining drive letters with no luck.

    If I boot from a winpe 3.0 cd I can still see the cd drive and can access other files on it.

    Can't figure out what's wrong.

    Help appreciated.

     

     


    Thursday, June 09, 2011 11:46 AM

All replies

  • Launch diskpart and do a show disks and show volumes to see all drives.

    My money is on the C or D drive actually being your USB key and one of the two volumes you are expecting to see on the local system either doesn't exist or does't have a drive letter assigned foor some reason.


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    Thursday, June 09, 2011 12:52 PM
  • Hi Jason,

    Not to be a jerk but its list disks and list volumes not show.  Also he is right the USB disk does not appear at all until you remove it then plug it back in.  Do you know why this happens?  I have downloaded the devcon (the x64 compatible version) and it does not recognize any new devices.

     

    Thanks

     

     

    Saturday, September 10, 2011 12:38 AM
  • Also he is right the USB disk does not appear at all until you remove it then plug it back in.  Do you know why this happens? 

    I've never had this issue so far, on many types of PC and quite a few different USB media (both UFD and UHD).
    (sure, sometimes the UFD isn't recognised at boot time, e.g. if it hasn't initialised, which is why i prefer UFD's with an LED in them)
    (admittedly I'm not using 6 year old white-box HW, so that could be an issue)
    Wondering if it's due to particular HW/BIOS/UFD combinations?
    Does a diskpart rescan make any difference?

    Don
    Saturday, September 10, 2011 5:38 AM
  • not getting access to the memory can be bad enough but is the main problem that the installtion stops because it can't find the SMS folder on the root of the UFD?

    That problem can be worked around by mounting the boot.wim and copying the SMS folder to the root of the mountpoint. You also must edit  mountpoint\sms\bin\i386\tsbootshell.ini and change the config path to x:\.

     

     

    Monday, September 12, 2011 6:54 AM
  • This might be helpful for somebody.

    My Winpe boot not recognizing USB (2.0 precisely). But USB was recognized using Windows 7. Solution: Disable USB 3.0 from BIOS if supporting and try boot winpe.

    Added USB 3.0 drivers from Intel website to winpe image and USB drives are accessed seamlessly.


    • Edited by Sasivardhan Wednesday, September 26, 2012 10:38 AM
    Tuesday, September 25, 2012 1:41 PM
  • Although this is an old thread I thought I'd respond with my solution.  I had exactly the same issue.  WinPE boots fine but the USB stick it booted from does not show up as a drive unless I remove the stick and reinsert it.

    The fix is to ensure the USB stick is formatted as NTFS, not FAT32.  Do that when you create the bootable media and everything should be fine.

    Tuesday, February 12, 2013 11:37 AM