none
Office 2007 Deploy Fails

    Question

  • What's the best way to troubleshoot this?  I know the package is good, because it has worked on some clients.  Others however, show "Failed" in the console, and there is no reason given why.  I see nothing in the clients Event Viewer, or the SCE Server Event Viewer under Operations Manager showing that the Office 2007 install failed or why.  On one of the clients that failed, I ran the Setup.exe manually and it installed fine. 


    Dale
    Friday, December 11, 2009 4:07 PM

All replies

  • Hello Dale,
    Can you please check WSUS version on your box.
    Is it WSUS 3.0 SP1 or you have upgraded it to WSUS 3.0 SP2?

    Is it failing while you are trying to create the office package using SCE console "create new package"?
    Also can you please check if you are using .msp file?
    Thanks, Anshu


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, December 11, 2009 8:52 PM
  • Hello Dale,

    Also can you please send some related screenshot to: SCEDATA@microsoft.com. for further investigations?

    Thanks, Anshu 

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, December 11, 2009 8:55 PM
  • Hello Dale,

    What is the OS version on the problematic computers? Please also open the %WINDIR%\windowsupdate.log on one of the problematic computer to see if any error message logged.

    Thanks,

    Yog Li - MSFT
    Monday, December 14, 2009 10:12 AM
    Moderator
  • There doesnt seem to be much consistency with way the package deployment works.  Some clients, when I add them to my "Deploy" group, would start upgrading immediately.  Others wait a day and then start installing the next morning.  Other clients dont install at all, they just sit in the state "The package is applicable but not yet downloaded or installed" for days.  Are there some kind of prerequsite Windows updates that have to be installed before Office 2007 will install?

    The ones that fail have the following error:

    Event Type: Error
    Event Source: Windows Update Agent
    Event Category: Installation
    Event ID: 20
    Date:  12/15/2009
    Time:  7:13:06 AM
    User:  N/A
    Computer: ECI_BO1
    Description:
    Installation Failure: Windows failed to install the following update with error 0x80070643: Office 2007.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 57 69 6e 33 32 48 52 65   Win32HRe
    0008: 73 75 6c 74 3d 30 78 38   sult=0x8
    0010: 30 30 37 30 36 34 33 20   0070643
    0018: 55 70 64 61 74 65 49 44   UpdateID
    0020: 3d 7b 44 42 36 46 35 35   ={DB6F55
    0028: 44 37 2d 36 37 38 39 2d   D7-6789-
    0030: 34 30 36 44 2d 38 44 41   406D-8DA
    0038: 35 2d 30 36 46 45 37 39   5-06FE79
    0040: 33 33 44 30 31 38 7d 20   33D018}
    0048: 52 65 76 69 73 69 6f 6e   Revision
    0050: 4e 75 6d 62 65 72 3d 31   Number=1
    0058: 20 00                      .     

    Thursday, December 17, 2009 2:14 PM
  • I am running WSUS SP1 and all the clients are XP Pro, most with SP3, some still at SP2.  Should I upgrade WSUS to SP2?
    Friday, December 18, 2009 2:12 PM
  • Hello Dale,

    You can upgrade the WSUS 3.0 to SP2. But it is not necessary to resolve this issue. Try the following steps to check whether the software will be installed on the client:

    1. Run "services.msc" on the problematic client, stop "Automatic Update" service.

    2. Navigate to "%windir%\software distribution" folder, rename the folder to "software distribution old".

    3. Run "services.msc" on the problematic client, start "Automatic Update" service.

    4. Delete "%windir%\system32\catroot2" folder.

    5. Run "wuauclt /detectnow" on the agents, check whether the problem still exists.

    Thanks,
    Yog Li - MSFT
    Wednesday, December 23, 2009 9:37 AM
    Moderator