none
Activities (Manual and Review) created without prefix (MA and RA)

    Question

  • Hello:

     SCSM 2010 SP1.

     Some activities, not all, are being created without prefix. I think, maybe there is an internal workflow not doing its job in the right way.

     Your comments or experiencies would be really appreciated.

     How could I solve this issue? Maybe a CU? or a power shell command?

     If it's a problem with the actual product, any workaround?

     Thanks for your answers.

    Best Regards,


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 5:44 PM

All replies

  • What CU are you on? I used to occassionally see this but currently we are on CU3 and I cannot see any instances of it now.
    Monday, March 05, 2012 6:55 PM
    Moderator
  • Using the latest version is always a good idea.

    Here is the latest CU for SCSM 2010 SP1:

    Cumulative Update 3 for System Center Service Manager 2010 SP1 (KB2588492)

    Are there any relations to the activities without a prefix? For instance are the afftected activities created by an Orchestrator/Opalis runbook or by a PowerShell script? Or it's completly random?


    Andreas Baumgarten | H&D International Group

    Monday, March 05, 2012 6:58 PM
    Moderator
  • Rob and Andreas:

     Thanks for your comments.

     Well, the issue was presented before CU3. A week ago, I applied CU3.

     I'm gonna ask my client, If the issue has happened again after CU3.

     Do you think CU3 solves the problem?

    Thanks,


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 7:27 PM
  • Andreas:

     The activities don't have an specific relation. No Opalis or Orchestrator. Yes, they are completely random.

    Thanks,


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 7:33 PM
  • I think there is no list with all fixes in the different CUs available.

    "presented before CU3" means it happens still in SCSM 2010 SP1 CU2? Or you  ugraded from SCSM 2010 SP1 directly to CU3? 


    Andreas Baumgarten | H&D International Group

    Monday, March 05, 2012 7:39 PM
    Moderator
  • Andreas:

     Thanks again.

     On this case, I applied CU3 directly to SCSM 2010 SP1, without any other CU. So, the issue was presented on SCSM 2010 SP1 with no CU.

    Regards,


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 7:54 PM
  • I would monitor on CU3 and see if the problem recurrs, as Andreas mentioned the CU fix lists never contains all of the fixes...
    Monday, March 05, 2012 8:03 PM
    Moderator
  • Rob & Andreas:

     I was on a private cloud training last week. So, we were working with Service Manager 2012. I suffered the same issue on that version.

     What do you think?


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 8:57 PM
  • In the beta of SCSM 2012 there was a bug reported about missing prefixes. The bug was reported and is marked as fixed.  I didn't noticed the bug in the two SCSM 2012 RC environments we are running.

    Here is the link to the connect website:

    https://connect.microsoft.com/site799/feedback/details/698351/scsm-2012-beta-srs-submitted-in-portal-do-not-attach-the-activity-prefix-to-the-activityid


    Andreas Baumgarten | H&D International Group


    Monday, March 05, 2012 9:00 PM
    Moderator
  •  I'm not 100% sure, but I think I was working with RC.

     So, Do you know about some workaround or fixed to this behavior?

    Regards,


    Felipe Román http://feliperoman.wordpress.com

    Monday, March 05, 2012 10:44 PM
  • I would not spend much energy and time in a workaround or fix on the SCSM 2012 RC version. Let's see what SCSM 2012 RTM will bring and if the issue is still available in the final version of SCSM 2012.

    Andreas Baumgarten | H&D International Group


    Monday, March 05, 2012 11:51 PM
    Moderator
  • Andreas:

     I was talking about a workaround or fix for SCSM 2010 SP1. It was only a comment, when I said that the bug was active on SCSM 2012.

     Any idea?

    Thanks,


    Felipe Román http://feliperoman.wordpress.com

    Tuesday, March 06, 2012 3:47 PM
  • The issue is still recurrs after installing SCSM 2010 SP1 CU3?

    Andreas Baumgarten | H&D International Group

    Wednesday, March 07, 2012 4:37 AM
    Moderator
  • Thanks for your reply Andreas.

     I installed the CU3 1 week ago. So, i'm going to monitor the issue.

     I'll tell you, when I have results.

    Regards,


    Felipe Román http://feliperoman.wordpress.com

    Wednesday, March 07, 2012 4:51 AM
  • Hello:
     I can confirm that the issue is still happening on SCSM 2010 SP1 + CU3.
     Any comment or idea? I really appreciate it.
    Regards,


    Felipe Román http://feliperoman.wordpress.com

    Thursday, March 15, 2012 3:54 PM
  • You could probably create a custom workflow triggered on MA creation that checks the Id and adds the prefix if it is missing. Not an ideal solution for you but it should work. You can also read the MA prefix vaue from the settings like this:

    //Get activity settings class
    ManagementPackClass mpcActivitySettings = emg.EntityTypes.GetClass(new Guid("5e04a50d-01d1-6fce-7946-15580aa8681d"));
    
    //Get the emo for the activity settings
    EnterpriseManagementObject emoActivitySettings = emg.EntityObjects.GetObject<EnterpriseManagementObject>(mpcActivitySettings.Id, ObjectQueryOptions.Default);
    
    //Get Prefix from the settings class
    string sManualActivityIdPrefix = emoActivitySettings[mpcActivitySettings, "SystemWorkItemActivityManualActivityIdPrefix"].Value.ToString(); //MA


    Thursday, March 15, 2012 6:04 PM
    Moderator
  • Do you have any workflow which apply templates with activities inside to existing requests?

    Can you post screenshot with History tab of the affected activities?


    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com


    Friday, March 16, 2012 3:21 PM
    Moderator
  • Rob --> Thanks, I'm going to discuss that with myy development partners.

    Anton --> I have no workflows wich apply templates with activities, I only have workflows for Notifications. Why? Thanks for your comment.


    Felipe Román http://feliperoman.wordpress.com

    Friday, March 16, 2012 3:34 PM
  • If you can't post Histry tab then some additional questions (all this presented on History tab):

    1. Who creator of that activity - normal users or workflow account?
    2. Activities created with empty prefix or they lost prefix later?


    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com

    Friday, March 16, 2012 3:47 PM
    Moderator
  • Anton:
     At this moment, I don't have an example of this behavior.
     But, I can tell you:
    1- The activity was created by me.
    2- The activities are created with empty prefix.
    Any idea?
    Regards,

    Confirmed what I wrote up. I obtained some examples from a client.


    Felipe Román http://feliperoman.wordpress.com


    Friday, March 16, 2012 6:47 PM
  • I can't tell you why it happens, but I can tell you how to fix it:

    Find your Review Activity/ Manual Activity in your management pack:

    After the Beginning of a Manual Activity Object Insert:

    <Property Path=”$Context/Property[Type='CustomSystem_WorkItem_Activity_Library!System.WorkItem.Activity']/Id$”>MA{0}</Property>

    You can do the same , but with RA for all review Activities.

    Tuesday, May 22, 2012 2:23 PM
  • I can't tell you why it happens, but I can tell you how to fix it:

    Find your Review Activity/ Manual Activity in your management pack:

    After the Beginning of a Manual Activity Object Insert:

    <Property Path=”$Context/Property[Type='CustomSystem_WorkItem_Activity_Library!System.WorkItem.Activity']/Id$”>MA{0}</Property>

    You can do the same , but with RA for all review Activities.

    Hi Grant:

     Thanks for your answer.

     Only a question, which management pack are you talking about? I'm not sure.

    Regards,


    Felipe Román http://feliperoman.wordpress.com

    Thursday, May 31, 2012 3:09 AM
  • Hello guys

    I have the exact same issue with System Center 2012 SP1 (incl. Orchestrator Update Rollup 2). My scenario is quite simple. I have created a service request which includes first a review activity and second a runbook automation activity. If the approval is successfully done the service manager starts the runbook activity automatically.

    After the runbook activity has successfully finished the Service Manager creates a corrupt review activity entry without a prefix.

    My question is: Is anybody out there who has not this issue? I think it is a little bit stupid to edit every service request in every management pack manuelly.

    Or could it be, that this issue depends on a (notification) workflow as Felipe_Roman_CRC has assumed in an earlier post? I suspect it because I do not get this stupid issue if I deactivate the notification workflow (which sends an E-Mail to the requested user when the SR is finished).

    Many thank in advance

    Peter


    Thursday, May 16, 2013 3:55 PM
  • I have reported a bug at https://connect.microsoft.com/SC/feedback/details/788292/activities-manual-and-review-created-without-prefix-ma-and-ra

    Tuesday, May 21, 2013 8:26 AM
  • Hi Peter:

     My issue was on SCSM 2010 SP1 + CU3, but I can tell you is still active on SCSM 2012.

     My final thought was that the issue is related to an internal workflow, which adds the suffix to the work item.

     We had some hardware limitations on the SQL Server, so when we could finally add more processors and memory to the server, SOME problems don't appear again. Some of them related to workflows.

     Look at this: http://blogs.technet.com/b/servicemanager/archive/2013/01/14/troubleshooting-workflow-performance-and-delays.aspx

     We discovered a big delay on workflows execution, that's why we improve the hardware on SQL Server. SM is highly intensive!

     I hope this help you.

    Thanks,


    Felipe Román http://feliperoman.wordpress.com

    Tuesday, May 21, 2013 3:24 PM
  • Do we know if this bug ever got fixed?
    Thursday, November 14, 2013 10:24 AM