none
Update Scan Error 0x80244018.

    Question

  • Hi All,

    SCCM Clients are failing to complete Software Update Scan Cycle, Below is the error found in WUAHandler.log

    OnSearchComplete - Failed to end search job. Error = 0x80244018.

    Scan failed with error = 0x80244018.

    Scenario:-

    SCCM Server on Domain A , SUP Server on Domain A

    SCCM Clients migrated from Domain B to Domain A. After migration they are not completing the Update Scan Cycle.

    Clients which are in Domain A are able to complete scan successfully.

    Checks Done: -

    1. No Proxy Server between Client and SUP/SCCM Site Server

    2. No Firewall between Client and SUP/SCCM Site Server

    3.  Ran WSUS Client Diag Tool Below is the Output

    C:\WSUSTool>ClientDiag.exe

    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is not running. PASS
            Wuaueng.dll version 7.4.7600.226. . . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 2 : Notify Prior to Download . . . . . . . PASS
                    Option is from Control Panel

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer = http://SUPSERVER:80
                    WUStatusServer = http://SUPSERVER:80
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
            Connection to server. . . . . . . . . . . . . . . . . . PASS
            SelfUpdate folder is present. . . . . . . . . . . . . . PASS

    Press Enter to Complete

    Appriciate your time and help.

    Regards,

    SB

    Wednesday, August 18, 2010 3:48 PM

All replies

  • Hve you seen this thread http://social.technet.microsoft.com/Forums/en-US/configmgrsum/thread/fe3bc090-c3bc-4bba-ae71-ee8d961f6a25 ?
    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    Wednesday, August 18, 2010 3:55 PM
    Moderator
  • Yes i did check this Link, but MS recommend to use FQDN for configuring Site Server.

    In my case i can't tamper the settings, becoz there are many client which are scanning successfully from Domain A.

     

    Regards,

    SB

    Wednesday, August 18, 2010 5:26 PM
  • Hi,

    Could you please try following steps on one of your clients:

    Open regedit and navigate to:

    HKLM\Software\Microsoft\Windows\CurrentVersionInternetSettings\Connections

    NOTE:If present, this key will be populated with the name of the configured proxy
    server

    Back up the Connections key and then delete it
    Then restart CCMEXEC and Automatic Updates services


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, August 20, 2010 8:14 AM
  • Hi,

    I did the above changes, but still i see the same error in WUAHandler.log.

    Regards,

    SB

    Friday, August 20, 2010 4:38 PM
  • Hi,

    As you didn't use proxy server for your clients, make sure that WinHTTP is not configured to use a proxy, then run this command:

    proxycfg -d


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 23, 2010 9:12 AM
  • Hi,

    I have done this earlier. But no use, i am still getting the same error.

    This has now become a big issue for us, close to 800+ machines are not able to scan, due to which the Patch Compliance is affecting badly. We have to patch these machines for last month released update ASAP.

    Please help... ...

    Regards,

    SB

    Monday, August 23, 2010 7:02 PM
  • Hi,

    Please post the lastes messages in WUAHandler.log & UpdatesHandler.log on the problematic client.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 25, 2010 3:04 AM
  • Hi,

    Below are the output from WUAHandler.log

    Its a WSUS Update Source type ({6D66A49C-176A-4F4F-800A-D1D715643330}), adding it.

    Existing WUA Managed server was already set (http://SERVER.FQDN:80), skipping Group Policy registration.

    Added Update Source ({6D66A49C-176A-4F4F-800A-D1D715643330}) of content type: 2

    Async searching of updates using WUAgent started.

    Async searching completed.

    OnSearchComplete - Failed to end search job. Error = 0x80244018.

    Scan failed with error = 0x80244018.

     

    UPDATESHANDLER.LOG

    Service startup notification received

    CUpdatesAgent::FinalConstruct entered

     

    Regards,

    SB

     

    Thursday, August 26, 2010 1:31 PM
  • Hi All,

    Any thoughts on this issue...?

     

    Regards,

    SB

    Monday, September 06, 2010 5:18 AM
  • Hi,

    I have the same issue. It was solved by running netsh winhttp reset proxy command. Client was then able to detect assigment and start installation.

    Regards

    DD

    • Proposed as answer by m0u333 Thursday, April 14, 2011 3:16 AM
    Monday, January 17, 2011 11:38 AM
  • Do you still have this issue or already resolved?


    Anoop C Nair
    Monday, January 17, 2011 12:31 PM