none
SCCM New Program Notifications

    Question

  • Hi,

    I have come across a issue with a new program we are rolling out regarding the new program notifications that are displayed on a users computer.  I have not encountered this before and do not know, and cannot seem to find any documentation to say this is either a bug or by design but the ballon informing a user that a new program is available does not appear on a machine for a program that has a previous advertisement ran.  So, we are doing some testing for a new application that we are deploying and we want the user to be informed via a sys tray notification that it is avaiable and also set a mandatory run time for 5 days in the future.  We do want the users to be able to run the program before the deadline if they wish

    Program notifications are enabled in the Software deployment client agent settings, and the program DOES NOT have the supress program notifications checked.  The advertisement has "Allow users to run the program independatly of assignments" and also "Display reminders according to the client agent reminder settings" enabled.  The first time this advertisement is targeted to a client it shows the ballon and everything works fine.  However, if we create a new advertisement with the same settings, to the same collection accept changing the Program re-run to always re-run program no notification is displayed on the client.  We are constantly amending the program we are deploying so are having to create new advertisments to test the rollout.  Am I right in thinking that the ballon notifications should always be diplayed or does SCCM supress them because it has already displayed them for this program previously?

    Thanks in advance

    Brian

    Monday, May 16, 2011 10:17 AM

Answers

  • Hi Brian,

     

    Clients may not get New Program is Available pop-up systray notifications in ConfigMgr even though the Display a Notification Message option is checked in the Admin Console.

     

    The New Program notification for clients is controlled by two Policy entries, and if either is set FALSE then the new program pop-up will not show:

     

    CCM_ClientAgentConfig/DisplayNewProgramNotification

    CCM_SoftwareDistributionClientConfig/DisplayNewProgramNotification

     

    The problem is that through the Admin Console it is relatively easy to get the policy into a state where DisplayNewProgramNotification becomes set to false under CCM_ClientAgentConfig even though the notification option is enabled in the UI.

     

    Run WBEMTEST query to determine if either of the ClientConfigs is set to FALSE:

     

    Connect to root\ccm\policy\machine select * from CCM_SoftwareDistributionClientConfig

    Double click the one row that is returned (note if there is more than one), click

    Show MOF and review the setting for DisplayNewProgramNotification.

     

    Also run this for the following query:

    Connect to root\ccm\policy\machine

    select * from CCM_ClientAgentConfig

    Double click the one row that is returned (note if there is more than one), click

    Show MOF and review the setting for DisplayNewProgramNotification.

     

    If either of these has DisplayNewProgramNotification set to FALSE, then as a work-around you can do the following:

     

    After the Notifications are re-enabled in Advertised Programs Client Agent Properties make a change in Computer Client Agent as well, such as changing the org name. This then forces the ClientAgentConfig policy to update.

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 18, 2011 9:23 AM