none
Service is marked as an interactive service - Event 7030

    Question

  • We are receiving an error in SCE 2010 that states:

    The BGInfo service is marked as an interactive service.  However, the system is configured to not allow interactive services.  This service may not function properly.

    What is the appropriate way to deal with this issue?  This service writes user specific information to the screen, and we wish to continue using it.  Do we create an Override for this specific error?  Is there an update or configuration setting that we can make to allow the use of this service without racking up errors in SCE?

    Thanks!

    David

    Thursday, November 04, 2010 10:56 PM

Answers

  • i have bginfo here and it's in the startup folder so it refreshes during a logon.  Not sure what's the best method for you to use.  You can override the rule in sce no problem if that's the route you want to take.  There's a registry hack to make the system ignore some services as interactive, but I didn't read too far down into it. 
    Ok, so I changed my name...you can still call me Tom if you like. It's a...jump...to conclusions...mat.
    Tuesday, November 09, 2010 5:37 PM

All replies

  • are you seeing this in the active alerts pane?  Can you post the whole error?
    Ok, so I changed my name...you can still call me Tom if you like. It's a...jump...to conclusions...mat.
    Friday, November 05, 2010 1:43 PM
  • Hi Tim,

    Unfortunately, that was the bulk of the error.  Here is the detail that is displayed on the Alert Properties dialog for this error:

    ======

    General tab–

    Service entered unpredictable state

    Alert Source: Microsoft Windows Server 2008 R2 Enterprise

    Severity: Critical

    Priority: Medium

    Age: 1 Day, 15 Hours, 24 Minutes

    Repeat Count: 39

    Alert Description: The BGInfo service is marked as an interactive service.  However, the system is configured to not allow interactive services.  This service may not function properly.

     

    Alert Context tab-

    Date and Time: 11/5/2010 7:48:48am

    Log Name: System

    Source: Service Control Manager

    Event Number: 7030

    Level: 1

    Logging Computer: svfr06.shs.loc

    User: N/A

    Description: The BGInfo service is marked as an interactive service. However, the system is configured to not allow interactive services. This service may not function properly.

    ===========

    I hope this helps.

    Thank you for your assistance!

     

    David

    Friday, November 05, 2010 4:06 PM
  •  

    Hi,

     

    Regarding the error, please try the methods in the following document:

     

    Event ID 7030 — Basic Service Operations

    http://technet.microsoft.com/en-us/library/cc756339(WS.10).aspx

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, November 08, 2010 9:55 AM
  • Thank you Nicholas,

    I have seen this article, but the problem with BGInfo is that it does not show in the Services view. 

    BGInfo needs to write data to the desktop/wallpaper, so setting it to not interact with the desktop would prevent it from working correctly, wouldn't it?

     

    Thanks for any your assistance.

     

    David

    Tuesday, November 09, 2010 3:48 AM
  • did you use the /all parameter when you installed bginfo?  /all will install as a service instead of the exe running at startup.
    Ok, so I changed my name...you can still call me Tom if you like. It's a...jump...to conclusions...mat.
    Tuesday, November 09, 2010 2:58 PM
  • Thanks Tim,

    My guess is it was not installed with the /all switch.  So, this begs two questions; first, if it is not installed as a service, why does SCE think it is and can we just override the rule, second, if we reinstall BGInfo and becomes a service, will it run correctly if we check the box that does not allow it to interact with the desktop?

     

    Thanks again for the assistance!!!

     

    David

    Tuesday, November 09, 2010 3:06 PM
  • i have bginfo here and it's in the startup folder so it refreshes during a logon.  Not sure what's the best method for you to use.  You can override the rule in sce no problem if that's the route you want to take.  There's a registry hack to make the system ignore some services as interactive, but I didn't read too far down into it. 
    Ok, so I changed my name...you can still call me Tom if you like. It's a...jump...to conclusions...mat.
    Tuesday, November 09, 2010 5:37 PM