none
Default management pack in SCOM R2 corrupted

    Question

  • Hi

    While I am editing the default management pack in notepad it’s corrupted. We are using SCOM R2 with CU4. From the backup I have restored the file. (The backup file I have took 4 months ago.) After this there are lots of changes to the environment in respect of MP. We have imported new mp. Is there will be any problem will arise because of this?

    Regards

    Donald D'souza

    Monday, July 18, 2011 6:19 PM

Answers

All replies

  • Hi Donald

    In theory, this shouldn't be a problem as changes should never be made to the default management pack. In practice, if changes have been made then I'd keep an eye on the OperationsManager event log for errors that might relate to Management Pack issues.

    I would suggest then whenever you export any unsealed management pack for editing in notepad (or in the Authoring console for that matter), that the first thing anyone does is take a copy of the original exported xml file and store it somewhere safe. That way, if something does go horribly wrong with the editing, there is still a good copy available.

    Cheers

    Graham


    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/
    Monday, July 18, 2011 7:29 PM
    Moderator
  • Remember that also you shouldn't touch Default Management Pack at all. No overrides, monitors, rules etc. should be kept there. This is ok from technical point of view but not the best practice.
    R.E.M. - YEAH!
    Monday, July 18, 2011 8:14 PM
  • Hi Graham

    I accidentally edited the default management pack(thinking i have a copy of the file). I have checked and getting every 10 minutes the below error in opsmgr event viewer.

    Event Type:    Warning
    Event Source:    OpsMgr Config Service
    Event Category:    None
    Event ID:    29105
    Date:        7/18/2011
    Time:        11:34:26 PM
    User:        N/A
    Computer:    IND-Ap142
    Description:
    The request for management pack identified by version independent identity "5cdfa10f-8b58-9bfd-4fd1-99b4d78e8a4b" and version dependent identity "b1678741-5b0c-49fc-a761-bb6f1b9ca5a8" requested by agent "0abd95a3-a88f-71ad-43f3-cb7820720d81" failed due to the following exception ": Cannot find management pack with version dependent id: b1678741-5b0c-49fc-a761-bb6f1b9ca5a8 in the database.
    Empty rowset returned from the database. Management pack cannot be loaded.".

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Help us to resolve this issue.

     

    Regards

    Donald D'souza

     

    Tuesday, July 19, 2011 7:08 AM
  • Is it always the same agent ID that is reported by the eventlog message?
    Regards,
    Marc Klaver
    http://jama00.wordpress.com/
    Tuesday, July 19, 2011 7:47 AM
  • Hi Donald

    Just to add to Marc's post - you can find out which agent is actually "generating" the event by looking at the event message - "requested by agent "0abd95a3-a88f-71ad-43f3-cb7820720d81"

    Use the GUID in the following query against the OperationsManager database:

    use operationsmanager
    go
    select DisplayName from MT_HealthService where BaseManagedEntityId = '0abd95a3-a88f-71ad-43f3-cb7820720d81'
    


    If it is just the one agent that is generating this problem then you could then try to flush the health service on this agent:

    - stop the system center management service

    - rename the \program files\system center operations manager 2007\Health Service State folder

    - start the system center management service

    Let us know how you get on.

    Cheers

    Graham 


    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/
    Tuesday, July 19, 2011 8:14 AM
    Moderator
  • Hi Graham

     

    I have executed the above query against OperationsManager database but getting the error as below

    Msg 207, Level 16, State 1, Line 1
    Invalid column name 'DisplayName'.

    Help us to resolve the issue.

    Regards

    Donald D'souza

     

    Tuesday, July 19, 2011 2:30 PM
  • Hi Donald

    Can you try the following instead:

    use operationsmanager
    go
    select * from MT_HealthService where BaseManagedEntityId = '0abd95a3-a88f-71ad-43f3-cb7820720d81'
    
    

    Cheers

    Graham


    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/
    Tuesday, July 19, 2011 4:04 PM
    Moderator
  • Hi Graham

    I tried above query and the got the below output. But unable to find the agent name which is causing the issue. Help us on this.

     

    BaseManagedEntityId RequestCompression MaximumSizeOfAllTransfereedFiles Port IsRHS InstallTime HeartbeatEnabled CreateListener MaximumQueueSize PatchList IsManuallyInstalled IsAgent AuthenticationName ActiveDirectoryManaged Version InstalledBy ActionAccountIdentity ProxyingEnabled HeartbeatInternal IsGateway DisplayName_55270A_AC47_C853_C617_236B0CFF9B4C IsManagementServer
    0ABD95A3-A88F-71AD-43F3-CB7820720D81 1 NULL NULL 0 12/6/2007 23:24 NULL 0 104857600 Cumulative Update 2 for Operations Manager 2007 R2 (KB979257);  0 1 NULL 0 6.1.7221.0 PROD\ind1 SYSTEM NULL NULL 0 NULL 0

     

    Regards

    Donald D'souza

    Tuesday, July 19, 2011 4:42 PM
  • hi Donald

    Try this:

    Use OperationsManager

    Go

    Select DisplayName, Path, basemanagedentityid from basemanagedentity where basemanagedentityid = '0abd95a3-a88f-71ad-43f3-cb7820720d81'

    I had tested my original query but on SCOM2012 and it would seem that some of the tables have changed between versions. This one should work on SCOM 2007 R2.

    Cheers

    Graham


    New SCOM 2012 Blog! - http://www.systemcentersolutions.com/blog/
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/
    • Marked as answer by Donald Dsouza Friday, July 22, 2011 2:15 PM
    Friday, July 22, 2011 8:09 AM
    Moderator
  • Hi Graham

    Using above query I am able to get the agent details which is the culprit creating the Event ID: 29105 issue. I have renamed the Health Service State folder but its not getting the mp details from the RMS sever. I have reinstalled the agent and it worked.

    Thanks for your help Graham

    Regards

    Donald D;souza

    Friday, July 22, 2011 2:15 PM