none
Have no measure

    Question

  • Hi all,

    I actually encountered an issue probably due to memory leak on one of ours Windows Server 2008 R2 SP1. After some explorations, the measure of "Memory Performance\Pool nonpaged bytes" will be very helpful to intentify this possible memory leak.

    Unfortunately, in my SCE Essentials 2010, when I look to this measure  in "Analysis\Microsoft Windows Server\Performance\Memory usage (physical)", I can get anything about "Memory Performance\Available Megabytes", but nothing about "Memory performance\Pool paged bytes" or "Memory performance\Pool nonpaged bytes".

    Would you have an idea about why I can't obtain these measures ?

    Thanks.


    FXE
    Tuesday, January 17, 2012 5:42 PM

Answers

  • Hello FXE,

    This is because by default these two performance collection rules are disabled.

    If you want those you can go to SCE console - Authoring - Management Pack Objects - Rules. Search for "Pool paged" (for the first one) and you will see the disabled (grey) collection rules. You can override for windows server 2008 operating system. Same thing for the pool "non-paged bytes". SO if you enable (override) those you will see the data.

    For further information, please see the following document:

    System Center Monitoring Pack for Windows Server Operating System
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=9296

    Thanks,


    Yog Li

    TechNet Community Support

    • Marked as answer by FXE Thursday, January 19, 2012 5:25 PM
    Thursday, January 19, 2012 9:53 AM
    Moderator

All replies

  • Hello FXE,

    This is because by default these two performance collection rules are disabled.

    If you want those you can go to SCE console - Authoring - Management Pack Objects - Rules. Search for "Pool paged" (for the first one) and you will see the disabled (grey) collection rules. You can override for windows server 2008 operating system. Same thing for the pool "non-paged bytes". SO if you enable (override) those you will see the data.

    For further information, please see the following document:

    System Center Monitoring Pack for Windows Server Operating System
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=9296

    Thanks,


    Yog Li

    TechNet Community Support

    • Marked as answer by FXE Thursday, January 19, 2012 5:25 PM
    Thursday, January 19, 2012 9:53 AM
    Moderator
  • Hello Yog and thank you for your answer.

    I overrided the "non-paged bytes" to "true" for "Windows Server".

    This parameter seems don't take effect immediately, I don't see anything in the measures.

    Could I do anything else ?

    Thank you.


    FXE
    Thursday, January 19, 2012 2:57 PM
  • OK I've found the solution. I didn't override the good rule : I overrided the "Octets de réserve non paginée de la mémoire" (my SCE is a french version) and it seems have no effect.

    So I overrided the "Memory Pool non-paged Bytes 2008" and now it's running.

    I don't know why the french rule don't run...

    Thank you.


    FXE
    Thursday, January 19, 2012 5:25 PM
  • Hello FXE,

    Glad to hear the issue resolved.

    I assume "Octets de réserve non paginée de la mémoire" only works for Windows Server 2003 or previous version?

    Thanks,


    Yog Li

    TechNet Community Support

    Friday, January 20, 2012 8:23 AM
    Moderator