none
Customized View Not Saving Data Fields

    Question

  • Greetings,

    I am using SCSM 2010 for my business. I have customized several fields in both the Knowledge Article and Computer Form forms and imported them through a customized management pack. For example, I created a “Version” field in the Knowledge Article form that is an empty text box that allows users to input text. However, every time I try and add text to that field in the console and click Apply>Save, the field shows up empty next time the form is open. The same is happening for every field that I added to each of these forms (several are text box, one is date picker, and two are lists). No input is saving on any field that I have added or replaced. Am I missing a step when customizing and importing my own management pack? I have restarted the console several times.

    Thanks,

    Tim

     

    Monday, January 30, 2012 8:16 PM

All replies

  • Hi,

    All these new fields needs to be bound to a property. You would need to extend the Knowledge and Computer class with these new properties and then you could bind the fields to the new properties.

    Take a look here:
    http://blogs.technet.com/b/servicemanager/archive/2010/09/27/adding-a-customer-property-to-the-incident-class-and-form.aspx

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    Monday, January 30, 2012 8:24 PM
    Moderator
  • I am going into the authoring tool and extending the Windows Computers form. I add the fields, for example a Flash Memory field with integer data type. I then go into the Computer form and customize it. I add the text box, add the label, and bound it to the field I created in the extension. The field is showing up in the form, as well as the extension tab at the top of the computer form. However, when I input data, it does not save in the form (only in the extension tab).

    The knowledge article worked and is running smooth, inputs saving and all.

    Any suggestions?

     

    Monday, January 30, 2012 10:35 PM
  • Okey - how is the binding mode for those fields configured? Try setting them to two-way.

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    Tuesday, January 31, 2012 8:07 AM
    Moderator
  • The binding was at default, I also tried two-way. Both of those did not work (I also tried binding directly to source to no avail). I am extending the Windows Computer class, I assume that is the right class because when I go to bind the text box my extended class fields show up in the menu for selection.

    Have any other ideas?

    Wednesday, February 01, 2012 5:36 PM
  • Just to make sure - you restarted your console inbetween importing and testing the changes to bindings? This is one of the things that requires a restart of the console.

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se

    Tuesday, February 07, 2012 9:27 AM
    Moderator