none
How to configure PXE in SCCM

    Question

  • Hi

     

    I can`t start  my Windows Vista installation with pxe boot. When running with Network boot "CD" everything works great. This is what I have done so far

     

    SCCM is installed on a Win2003 box with SP2 WDS and PXE service point installed. Boot Image is distributed to SMSPXEIMAGES$ "distribution point". PXE/WDS server is installed on a separate machine from the DHCP server but in the same subnet, clients are on a separate subnet I am using DHCP option 66 "WDS servername" and Option 67 with path to smsboot\x86\pxeboot.com is that right path???

     

    In the future we are going to use IP helper-adress on the router instead which is the recommended way to implement PXE MS say.

     

    So my main question here is what kind of configuration do I need to do to get PXE working if any? I can`t find any good documentation about PXE/WDS with SCCM.

     

     

    Here is the error code i recieve after getting an IP-apdress in the PXE boot

     

    Windows Boot Manager  (Server IP: XXX.XXX.XXX.XXX) "SCCM serverns IP adress"

     

    Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:

     

    1. Insert you Windows installation disc and restart your computer..

    2. Choose your language settings, and then click next.

    3. Click repair you computer

     

    File: \Boot\BCD

     

    Status: 0xc000000f

     

    Info: An error occured while attempting to read the boot configuration  data.

     

    Thanks

     

     

    Wednesday, September 26, 2007 7:11 AM

Answers

  • You do not need to configure the WDS server. The SMS PXE is a provider in WDS. It does not have to be configured in WDS.

     

    Try this:

    1. Remove the SMS PXE role. Look at the PXESetup.log file to verify that the uninstall is complete and successful.

    2. Uninstall the WDS server.

    3. Reboot the machine.

    4. Re-install the WDS server, but "do not configure it". Do nothing at all other than installing WDS.

    5. Add the SMS PXE role. Look at the PXESetup.log file to verify that the installation is complete and successful.

    6. Add the boot images to the SMS PXE DP share. Look at the distmgr.log file to verify that the replication of the boot image to the DP is complete and successful.

    7. Try booting a PXE client.

    Wednesday, September 26, 2007 4:58 PM
  • Hello

    Have you made the required boot images available on a standard distribution point accessible to the target computer?  You have to add boot images to both the PXE DP and a standard Configuration Manager 2007 distribution point.

     

    Have you imported the target computers into the Configuration Manager 2007 database?

     

    Dan

     

    Friday, October 12, 2007 6:07 PM
  • Adding the ip helper address worked for us using both pxe and ADS. but we also ran into some issues and had to make sure the cisco switches we were using were running at least 12.3 for IOS.  Also my cisco admins flipped out at changing the orginal ip helper address. they did not know that you can mutliple ip helper address statements.  just make sure the dhcp is first if you have the pxe running on a different box.

    Thursday, October 25, 2007 10:45 PM

All replies

  • You do not need to configure the WDS server. The SMS PXE is a provider in WDS. It does not have to be configured in WDS.

     

    Try this:

    1. Remove the SMS PXE role. Look at the PXESetup.log file to verify that the uninstall is complete and successful.

    2. Uninstall the WDS server.

    3. Reboot the machine.

    4. Re-install the WDS server, but "do not configure it". Do nothing at all other than installing WDS.

    5. Add the SMS PXE role. Look at the PXESetup.log file to verify that the installation is complete and successful.

    6. Add the boot images to the SMS PXE DP share. Look at the distmgr.log file to verify that the replication of the boot image to the DP is complete and successful.

    7. Try booting a PXE client.

    Wednesday, September 26, 2007 4:58 PM
  • I have done exectly what you discribe and I still get that error.

    Thursday, September 27, 2007 11:41 AM
  • And what do you see in the SMSPXE.log file regarding the client that is trying to boot?

    Thursday, September 27, 2007 2:56 PM
  • Hi

     

    Thank you for the answer unfortanely it didnt solve my problem exactly the same error after doing what you said. I am going to check the log file smspxe you mentioned.

     

    What about dhcp option 67 what path should i define I think smsboot\x86\pxeboot.com ?

     

    I have also tried PXE booting on the same subnet as the PXE and DHCP server without DHCP options then the client don't get any IP adress?

    Thursday, September 27, 2007 3:16 PM
  • You should not configure WDS at all. If you have, that might be the root the problem. All you need to do is install WDS (then don't touch it) and then install the SMS PXE role.

    Thursday, September 27, 2007 3:50 PM
  • Hi

    I haven't configured anything now neither in WDS or in DHCP options.

     

    This is what I see in SMSPXE.log I have marked some sections in red that I belive are important. I have also seen that that device is found in database look in section 2 for that

     

     

    Logfile section 1

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    <![LOG[Policy Provider settings flushed due to registry change
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:255">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\Identification:
    SMS Site Settings:
     Server: APHK-PACK
     SiteCode: C01
     Parent SiteCode: <empty>
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:348">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    PXE Settings:
        IsActive: Yes
        ResponseDelay: 0
        CacheExpire: 3600
        HTTP Port: 80
        HTTPS Port: 443
        IISSSLState: 0x0
        BindPolicy: Exclude <empty>
        TRK: <non empty>
        SiteSignCert: <empty>
        Root CA Certs: <empty>
        PXE GUID: 3473d9a9-f0aa-403a-b3f6-7076e238a924
        PXEPassword: <empty>
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:506">
    <![LOG[Loaded TFTP settings from reg key HKLM\SYSTEM\CurrentControlSet\Services\TFTPD\Parameters:
    TFTP Settings:
     Directory: F:\RemoteInstall
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:667">
    <![LOG[Loaded Database settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    Database Settings:
     Server: APHK-PACK
     Database: SMS_C01
     User: <empty>
     Password: <empty>
     Use Integrated Security: No
     Impersonation Required: No
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:834">
    <![LOG[PXE Provider Settings Changed]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:291">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\Identification:
    SMS Site Settings:
     Server: APHK-PACK
     SiteCode: C01
     Parent SiteCode: <empty>
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:348">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    PXE Settings:
        IsActive: Yes
        ResponseDelay: 0
        CacheExpire: 3600
        HTTP Port: 80
        HTTPS Port: 443
        IISSSLState: 0x0
        BindPolicy: Exclude <empty>
        TRK: <non empty>
        SiteSignCert: <empty>
        Root CA Certs: <empty>
        PXE GUID: 3473d9a9-f0aa-403a-b3f6-7076e238a924
        PXEPassword: <empty>
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:506">
    <![LOG[Loaded TFTP settings from reg key HKLM\SYSTEM\CurrentControlSet\Services\TFTPD\Parameters:
    TFTP Settings:
     Directory: F:\RemoteInstall
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:667">
    <![LOG[Loaded Database settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    Database Settings:
     Server: APHK-PACK
     Database: SMS_C01
     User: <empty>
     Password: <empty>
     Use Integrated Security: No
     Impersonation Required: No
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:834">
    <![LOG[Executing PxeGetCert(3473d9a9-f0aa-403a-b3f6-7076e238a924)]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="database.cpp:743">
    <![LOG[CDatabaseProxy :: GetPxeCert succeeded: 3473d9a9-f0aa-403a-b3f6-7076e238a924 \\APHK-PACK <non empty>]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="database.cpp:815">
    <![LOG[Loaded PXE settings from DB:
        PXE Cert: <non empty>
    ]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="provsettings.cpp:561">
    <![LOG[No need to check cert]LOG]!><time="12:00:45.656+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="700" file="certhdl.cpp:122">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2e2ed6c]LOG]!><time="12:01:03.313+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[Executing LookupDevice(46746E94-D140-497A-8C46-5463A8F006FD, FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF)]LOG]!><time="12:01:03.313+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:395">
    <![LOG[CDatabaseProxy :: LookupDevice succeeded: 0 0 0 0]LOG]!><time="12:01:03.313+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:445">
    <![LOG[MAC=FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF SMBIOS GUID=46746E94-D140-497A-8C46-5463A8F006FD > Device not found in the database.]LOG]!><time="12:01:03.313+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="pxehandler.cpp:335">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2e2fe24]LOG]!><time="12:06:03.317+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[Executing LookupDevice(46746E94-D140-497A-8C46-5463A8F006FD, FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF)]LOG]!><time="12:06:03.317+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:395">
    <![LOG[CDatabaseProxy :: LookupDevice succeeded: 0 0 0 0]LOG]!><time="12:06:03.317+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:445">
    <![LOG[MAC=FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF SMBIOS GUID=46746E94-D140-497A-8C46-5463A8F006FD > Device not found in the database.]LOG]!><time="12:06:03.317+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="pxehandler.cpp:335">

    Logfile Section 2

     

     

    <![LOG[Policy Provider settings flushed due to registry change
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:255">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\Identification:
    SMS Site Settings:
     Server: APHK-PACK
     SiteCode: C01
     Parent SiteCode: <empty>
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:348">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    PXE Settings:
        IsActive: Yes
        ResponseDelay: 0
        CacheExpire: 3600
        HTTP Port: 80
        HTTPS Port: 443
        IISSSLState: 0x0
        BindPolicy: Exclude <empty>
        TRK: <non empty>
        SiteSignCert: <empty>
        Root CA Certs: <empty>
        PXE GUID: 3473d9a9-f0aa-403a-b3f6-7076e238a924
        PXEPassword: <empty>
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:506">
    <![LOG[Loaded TFTP settings from reg key HKLM\SYSTEM\CurrentControlSet\Services\TFTPD\Parameters:
    TFTP Settings:
     Directory: F:\RemoteInstall
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:667">
    <![LOG[Loaded Database settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    Database Settings:
     Server: APHK-PACK
     Database: SMS_C01
     User: <empty>
     Password: <empty>
     Use Integrated Security: No
     Impersonation Required: No
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:834">
    <![LOG[PXE Provider Settings Changed]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:291">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\Identification:
    SMS Site Settings:
     Server: APHK-PACK
     SiteCode: C01
     Parent SiteCode: <empty>
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:348">
    <![LOG[Loaded PXE settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    PXE Settings:
        IsActive: Yes
        ResponseDelay: 0
        CacheExpire: 3600
        HTTP Port: 80
        HTTPS Port: 443
        IISSSLState: 0x0
        BindPolicy: Exclude <empty>
        TRK: <non empty>
        SiteSignCert: <empty>
        Root CA Certs: <empty>
        PXE GUID: 3473d9a9-f0aa-403a-b3f6-7076e238a924
        PXEPassword: <empty>
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:506">
    <![LOG[Loaded TFTP settings from reg key HKLM\SYSTEM\CurrentControlSet\Services\TFTPD\Parameters:
    TFTP Settings:
     Directory: F:\RemoteInstall
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:667">
    <![LOG[Loaded Database settings from reg key HKLM\Software\Microsoft\SMS\PXE:
    Database Settings:
     Server: APHK-PACK
     Database: SMS_C01
     User: <empty>
     Password: <empty>
     Use Integrated Security: No
     Impersonation Required: No
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:834">
    <![LOG[Executing PxeGetCert(3473d9a9-f0aa-403a-b3f6-7076e238a924)]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="database.cpp:743">
    <![LOG[CDatabaseProxy :: GetPxeCert succeeded: 3473d9a9-f0aa-403a-b3f6-7076e238a924 \\APHK-PACK <non empty>]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="database.cpp:815">
    <![LOG[Loaded PXE settings from DB:
        PXE Cert: <non empty>
    ]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="provsettings.cpp:561">
    <![LOG[No need to check cert]LOG]!><time="07:00:45.176+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="5668" file="certhdl.cpp:122">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2efcb14]LOG]!><time="07:01:03.082+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2efdbcc]LOG]!><time="07:06:03.086+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2efec84]LOG]!><time="07:11:03.090+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2effd3c]LOG]!><time="07:16:03.094+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2f00df4]LOG]!><time="07:21:03.098+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2f01eac]LOG]!><time="07:26:03.102+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[[127.000.000.001:4011] Recv From:[127.000.000.001:9000] Len:274 2f02f64]LOG]!><time="07:31:03.105+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6532" file="smspxe.cpp:663">
    <![LOG[Executing LookupDevice(46746E94-D140-497A-8C46-5463A8F006FD, FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF)]LOG]!><time="07:31:03.105+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:395">
    <![LOG[CDatabaseProxy :: LookupDevice succeeded: 41 1 0 0]LOG]!><time="07:31:03.105+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="database.cpp:445">
    <![LOG[MAC=FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF SMBIOS GUID=46746E94-D140-497A-8C46-5463A8F006FD > Device found in the database. MacCount=0 GuidCount=1]LOG]!><time="07:31:03.105+-120" date="10-05-2007" component="smspxe" context="" type="0" thread="6712" file="pxehandler.cpp:327">


     

    Friday, October 05, 2007 10:27 AM
  • Hello

    Have you made the required boot images available on a standard distribution point accessible to the target computer?  You have to add boot images to both the PXE DP and a standard Configuration Manager 2007 distribution point.

     

    Have you imported the target computers into the Configuration Manager 2007 database?

     

    Dan

     

    Friday, October 12, 2007 6:07 PM
  • I have the same message in my logs.  I have imported the target computer and also added the boot image to both PXE and CM DPs.  Anything else to look at?

     

    Thanks,

    Paul

    Wednesday, October 17, 2007 11:20 AM
  • At the beginning of this thread you said "DHCP server but in the same subnet, clients are on a separate subnet"

     

    PXE Protocol requires dhcp to be in same subnet (due to the MAC Address being used for all the initial handshakes) or a DHCP proxy to be setup (external to product)

    Thursday, October 18, 2007 11:47 PM
  • Please do not add your own DHCP options on your DHCP server ( option 66 "WDS servername" and Option 67 with path to smsboot\x86\pxeboot.com )

     

    the needed options will be added by the SCCM PXE reply.

    if you add these options yourself, then the correct path to the boot.bcd needed to boot will not be provided to the client and as such you will get the error you get.

     

    Marios

    Monday, October 22, 2007 10:27 AM
  • I don't think the highlighted MAC  and BIOS GUIDs are your booting device - I get the same messages - some other PXE broadcast on your network.

     

    (EDIT : MAC=FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF:FF SMBIOS GUID=46746E94-D140-497A-8C46-5463A8F006FD  - This is your SMS PXE point checking itself to see that it is working Smile  - look at pxecontrol.log - happens every 5 minutes )

     

     

    Immediately prior to your device being found you'll see something like - (use sms toolkit log viewer to watch smspxe.log):

    [010.001.104.060:67] Recv From:[000.000.000.000:68] Len:548 7689cc

    (where 010.001.104.060 is the IP of  my SMS server)

     

    Check the screen when you boot your device to get MAC and GUID to look for.

     

    You've got boot images - as you've said

    You've added you device with it's MAC or GUID

    Have you created a task sequence and advertised it to your manually added device ?

    Check Site Status - > Component Status - > SMS_PXE_SERVICE_POINT (all messages) for more info.

    This initially told me I didn't have boot images for the SMS service point.

     

    If you've made changes to WDS , PXE Service point etc after adding the boot images try removing them and adding them again - this worked for me.

     

    That's as far as i've got - it boots the PXE image - now to get the right drivers for my machine (I think)

     

    The MS documentation on this is sparse - to say the least - let's try help each other Smile

    Tuesday, October 23, 2007 8:57 AM
  • Hi

     

    Today we got PXE boot working when connected the client on the same subnet as the DHCP and PXE server.

     

    Hard to tell exactly which action how solved the problem. This is some of our actions

    • Reinstalled PXE and WDS
    • Installed PXE point and WDS with a account who had Domain Admins right
    • Added both X86 boot imagen and X64 Imagen to distribution points

    Now we only need to fix the network configuration so clients from different subnets than PXE and DHCP server can start PXE boot because that's not working.

     

    Perhaps we have to define a IP helper adress to PXE server in our switches or we can fix it through a DHCP option/setting

     

    Anyone know?

     

     

    Wednesday, October 24, 2007 6:48 PM
  • Adding the ip helper address worked for us using both pxe and ADS. but we also ran into some issues and had to make sure the cisco switches we were using were running at least 12.3 for IOS.  Also my cisco admins flipped out at changing the orginal ip helper address. they did not know that you can mutliple ip helper address statements.  just make sure the dhcp is first if you have the pxe running on a different box.

    Thursday, October 25, 2007 10:45 PM
  • Finally everything works we added IP helper adress for PXE server which solved the problem.

     

    Thanks for all your help

    Monday, October 29, 2007 8:50 AM
  • Dear All,
    i have the same senario but i have another error message

    PXE-T01: File not found
    PXE-E3B: TFTP Error - File Not Found

    Anyone know anything about this error????


    Please help
    Thursday, February 21, 2008 9:14 AM
  •  

    your issue seems different.

     

    please add both x86 & x64 boot images on your PXE DP.

     

    is you still have the issue, please check what files are in \remoteinstall\smsboot folder

     

    and also check for errors in smspxe.log (in the SMS_CCM dir)

     

    thanks

     

     

     

    Marios
    Thursday, February 21, 2008 5:01 PM
  • i already added the 2 boot images in the DP and this folder \remoteinstall\smsboot contains x86 and x 64 folders but these folder empty but it was has pxeboot files but now it's empty

    should i remove the 2 DHCP Options 66, 67?
    i need the full steps configuration on SCCM and on DHCP

    Thanks
    Saturday, February 23, 2008 8:57 AM
  • please remove the DHCP options 66, 67, as SCCM PXE will not work with these options set.

     

    if these folders are still empty, and you have deployed images to your SCCM PXE server, then we need to look at the issue of this failure. under normal circumstances, these folders should contail smsboot.com / wdsnbp.com and other files that come from the boot images.

     

    please look at the smspxe.log (under SMS_CCM\Logs dir) for errors.

     

    Marios

    Tuesday, February 26, 2008 1:12 PM
  • I removed DHCP Options 66 , 67 and checked again. The error this time also about the boot file name

     

    PXE-E53: No boot file name received

    ?????

    Thursday, February 28, 2008 8:03 AM
  • please check the smspxe.log for errors.

    also is there any files extracted to the remoteinstall\smsboot folder ?

     

    thanks

     

    Marios

    Wednesday, March 12, 2008 11:42 AM
  •  

    it's Empty
    Sunday, March 16, 2008 8:58 AM
  • I assume that you mean the directory is empty.

     

    In that case, I assume that you have deployed an x86 & x64 boot image to the PXE server.

    If so, and the directory above is still empty, check the log file for errors while extracting the boot image.

    this will be an error during the start of the process (restart the service to cause the error again).

    we have seen some errors during the extraction process and this was due to some weird ACLs inherited to the windows temp folder. delete the files mentioned there in that case.

     

    Marios

    Monday, March 17, 2008 12:27 PM
  • My SMSBoot folder has no .com files present. When I update the pxe and management points, the following error is in the smspxe.log:

     

     

    <![LOG[Boot image SMSPKG\PGN00028 has changed since added]LOG]!><time="15:15:07.481+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="bootimagemgr.cpp:904">
    <![LOG[Opening image file C:\RemoteInstall\SMSImages\SMSPKG\PGN00028\boot.PGN00028.wim]LOG]!><time="15:15:09.232+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="wimfile.cpp:255">
    <![LOG[Found Image file: C:\RemoteInstall\SMSImages\SMSPKG\PGN00028\boot.PGN00028.wim
           PackageID: SMSPKG\PGN00028
         ProductName: Microsoft® Windows® Operating System
        Architecture: 0
         Description: Microsoft Windows Vista PE (x86)
             Version: 
             Creator:
           SystemDir: WINDOWS
    ]LOG]!><time="15:15:09.963+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="bootimagemgr.cpp:715">
    <![LOG[Closing image file C:\RemoteInstall\SMSImages\SMSPKG\PGN00028\boot.PGN00028.wim]LOG]!><time="15:15:09.963+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="wimfile.cpp:291">
    <![LOG[Mutex was not owned. Now have ownership.]LOG]!><time="15:15:09.963+300" date="03-18-2008" component="smspxe" context="" type="0" thread="860" file="TSBoot.h:671">
    <![LOG[Unable to delete directory C:\WINDOWS\TEMP\PXEBootFiles\Windows\Boot\PXE (0x80070005).  Continuing.]LOG]!><time="15:15:13.176+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="ccmfile.cpp:992">
    <![LOG[Unable to delete directory C:\WINDOWS\TEMP\PXEBootFiles\Windows\Boot (0x80070005).  Continuing.]LOG]!><time="15:15:13.176+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="ccmfile.cpp:992">
    <![LOG[Unable to delete directory C:\WINDOWS\TEMP\PXEBootFiles\Windows (0x80070091).  Continuing.]LOG]!><time="15:15:13.176+300" date="03-18-2008" component="smspxe" context="" type="1" thread="860" file="ccmfile.cpp:992">
    <![LOG[Warning: Failed to copy the needed boot binaries from the boot image C:\RemoteInstall\SMSImages\SMSPKG\PGN00028\boot.PGN00028.wim.
    Cannot create a file when that file already exists. (Error: 800700B7; Source: Windows)]LOG]!><time="15:15:13.176+300" date="03-18-2008" component="smspxe" context="" type="3" thread="860" file="bootimagemgr.cpp:1060">

     

     

    The Windows\Temp\pxebootfiles does not exist. Should it? Or is this a red herring? I

    Tuesday, March 18, 2008 8:36 PM
  •  

    exactly the problem I was referring to.

    you seem to get an access denied.

     

    this is a temporary directory created while extracting the boot image.

    what antivirus program are you running ? can you try disabling for a minute and see if restarting the service succeeds creating these files.

     

    also, can you check the ACLs on the temp directory. LocalSystem account should have write access.

    is there anything weird in the ACLs ?

     

    hope this helps

     

    Marios

     

     

    Tuesday, March 18, 2008 9:20 PM
  • Hi Marios,

     

    I sincerely hope this helps. I had the exact same issue ... spent 2 days removing/reinstalling, going through all the checks (also  disabling AV - McAfee Enterprise in our case) to no avail. I finished by reinstalling the server from  scratch today and every works like a charm now.

     

    Although, I which I had checked the ACL's on the Temp folder first

     

    Cheers,

    Serge

    Tuesday, March 18, 2008 10:14 PM
  • Marios,

     

    Thanks for the help. The problem was goofy ACLs on the c:Windows\temp\pxebootfiles. When I attempted to revised security, I got an Access is Denied message. Once the above directory was deleted, the SMSBoot folder would populate when the bootimage was refreshed on the PXE point.

     

    Thanks!

     

    Wednesday, March 19, 2008 1:49 PM
  • Hey everyone,

     

    I am having this problem with the PXE client, however i have NO ERRORS (that i can see) in my SMSPXE log.

     

    I have a \SMSBoot\x86 directory that is populated correctly...

     

    I don't know where to go from here... google is coming up short

     

    Wednesday, June 11, 2008 6:31 PM
  • I have this issue with boot up across another VLAN...was there any other solutions?

     

    my smsboot folder, has files populate, no errors in logs.

     

    After removing option 66/67 from DHCP:

     

    PXE-E53 - no bootfile

    Thursday, August 14, 2008 1:18 PM
  •  

    I have this issue with boot up across another VLAN...was there any other solutions?

     

    my smsboot folder, has files populate, no errors in logs.

     

    After removing option 66/67 from DHCP:

     

    PXE-E53 - no bootfile

    Thursday, August 14, 2008 1:53 PM
  • I am having the same issue at one of my sites. I have removed the 66&67 options from DHCP.

     

    The server is seeing some requests from my test machine, but I get the no bootfile error as well.

     

    I have a sneaking suspicion that this may be related to ip helper-address settings in the router. There is an entry for the DHCP server, one for my PXE point, and one that points to an address that does not ping. Anyone have any experience similar to this?

     

    Thanks,

    Jason

     

    Wednesday, October 01, 2008 4:53 PM
  •  

    I also had this issue for quite a while. When I was thinking about it the only possible sollution could be in the boot images. They might even be corrupted or something. Well what I did was after reinstalling WDS and PXE service points several times I had made a second install of sccm on a virtual pc within a test enviroment just one dc and one sccm. I than copied the standard boot files from the new installation to my sccm primary server and created both boot images with them. After I made a new task sequence and advertised it I was able to boot and deploy fine. Don't forget to add the hw address of the nic to the sccm database otherwise it will never work. But I also believer that that is another error.

     

    Hope this helps good luck

     

    Thursday, October 30, 2008 7:34 PM
  • Also struggled with this for a while but have now got it working.

    SCCM Server (R2): Removed PXE service point & WDS. Rebooted & reinstalled WDS (no configuration) and PXE service point.

     

    SCCM: Made sure that I had both x86 & x64 at both the regular & PXE DPs.

    I had imported the computer using MAC address and added to collection to which the task sequence was being added.

     

    DHCP Server: Just added Option 60 with PXEClient as the string. No option 66/67.

     

    No mention of Option 60 in the other posts but it didn't work without that for me. I guess you don't need it if you have IP helpers configured on the routers - maybe someone can clarify?

     

    Thanks

     

    Muro.

     

    Friday, November 07, 2008 10:56 AM
  •  

    I'm curious. Is there any documentation that says you can use PXE that is running on a unix server and NOT the PXE installed with MDT or WDS?

     

    Brad.

    Tuesday, November 25, 2008 7:14 AM
  • Just to clarify my earlier post.

    The DHCP option 60 only worked when SCCM  and DHCP were on the same server. This was true in the test environment. In production, where the DHCP server was a different server on a different subnet I put no options in DHCP and an IP helper on the router.

     

    SCCM Server (R2): Removed PXE service point & WDS. Rebooted & reinstalled WDS (no configuration) and PXE service point.

     

    SCCM: Made sure that I had both x86 & x64 at both the regular & PXE DPs.

    I had imported the computer using MAC address and added to collection to which the task sequence was being added.

    All worked after this.

     

    Tuesday, November 25, 2008 9:51 AM
  • You do not need to configure the WDS server. The SMS PXE is a provider in WDS. It does not have to be configured in WDS.

     

    Try this:

    1. Remove the SMS PXE role. Look at the PXESetup.log file to verify that the uninstall is complete and successful.

    2. Uninstall the WDS server.

    3. Reboot the machine.

    4. Re-install the WDS server, but "do not configure it". Do nothing at all other than installing WDS.

    5. Add the SMS PXE role. Look at the PXESetup.log file to verify that the installation is complete and successful.

    6. Add the boot images to the SMS PXE DP share. Look at the distmgr.log file to verify that the replication of the boot image to the DP is complete and successful.

    7. Try booting a PXE client.



    Can you explain Step 6 in more detail?  How do you add the boot images to the Distribution Point?  Where does the boot image come from?


    Thursday, November 05, 2009 4:47 PM
  • I have exactly the same issue. Somehow the SMS PXE DP share became empty. How do you add the boot images to the Distribution Point? (point 6)

    I am missing all files in SMSBoot\x86, SMSBOT\x64 and etc..
    Boudewijn Plomp, BPMi Infrastructure & Security
    Friday, February 05, 2010 2:08 PM
  • Right click the Boot Image and OS Image and Manage the Distribution Points.  Then check the server you want to PXE from, and make sure you add the proper Boot Image and OS images needed by the Task Sequence you are running.

     

    When you install SCCM 2007, it should install with a x64 and x86 boot image.  Then you just have to go through each of them and add your needed network and Mass Storage Device Drivers.


    Eddie
    Thursday, April 01, 2010 9:38 PM
  • Joan,

    I have the same issue as you all.

     

    When I try to delete the directory  c:Windows\temp\pxebootfiles i get an error  saying Cannot delete bootmgfw Access is denied.

     

    How do i get round this!!

     

    Help!!

     

    Ricky

    Friday, April 23, 2010 12:43 PM
  • Hi, I came up against this one (and still do from time to time) in my VMWare test environment.

    Provided everything else is in place (boot images on DPs, task sequences advertised etc) I find that restarting the "Windows Deployment Services Server" service usually kicks it back into life - also deleting any old / redundant entries fom the DHCP leases (e.g. minint-k2e90ij.domainname.com) may help.

    Cheers,
    Rob.

    Tuesday, November 23, 2010 1:42 PM
  • I had the same problem. Resolved it by deleting  c:Windows\temp\pxebootfiles folder and repopulating boot images to PXE DP.

    Btw no DHCP options are needed if PXE point and DHCP servers are on the same subnet.

    Skirmantas

    Wednesday, May 11, 2011 6:22 AM
  • Hi

     

    Thank you for the answer unfortanely it didnt solve my problem exactly the same error after doing what you said. I am going to check the log file smspxe you mentioned.

     

    What about dhcp option 67 what path should i define I think smsboot\x86\pxeboot.com ?

     

    I have also tried PXE booting on the same subnet as the PXE and DHCP server without DHCP options then the client don't get any IP adress?


    I have recreated the problem that the OP had (this topic does include other problems, for those I recommend
    http://blogs.technet.com/b/configurationmgr/archive/2011/01/05/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007.aspx).

     

    If you cannot use IP Helpers, you can define DHCP option 67 as smsboot\x86\wdsnbp.com.  wdsnbp.com detects the architecture and downloads either smsboot\x86\pxeboot.com or smsboot\x64\pxeboot.com which in turn downloads Windows Boot Manager (bootmgr.exe).  pxeboot.com requires you to press F12 to load bootmgr.exe, but you can replace pxeboot.com with pxeboot.n12 (ie rename pxeboot.n12 to pxeboot.com) that loads bootmgr.exe automatically.


    • Edited by HolyHa1fDead Wednesday, June 15, 2011 11:33 PM spelling correction
    Friday, June 10, 2011 1:01 AM
  • Thanks you Mr Duncan clay2 i add the smsboot\x86\wdsnbp.com it's working fine 

     


    Essam Refat System Admin SMS SCCM Exchange
    Thursday, September 15, 2011 5:51 AM
  • I followed till step 4

    When I go back to add PXE , it gives me all other options but PXE service role.

    Monday, November 04, 2013 8:13 PM