none
Short File Name (8.3) Support (Site System) ERROR

    Question

  • We are trying to install a single SCCM 2007 sp1 Primary site using a server (SCCM01) running Win2008 x64 Standard SP2.

    The site database is to go on a separate two node cluster (Win2008 x64 Enterprise SP2) with a clustered instance of SQL2008 x64 Enterprise (SQL Virtual name is CLUSQL02). The named instance for SCCM is called CLUSQL02\MSSQLServer_02 and the SQL instance has been configured to specifically use Port 1434.

     

    When I enter the Pre-Req details including the CLUSQL02\MSSQLServer_02 for the ‘’SQL Server and Instance’’ the checks pass except for only one error:-

    “Short File Name (8.3) Support (Site System) ERROR.

    The expanded error details say:-

    Setup either could not verify that short file name (8.3) support is enabled on the computer specified for site system installation or the server could not be contacted to determine short file name support information. No further prerequisite checking rules can be evaluated on the specified system. Setup cannot continue.

     

    To try to resolve this we have tried and checked all of the following:-

    • The Remote Registry Service in started on all the above servers
    • The fsutil.exe behavior set disable8dot3 0 has been set on all cluster Nodes and SCCM01 and rebooted the servers after this change.
    • The registry key and NtfsDisable8dot3NameCreation is set to "0" (think this is the default anyway).
    • The SQL Browser is started.
    • Named Pipes is Enable
    • The Virtual SQL server names all have DNS Host (A) records and nodes are on the domain.
    • The computer account for the site server is local admin on all of the SQL cluster nodes
    • The account running the pre-req/install is a Local Admins on SQL server nodes and of the SCCM server.
    • We flushed my DNS cache and ran ipconfig /registerdns on all servers
    • We have checked accessing the registry on other servers by connecting to the registry of the computer name of the SQL server cluster resources. Connecting to the physical nodes and the cluster name itself works with regedit, but not to the Cluster SQL server name.
    • The SPN entries were created for the SQL Instance service account:-

    MSSQLSvc/CLUS02

    MSSQLSvc/CLUSQL02.domainname.local

    MSSQLSvc/CLUSQL02:1434  (1434 port configured for instance)

    MSSQLSvc/CLUSQL02.domainname.local:1434

    • We have tried running the setup from a command line as <Setup.exe /prereq /pri /sql CLUS02\MSSQLServer_02> but still get the same 8.3 error.
    • We also tried using the SQL Default Instance on the same cluster (and configured the appropriate SPN) but this also throws the same error during Pre reqs.

    Does anyone have any other possible ideas on how to fix this or get around the pre-req error?

     

    Wednesday, November 04, 2009 3:49 PM

Answers

  • Of the tests we conducted above the root cause of the short file name error during the Pre-req checks was found to be the fact that we were not able to remotely access the registry using the SQL Virtual name which we should have been able to do. On contacting Microsoft Support we were informed that there are known issues around NoRemap registry key needing to be set if you are using Network Name resource that is dependent on a separate new IP Address resource – see http://support.microsoft.com/?id=306985


    The final solution was to add a new REG_MULTI_SZ registry key to BOTH cluster nodes called:-

    NoRemapPipes to:- 

    HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\ 

     

    This key should contain the values of:-

    WINREG

    EVENTLOG

    svcctl

     

    After adding the above key and values we needed to reboot both cluster nodes and then we were able to connect to the SQL Virtual names (CLUSQL02 + CLUSQL01) using Regedit (Remote registry). Running the SCCM Pre –req checker now returns no errors.

    Hope this soluton helps someone else.


     

     

    • Marked as answer by CPP2 Wednesday, November 11, 2009 5:43 PM
    Wednesday, November 11, 2009 5:43 PM

All replies

  • Can you check all SCCM required ports are enabled on network. refer this link for required ports http://technet.microsoft.com/en-us/library/bb632618.aspx
    Surendar Reddy
    Wednesday, November 04, 2009 4:06 PM
  • I have seen this a few times before, and it's usually connected to missing permissions. Is the site server member of the local admin group on both nodes?
    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    Wednesday, November 04, 2009 6:26 PM
  • Hi,

    ·     The site server computer account is in the local Admin group of both of the SQL cluster nodes.

    ·     The user account running the pre-req/install is also an explicit member Local Admins group on both SQL server nodes and of the SCCM site server.

    Note also that our Windows Server 2008 cluster is using the recommended and now default setting of Service SIDs (server security IDs) if that is relevant.

    I have also since done a test against a temporary standalone SQL 2008 instance and this worked so would indicate that the problem may be realting to clustering (either Win2008 or SQL 2008).

    Thanks.

    Thursday, November 05, 2009 5:10 PM
  • Of the tests we conducted above the root cause of the short file name error during the Pre-req checks was found to be the fact that we were not able to remotely access the registry using the SQL Virtual name which we should have been able to do. On contacting Microsoft Support we were informed that there are known issues around NoRemap registry key needing to be set if you are using Network Name resource that is dependent on a separate new IP Address resource – see http://support.microsoft.com/?id=306985


    The final solution was to add a new REG_MULTI_SZ registry key to BOTH cluster nodes called:-

    NoRemapPipes to:- 

    HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\ 

     

    This key should contain the values of:-

    WINREG

    EVENTLOG

    svcctl

     

    After adding the above key and values we needed to reboot both cluster nodes and then we were able to connect to the SQL Virtual names (CLUSQL02 + CLUSQL01) using Regedit (Remote registry). Running the SCCM Pre –req checker now returns no errors.

    Hope this soluton helps someone else.


     

     

    • Marked as answer by CPP2 Wednesday, November 11, 2009 5:43 PM
    Wednesday, November 11, 2009 5:43 PM