none
SCOM-BMC remedy ar system integration

    Question

  • Hi

    I am new to opalis and iam working on SCOM BMC Remedy AR System(ITSM) Integration using OPALIS. When i create the BMC Remedy connection and test the communication. it communicates on port 111 even if i unselect the port mapper also the communication is on 111. But my BMC Listens on 1803. how to set the port to 1803.

    THIRU


    THIRU
    Monday, October 18, 2010 5:41 PM

Answers

  • BY adding the environment variable artcpport with the custom port value the issue got resolved.
    THIRU
    • Marked as answer by NTHIRU Thursday, October 21, 2010 1:31 PM
    Thursday, October 21, 2010 1:31 PM

All replies

  • Are you sure you are using the portmapper?  The Remedy portmapper uses port 111 and the the connection request is transferred to a different port.  Uncheck the portmapper option and provite the TCP port and RPC# information the Opalis Integration Pack connection configuration is requesting.  The TCP Port will be customer-specific (i.e. there is no way I can tell you what value to use, you need to find out how your Remedy environment is configured).  The same is true for the RCP# but the value is usually 0.

    Tuesday, October 19, 2010 4:30 PM
  • In BMC end we are using static port TCP 1803.

    I have unchecked and provided the tcp port as 1803 and rpc port as 0, but still it is using portmapper. when i try monitor using netmon the communication is on portmap RPC 111.


    THIRU
    • Marked as answer by NTHIRU Thursday, October 21, 2010 1:30 PM
    • Unmarked as answer by NTHIRU Thursday, October 21, 2010 1:30 PM
    Wednesday, October 20, 2010 5:02 AM
  • BY adding the environment variable artcpport with the custom port value the issue got resolved.
    THIRU
    • Marked as answer by NTHIRU Thursday, October 21, 2010 1:31 PM
    Thursday, October 21, 2010 1:31 PM
  • Thiru,

    Which version of the Remedy IP are you using?
    I'm using 5.40 and I do NOT need the environment variable!
    I just configured the Remedy connection using the proper TCPPort number.

    Regards,
    Rob

     


    Regards, Rob van Eerd
    Thursday, November 04, 2010 2:56 PM
  • Thank you for the solution!

    FYI my specific issue was connecting to a NLB instance of Remedy (VIP to 4 Remedy servers), and the connections would time out.  I was not aware of the variable you mentioned until today! 

    Wednesday, November 10, 2010 4:07 AM
  • Hi Rob

     

    Below URL is for your reference.... :)

    http://blogs.technet.com/b/opalis/archive/2010/11/03/solution-connecting-to-bmc-remedy-via-opalis-integration-server-fails-with-quot-connection-test-failed-quot.aspx

     

     


    THIRU


    Hi Thiru,

     

    Have you seen my comments below the contents of the link?

     

    Regards,

    Rob.


    Regards, Rob van Eerd
    Monday, November 22, 2010 6:46 AM
  • Hi Rob

    But i have tested in Remedy 7.x, after adding the environment variable only my problem got resolved.

     

     


    THIRU
    Monday, November 22, 2010 3:15 PM
  • Hi Thiru,

    That still doesn't answer the question on what version of the Remedy IP your using.
    As far as I know, setting the variable isn't a requirement of the Remedy version, it's a requirement of the Opalis Remedy IP.
    I'm using the Remedy IP in an environment where I'm simultaneous talking to both a Remedy 5.x as well as a Remedy 7.x environment without setting the environment variable.

    I just specified the portnumbers on the connection defined in the BMC Remedy Options panel.

    Regards,
    Rob.


    Regards, Rob van Eerd
    Tuesday, November 23, 2010 5:59 AM
  • Hi Rob

    I am also using 5.40(5.40_5.4.0.0001) only.


    THIRU
    Tuesday, November 23, 2010 8:53 AM
  • Hi Thiru,

    Can you send me a screenshot of your connection definitions (within the Client: Options / BMC Remedy)?

    Regards,
    Rob


    Regards, Rob van Eerd
    Friday, November 26, 2010 6:01 AM
  • Hi Thiru,

     

    Today I installed a new Opalis Environment including the BMC Remedy IntegrationPack.

    As I didn't check what version we're running in our Production environment, I installed the latest (5.40) running into the exact same problem you described. I had to set the ARTCPPORT environment Variable.

    Then I reverted to version 5.23 and all was fine again, I was able to define the ports to be used from the Connection panel without setting the environment variable.

    Hope this still helps for you.

     

    Regards,

    Rob van Eerd


    Regards, Rob van Eerd
    Tuesday, February 01, 2011 9:37 AM
  • Hi Rob Thanks, i have not tested this, if i get a chance i will check and let you know. THIRU
    THIRU
    Tuesday, February 01, 2011 5:13 PM
  • Thanks Thiru


    Thanks Shajeer.K

    Friday, April 06, 2012 7:08 AM