none
Alert: The agent was not able to submit data on behalf of another computer because agent proxy is not enabled. - on Management Server

    Question

  • Hello everyone. I recently installed SCOM 2012 SP1 and I'm receiving alerts regarding a agent proxy on the management and web console. Do I need to install the agent on the Management server? 

    Thanks


    Exchange 2010 Outlook 2007 (cache mode)

    Monday, February 04, 2013 5:26 PM

Answers

  • No. You need to enable proxying on all agents deployed in SCOM. Go into Administration - Agent Managed and for each agent, right click, select Properties and in the Security tab, check the Agent Proxy checkbox.

    "Fear disturbs your concentration"

    • Marked as answer by SACIT Thursday, February 07, 2013 5:57 PM
    Monday, February 04, 2013 6:05 PM

All replies

  • No. You need to enable proxying on all agents deployed in SCOM. Go into Administration - Agent Managed and for each agent, right click, select Properties and in the Security tab, check the Agent Proxy checkbox.

    "Fear disturbs your concentration"

    • Marked as answer by SACIT Thursday, February 07, 2013 5:57 PM
    Monday, February 04, 2013 6:05 PM
  • Hi, Administration->Management Servers->Select Management Server->Right Click (Properties)->Security (Allow this server to act as a proxy). Management Server already has agent installed, so no need to install agent on MS.
    Monday, February 04, 2013 7:28 PM
  • Alexis-- this was already checked on the management server yet I continue to receive alerts from the system.

    Error from Alerts:


    Exchange 2010 Outlook 2007 (cache mode)


    • Edited by SACIT Monday, February 04, 2013 8:47 PM
    Monday, February 04, 2013 8:45 PM
  • I enable Agent Proxy for 'All Windows Computers' using this tool from time to time in our environment: http://blogs.msdn.com/b/boris_yanushpolsky/archive/2007/08/02/enabling-proxying-for-agents.aspx.  It's also a good way to check which servers have/haven't had it enabled (Including servers).
    Tuesday, February 05, 2013 1:13 AM
  • To the original poster - Andy is correct. The alert detail should also show the name of the agent that requires Agent Proxy enabled. You actually only need to enable agent proxy on this single agent ... not all of them. But because so many management packs require agent proxy enabled, many administrators just enable it for all agents,

    I have this from a previous similar question - http://systemcentersolutions.wordpress.com/2010/03/29/security-risk-of-enabling-agent-proxy/

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Tuesday, February 05, 2013 6:32 AM
    Moderator
  • Thanks everybody. I've used the tool Leigh mentioned and have enabled the security options on all of our production servers. I noticed I was getting alerts from only the active directory servers. It could be because I recently enabled a few AD management packs.


    Exchange 2010 Outlook 2007 (cache mode)

    Thursday, February 07, 2013 5:57 PM