none
Format USB disk error with create stand alone media

    Question

  • To support remote computers we would like to use USB keys to distribute the task sequence.  When I run through the create stand alone media wizard for USB it gets to the point where it will format and fails.  The error in the CreateTSMedia.log is:

    Format failed (0x8004242D) CreateTsMedia 12/9/2010 5:33:39 PM 1528 (0x05F8)
    Error formatting volume K:\ (0x8004242d) CreateTsMedia 12/9/2010 5:33:39 PM 1528 (0x05F8)
    Failed to create media (0x8004242d) CreateTsMedia 12/9/2010 5:33:39 PM 1528 (0x05F8)

    I am running Windows 7 x64 with SCCM 2007 R2 SP2.  The USB device is 64 GB in size, I've tried formatting it as NTFS and exFAT with the same results.  The help file indicates with Vista that the disk must be formatted prior to use, but does not indicate how it should be formatted, I assume the same is true for Windows 7.

    Any thoughts?


    Bob
    Friday, December 10, 2010 1:27 PM

All replies

  • Assuming the key is DISK 1 run the following commands in diskpart from win 7

    • sel dis 1
    • clean
    • cre par pri
    • sel par 1
    • active
    • format fs=fat32
    • exit
    Michael
    http://kongkuba1.spaces.live.com
    Friday, December 10, 2010 1:56 PM
  • i've only been able to get those 64gb keys to work with a configmgr admin console running on XP, when trying it on windows 7 it always failed, can you try running it from a winxp console ?


    My step by step SCCM Guides
    I'm on Twitter > ncbrady
    Friday, December 10, 2010 1:56 PM
  • The diskpart command won't do the format, the error is disk is too big.

    I'll try and see if I can find an XP box. 

    Sure would be nice if they would have used NTFS.  I understand FAT32 for the CD/DVD, but it's a pain for USB keys.


    Bob
    Friday, December 10, 2010 3:13 PM
  •  

    I use USB keys 32 GB here's what I do:

    On a Win7 box do the following in cmd with diskpart up

            * sel dis 1
            * clean
            * cre par pri
            * sel par 1
            * active
            * format fs=ntfs quick
            * exit
    Then on a XP machine with the SCCM console I create the USB. 

    One other tip I found online. The USB will ask for user input at the begining to get around this go to:

    USB drive:\SMS\data\TsmBootstrap.ini

    replace Unattended=false with Unattended=true

    Wednesday, December 29, 2010 4:52 PM
  • I have a question.  How can I get the SCCM task sequence media wizard not to use fat 32 formating by defualt on a SCCM console that sits on a 2008 server?  I have a package that is over 4gb and I believe that is too big for the fat filesystem.
    Wednesday, December 29, 2010 4:58 PM
  • I was able to workaround this issue when running a Remote Console from a Windows Server 2008 R2 system.

    I created an NTFS 32 GB parition (the 120 GB flash drive would fail with the same error).

    # = disk number of your USB Flash drive (use lis dis to get list)

            * sel dis #
            * clean
            * cre par pri
            * sel par 1
            * active
            * format fs=ntfs quick size=32768
            * exit

    Reran the TS Wizard to create Standalone Media and it got past this error.


    Levi Stevens Technical Consultant - End User Computing - West Region Dell | Services
    • Proposed as answer by Levi Stevens Tuesday, February 15, 2011 9:56 PM
    Tuesday, February 15, 2011 9:56 PM
  • well after trying all the above on Windows 7 it still bombs out in the ConfigMgr console (CM07) when i use a 64GB key,

    so today I tried again with diskpart but this time i added the following (as the advice above didnt work, size was rejected)

     

    sel dis #
    clean
    cre par pri
    sel par 1
    active
    shrink desired=32768 minimum=32768
    format fs=ntfs quick
    exit

    the magic line is shrink desired=32768 minimum=32768, works now in windows 7 !

    cheers

    niall

     



    My step by step SCCM Guides
    I'm on Twitter > ncbrady
    Wednesday, September 21, 2011 2:03 PM
  • Works like a champ. Also works for CM2012.

    Thanks Niall

    Tuesday, September 11, 2012 6:57 PM
  • Just to throw it out there, I was having the same issue as this post however I have a 256 GB USB stick I was attempting to use.  I did follow your instructions Niall, thanks.  However I had to do the create partition command using the 32768 so that the partition would only be that size.  Following your instructions, when the partition was created in used the whole stick.  I am now creating the USB boot media utilizing only 32 GB on a 256 GB stick (real nice).  Just throwing it out there for future reference.
    Tuesday, September 25, 2012 4:07 PM
  • Hi

    I have a 64 gig jump drive and am trying to create TS media. The problem is our image and all the TS files is bigger than 32 gigs. How would I go about doing this? I noticed everyone in the previous posts dont need anything bigger than 32 gigs. Thanks

    Monday, November 12, 2012 8:23 PM
  • Hi can anyone help with this? I am still encountering this problem but no solution. I am trying to create TS media on a 64gb jump drive.

    I can successfully create media from an XP machine but thats really not the long term solution.

    Since our image is over 32gb the below wont work?

    Can this desired number be anything?

    sel dis #
    clean
    cre par pri
    sel par 1
    active
    shrink desired=32768 minimum=32768
    format fs=ntfs quick
    exit

    The CreateTSMedia.log has these errors:

    Format failed (0x8004242D) CreateTsMedia 2/6/2013 6:33:15 AM 12244 (0x2FD4)
    Error formatting volume F:\ (0x8004242d) CreateTsMedia 2/6/2013 6:33:15 AM 12244 (0x2FD4)
    Failed to create media (0x8004242d) CreateTsMedia 2/6/2013 6:33:15 AM 12244 (0x2FD4)

    • Edited by Yamini56 Wednesday, February 06, 2013 12:43 PM
    Wednesday, February 06, 2013 12:42 PM
  • I have not tried this myself but you might want to look at the SDK for creating the media.  The reason is that there are two USB media types: UFD and UFD+FORMAT.  It's just an assumption but I think these two types are the difference between running the console on XP and Win 7.  By using the SDK you might be able to get the process to work as if it was running on XP.

    http://msdn.microsoft.com/en-us/library/cc146147.aspx

    http://msdn.microsoft.com/en-us/library/cc144756.aspx

    Just a thought but might be worth trying.

    Mark.

    Wednesday, February 06, 2013 2:28 PM
  • I had the SAME problem! Once you diskpart, clean and create your ntfs partition on a win 7 box, find a winxp box with console installed. Insert your usb stick, SHARE it out to EVERYONE. Give the Machine local account full rights to the key as well. Open console and let her rip! 
    • Proposed as answer by MBroome Thursday, February 07, 2013 9:13 PM
    Thursday, February 07, 2013 9:13 PM
  •         In my environment we need 100+ Stand Alone keys. That's ALOT of man hours. By the time I was done creating the keys, the next quarterly update cycle would come due. To solve this problem we bought this little gem, its proven priceless!

    http://www.fullcompass.com/product/384561.html?utm_source=googleps&utm_medium=shopping&utm_campaign=googleps&gclid=CNXNs_mOpbUCFQeynQod6BwA4Q

    Thursday, February 07, 2013 9:16 PM
  • Has anyone found a better solution then shrink the usbkey till 32Gb ? 

    Wednesday, April 10, 2013 8:55 AM