none
Unattend.xml not applying by deploying a service template

    Question

  • Hello,

    i use scvmm 2012.

    I installed a fresh blank windows 2008 r2 server, shut it down and create from this a vm template sucessfully. 

    The i create a new answer file for deploying some settings and roles. The answer file can you find here.

    SO my new vm with windows would be created successfully. No errors. But none of the above settings are applied to my vm.

    Is the problem, that i created a template of an existing blank windows system?

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing>
            <package action="configure">
                <assemblyIdentity name="Microsoft-Windows-Server-Refresh-LanguagePack-Package" version="6.1.7601.17514" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="de-DE" />
            </package>
            <package action="configure">
                <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.1.7601.17514" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
                <selection name="DNS-Server-Tools" state="true" />
                <selection name="DNS-Server-Full-Role" state="true" />
                <selection name="DirectoryServices-DomainController-Tools" state="true" />
                <selection name="DirectoryServices-AdministrativeCenter" state="false" />
                <selection name="BdeAducExtTool" state="true" />
                <selection name="NetFx3" state="true" />
                <selection name="DirectoryServices-ADAM" state="true" />
                <selection name="DirectoryServices-DomainController" state="true" />
            </package>
        </servicing>
        <settings pass="specialize">
            <component name="Microsoft-Windows-IE-ESC" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <IEHardenAdmin>false</IEHardenAdmin>
                <IEHardenUser>false</IEHardenUser>
            </component>
            <component name="Microsoft-Windows-ServerManager-SvrMgrNc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotOpenServerManagerAtLogon>true</DoNotOpenServerManagerAtLogon>
            </component>
            <component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <fDenyTSConnections>false</fDenyTSConnections>
            </component>
            <component name="Security-Malware-Windows-Defender" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableAntiSpyware>true</DisableAntiSpyware>
            </component>
            <component name="Microsoft-Windows-IE-ESC" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <IEHardenAdmin>false</IEHardenAdmin>
                <IEHardenUser>false</IEHardenUser>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <Manufacturer>Systemhaus Krick VM</Manufacturer>
                </OEMInformation>
                <AutoLogon>
                    <Password>
                        <Value>YQBkAG0AaQBuACMAMQAyADMAUABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Username>Administrator</Username>
                    <Enabled>true</Enabled>
                    <LogonCount>1</LogonCount>
                </AutoLogon>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>0407:00000407</InputLocale>
                <SystemLocale>de-de</SystemLocale>
                <UILanguage>de-de</UILanguage>
                <UILanguageFallback>de-de</UILanguageFallback>
                <UserLocale>de-de</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/tmp/install.wim#Windows Server 2008 R2 SERVERSTANDARD" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    Thursday, April 12, 2012 7:54 PM

All replies

  • Hi,

    Can you please test first the VM Template without Service Template with Unattended file?

    Unattended file is very sensitive about arguments.

    After you deploy VM Template , you can test in service template.

    Sincerely,

    Murat Demirkiran


    If the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. www.scvmm2012.com (TR Language)

    Friday, April 13, 2012 8:19 AM
  • Hi,

    thanks for your answer. I tested my answer file with my vm template and here nothing would be installed, too. But on the creating process of the answer file, the validation is ok and i got no errors in scvmm.

    Need i some special arguments in my answer file, which i don't configure ? 

    Friday, April 13, 2012 11:36 AM
  • Hi,

    Have you checked the unattend file in WAIK?

    Check this blogsite. This is for SCVMM 2008 but this should also work for SCVMM 2012.

    http://blogs.technet.com/b/chrad/archive/2009/06/30/scvmm-sample-unattend-xml-for-windows-server-2008-r2.aspx

    Friday, April 13, 2012 1:24 PM
  • yes i checked und created the file with WAIK.

    Here i have another simple unattend.xml file. the name is dnsserver.xml with this settings

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing>
            <package action="configure">
                <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.1.7601.17514" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
                <selection name="DNS-Server-Full-Role" state="true" />
                <selection name="DNS-Server-Tools" state="true" />
            </package>
        </servicing>
        <cpi:offlineImage cpi:source="wim:c:/tmp/install.wim#Windows Server 2008 R2 SERVERSTANDARD" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    But this unattended.xml file doesn't work. I would only to install dns role. Or should i configure some other options?

    Friday, April 13, 2012 1:52 PM
  • What does the eventviewer tells you?

    Have you tried it with a more simple unattended file:

    http://blogs.technet.com/b/davguents_blog/archive/2010/08/06/vmm-2008-r2-creating-template-with-keyboard-layout.aspx

    You can also use the new feature in SCVMM 2012 to add a windows role and/or feature when you want to deploy a service.

    You can deploy a service that only contains 1 vm (template)

    http://www.hyper-v.nu/archives/pnoorderijk/2011/04/scvmm-2012-guest-os-profiles/




    • Edited by Trail2012 Tuesday, April 17, 2012 7:03 AM
    Monday, April 16, 2012 7:14 PM
  • Yes, i tested it with the simple unattended file above for dns server installation.

    I tested the deployment with sccm 2012 and here, nothing happens. I think i have a problem with my template.

    Is it right that i install a windows 2008 r2 system and then convert this vm to a template. Now i should install a a vm from this template with the unattended file. Is that's right ?

    Edit: Both links doesn't work...

    • Edited by StefanWend Tuesday, April 17, 2012 6:29 AM
    Tuesday, April 17, 2012 6:25 AM