none
SCOM 2012 Beta Install wizard can not find the SQL server/instance while installing

    Question

  • Hello,

      I am trying to install the SCOM 2012 Beta. And I follow the guide down here:

    http://www.bictt.com/blogs/bictt.php/2011/07/20/scom-2012-beta-first-install

     

      At the step for "configuring the operational database", I enter the hostname/instance for the field. However, the wizard seems not to accept the parameters or not finds the SQL server. (I am using the default instance on SQL server, so I just type up the SQL server name.) Then, I tried to use ODBC connection in the OS for testing the SQL server connection. It seems the testing was good and the OS should find the SQL server.

      Another try step down here: I create another new instance on the SQL Server, I checked the SQL tools could find this new intstance and so did OS can connect it. Then, I re-tried to install, but in vain. May I ask is there any other ways to resolve this issue? Thanks!

    --------------------------------------------------

    My Env:

    OS: win2008 R2 SP1(Update to the lastest version)

           IIS server 6

           .Net framework 4

    SQL: Win2008 R2 SQL server (The SQL server is install on the SCOM Server. I plan to install a single-server type.)

     

    Additional 2 issue make me concerned :

    A. The OS language version is Traditional-Chinese. Is that possible to affect the installation?!

    B. OS hostname: WIN-SCOM  ---> Does "-"  affect the installation?

     

    If you need more information, please let me know. Thanks!

    Thursday, August 18, 2011 1:40 AM

Answers

  • Hi Howard,

    Well if you do a next next next install of SQL than I am SURE you do not have the right collation. It is a step in the installation of SQL to go to a second tab to change the collation of the installation and finding it in the dropdown lists and setting checkboxes.

    and yes you need .net framework 3.5 as well.

    SQL also has updates. I think we are at SQL 2008 R2 CU6 or 7 already (if you get sql 2008 r2 sp1 you will be at CU6 already), so suggest you get that one as well. However after you fix the collation issue!!! http://www.bictt.com/blogs/bictt.php/2011/06/27/scom-trick-43-collation

    over here some screenshots where you can check the collation on a database and on the server: http://thoughtsonopsmgr.blogspot.com/2010/04/failed-to-store-data-in-data-warehouse.html
    remember the sql server must be installed with this collation. If not you best remove sql and re-install it with correct settings, otherwise you will have problems for a long time. In sql management studio, right click server, properties. first screen should show you the server collation already.

     

     


    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Marked as answer by Howard Hsiao Thursday, August 18, 2011 8:26 AM
    Thursday, August 18, 2011 7:35 AM
    Moderator

All replies

  • Hi Howard, so you were the one who read my post *grin*

    Have you checked that sql full-txt search is installed on the instance?
    Have you checked that the sql browser is running on the sql box? sql agent service must be running as well.

    I am not sure if the OS language would affect you. I imagine it should work.
    The host name can have a -dash- in it, that is no problem.

    Have you made sure that the collation is set correctly while installing SQL server?
    Have you installed any service pack or CUx fixes on top of your SQL 2008 R2 installation?

    Check that you conform to the following requirements:
    http://technet.microsoft.com/en-us/library/hh205990.aspx
    .net framework 3.5 and 4 are also required.

    As you have read in my post I have run into some issues before I could actually connect to the SQL box, due to services not started and features not installed. However when I read the requirements in the link above it did help a lot to get things going.

    And you are right, when you use the default instance you can just enter the netbios server name into the server field and it should connect for you if all works correctly. By the way also do a quick check if the firewall on the sql box is stopping your connection on the sql port, just to be extra sure.


    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    Thursday, August 18, 2011 6:45 AM
    Moderator
  • Hello Bob,

     

       First, thanks your reply. I am so surprised to meet the original author.

       Here are my checking list during debugging(I hope these could be useful.):

    A. SQL Full-text Filter Daemon Launcher  service is started.

    B. SQL Server Browser service is started. (In fact, I installed the MSSQL Server 2008 R2 with default but fully installation.)

    C. SQL Agent server service is started.

    D. .net framework is ruuning with v4.0.30319. (But, I do not know .net 3.5 should be declared to use on. If the .net 3.5 need to be actived on. please let me know.)

    E. Collation ---> This is a big problem for me. I do not know how to check on or set up my current collation. (But, installation is default value.)

    F. Firewall is turned off for all the function.

    G. "Netstat -an" ---> port 1433 should be listened on.

    H. SQL server current version is win2008 R2 64bit. I do not know which patches in Win2008 R2 SP1 should be installed. I check the windows update. But, the OS windows update told me there are no more patches should be installed.

    ----------------------------------

    I did re-downloaded the installation program for checking. But, still hang on the same step....

    Please help me out of issue. Thanks!

    Thursday, August 18, 2011 7:12 AM
  • Hi Howard,

    Well if you do a next next next install of SQL than I am SURE you do not have the right collation. It is a step in the installation of SQL to go to a second tab to change the collation of the installation and finding it in the dropdown lists and setting checkboxes.

    and yes you need .net framework 3.5 as well.

    SQL also has updates. I think we are at SQL 2008 R2 CU6 or 7 already (if you get sql 2008 r2 sp1 you will be at CU6 already), so suggest you get that one as well. However after you fix the collation issue!!! http://www.bictt.com/blogs/bictt.php/2011/06/27/scom-trick-43-collation

    over here some screenshots where you can check the collation on a database and on the server: http://thoughtsonopsmgr.blogspot.com/2010/04/failed-to-store-data-in-data-warehouse.html
    remember the sql server must be installed with this collation. If not you best remove sql and re-install it with correct settings, otherwise you will have problems for a long time. In sql management studio, right click server, properties. first screen should show you the server collation already.

     

     


    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    • Marked as answer by Howard Hsiao Thursday, August 18, 2011 8:26 AM
    Thursday, August 18, 2011 7:35 AM
    Moderator
  • Hello Bob,

      You are right at the collation. I've just re-created another instance for collation at the SQL_Latin1_General_CP1_CI_AS . Now the wizard is able to recognize the SQL server/instance at once. And the installer is running the installation.  Thanks a lot! I do appreciate.

      Thanks!

    Thursday, August 18, 2011 8:26 AM
  • Bob,

    I am having the very same problem as described here -- I can connect to by SQL 2008 server with the server studio application, but the System Center installation refuses to recognize the database.

    I've confirmed that the collation of the server is what you specified here (SQL_Latin2_General_CP1_CI_AS), but no luck, I just get this message:

    The version of SQL Server on this computer is either not supported or could not be validated because of an issue connecting to the WMI provider. For a complete list of the supported SQL Server versions and editions, see the System Center 2012 - Operations Manager Supported Configurations document in the TechNet library.

    Thursday, May 24, 2012 9:45 PM
  • I hope it is Latin1 and not Latin2 for the collation. Perhaps just a typo on your side.
    check SQL is not an express edition. Check sql updates are there. Check collation for server. Check that the account you use has rights in sql and computer. (when in doubt I sometimes login using the service account I want to use for DAS/Config/SDK and start install from that one, assuming that one has confirmed to have the correct rights. CHeck if WMI is started on that sql server.


    Bob Cornelissen - BICTT (My Blog about SCOM) - MVP 2012 and Microsoft Community Contributor 2011 Recipient

    Friday, May 25, 2012 6:28 AM
    Moderator
  • Hi bob,

    I have run into the same exact problem and my question is: do you need -NET 3.5 & .NET 4.0 on the SQL server box as well or that is just on the SCOM 2012 server?

    Forgive me if this sounds as an "over kill" of what's allerady been explained

    Regards, 

    Friday, May 25, 2012 7:52 AM
  • Yes, both versions are needed on the SQL box as well.

    Bob Cornelissen - BICTT (My Blog about SCOM) - MVP 2012 and Microsoft Community Contributor 2011 Recipient

    Friday, May 25, 2012 7:59 AM
    Moderator
  • Yes, it is SQL_Latin1_General_CP1_CI_AS.  Cut an paste wasn't working for me, and my typing skills are poor.

    At this point, I'm just evaluating 2012, so I just configured all accounts to be the local Administrtor.  I'm not using express, but the SQL server evaluation edition.

    How do I check the WMI status?  I don't recall this as an option during the install.  Is this an option within the configuration manager?

    Thanks,

    -Evan-

    Friday, May 25, 2012 4:40 PM
  • Try it with a full version of sql and not eval.

    wmi is a windows service by the way.


    Bob Cornelissen - BICTT (My Blog about SCOM) - MVP 2012 and Microsoft Community Contributor 2011 Recipient

    Friday, May 25, 2012 4:54 PM
    Moderator
  • Unfortunately, using a full version isn't an option, as I'm just evaluating the system center at this point.

    The WMI service is indeed running.

    One detail I did not reveal was that I am installing SQL server and System Center on the same virtual server.  Is this the source of my problems?

    -Evan-

    Friday, May 25, 2012 5:27 PM
  • No same system is good. You can still install a full sql on the box. Should not be eval version. Dont worry about licensing if you are just testing it.


    Bob Cornelissen - BICTT (My Blog about SCOM) - MVP 2012 and Microsoft Community Contributor 2011 Recipient

    Friday, May 25, 2012 6:46 PM
    Moderator
  • Unfortunately, the 2008 download links force me to the SQL server 2012 download page, so I can't download anything except the trial version of 2008:

    http://www.microsoft.com/sqlserver/2008/en/us/R2Downloads.aspx

    -Evan-

    Friday, May 25, 2012 11:21 PM
  • Hi again,

    I am not getting any satisfying results actually. I tried every thing beginig with installing .NET 4.0 on the SQL machine and made shure that .NET 3.5 is allso installed. Updated the SCOM instance which is 2008 R2 to SP1 and installed CU#6 update (which I believe is the latest)

    I am still getting the "this SQL instance collation is not supported" and am out of ideas.

    Monday, May 28, 2012 6:43 AM
  • Perhaps you can get hold of the eval edition of sql 2008 (but add SP1 or SP2 to that!) at http://msdn.microsoft.com/en-us/sqlserver/bb671149.aspx

    However I still think this error can be related to eval edition of SQL. And SQL 2012 version will not do at the moment as you found.

    The whole list of supported configurations is at http://technet.microsoft.com/en-us/library/hh205990 , so the prereq software.

    You could try to install the sql isntance with collation: Latin1_General_CI_AS  and see what happens. By the way, I have been talking about the english installation of SCOM in combination with those sql collations.


    Bob Cornelissen - BICTT (My Blog about SCOM) - MVP 2012 and Microsoft Community Contributor 2011 Recipient

    Monday, May 28, 2012 8:24 AM
    Moderator
  • Thanks for your patience with me.  I now have SQL 2008 R2 installed, and I still can't get things to work in the SCOM install.

    At the DB setup step, I've tried various entries for the "Server name and instance" entry, to no avail:

    system-center (my server name)

    .\MSSQLSERVER (I used the default at install)

    system-center\MSSQLSERVER

    .

    (blank)

    This is probably just operator error, but I just can't get past this point.  The SQL configuration manager connects just fine.

    Thanks,

    -Evan-

    Wednesday, May 30, 2012 4:23 PM
  • Hi Evan,

    Kevin's has a quickstart guide here:

    http://blogs.technet.com/b/kevinholman/archive/2012/04/26/deploying-opsmgr-2012-a-quick-start-guide.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 31, 2012 6:40 AM
  • Dear Team,

    Today I have faced issue while SCOM 2012 installation, details and Solution is mentioned below.

    Error:

    This SQL instance collation is not supported, please select a sql server and instance with a supported collation

    Reason :

    Latin1_General_CP1_CI_AI

    Required to solve error:

    Latin1_General_CP1_CI_AS

    Solution:

    command need to be run in command Prompt.

    setup.exe /q /ACTION=RebuildDatabase /INSTANCENAME=InstanceName /SAPWD="New SA Password" /SQLCollation=CollationName /SQLSYSADMINACCOUNTS="Admin ID"

    Link:

    http://sql-articles.com/articles/dba/how-to-change-server-collation-in-sql-server-2008/#ixzz1xlrb9MRu

    Thanks

    Kirpal Singh

    Thursday, June 14, 2012 1:41 PM
  • I had the same problem with SCOM 2012 SP1 and SQL 2012 SP1

    First I used a named instance, so I had to set a static port.

    Then the problem stayed and I found out I had not installed full-text search on the named instance.

    Problem solved for me then!

    Tuesday, April 23, 2013 9:05 AM
  • Hi Mark,

    Thanks for sharing workaround of your setup !!!


    Kirpal Singh

    Wednesday, May 08, 2013 4:59 AM