none
Setting up SCCM Environment

    Question

  • All,

    I'm in the middle of setting up a new SCCM environment. Here's what has been done so far.

    - Installed WIN2K3_x64 on a brand new server. Installed and configured. Tied into AD, etc etc.

    - Installed SQL2K5, configured. Not too much since this will be a dedicated SQL server for SCCM.

    - Installed IIS 6.0, BITS, enabled WEBDAV, ASP.

    - Installed SCCM. Everything ran fine during the predeployment checks. So everything seemed to work fine.

    - Attempting to set up all the server roles, MP, SLP, etc etc, pretty much all of them since this will be the main and only SCCM server, central site, etc.

    - Looked at the system status, errors everywhere.

    I looked at the event viewer, and pretty much every role that the SCCM is supposed to be doing, each of the system role installations failed out. MP, SLP, etc. All the installations failed with 80020009 errors. When I was in the ConfigMgr console, and tried to go through the System/Service Manager, I queried each component, and they all came back with "Failed to communicate with component".

    I read all the logs concerning with each of the role installations, and they all show the same 80020009 error message. I tried to copy and paste the command line, errored out. I tried to run the command by itself, errored out. Try to run the command from the SCCM DVD, failed.

    Thoughts??

    • Edited by sonnyali Friday, April 02, 2010 2:42 PM
    Thursday, April 01, 2010 3:19 AM

Answers

All replies

  • Hi,

    You should not run the msi files directly from the DVD, I don't think that will help you. Do you have any errors in the sitecomp.log file?


    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    Thursday, April 01, 2010 6:04 AM
  • Every role (MP, FSP, SLP, ... *setup.log) does create its own setup logfile. Just examine those to get an idea what was failing.

    Thursday, April 01, 2010 6:27 AM
  • anything specific i should be checking for? i know specifically, each of the *.msi files all fail with that specific error code. but i think that may be a general error?
    Friday, April 02, 2010 1:33 AM
  • anything specific i should be checking for? i know specifically, each of the *.msi files all fail with that specific error code. but i think that may be a general error?
    Friday, April 02, 2010 1:34 AM
  • Let's start simply by checking mpsetup.log and posting errors here.

     

     


    John Marcum | http://myitforum.com/cs2/blogs/jmarcum |
    Friday, April 02, 2010 2:48 AM
    Moderator
  • anything specific i should be checking for? i know specifically, each of the *.msi files all fail with that specific error code. but i think that may be a general error?


    Could you please let us know what the error code is?

     

    Friday, April 02, 2010 2:55 AM
  • Will look at the log in a sec.

    Error code is in OP. 80020009.

    Friday, April 02, 2010 2:41 PM
  • Nice. Got past that point.

    Seems that GPO was blocking DTC and COM services from successfully starting. Now that I updated the GPO, each of the roles were successfully installed and started.

    I'm now seeing in the logs, that http requests to the SCCM server are getting 401 errors. I'm not sure what specific things to configure in IIS for SCCM. This is my first time setting up SCCM. When I configured a SMS 2003 environment, I didn't need to do anything specific with IIS...not that I can recall.

    Another issue I'm seeing, when I go to Site Status, Site System Status, all the local drives show up with Unknown Unknown.

    And when I start SMS Service Manager, all the queries to the components fail to communicate.

    Friday, April 02, 2010 4:25 PM
  • Any reasons for this?
    Tuesday, April 06, 2010 2:01 AM
  • Error 401 = unauthorized. So double check the IIS logs to get an idea where exactly it is failing.
    Tuesday, April 06, 2010 7:41 AM
  • Error 401 = unauthorized. So double check the IIS logs to get an idea where exactly it is failing.
    Tuesday, April 06, 2010 7:41 AM