none
VMM 2012 RC Managment installation process fails with the error :: RESOLVED

    Question

  • Issue Resovled:

    A group policy was setting the port to 5985, I disabled to policy for this server.

    winrm enumerate winrm/config/listener

    Listener [Source="GPO"]
    Address = *
    Transport = HTTP
    Port = 5985
    Hostname Enabled = true
    URLPrefix = wsman
    CertificateThumbprint
    ListeningOn = 127.0.0.1, 192.168.0.117

     

    I then reconfigured the WinRm listener to port 80

    winrm set winrm/config/listener?Address=*+Transport=HTTP @{Port=”80”}
    winrm enumerate winrm/config/listener

    Listener
        Address = *
        Transport = HTTP
        Port = 80
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 127.0.0.1, 192.168.0.117, ::1, fe80::5efe:192.168.0.117%12, fe
    80::d190:5e3b:5ffc:98f4%11

     

    After which the installation completed normally.

     

     


    During the install, at the point where the VMM managment is installing, the process fails with the error:
     
    A Hardware Managment error has occurred trying to contact server <myserver.domain.com>.
     
    Check that WinRM is installed and running on server <myserver.domain.com>. For more information use the command "winrm helpmsg hrresult.
     
    From the setup log:
     
    VMMPostinstallProcessor threw an exception: Threw Exception.Type: Microsoft.Carmine.WSManWrappers.WSManProviderException, Exception.Message: A Hardware Management error has occurred trying to contact server <myserver.domain.com>. .
     
    InnerException.Type: System.Runtime.InteropServices.COMException, InnerException.Message: The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol.



    Checked the WinRM:

    winrm enumerate winrm/config/listener

    Listener [Source="GPO"]
        Address = *
        Transport = HTTP
        Port = 5985
        Hostname Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 127.0.0.1, 192.168.0.117

     


    winrm id -r:http://localhost
    WSManFault
        Message = The WinRM client sent a request to an HTTP server and got a respon
    se saying the requested HTTP URL was not available. This is usually returned by
    a HTTP server that does not support the WS-Management protocol.

     

    Error number:  -2144108269 0x80338113
    The WinRM client sent a request to an HTTP server and got a response saying the
    requested HTTP URL was not available. This is usually returned by a HTTP server
    that does not support the WS-Management protocol.


    winrm id -r:http://localhost:5985
    IdentifyResponse
        ProtocolVersion = http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd
        ProductVendor = Microsoft Corporation
        ProductVersion = OS: 6.1.7601 SP: 1.0 Stack: 2.0


    winrm id -r:http://<my-serverName>:5985
    WSManFault
    Message = The WinRM client sent a request to an HTTP server and got a respon
    se saying the requested HTTP URL was not available. This is usually returned by
    a HTTP server that does not support the WS-Management protocol.

    Error number:  -2144108269 0x80338113
    The WinRM client sent a request to an HTTP server and got a response saying the
    requested HTTP URL was not available. This is usually returned by a HTTP server
    that does not support the WS-Management protocol.

     


     

    Is the listening port supposed to be 80, is that the problem?
    How did the listening port get set to 5985 ?


    ACan anyone point me to some resources to check out?
     
    Thanks,
     
    Rick








    • Edited by Rick O_Shey Tuesday, October 04, 2011 5:42 AM
    Tuesday, October 04, 2011 1:53 AM

Answers

  • This post is older than 30 days ..  I can see that you resolved your problem, Thanks for sharing

    Issue Resovled:

    A group policy was setting the port to 5985, I disabled to policy for this server.

    winrm enumerate winrm/config/listener

    Listener [Source="GPO"]
    Address = *
    Transport = HTTP
    Port = 5985
    Hostname Enabled = true
    URLPrefix = wsman
    CertificateThumbprint
    ListeningOn = 127.0.0.1, 192.168.0.117

     

    I then reconfigured the WinRm listener to port 80

    winrm set winrm/config/listener?Address=*+Transport=HTTP @{Port=”80”}
    winrm enumerate winrm/config/listener

    Listener
        Address = *
        Transport = HTTP
        Port = 80
        Hostname
        Enabled = true
        URLPrefix = wsman
        CertificateThumbprint
        ListeningOn = 127.0.0.1, 192.168.0.117, ::1, fe80::5efe:192.168.0.117%12, fe
    80::d190:5e3b:5ffc:98f4%11

     

    After which the installation completed normally.


    Mohamed Fawzi | http://fawzi.wordpress.com

    Saturday, October 06, 2012 2:39 AM
    Moderator