none
Trouble with SCCM (Error HTTP 500)

    Question

  • I'm a total newbie to SCCM, and I don't know a lot about IIS, so I need a little help with a problem I'm having with a new SCCM install.

    I just installed SCCM SP1 R2 on a Windows 2008 x64 server with IIS 7, SQL 2005 SP3 is installed on the same server, with all Windows Updates including IE 8. It looked like everything went fine with the SCCM install, and I am able to push clients out to machines and see them and do discoveries on the domain. However, I then tried to run a report, which is where the problems started. Whenever I try to run a report I immediately get a 500 error. When I look at the IIS log on the SCCM server, here's what I see:

    2009-05-14 13:05:28 xx.xx.xx.xx CCM_POST /ccm_system/request - 82 - yy.yy.yy.yy ccmhttp 500 0 64 12
    2009-05-14 13:06:09 xx.xx.xx.xx GET /SMSReporting_WCM/Report.asp ReportId=125|6|800a01a8|Object_required:_'Session(...)' 82 - yy.yy.yy.yy Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+2.0.50727;+.NET+CLR+1.1.4322;+.NET+CLR+3.0.04506.30;+InfoPath.2;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 500 0 0 3
    2009-05-14 13:07:57 ::1 GET /SMS_MP/.sms_aut MPLIST 82 - ::1 SMS_MP_CONTROL_MANAGER 500 0 193 12
    2009-05-14 13:07:57 ::1 GET /devicemgmt selftest 82 - ::1 SMS_MP_CONTROL_MANAGER 500 0 193 8
    2009-05-14 13:12:57 ::1 GET /SMS_MP/.sms_aut MPLIST 82 - ::1 SMS_MP_CONTROL_MANAGER 500 0 193 9
    2009-05-14 13:12:57 ::1 GET /devicemgmt selftest 82 - ::1 SMS_MP_CONTROL_MANAGER 500 0 193 7


    Also, I looked in the MPControl.log file and I see this (repeatedly):

    Call to HttpSendRequestSync failed for port 82 with status code 500, text: Internal Server Error  $$<SMS_MP_CONTROL_MANAGER><Thu May 14 08:12:57.122 2009 Central Daylight Time><thread=3404 (0xD4C)>
    Http test request failed, status code is 500, 'Internal Server Error'.~  $$<SMS_MP_CONTROL_MANAGER><Thu May 14 08:12:57.125 2009 Central Daylight Time><thread=3404 (0xD4C)>
    Successfully performed Management Point availability check against local computer.~  $$<SMS_MP_CONTROL_MANAGER><Thu May 14 08:12:57.126 2009 Central Daylight Time><thread=3404 (0xD4C)>

    So it looks like there is a problem with SCCM getting something to/from IIS, but I'm lost as to what is wrong. I need help to see what might be configured incorrectly that is causing this. I've done a ton of searches but haven't found anything that has helped.

    Thank you!
    Thursday, May 14, 2009 1:20 PM

Answers

  • Hi,

    this issue has been already seen on a project i handled.

    The problem concern running 32Bit Application on a 64Bit server.

    You should try running this command as an administrator on the server hosting IIS7 then execute the following command :

    %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

    it should set the Enable32BitAppOnWin64 to false.

    Then do a IISRESET and restart the computer. The MP should work properly now.
    Friday, May 15, 2009 2:11 PM

All replies

  • I am not completely clear on what  is the exact issue. Looks like you are trying to run reports and the reports are not running. Is that correct? Did you install the reporting point role on the same machine as the site server?

    Thanks,

    Bhaskar
    Thursday, May 14, 2009 2:19 PM
  • Make sure to follow http://technet.microsoft.com/en-us/library/cc431377.aspx ("How to Configure Windows Server 2008 for Site System") EXACTLY.
    ASP is needed for the reporting point. Have you enabled that, too?
    Uninstalling and reinstalling the MP might also help.
    Thursday, May 14, 2009 2:22 PM
    Moderator
  • Yes, I am trying to run reports, and I have installed the reporting point role.
    Thursday, May 14, 2009 2:34 PM
  • I did follow those instructions, and ASP is also installed.
    Thursday, May 14, 2009 2:36 PM
  • New information:

    I had an old SMS 2003 server to refer to (Windows 2003, IIS 6). I noticed that on that server, the SMSReporting_xxx object was an application, while on my new SCCM server, the SMSReporting_xxx object was a virtual directory. I converted the SMSReporting_xxx object on the SCCM server to an application, and now some reports run (showing a blank space where the report data should be), and some still show HTTP error 500, but now with this error:

    2009-05-14 14:38:49 xx.xx.xx.xx GET /SMSReporting_WCM/Report.asp ReportId=198|63|ASP_0178_:_80070005|Server.CreateObject_Access_Error 82 - yy.yy.yy.yy Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+2.0.50727;+.NET+CLR+1.1.4322;+.NET+CLR+3.0.04506.30;+InfoPath.2;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 500 0 0 139

    From searching Google, it would seem this is most likely a DCOM permission problem, which I just verified by looking at the Event Viewer:

    "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    {2D527A8C-A4B6-4E74-A63F-E867360D401C}
     to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool."

    However, looking in DCom Config, I see no CLSID with that number, or "SMSRPHost.SMSReporting", which the registry shows as being this CLSID.
    • Edited by M. Clark Thursday, May 14, 2009 3:17 PM
    Thursday, May 14, 2009 2:43 PM
  • Hi,

    Just wanted to follow up. I removed the Reporting Point role and reinstalled it, and now reports seem to be OK. I also did this several times before posting, so I don't know why it worked this time, but it did.
    Thursday, May 14, 2009 4:20 PM
  • If you are not managing hand held devices uncheck the box "Allow devices to connact to this management point" and your HTTP 500 errors will stop.
    John Marcum, Systems Management Architect - www.TrueSec.com
    Thursday, May 14, 2009 4:39 PM
    Moderator
  • Hi,

    this issue has been already seen on a project i handled.

    The problem concern running 32Bit Application on a 64Bit server.

    You should try running this command as an administrator on the server hosting IIS7 then execute the following command :

    %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

    it should set the Enable32BitAppOnWin64 to false.

    Then do a IISRESET and restart the computer. The MP should work properly now.
    Friday, May 15, 2009 2:11 PM
  • Thank you for this suggestion. I will try it shortly and follow back up if I still have problems. I just wanted to follow up now that I actually totally uninstalled IIS, SCCM, WebDav, etc. and started over with everything to attempt to solve the 500 error. Even still, I am getting the following errors in mpcontrol.log after the reinstall.

    Successfully performed Management Point availability check against local computer.~  $$<SMS_MP_CONTROL_MANAGER><Fri May 15 11:02:44.185 2009 Central Daylight Time><thread=5428 (0x1534)>

    Call to HttpSendRequestSync failed for port 82 with status code 500, text: Internal Server Error  $$<SMS_MP_CONTROL_MANAGER><Fri May 15 11:02:44.446 2009 Central Daylight Time><thread=5428 (0x1534)>

    Http test request failed, status code is 500, 'Internal Server Error'.~  $$<SMS_MP_CONTROL_MANAGER><Fri May 15 11:02:44.449 2009 Central Daylight Time><thread=5428 (0x1534)>

    STATMSG: ID=5480 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_MP_CONTROL_MANAGER" SYS=SCCM-SITE SITE=WCM PID=4348 TID=5428 GMTDATE=Fri May 15 16:02:44.452 2009 ISTR0="500" ISTR1="Internal Server Error" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0  $$<SMS_MP_CONTROL_MANAGER><Fri May 15 11:02:45.285 2009 Central Daylight Time><thread=5428 (0x1534)>
    Friday, May 15, 2009 4:16 PM
  • THANK YOU!  This fixed the problem. I followed your directions and now the MP is running correctly. I get results back now when running

    http://sccm-site/sms_mp/.sms_aut?mplist and
    http://sccm-site/sms_mp/.sms_aut?mpcert

    and the log shows successful communications.

    Thank you again for posting this.
    Friday, May 15, 2009 5:29 PM
  • THANK YOU!  This fixed the problem. I followed your directions and now the MP is running correctly. I get results back now when running

    http://sccm-site/sms_mp/.sms_aut?mplist and
    http://sccm-site/sms_mp/.sms_aut?mpcert

    and the log shows successful communications.

    Thank you again for posting this.


    Several points don't make sense. Here it is almost 1 year later, and I am having this exact problem (or very close).

    1) You never said "which" solution solved it - was it the 32-bit vs. 64-bit settings? or was it the tip about unchecking "handheld" - wherever that check-box may be - because the person posting was rather vague

    2) Why would the 32-bit thing even be an issue? I noticed sccm/sms is indeed in the x86 area - does this mean MS does NOT have a 64-bit version of SCCM? That's disturbing, to have all that horsepower, full 64-bit server and o/s and yet have to run 32-bit app.

    3) MS should hop on here and say "which" error is the issue; and "why" it is an issue

    4) When I go from an XP 32-bit workstation via browser, to http://mysccmbox/SMSReporting_SRV/Reports.asp, I get the infamous HTTP 500 - Internal server error. BUT when I go directly onto the SCCM Windows Server 2008 SP2 system and invoke that same URL, it gives me the reporting pages, with no problems!

    So, what gives? What is the 'real' issue? Is it indeed something dealing with 32-bit vs. 64-bit? Why does it work okay via localhost, i.e., directly logged into the SCCM server, but not via my workstation browser? (yes, my wokrstation is IE 6 btw)

    Why does it work okay for some of my co-admins' workstations (I think they are on Windows 7 Professiona 64-bit btw).

    AND, now in further testing, I go from another Windows Server (2003) via IE7, and it works fine.

    Confirmed Browser on the working systems: IE7 on the 'localhost' and IE7 or higher on the 2 working co-admin workstations.

    Thanks for any info.

    Thursday, May 06, 2010 1:35 PM
  • First of all let me state that you'd get more help by posting a new post rather than asking a question in a post that is marked as answered....

    Now to the issue.

    1. HTTP 500 on the MP has nothing to do with getting HTTP 500 when going to reports.

    2. I've never heard of reports working from one workstation but not from another one.

    3. The most common issues that causes HTTP 500 errors are checking the box "Allow devices to connect my this MP" and SQL permissions issues where a secondary site can't connect to SQL on the primary site. (unless the MP never worked then see #4)

    4. If the MP never worked and this is server 2008 you probably didn't configure IIS correctly. This could break the RP too.

     

     

     

     


    John Marcum | http://myitforum.com/cs2/blogs/jmarcum |
    • Proposed as answer by Micmaher Thursday, June 17, 2010 12:46 PM
    Thursday, May 06, 2010 10:32 PM
    Moderator