none
SQL Server MP 6.4.0.0: Operations Manager Failed to convert performance data

    Question

  • Hi all,

    I have updated SQL MP to version 6.4.0.0 and since I receive tons of alerts:

    Module was unable to convert parameter to a double value Original parameter:
    '$Data/Property[@Name='CPUUsage']$' Parameter after $Data replacement: '-1.#IND'
    Error: 0x80020005 Details: Type mismatch. One or more workflows were affected by
    this. Workflow name: Microsoft.SQLServer.2008.DBEngine.CPUUsagePercentMonitor
    Instance name: MSSQLSERVER Instance ID: {yyyy}
    Management group: xxxx

    Source: Operations Manager

    Event Number: 11052

    Before MP update, I never had these alerts... All impacted servers are running SQL 2008 or SQL 2008 R2 instances.

    Any help would be appreciated! Thanks in advance.

    Jean-Marc

    Thursday, September 12, 2013 3:12 PM

Answers

All replies

  • You are not alone.  We're seeing the same thing, exact same case.  Started within minutes of updating to 6.4.0.0.

    I'm about to disable the rule for CPU Usage monitoring, since it's a new feature in 6.4.0.0.  I came across your post using Google...

    Friday, September 13, 2013 4:55 AM
  • I'm not alone! :-S

    I have tried to disable the CPU Utilization (%) monitor in SQL Server 2008 DB Engine, but without any impact: still having alerts.

    Friday, September 13, 2013 12:28 PM
  • Same here -- I disabled it, and then went to bed... and woke up this morning to find that it's still generating alerts.  I suppose we could try disabling the alert that is generating the alert -- but that's not a good idea.

    I guess this is what we get for being the first to "test" it.   Argh...   We're on SCOM 2012 SP1 CU3.


    Friday, September 13, 2013 2:16 PM
  • Yep, we are getting this too.  SCOM 2012 SP1 CU3 :(

    Happens on all SQL 2008 SP3 and SQL 2012 SP1 servers.

    Monday, September 16, 2013 4:28 AM
  • The same issue

    Aleksandrs

    Monday, September 16, 2013 9:06 AM
  • On our SQL servers we get the following messages after importing the new management pack:

    On SQL 2012 Servers we get the following message in the eventlog:

    Managegement Group: name. Script: Main :

    Exception calling "Fill" with "1" argument(s): "The user does not have permission to perform this action."Error occured during CPU Usage for SQL Instances data source executing.
    Computer:dbservername
    Reason: Exception calling "Fill" with "1" argument(s): "The user does not have permission to perform this action."

    On SQL 2008 servers we get his one:

    Operations Manager Failed to convert performance data

    The module cannot convert the parameter to a double value.

    Original parameter: $Data/Property[@Name='CPUUsage']$

    Parameter after replacement of $Data: -1.#IND

    Error: 0x80020005

    Details: Type mismatch.

    Werkstroomnaam: Microsoft.SQLServer.2008.DBEngine.CPUUsagePercentMonitor

    Has anybody found a way to solve this or seen this happening as well?

    Tuesday, September 17, 2013 9:02 AM
  • Same as you:

    • SCOM 2012 SP1 with CU3
    • alert generated on all SQL 2008 and 2012 servers

    Any help from Microsoft or from any MVP would be appreciated... as well as any information (known bug in MP, workaround, etc...).

    Thanks in advance!

    Wednesday, September 18, 2013 9:42 AM
  • Same issue, 

    Managegement Group: MGMTGRP. Script: Main : 

    Exception calling "Fill" with "1" argument(s): "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"Error occured during CPU Usage for SQL Instances data source executing.
    Computer:MyDBMachineName

    Reason: Exception calling "Fill" with "1" argument(s): "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

    Exception calling "Fill" with "1" argument(s): "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)"Error occured during CPU Usage for SQL Instances data source executing.
    Computer:MyDBMachineName

    Reason: Exception calling "Fill" with "1" argument(s): "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)"


    Thanks, Chris

    Wednesday, September 18, 2013 4:00 PM
  • I'm also getting the same error after updating the SQL MP to version 6.4.0.0

    • System Center Operations Manager 2012 SP1 CU3
    • SQL Server 2008 R2
    Wednesday, September 18, 2013 5:19 PM
  • We also are experiencing this issue.

    Just upgraded the management pack yesterday and all the sudden all my SQL 2008 installations are reporting this error.

    :(

    Someone said they tried to disable it and it didn't work....can ANYONE from MS chime in here and tell us at least how to disable the damn thing until it's fixed?

    Mike

    SCOM 2012 RTM RU 3



    Module was unable to convert parameter to a double value

    Original parameter: '$Data/Property[@Name='CPUUsage']$'

    Parameter after $Data replacement: '-1.#IND'

    Error: 0x80020005

    Details: Type mismatch

    Thursday, September 19, 2013 3:23 PM
  • Same issue for me after updating SQL Server MP to version 6.4.0.0. Alert source is the primary SQL server in a Failover Cluster. I've notice other new actionable alarms with this new MP, but not this one.

    I'm very interested in how to resolve this issue.

    Thursday, September 19, 2013 4:47 PM
  • We also are experiencing this issue.

    Just upgraded the management pack yesterday and all the sudden all my SQL 2008 installations are reporting this error.

    :(

    Someone said they tried to disable it and it didn't work....can ANYONE from MS chime in here and tell us at least how to disable the damn thing until it's fixed?

    Mike

    SCOM 2012 RTM RU 3



    Module was unable to convert parameter to a double value

    Original parameter: '$Data/Property[@Name='CPUUsage']$'

    Parameter after $Data replacement: '-1.#IND'

    Error: 0x80020005

    Details: Type mismatch

    You should disable the following rules:

    MSSQL 2012: Collect DB Engine CPU Utilization (%)

    MSSQL 2008: Collect DB Engine CPU Utilization (%)

    The following monitors:

    CPU Utilization (%) for 2008

    CPU Utilization (%) for 2012

    Thursday, September 19, 2013 7:37 PM
  • You should disable the following rules:

    MSSQL 2012: Collect DB Engine CPU Utilization (%)

    MSSQL 2008: Collect DB Engine CPU Utilization (%)

    The following monitors:

    CPU Utilization (%) for 2008

    CPU Utilization (%) for 2012

    Thanks Aleksander for this tip to stop these noisy alerts, it worked for me.

    Anyway, still no official news from Microsoft on this issue...

    Friday, September 20, 2013 7:38 AM
  • Hi all,

    Thanks for the feedback, I would log this issue, also for feedback to product, it is recommended to submit it in connect website:

    Search Products accepting bugs or suggestions

    https://connect.microsoft.com/


    Alex Zhao
    TechNet Community Support

    Thursday, September 26, 2013 6:32 AM
  • Hello, everyone.

    It looks like a bug in the script
    function Main {param ($ computerName) - called with cluster host name

    and then listing of active instances of SQL on node 

    $ counters = (Get-Counter ("\ Process (sqlservr *) \ ID Process")). CounterSamples
    $ counters | foreach {

    And here is the error:
    $ allowedCoreCount = GetSQLAllowedCoreCount $ computerName $ instanceName $ logicalCoresCount
    The computerName may be different.  

    In my case, the configuration is as follows:
    A two-node cluster, and 3 instances of the SQL:
    cl-sql-01\sql1
    cl-sql-02\sql2
    cl-sql-03\sql3

    This rule is invoked for the first instance of an error does not occur in first foreach.
    However, the second will be generated connection string sql-sc-01\sql2 that will cause an error.

    Best regards.
    Kuchynski Andrei.
    Thursday, October 03, 2013 7:39 AM
  • I have the same problem on SCOM 2007 R2.

    After disabling the rules an monitors I get other warnings like this:

    -----------------

    Forced to terminate the following PowerShell script because it ran past the configured timeout 200 seconds.

    Script Name: SQLReCompilation.ps1

    One or more workflows were affected by this.

    Workflow name: Microsoft.SQLServer.2008.DBEngine.SQLReCompilationMonitor

    Instance name: MSSQLSERVER

    Instance ID: {D95D8D69-CB8A-13B8-904E-BCB91133493F}

    Management group: xxx

    -----------------

    It's only an example.

    Barbara

    Tuesday, October 08, 2013 12:22 PM
  • I found the similar error for 'FreeSpaceAutoGrowPercent', I verified all the database have fixed db growth defined. None of them have 10% or 15% db file growth.

    Alert description:
    Module was unable to convert parameter to a double value
    Original parameter: '$Data/Property[@Name='FreeSpaceAutoGrowPercent']$'
    Parameter after $Data replacement: ''
    Error: 0x80020005
    Details: Type mismatch.

    Friday, October 11, 2013 3:11 PM
  • I don't know about anyone else but overriding those monitors and rules didn’t work for me, I had to override<o:p></o:p>

    SQL Re-Compilation monitor for SQL 2012 DB Engine<o:p></o:p>

    SQL Re-Compilation monitor for SQL 2008 DB Engine<o:p></o:p>

    Average Wait Time monitor for SQL 2012 DB<o:p></o:p>

    Average Wait Time monitor for SQL 2008 DB<o:p></o:p>

    Now I am wondering if other monitors are valid as well in particular I have multiple alerts for<o:p></o:p>

    Buffer Cache Hit Ratio monitor for SQL 2008 DB Engine is too low<o:p></o:p>

    Page Life Expectancy (s) for 2008 DB Engine is too low<o:p></o:p>

    is anyone else seeing these issues as well?
    Sunday, October 13, 2013 11:39 PM
  • Same issue with all new monitors and rules in the MP 6.4 like listed here:

    http://www.sc-operationsmanager.eu/index.php/blog/203-scom-2012-neue-version-des-sql-mps

    Only the monitor and rule for CPU Utilization can be disabled.

    For me the SQL MP is useless in this version cause I waste time with analyzing is there a real problem or not.

    Barbara

    Monday, October 14, 2013 6:34 AM
  • There has been an updated MP which fixes a lot of issues mentioned here.

    http://www.microsoft.com/en-us/download/details.aspx?id=10631

    Monday, October 14, 2013 5:24 PM
  • There has been an updated MP which fixes a lot of issues mentioned here.

    http://www.microsoft.com/en-us/download/details.aspx?id=10631


    Applied today and confirm it fixed the issue!
    Tuesday, October 15, 2013 8:04 AM
  • There has been an updated MP which fixes a lot of issues mentioned here.

    http://www.microsoft.com/en-us/download/details.aspx?id=10631


    Applied today and confirm it fixed the issue!

    Yep, me too.  All clear now thanks.
    Tuesday, October 15, 2013 8:04 PM
  • After installation of the update yesterday the errors disappear for round about 4 hours. Then the error messages starts again.
    Wednesday, October 16, 2013 6:34 AM
  • I installed the new MP on Friday and alerts disappeared as well. Came in this morning and they have started again. MP v6.4.1 for both Discovery and Monitoring on SQL 2012. Documentation says it covers SQL 2008 as well. Any assistance appreciated thanks
    Sunday, October 27, 2013 9:54 PM
  • We also upgraded to MP 6.4.1 and the issue with these alerts is NOT resolved.

    We are seeing the alert on our SQL servers both clustered and non clustered SQL servers.

    Servers are running Win2008R2

    Tuesday, October 29, 2013 1:01 PM
  • Also upgraded to MP 6.4.1 and still receiving the alerts. Servers are running WIN2k8R2
    Monday, November 04, 2013 9:54 AM
  • Still getting alerts like:

    Forced to terminate the following PowerShell script because it ran past the configured timeout 200 seconds.
    Script Name: CPUUsagePercent2008DataSource.ps1
    One or more workflows were affected by this.
    Workflow name: Microsoft.SQLServer.2008.DBEngine.CPUUsagePercentMonitor

    Monday, November 04, 2013 9:59 AM
  • Still getting alerts like:

    Forced to terminate the following PowerShell script because it ran past the configured timeout 200 seconds.
    Script Name: CPUUsagePercent2008DataSource.ps1
    One or more workflows were affected by this.
    Workflow name: Microsoft.SQLServer.2008.DBEngine.CPUUsagePercentMonitor

    Me too, not for all of our SQL fleet, but for about 10/100 SQL servers...

    Cheers

    Tuesday, November 05, 2013 2:03 AM
  • Maybe this will help to someone.

    I just installed new SCOM 2012 R2, and imported SQL MP 6.4.1. and also got alert storm in event log. As I have single server architecture with local SQL server and local SCOM agent service runs under "local system" account, I had added NT AUTHORITY\SYSTEM with sysadmin permissions on SQL as I thought that will be used to monitor my SQL instance (it had worked before). But no luck, many events in log stating that I don't have permissions.

    So I opened up SQL MP Guide and found the quote there: "By default, all discoveries, monitors, and tasks defined in the SQL Server management packs default to using the accounts defined in the “Default Action Account” Run As profile."

    So that means I had to configure rights not for the agent run-as account, but default action account (Management Server Action Account specified while installing). As I changed the permissions, alerts where gone and I saw that the correct perf data started to gather.

    GL!


    Janis Berzins / Infrastructure Solutions Consultant



    • Edited by Janis Berzins Tuesday, December 10, 2013 4:04 PM readability
    Tuesday, December 10, 2013 3:57 PM
  • Hi,

    I have already installed this updated MP in my SCOM 2012 SP1 environment but still I am getting lots of same alert. Is there any other work around to fix this issue?

    Monday, March 10, 2014 10:34 AM
  • hello

    I have already installed  MP Version 6.4.1.0in my SCOM 2012 SP1 environment but still I am getting lots of alerts like this:

    Exception calling "Fill" with "1" argument(s): "The user does not have permission to perform this action."Error occured during CPU Usage for SQL Instances data source executing.

    Reason: Exception calling "Fill" with "1"

    I really don't think this alerts are related to permission. what I have to do?

    Tuesday, March 18, 2014 6:47 AM
  • Hello,

    Same here with SCOM 2007 a lot of errors:

    Exception calling "Fill" with "1" argument(s): "The user does not have permission to perform this action."Error occured during CPU Usage for SQL Instances data source executing.

    What to do?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Thursday, March 20, 2014 9:18 PM
  • another update on the MP here http://www.microsoft.com/en-us/download/details.aspx?id=10631

    (yes, that's the same link as above)

    Monday, July 07, 2014 2:10 PM