none
Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows)

    Question

  • Hi All

    I am running a well established SCCM 2007 (version 4.00.6487.2000) R3 infrastructure which has been working flawlessly for a year or more. Yesterday I created a scripted install for a new HP 8460p laptop (32bit Windows 7 SP1 OS and drivers) and receive the following error when deploying the display driver (from the smsts log file):

    • The execution of the group (Deploy Standard Build) has failed and the execution has been aborted. An action failed.
      Operation aborted (Error: 80004004; Source: Windows)
    • Failed to run the last action: Install 8460p Display Driver. Execution of task sequence failed.
      Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows)

    I am a bit puzzled as the driver installation works perfectly when I map a drive to the SCCM software share and run the install manually. I have encountered this problem when deploying 64bit drivers to an HP 2540p laptop in the past but never bothered to troubleshoot it further as we do not require a 64bit OS. All other drivers appear to install OK.

    Any help would be appreciated.

    Arthur

    • Moved by Torsten [MVP]MVP Thursday, August 18, 2011 3:58 PM moved to OSD (From:Configuration Manager Setup/Deployment)
    Thursday, August 18, 2011 3:43 PM

All replies

  • Hello - Any helpful information in SMSTS.log? Do you have many driver packages assigned ? If yes, Try removing some of unwanted driver packages?
    Anoop C Nair - This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 18, 2011 4:51 PM
  • Hi and thanks for the reply...I can't see anything that looks obviously wrong; below is the log from where the package install begins. I have found that the error occurs even if I deploy the driver AFTER the TS build sequence has completed i.e. I disable the Graphics driver in the OS deployment script and then deploy it after the OS has been built. This was the same when I was deploying the 64bit OS.

    Installing software for PackageID='EEL001D4' ProgramID='8460p Graphics Driver' AdvertID='EEL200CB' has started, jobID='{A0658DFA-BBF3-49FD-BBF2-95D3E7D58E2B}' InstallSoftware 18/08/2011 14:48:47 3492 (0x0DA4)
    Setting TSEnv variable 'SMSTSInstallSoftwareJobID_EEL001D4_EEL200CB_8460p Graphics Driver'='{A0658DFA-BBF3-49FD-BBF2-95D3E7D58E2B}' InstallSoftware 18/08/2011 14:48:47 3492 (0x0DA4)
    Waiting for installation job to complete.. InstallSoftware 18/08/2011 14:48:47 3492 (0x0DA4)
    CompleteExecution received InstallSoftware 18/08/2011 14:49:05 3024 (0x0BD0)
    CompleteExecution processed InstallSoftware 18/08/2011 14:49:05 3024 (0x0BD0)
    Received job completion notification from Execution Manager InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Installation completed with exit code 0x8007000e InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Installation failed with error (0x8007000e) InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Setting TSEnv variable 'SMSTSInstallSoftwareJobID_EEL001D4_EEL200CB_8460p Graphics Driver'='' InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    GetExecRequestMgrInterface successful InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Releasing job request, jobID='{A0658DFA-BBF3-49FD-BBF2-95D3E7D58E2B}' InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Releasing of Job Request successful InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    CompleteJob successful InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Entering ReleaseSource() for C:\_SMSTaskSequence\Packages\EEL001D4 InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    reference count 1 for the source C:\_SMSTaskSequence\Packages\EEL001D4 before releasing InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Delete source directory C:\_SMSTaskSequence\Packages\EEL001D4 InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Released the resolved source C:\_SMSTaskSequence\Packages\EEL001D4 InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    pInstall->Install(sPackageID, sProgramName), HRESULT=8007000e (e:\nts_sms_fre\sms\client\osdeployment\installsoftware\main.cpp,374) InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Install Software failed, hr=0x8007000e InstallSoftware 18/08/2011 14:49:05 3492 (0x0DA4)
    Process completed with exit code 2147942414 TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    !--------------------------------------------------------------------------------------------! TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Failed to run the action: Install 8460p Display Driver.
    Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows) TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Sending status message . . . TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Send a task execution status message SMS_TSExecution_ActionFailError TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    MP server EELSCCM01.EU.EISAI.LOCAL and port 80. SSL=false. CRL=false. TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Site code: EEL TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Client machine name: EELCNBTEST TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Client Identity: GUID:055DB966-5992-457C-9D1A-FBF55D31A392 TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Advertisement ID: EEL200CB TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Package ID: EEL00191 TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Sending StatusMessage TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Formatted header: TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    <Msg SchemaVersion="1.1" ReplyCompression="zlib"><ID/><SourceID>2e648c42-7a75-4b23-b3bb-58a5892da051</SourceID><SourceHost/><TargetAddress>mp:[http]MP_StatusManager</TargetAddress><ReplyTo>direct:OSD</ReplyTo><Priority>3</Priority><Timeout>3600</Timeout><SentTime>2011-08-18T13:49:05Z</SentTime><Protocol>http</Protocol><Body Type="ByteRange" Offset="0" Length="4238"/><Hooks/><Payload Type="inline"/><TargetHost/><TargetEndpoint>StatusReceiver</TargetEndpoint><ReplyMode>Sync</ReplyMode><CorrelationID/></Msg>
     TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    CLibSMSMessageWinHttpTransport::Send: URL: EELSCCM01.EU.EISAI.LOCAL:80  CCM_POST /ccm_system/request TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    The request has succeeded. 200 OK TSManager 18/08/2011 14:49:05 2720 (0x0AA0)
    Set a global environment variable _SMSTSLastActionRetCode=-2147024882 TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Set a global environment variable _SMSTSLastActionSucceeded=false TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Clear local default environment TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Let the parent group (HP-8460p) decides whether to continue execution TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Let the parent group (Deploy Eisai Standard Build) decide whether to continue execution TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    The execution of the group (Deploy Eisai Standard Build) has failed and the execution has been aborted. An action failed.
    Operation aborted (Error: 80004004; Source: Windows) TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Failed to run the last action: Install 8460p Display Driver. Execution of task sequence failed.
    Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows) TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Sending status message . . . TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Send a task execution status message SMS_TSExecution_TaskSequenceFailError TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    MP server EELSCCM01.EU.EISAI.LOCAL and port 80. SSL=false. CRL=false. TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Site code: EEL TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Client machine name: EELCNBTEST TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Client Identity: GUID:055DB966-5992-457C-9D1A-FBF55D31A392 TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Advertisement ID: EEL200CB TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Package ID: EEL00191 TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Sending StatusMessage TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Formatted header: TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    <Msg SchemaVersion="1.1" ReplyCompression="zlib"><ID/><SourceID>2e648c42-7a75-4b23-b3bb-58a5892da051</SourceID><SourceHost/><TargetAddress>mp:[http]MP_StatusManager</TargetAddress><ReplyTo>direct:OSD</ReplyTo><Priority>3</Priority><Timeout>3600</Timeout><SentTime>2011-08-18T13:49:06Z</SentTime><Protocol>http</Protocol><Body Type="ByteRange" Offset="0" Length="2132"/><Hooks/><Payload Type="inline"/><TargetHost/><TargetEndpoint>StatusReceiver</TargetEndpoint><ReplyMode>Sync</ReplyMode><CorrelationID/></Msg>
     TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    CLibSMSMessageWinHttpTransport::Send: URL: EELSCCM01.EU.EISAI.LOCAL:80  CCM_POST /ccm_system/request TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    The request has succeeded. 200 OK TSManager 18/08/2011 14:49:06 2720 (0x0AA0)
    Execution::enExecutionFail != m_eExecutionResult, HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmanager\tsmanager.cpp,767) TSManager 18/08/2011 14:50:19 2720 (0x0AA0)
    Task Sequence Engine failed! Code: enExecutionFail TSManager 18/08/2011 14:50:19 2720 (0x0AA0)
    **************************************************************************** TSManager 18/08/2011 14:50:19 2720 (0x0AA0)
    Task sequence execution failed with error code 80004005 TSManager 18/08/2011 14:50:19 2720 (0x0AA0)

    Thursday, August 18, 2011 5:05 PM
  • I am also experiencing the same issue with the Intel HD Graphics for the same series of HP elitebook.  Were you able to come up with a solution?

    Wednesday, September 14, 2011 5:44 PM
  • If it helps anyone, I was able to use the "Continue on Error" checkbox for that step in the task sequence.  Apparently it does install, but still trips that error.  When I allowed it to continue to the next step, the image worked fine.

    Wednesday, September 21, 2011 1:50 PM
  • I had the same problem. But my problem is stuck at Restore User files and settings task and turn out that all the user data is not migrated over to Win7. My smsts.log file says

    Failed to run the action: Restore User Files and Settings.
    Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows)

    But it cannot be "not enough storage space" because before migrate, got 50 GB free HD space.... If i select the continue on error option, will it restore user files?
    • Edited by Efa77 Friday, October 07, 2011 9:17 AM
    Friday, October 07, 2011 8:01 AM
  • has anyone found an aswer to this?
    Thursday, December 15, 2011 8:02 PM
  • try forcing the installation of the driver to log its progress, you'll need to find out what the switch is to create the log then get it to log to a local temp folder eg: c:\tmp\videodriver.log

    does that help ?



    Step by Step ConfigMgr 2007 Guides
    Step by Step ConfigMgr 2012 Guides
    I'm on Twitter > ncbrady
    Thursday, December 15, 2011 8:45 PM
    Moderator
  • I am seeing this as well...I will post back if I find a solution.

    David Baur

    Friday, July 20, 2012 4:40 PM
  • how much RAM in the system ?


    Step by Step ConfigMgr 2007 Guides | Step by Step ConfigMgr 2012 Guides | I'm on Twitter > ncbrady

    Friday, July 20, 2012 7:22 PM
    Moderator
  • 8 GB, and 460 GB Free...so this is definitely not the cause.

    (I think Configuration Manager is confusing an issue with a Local Account and not being able to restore the profile to the target system and treast this as a "memory" issue...since it probably does not have logic to be more clear on what the problem is.)

    Actually, I think it fails due to a Local Account that will not transfer as we are not setting the password. Changing the switches did not resolve this. The error in the log is:

    "The account PCNAME\LocalAccountName is chosen for migration, but the target does not have account NEWCOMPUTERNAME\LocalAccountName. See documentation on /lac, /lae, /ui, /ue and /uel options."

    It fails after that. This would amke sense, as if we do not set the new Pasword for Local Accounts, then it would fail. I am testing this to verify this is the failure by deleting the local account, and then will try to do a Capture and Restore. (Capture works...it just fails to restore)...So we will see how it does.


    David Baur

    Friday, July 20, 2012 7:45 PM
  • The storage that the error refers to is not the disk but most likely the memory.

    Also, the failure is not in the task sequence engine but in the execution manager. You need to take a look at the execution manager log to see what failed.

    Monday, July 23, 2012 5:57 PM
  • As noted already, the system has 8 GB of RAM. Definitely not Memory, but in looking at the Client, the SCCM client Install keeps repeating...so I think this is just a bad system to be doing a capture From. I will see if I get the same problem with another PC. Thanks!

    David Baur

    Monday, July 23, 2012 10:22 PM
  • Could the driver be dependent on something else like a .net framework which some of these video drivers require first?

    Or could it be a rights issue. 

    Wednesday, August 01, 2012 1:27 AM
  • Hi I am seeing the same issue but I am seeing this on regular packages in my Task Sequence, such as Bluetooth Software and Wireless Software.

    Here is the error in the smsts.log file:

    The execution of the group (Post-Build Configuration) has failed and the execution has been aborted. An action failed.
    Operation aborted (Error: 80004004; Source: Windows) TSManager 8/20/2012 12:17:18 PM 1824 (0x0720)
    Failed to run the last action: Install Intel ProSet Wireless Software 15.1.0.18. Execution of task sequence failed.
    Not enough storage is available to process this command. (Error: 80070008; Source: Windows) TSManager 8/20/2012 12:17:18 PM 1824 (0x0720)

    The computer has 4gigs of RAM.

    Has anyone else seen this issue? I had to set the step to continue on error but the software does not install (which is needed so this is not a fix for us)

    • Proposed as answer by DonD1976 Wednesday, August 29, 2012 11:09 PM
    • Unproposed as answer by DonD1976 Wednesday, August 29, 2012 11:09 PM
    Wednesday, August 22, 2012 8:47 PM
  • Are you using a custom INI file to install the drivers/software?  I had the same issue with the Lenovo T430s USB 3.0 Driver.  Most likely if you are using a custom INI file and a Base variable to dictate your installs, it throws up an error message that SCCM doesn't know how to handle, but installs the driver anyway.  The way we got around it is instead of using the custom INI, we had to specify it in the actual Task sequence as a Apply Driver step and that installed successfully. 


    Don D.

    Wednesday, August 29, 2012 11:14 PM
  • Don,

    How were you using the INI file and how did you remove it? If you used an Auto Apply Drivers, it sounds like you imported the drivers instead of running the OEM installer? Is that right?

    Thanks,

    Rob

    Tuesday, October 02, 2012 5:03 PM