none
Error when upgrading Management Group to SCOM 2012

    Question

  • I have 2 management servers in Ops Mgr 2007 R2, RMS and secondary. They we'rent 64 bit so I setup 2 new 64 bit machines and installed opsmgr2007R2 on them as secondary management servers into the group. I then upgraded both them to OpsMGR 2012 with no issue. I then restored the registry keys for encryption keys for Opsmgr2007R2 onto the new 2012 mgmt servers since they are removed during the upgrade. The I try to do the management group upgrade from one of the new 2012 management servers and It fails when configuring the operations manager database. I was able to restore the database back so that I can access the RMS through 2007R2 Operations Console. Below is the section of the log that has the error. Any help would be appreciated. 

    Always: :Current Action: RunAdminScripts
    [10:58:38]: Info: :Info:Using DB command timeout = 1800 seconds.
    [10:58:38]: Info: :Adding Script files to dictionary.
    [10:58:38]: Info: :
        .\build_mom_db_admin.sql
      
    [10:58:38]: Info: :Added 
        .\build_mom_db_admin.sql
       to the dictionary.
    [10:58:38]: Info: :
        .\build_mom_db.sql
      
    [10:58:38]: Info: :Added 
        .\build_mom_db.sql
       to the dictionary.
    [10:58:38]: Info: :
        .\build_momv3_localization.sql
      
    [10:58:38]: Info: :Added 
        .\build_momv3_localization.sql
       to the dictionary.
    [10:58:38]: Info: :
        .\build_mom_db_postMPimport.sql
      
    [10:58:38]: Info: :Added 
        .\build_mom_db_postMPimport.sql
       to the dictionary.
    [10:58:38]: Info: :
        .\build_mom_db_postMPimport.sql
      
    [10:58:38]: Info: :Not Added to dictionary: 
        .\build_mom_db_postMPimport.sql
      
    [10:58:38]: Info: :
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:38]: Info: :Added 
        .\build_om_db_ConfigSvcRole.sql
       to the dictionary.
    [10:58:38]: Info: :
        .\cleanup_mom_db.sql
      
    [10:58:38]: Info: :Not Added to dictionary: 
        .\cleanup_mom_db.sql
      
    [10:58:38]: Info: :
        .\cleanup_mom_db.sql
      
    [10:58:38]: Info: :Not Added to dictionary: 
        .\cleanup_mom_db.sql
      
    [10:58:38]: Info: :
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:38]: Info: :Not Added to dictionary: 
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:38]: Info: :Done loading scripts
    [10:58:48]: Info: :RunAdminScripts completed.
    [10:58:48]: Always: :Current Action: RunStandardScripts
    [10:58:48]: Info: :Info:Using DB command timeout = 1800 seconds.
    [10:58:48]: Info: :Adding Script files to dictionary.
    [10:58:48]: Info: :
        .\build_mom_db_admin.sql
      
    [10:58:48]: Info: :Added 
        .\build_mom_db_admin.sql
       to the dictionary.
    [10:58:48]: Info: :
        .\build_mom_db.sql
      
    [10:58:48]: Info: :Added 
        .\build_mom_db.sql
       to the dictionary.
    [10:58:48]: Info: :
        .\build_momv3_localization.sql
      
    [10:58:48]: Info: :Added 
        .\build_momv3_localization.sql
       to the dictionary.
    [10:58:48]: Info: :
        .\build_mom_db_postMPimport.sql
      
    [10:58:48]: Info: :Added 
        .\build_mom_db_postMPimport.sql
       to the dictionary.
    [10:58:48]: Info: :
        .\build_mom_db_postMPimport.sql
      
    [10:58:48]: Info: :Not Added to dictionary: 
        .\build_mom_db_postMPimport.sql
      
    [10:58:48]: Info: :
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:48]: Info: :Added 
        .\build_om_db_ConfigSvcRole.sql
       to the dictionary.
    [10:58:48]: Info: :
        .\cleanup_mom_db.sql
      
    [10:58:48]: Info: :Not Added to dictionary: 
        .\cleanup_mom_db.sql
      
    [10:58:48]: Info: :
        .\cleanup_mom_db.sql
      
    [10:58:48]: Info: :Not Added to dictionary: 
        .\cleanup_mom_db.sql
      
    [10:58:48]: Info: :
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:48]: Info: :Not Added to dictionary: 
        .\build_om_db_ConfigSvcRole.sql
      
    [10:58:48]: Info: :Done loading scripts
    [11:01:05]: Info: :RunStandardScripts completed.
    [11:01:05]: Always: :Current Action: InsertManagementGroupInfo
    [11:01:05]: Info: :   This method was not run for this setup operation.
    [11:01:05]: Info: :InsertManagementGroupInfo completed.
    [11:01:05]: Always: :Current Action: ImportEulas
    [11:01:05]: Info: :Info:Using DB command timeout = 1800 seconds.
    [11:01:05]: Info: :Attempting to import eula_CONSOLE_eval.rtf into the database.
    [11:01:05]: Warn: :Could not find eula_CONSOLE_eval.rtf; we will continue
    [11:01:05]: Info: :Attempting to import eula_CONSOLE_oem.rtf into the database.
    [11:01:05]: Warn: :Could not find eula_CONSOLE_oem.rtf; we will continue
    [11:01:05]: Info: :Attempting to import eula_CONSOLE_fpp.rtf into the database.
    [11:01:05]: Warn: :Could not find eula_CONSOLE_fpp.rtf; we will continue
    [11:01:05]: Info: :Attempting to import eula_EN_eval.rtf into the database.
    [11:01:05]: Info: :Attempting to import eula_EN_oem.rtf into the database.
    [11:01:05]: Info: :Attempting to import eula_EN_fpp.rtf into the database.
    [11:01:06]: Info: :Attempting to import eula_LOGS_eval.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_LOGS_eval.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_LOGS_oem.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_LOGS_oem.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_LOGS_fpp.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_LOGS_fpp.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_REPORTING_eval.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_REPORTING_eval.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_REPORTING_oem.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_REPORTING_oem.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_REPORTING_fpp.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_REPORTING_fpp.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SERVER_eval.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SERVER_eval.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SERVER_oem.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SERVER_oem.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SERVER_fpp.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SERVER_fpp.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SHAREPOINT_eval.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SHAREPOINT_eval.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SHAREPOINT_oem.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SHAREPOINT_oem.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_SHAREPOINT_fpp.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_SHAREPOINT_fpp.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_WEBCONSOLE_eval.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_WEBCONSOLE_eval.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_WEBCONSOLE_oem.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_WEBCONSOLE_oem.rtf; we will continue
    [11:01:06]: Info: :Attempting to import eula_WEBCONSOLE_fpp.rtf into the database.
    [11:01:06]: Warn: :Could not find eula_WEBCONSOLE_fpp.rtf; we will continue
    [11:01:06]: Info: :ImportEulas completed.
    [11:01:06]: Always: :Current Action: PopulateRegistryKeys
    [11:01:06]: Info: :PopulateRegistryKeys completed.
    [11:01:06]: Always: :Current Action: PopulateUserRoles
    [11:01:06]: Info: :Info:GetLocalizedAdminGroupName: Administrators Group Name is: BUILTIN\Administrators
    [11:01:15]: Info: :PopulateUserRoles completed.
    [11:01:15]: Always: :Current Action: ProvisionServers
    [11:01:16]: Error: :ProvisionServers failed with the following exception: : Threw Exception.Type: System.Reflection.TargetInvocationException, Exception Error Code: 0x80131604, Exception.Message: Exception has been thrown by the target of an invocation.
    [11:01:16]: Error: :StackTrace:   at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
       at System.RuntimeMethodHandle.InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
       at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
       at System.Delegate.DynamicInvokeImpl(Object[] args)
       at Microsoft.EnterpriseManagement.SetupFramework.ActionEngine.Action.Run(String displayStringNamespace, ProgressData progressData, Func`2 progressDelegate)
       at Microsoft.EnterpriseManagement.SetupFramework.ActionEngine.InstallStep.Run(String displayStringNamespace, ProgressData progressData, Func`2 progressDelegate)
    [11:01:16]: Error: :Inner Exception.Type: System.Exception, Exception Error Code: 0x80131604, Exception.Message: Exception decrypting. Key not valid for use in specified state
    [11:01:16]: Error: :InnerException.StackTrace:   at Microsoft.EnterpriseManagement.OperationsManager.Setup.DBUpgradeConfiguration.DPAPIWrapper.Decrypt(Byte[] cipherText)
       at Microsoft.EnterpriseManagement.OperationsManager.Setup.DBUpgradeConfiguration.DatabaseUpgrade.Provision()
    [11:01:16]: Error: :FATAL ACTION: ProvisionServers
    [11:01:16]: Error: :FATAL ACTION: DatabaseActions
    [11:01:16]: Error: :ProcessInstalls: Running the PostProcessDelegate returned false.
    [11:01:16]: Always: :SetErrorType: Setting VitalFailure. currentInstallItem: Database Configuration
    [11:01:16]: Error: :ProcessInstalls: Running the PostProcessDelegate for OMDATABASE failed.... This is a fatal item.  Setting rollback.
    [11:01:16]: Info: :SetProgressScreen: FinishMinorStep.
    [11:01:16]: Always: :!***** Installing: OMSERVER ***
    [11:01:16]: Info: :ProcessInstalls: Rollback is set and we are not doing an uninstall so we will stop processing installs
    [11:01:16]: Always: :****************************************************************
    [11:01:16]: Always: :****Starting*RollBack*******************************************
    [11:01:16]: Always: :****************************************************************

    Tuesday, April 17, 2012 3:32 PM

Answers

  • This is a production environment. Thankfully everything works and is healthy until I have the issue resolved. I have submitted a support request to Microsoft for assistance since no one has seen this error yet before in the support forums. I will post back after I get the upgrade completed with Microsoft. 
    Thursday, April 19, 2012 2:16 PM

All replies

  • Just to ensure, did you apply CU5 to your SCOM 2007 R2 env before upgrading to SCOM 2012...

    Thanks,

    Varun

    Wednesday, April 18, 2012 9:00 AM
  • That is correct. I did apply CU5 before the upgrade. I applied it when CU5 came out. I also installed it on the new secondary management servers when I had to make new ones on Server 2008 R2 64 bit so I could go to SCOM 2012
    Wednesday, April 18, 2012 10:19 PM
  •  

    Hi,

    Please check the configurations referring to the following documents:

    Upgrade Path Checklists for Operations Manager
    http://technet.microsoft.com/en-us/library/hh241293.aspx

    Pre-Upgrade Tasks for Operations Manager
    http://technet.microsoft.com/en-us/library/hh205986.aspx

    For upgrading from SCOM 2007 R2 CU5, please also see:

    Migrating from SCOM R2 CU#5 to OM12. Part I: The environment
    http://thoughtsonopsmgr.blogspot.com/2012/04/migrating-from-scom-r2-cu5-to-om12-part.html

    Migrating from SCOM R2 CU#5 to OM12. Part II: Prepare yourself…
    http://thoughtsonopsmgr.blogspot.com/2012/04/migrating-from-scom-r2-cu5-to-om12-part_10.html

    Hope this helps.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Thursday, April 19, 2012 8:44 AM
    Moderator
  • Hope you would have gone through the links shared here... How about your DB server which platform it is running on and what version,,

    Did you use Operations Manager Upgrade MP before upgrading to SCOM 2012?

    Thursday, April 19, 2012 10:34 AM
  • To the original poster - is this a production environment or a test environment?

    If this is production and you need to get the SCOM environment back to health quickly then I'd suggest contacting Microsoft PSS and opening a ticket. Unless someone has seen your specific error all you are getting here is people pointing you back at documentation you have already read.

    If someone has seen this error before then you may be lucky and get a response. Otherwise Microsoft engineers can dedicate time to you and have a database of information available to them that isn't available to anyone on the forums.

    Good Luck

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Thursday, April 19, 2012 10:57 AM
    Moderator
  • Yes, I imported the upgrade management pack into my environment before I started. 
    Thursday, April 19, 2012 2:13 PM
  • This is a production environment. Thankfully everything works and is healthy until I have the issue resolved. I have submitted a support request to Microsoft for assistance since no one has seen this error yet before in the support forums. I will post back after I get the upgrade completed with Microsoft. 
    Thursday, April 19, 2012 2:16 PM
  • I'm running SQL Server 2008 R2 SP1 on Windows Server 2008 R2 SP1
    Thursday, April 19, 2012 2:21 PM
  • This is a RMS key issue. The solution is:

    * Log on in management servers that were upgraded with an account with admin rights
    * Go to SCOM installation path of the RMS server via UNC : \\RMS_Server\Program Files\System Center Operations Manager 2007\ and execute the file “SecureStorageBackup” as administrator

    *Proceed through the key restore this way


    • Edited by notinuse1 Tuesday, July 24, 2012 1:28 PM Solution Found
    • Proposed as answer by MarceloLucas Thursday, October 24, 2013 4:04 PM
    Monday, July 23, 2012 8:57 PM