none
Unregistering a Data Warehouse from SCSM 2012 after having it uninstalled first

    Question

  • I am attempting to unregister a data warehouse after uninstalling it. When I do i receive an error:

    System.Argument.Exception: sm data source not found. At Microsoft.EnterpriseManagement.ServiceManager.UI.Administration.DWRegistration.Unregistration.DWUnregisterationHelper.AcceptChanges(WizardMode wizardMode)

    I have checked powershell cmdlets but could not find anything that would allow for unregistering the data warehouse in 2012. I have also attempted uninstalling and re installing the Service Manager Management Server. I am running the RC version of SCSM 2012. Any ideas short of a full redeployment would be appreciated.

    Friday, March 16, 2012 10:56 PM

Answers

  • I was finally able to correct this issue by upgrading the console to the RTM version. After completing the upgrade i went into the console under the administration tab and click on the Unregister the Data Warehouse link. A dialog box will appear saying that there is no data warehouse currently registered and asks if you want to remove all remaining connections and give you an option of yes or no. I clicked on yes and was able to register my data warehouse after i upgraded it as well.
    Tuesday, April 24, 2012 9:52 PM

All replies

  • Almost the same issue here - I upgraded my SCSM 2010 to the 2012 Beta and have run into the exact same error when trying to unregister a data warehouse.  Nothing else shows an error. 

    Hopefully someone here has some advice.

    Wednesday, March 21, 2012 9:35 PM
  • Hi

    The way I got around this was to, in the Data Warehouse tab, Data Sources - I had only one data source registered. 

    I unregistered the data source. Uninstalled the Datwarehouse management server and deleted the datawarehouse \ olap databases. This removed the old registration.

    I could then reinstall the datawarehouse management and register it successfully in the administration tab.

    Cheers

    Graham


    Regards Graham New System Center 2012 Blog! - http://www.systemcentersolutions.co.uk
    View OpsMgr tips and tricks at http://systemcentersolutions.wordpress.com/

    Tuesday, April 17, 2012 9:16 AM
    Moderator
  • I was finally able to correct this issue by upgrading the console to the RTM version. After completing the upgrade i went into the console under the administration tab and click on the Unregister the Data Warehouse link. A dialog box will appear saying that there is no data warehouse currently registered and asks if you want to remove all remaining connections and give you an option of yes or no. I clicked on yes and was able to register my data warehouse after i upgraded it as well.
    Tuesday, April 24, 2012 9:52 PM