none
MP Control Manager detected management point is not responding to HTTP requests. The HTTP status code and text is 500, Internal Server Error.

    Question

  • I am running SCCM SP2 Native Mode on windows Server 2008 R2, and on remote server WSUS 3.0 SP2 integerated with SCCM Server, i am facing the below mentioned error message;

    Problem # 1
    MP Control Manager detected management point is not responding to HTTP requests.  The HTTP status code and text is 500, Internal Server Error.

    Problem #2:

    Secondly i am facing problem on client machine,,,,SCCM Client is installed,,,in General and components all data available but in actions tab on two actions item below mentioned are displayed:
    1. Machine Policy Retrival & Evaluation Cycle
    2. User Policy Retrival & Evaluation Cycle
    other action items are not available though i have reparied client and also installed on different machines but same issue there.

    Monday, March 21, 2011 7:30 AM

All replies

  • What do the IIS logs say?  Which server is having the 500 error?  This might help but it's for older servers.  http://support.microsoft.com/kb/311766

    When you repaired the client did you uninstall completely?  I've had problems like that before.  Totally removing the client, rebooting, then reinstalling helps.

    Tuesday, March 22, 2011 2:49 AM
  • Thanks for your Help, i have run the Managment Point Pre and Post Installation Troubleshooter tool, Management Point Pre-installation all tests are passed, but management point post installation two test failed , the below mentioned are the results of failed tests; as my SQL Server is Separate from Management Point server 

    1.   Test Name: Test MPCERT HTTP or HTTPS request functionality.
          Test Result: Failed
    Detail result information:
    Exception Message:Fail to retrieve the content in [HTTPS://V-AP-TSCCM.CONTOSO.COM:443/SMS_MP/.SMS_AUT?MPCERT] with certificate:[C:\USERS\ADMINISTRATOR.CONTOSO\DESKTOP\CERT-FOLDER\CERT-AUTHENTICATION.CER].
    Exception Message:The underlying connection was closed: An unexpected error occurred on a send.a) Create and Configurate Certificate for native mode:
    For Windows Server 2003: http://technet.microsoft.com/en-us/library/bb694035.aspx
    For Windows Server 2008: http://technet.microsoft.com/en-us/library/cc872789.aspx
    b) Export the client certificate from MMC tools' Certificates to file in X.509 format without username and password. The exported file is the client certificate needed in this program.

    2. Test Name:Test MPLIST HTTP or HTTPS request functionality.
        Test Result:Failed

    Detail result information:
    Exception Message:Fail to retrieve the content in [HTTPS://V-AP-TSCCM.CONTOSO.COM:443/SMS_MP/.SMS_AUT?MPLIST] with certificate:[C:\USERS\ADMINISTRATOR.CONTOSO\DESKTOP\CERT-FOLDER\CERT-AUTHENTICATION.CER].
    Exception Message:The underlying connection was closed: An unexpected error occurred on a send.a) Create and Configurate Certificate for native mode:
    For Windows Server 2003: http://technet.microsoft.com/en-us/library/bb694035.aspx
    For Windows Server 2008: http://technet.microsoft.com/en-us/library/cc872789.aspx
    b) Export the client certificate from MMC tools' Certificates to file in X.509 format without username and password. The exported file is the client certificate needed in this program.

    Please suggest how i can fix these issues.

    Thursday, March 24, 2011 11:11 AM
  • This problem could be caused by the ASP.NET registry keys are missing. The ASP.NET registry keys are missing when you install ASP.NET after the Enable32bitAppOnWin64 Microsoft Internet Information Services (IIS) metabase setting is set to a value of 1. Because IIS is configured to run in the 32-bit mode, the ASP.NET installation does not create the ASP.NET registry keys in the 64-bit registry. The ASP.NET installation creates the ASP.NET registry keys only in the 32-bit registry.

    To resolve this problem, follow these steps for 32-bit or 64-bit mode :
    ==========================================================


    To enable the 64-bit mode
    ===========================
    1. Click Start, click Run, type cmd, and then click OK.

    2. Type the following command, and then press ENTER:
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET
    W3SVC/AppPools/Enable32bitAppOnWin64 0

    3. Type the following command, and then press ENTER:
    cd C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727

    4. To install the 64-bit version of ASP.NET, type the following command, and then

    press ENTER:
    aspnet_regiis -i

    5. Type the following command, and then press ENTER:
    iisreset


    To enable the 32-bit mode
    ===========================
    1. Click Start, click Run, type cmd, and then click OK.

    2. Type the following command, and then press ENTER:
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET
    W3SVC/AppPools/Enable32bitAppOnWin64 1

    3. Type the following command, and then press ENTER:
    cd C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    4. To install the 32-bit version of ASP.NET, type the following command, and then

    press ENTER:
    aspnet_regiis -i

    5. Type the following command, and then press ENTER:
    Iisreset

    Does it work? Hope it helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by nickmo Saturday, December 15, 2012 4:06 PM
    Monday, March 28, 2011 2:37 AM
  • When you created your certificate did you import it into the local machine?  It looks like from the results above you're trying to read a cert from an admin folder. 

    I haven't coverted to native mode yet myself.


    David Jenkins
    Monday, March 28, 2011 2:44 AM
  • Thanks All for your help.

    the below mentioned are the logs:
    MP_RegistrationManager.log
    Couldn't locate IIS certificate. MP_RegistrationManager 3/28/2011 1:43:48 PM 2780 (0x0ADC)
    MP Reg: Registration request body is invalid. MP_RegistrationManager 3/28/2011 1:43:48 PM 2780 (0x0ADC)
    MP Reg: Registration failed. MP_RegistrationManager 3/28/2011 1:43:48 PM 2780 (0x0ADC)
    MP Reg: Failed to send reply. Error: 0x80092004 MP_RegistrationManager 3/28/2011 1:43:48 PM 2780 (0x0ADC)
    MP Reg: Processing completed. Completion state = 4 MP_RegistrationManager 3/28/2011 1:43:48 PM 2780 (0x0ADC)

    ClientIDmanagerStartup.log
    RegTask: Client is not registered. Sending registration request... ClientIDManagerStartup 4/1/2011 7:46:15 AM 768 (0x0300)
    RegTask: Failed to send registration request message. Error: 0x80040231 ClientIDManagerStartup 4/1/2011 7:46:15 AM 768 (0x0300)
    RegTask: Failed to send registration request. Error: 0x80040231 ClientIDManagerStartup 4/1/2011 7:46:15 AM 768 (0x0300)

    PolicyAgent.log

    Registered for MP notifications. PolicyAgent_Startup 3/31/2011 7:00:05 PM 2212 (0x08A4)
    Processing system event for logged-on user PolicyAgent_RequestAssignments 3/31/2011 7:00:10 PM 2212 (0x08A4)
    Requesting User policy assignments at logon time for 'S-1-5-21-2484531554-1025925944-3527175823-500' PolicyAgent_RequestAssignments 3/31/2011 7:00:10 PM 2212 (0x08A4)

    SMS_MP_Control_Manager error:
    MP Control Manager detected MP is not responding to HTTP requests.  The http error is 12030.
    MP Control Manager detected DMP is not responding to HTTP requests.  The http error is 12030.

    Please suggest how i can resolve these issue?

    Friday, April 01, 2011 6:10 AM
  • I have same problem after install the AdminStudio

    Reinstalling IIS and MP role did not resolved the problem.

    Monday, October 14, 2013 8:31 AM
  • You can uninstall and install the MP and check it

    and

    Verify that the IIS IWAM_computername account and the copy of IWAM_computername are synchronized. For more information, seethe below article

    http://support.microsoft.com/kb/297989



    Friday, October 18, 2013 12:48 PM