none
error adding a host in scvmm 2012

    Question

  • Hi

    I am installing SCVMM 2012 RC1, and when we adding a third node in the cluster we receive the following error messages:

    error (20506)

    Virtual machine manager cannot complete the windows remote management (WinRM) request on computer computer.domain.com.

    Recomended action

    Ensure that the windows remote management (WinRM) service and virtual machine manager agent service are installed and running. If it a firewall is enabled on the computer, ensure that the following firewall exceptions has been added: Port excetions,  for http; https have been added;  A program exception for servidor scc

    Warning (2927)

    A hardware management error has ocurred trying to contact server computer.domain.com

    unknown error (0x80338112)

    Recomended action

    Check that WinRM is installed and running in computer.domain.com

    Warning (13926)

    Host cluster for cluster_name.domain.com was not fully refreshed because not all nodes could be contacted 

    Recomended action

    Ensure that all the nodes are online and do not have not responding status in virtual machine manager. Then refresh the cluster again.

    Because all these error messages I cant manage the third node in the cluster. I dont have the firewall online, all the servers are in the same domain, and in the same network segment, and I followed the steps detailed in:

    http://technet.microsoft.com/en-us/library/dd347642.aspx

    http://social.msdn.microsoft.com/Forums/en/servervirtualization/thread/d97e2be7-ec65-418a-a24c-cd84dd7c36e4

    http://boardreader.com/thread/Hosts_Needs_Attention_Error_2927_and_War_ltpz__8085a71c-6de8-443c-8cad-6722d6a3d713.html

    http://blogs.technet.com/b/jonjor/archive/2010/04/17/scvmm-2008-error-2927-a-hardware-management-error-has-occurred-trying-to-contact-server.aspx

    http://technet.microsoft.com/en-us/library/dd347642.aspx

    all with the same result


    Raulito



    • Edited by Vientos Monday, March 12, 2012 6:29 PM
    Friday, March 09, 2012 9:04 PM

Answers

  • The problem was solved with pss participation. We must to create a GPO to allow the WINRM access from everywhere

    Raulito

    • Marked as answer by Vientos Wednesday, May 09, 2012 9:20 PM
    Wednesday, May 09, 2012 9:20 PM

All replies

  • Is anybody in there?, I need to solve this problem ASAP, with SCVMM 2008 R2 I have a similar problem, but even when I've followed all the recomended actions I cant resolve the issue. I installed SCVMM 2012 RC1 thinking that this kind of problem was solved, but when I added a third node I have this errors!

    Raulito



    • Edited by Vientos Monday, March 12, 2012 6:42 PM
    Monday, March 12, 2012 6:24 PM
  • Try using "winrm /quickconfig" and then press y to continue with the remote manage. Also add the  SCVMM$ computer in the local admin group of the hyperv nodes

    Mohamed Fawzi | http://fawzi.wordpress.com

    Monday, March 12, 2012 9:07 PM
  • I already do thats procedures. With winrm/quickconfig only says that machine is already accepting connections.


    Raulito

    Monday, March 12, 2012 10:30 PM
  • do you have PowerShell 3.0 installed on the host?  I was getting this error and then uninstalled PowerShell 3.0 and then it worked.
    Tuesday, March 13, 2012 4:32 AM
  • No, I dont have installedPS 3.0


    Raulito

    Tuesday, March 13, 2012 12:53 PM
  • Is there someone?

    Raulito

    Wednesday, March 14, 2012 12:51 PM
  • These are the eventvwr data

    Config
        MaxEnvelopeSizekb = 800
        MaxTimeoutms = 600000
        MaxBatchItems = 20
        MaxProviderRequests = 4294967295
        Client
            NetworkDelayms = 5000
            URLPrefix = wsman
            AllowUnencrypted = false
            Auth
                Basic = true
                Digest = true
                Kerberos = true
                Negotiate = true
                Certificate = true
                CredSSP = false
            DefaultPorts
                HTTP = 5985
                HTTPS = 5986
            TrustedHosts = *
        Service
            RootSDDL = O:NSG:BAD:P(A;;GA;;;BA)(A;;GA;;;S-1-5-21-2756180211-2712678406-1506239216-1003)S:P(AU;FA;GA;;;WD)(AU;SA;GWGX;;;WD)
            MaxConcurrentOperations = 4294967295
            MaxConcurrentOperationsPerUser = 200
            EnumerationTimeoutms = 600000
            MaxConnections = 15
            MaxPacketRetrievalTimeSeconds = 120
            AllowUnencrypted = false
            Auth
                Basic = false
                Kerberos = true
                Negotiate = true
                Certificate = false
                CredSSP = false
                CbtHardeningLevel = Relaxed
            DefaultPorts
                HTTP = 5985
                HTTPS = 5986
            IPv4Filter = *
            IPv6Filter = *
            EnableCompatibilityHttpListener = false
            EnableCompatibilityHttpsListener = false
            CertificateThumbprint
        Winrs
            AllowRemoteShellAccess = true
            IdleTimeout = 180000
            MaxConcurrentUsers = 5
            MaxShellRunTime = 2147483647
            MaxProcessesPerShell = 15
            MaxMemoryPerShellMB = 150
            MaxShellsPerUser = 5


    Raulito

    Tuesday, March 20, 2012 12:29 PM
  • Have you found a solution, Vientos?  I have the same error after upgrading a VMM 2008 R2 installation to 2012.  The hyper-v box VMM is installed on and one other hyper-v box show up no problem but one other hyper-v box refuses to co-operate. 

    Bert

    Wednesday, April 11, 2012 3:05 AM
  • Hi,

    Can you please try the SC2012VMMCA-64.msi from the following link?

    http://www.microsoft.com/download/en/details.aspx?id=29309


    If the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. www.scvmm2012.com (TR Language)

    Wednesday, April 11, 2012 8:21 PM
  • Hi Vientos,

    Did your issue resolved?

    Sincerely,
    Murat Demirkiran


    If the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. www.scvmm2012.com (TR Language) Please note that I'm not a Microsoft Representative or SpokesPerson.

    Tuesday, May 08, 2012 4:25 PM
  • The problem was solved with pss participation. We must to create a GPO to allow the WINRM access from everywhere

    Raulito

    • Marked as answer by Vientos Wednesday, May 09, 2012 9:20 PM
    Wednesday, May 09, 2012 9:20 PM
  • Please. Maybe more details?

    Thursday, July 19, 2012 7:36 AM