none
MP.Msi exited with return code 1603

    Question

  • Hi Team,

    I am trying to install the MP site system role but i get an erron in log (MPSetup)

    <03-12-2010 13:09:02>         ======== Installing Pre Reqs for Role SMSMP ========
    <03-12-2010 13:09:02> Found 1 Pre Reqs for Role SMSMP
    <03-12-2010 13:09:02> Pre Req MSXML60 found.
    <03-12-2010 13:09:02> MSXML60 already installed (Product Code: {0A869A65-8C94-4F7C-A5C7-972D3C8CED9E}). Would not install again.
    <03-12-2010 13:09:02> Pre Req MSXML60 is already installed. Skipping it.
    <03-12-2010 13:09:02>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <03-12-2010 13:09:02> Installing the SMSMP
    <03-12-2010 13:09:02> Passed OS version check.
    <03-12-2010 13:09:02> IIS Service is installed.
    <03-12-2010 13:09:02> No versions of SMSMP are installed.  Installing new SMSMP.
    <03-12-2010 13:09:02> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <03-12-2010 13:09:02> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=63 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <03-12-2010 13:09:19> mp.msi exited with return code: 1603
    <03-12-2010 13:09:19> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <03-12-2010 13:09:19> Fatal MSI Error - mp.msi could not be installed.

     

    Any suggestions will be appreciated to resolve it . Thanks

     

    Regards,

    MS expert

    Wednesday, April 07, 2010 7:05 AM

Answers

  • <03-12-2010 13:09:02> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log

    That has been discussed numerous times here in the forums. See that logfile; it contains the actual error / problem (search for 'return value 3' in the log. The error will be listed a few lines above it). Also make sure that you followed http://technet.microsoft.com/en-us/library/cc431377.aspx exactly if you're trying to install on Server 2008.
    Wednesday, April 07, 2010 7:24 AM
    Moderator

All replies

  • <03-12-2010 13:09:02> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log

    That has been discussed numerous times here in the forums. See that logfile; it contains the actual error / problem (search for 'return value 3' in the log. The error will be listed a few lines above it). Also make sure that you followed http://technet.microsoft.com/en-us/library/cc431377.aspx exactly if you're trying to install on Server 2008.
    Wednesday, April 07, 2010 7:24 AM
    Moderator
  • Could you please check MPMSI.LOG? I know a similar case caused by CommonFilesDir registry keys were pointing to the incorrect place.

    Hope it helps.

    Thursday, April 08, 2010 7:05 AM