none
Error 406 access denied while trying to Add Windows 2008 HV host in SCVMM 2008.

    Domanda

  • I am trying to add Windows 2008 HV host in SCVMM 2008. While adding host i am getting error message...

    Error (406)

    Access has been denied while contacting the server <server name>. 

     

    Recommended Action

    1. Verify that the specified user account has administrative privileges on <server name>.

    2. Verify that DCOM access, launch, and activation permissions are enabled on <server name> for the Administrators group. Use dcomcnfg.exe to modify permissions, and then try the operation again.


    I have already done DCOM security modification for my user. I am able to RDP or any file sharing HV host from SCVMM machine. My user is member of local administrator for both the machines. 


    Before that i have added one Windows 2008 HV (Core) successfully and 2 ESX host in same SCVMM machine. 


    Any Help would be greatly appreciated.



    vaibhav
    mercoledì 4 febbraio 2009 13:36

Risposte

Tutte le risposte

  • Still havent received any reply on that. Does any one face such issue?
    vaibhav
    giovedì 26 marzo 2009 17:28
  • do u have firewall enabled on this host?
    Fawzi
    lunedì 30 marzo 2009 20:19
    Moderatore
  • no, i haven't enabled firewall. All the permission for SCVMM machine seem OK.
    vaibhav
    martedì 31 marzo 2009 20:53
  • Is your VMM server installed on Domain Controller?
    Fawzi
    giovedì 2 aprile 2009 13:55
    Moderatore
  • No, its not on DC.
    vaibhav
    giovedì 2 aprile 2009 19:41
  • Hi guys,

    some suggestions from my side.First I would suggest to run the SCVMM with Run as Administrator even if you have admin priviliges.Additionally I have seen similar issues with some endpoint protection softwares.

    If you have such a software please disable it and try again.

    Regards,
    Cengiz Kuskaya

    EDU
    giovedì 2 aprile 2009 21:54
  • Same problem exactly - on Windows Server 2008 Std w/ Hyper-V, and now - on a fresh install of 2008 R2 Beta Enterprise.

    Will try with a fresh install of SC VMM tomorrow.
    mercoledì 15 aprile 2009 03:09
  • Running SCVMM Admin Console as an administrator didn't help.  Same problem.
    mercoledì 15 aprile 2009 03:14
  • vaibhav, you haven't solved that yet, have you?
    mercoledì 15 aprile 2009 03:19
  • Fresh install of Hyper-V on WS 2008 R2 Beta, fresh install of SC VMM 2008 R2 Beta (pre-configured VHD).

    Samer error.
    mercoledì 15 aprile 2009 03:38
  • Hi,

    Also got the same problem here. Managed to add one host but the second host is giving this error message.
    mercoledì 29 aprile 2009 13:23
  • Another one here. Error 406 while adding a active/active Hyper-V cluster.

    Successful on first node, fails on the second. SCVMM 2008 R2 Beta, from preconfigured VHD.
    domenica 3 maggio 2009 09:56
  • The firewall in Server 08 R2 is on by default.  You must turn it off before you can add a hosts.

    mercoledì 6 maggio 2009 21:40
  • The firewall is not the problem. Tried with or without the fw, same problem.
    giovedì 7 maggio 2009 07:27
  • Is your VMM Server and host up to date with all required patches?

    You can download VMMCA 2008 Update 1 and run it on your VMM server to determine if you have all required updates or you can reference this link:

    http://support.microsoft.com/default.aspx/kb/962941 

    lunedì 11 maggio 2009 18:17
    Proprietario
  • yes ,i have the same issue and resolved ;
    1.VMM Server and host up to date with all required patches , http://support.microsoft.com/default.aspx/kb/962941 
    2.Turn Off the Host 's firewall .or enable the Windows Remote Management program through the firewall;
    Xin Lan
    martedì 12 maggio 2009 01:58
  • I am having the same issue, but with RTM version of both Windows 2008 R2 and SCVMM r2.
    I have a fail-over cluster enviroment with hyper-v installed on both nodes. Cluster is fine, but SCVMM refuse to add them under the host group with the same error 406.
    Firewall on both is off.

    Anyone encountered the same issue ?
    martedì 13 ottobre 2009 20:49
  • He OxYI,

    Did you resolve this issue with win 2008 r2 and scvmm 2008 r2?
    I also have the problem when I try to add my cluster as a host.

    THNX!
    giovedì 12 novembre 2009 16:08
  • hey there,

    I couldn't via the regular way. But weird thing is that I am able to add it, if one of the nodes is power down, it would add without any problem, but as soon as the other node came back from rebooting, it will not able to add.

    So I use this way to add my cluster in and see the nodes under it, at first, it added, but it will not communicate with it, but after a couple days, it just fixed itself, now it is working flawlessly...

    weird if u asked me..
    lunedì 16 novembre 2009 18:29
  • Hi All,

    Need to change VMM server and Agent service accounts to an account that has admin previlages and also add that account to distributed com users group. This group is there in Build in groups in ad.
    domenica 29 novembre 2009 02:11
  • Hi,

    I have faced the same issue and solved by giving the local administrator privilege to the Domain User. I have given the privilege to Domain user by following the link (http://translate.google.co.in/translate?hl=en&sl=fr&u=http://www.sebastien-cubito.com/tout-sur-la-virtualisation-avec-hyper-v-quatrieme-partie/&ei=kNidS9X7EcO88ga1yd27Cg&sa=X&oi=translate&ct=result&resnum=10&ved=0CB8Q7gEwCTgK&prev=/search%3Fq%3Dhow%2Bto%2Bmodify%2Bthe%2Bpermissions%2Busing%2Bdcomcnfg.exe%2Bto%2Badd%2Bhost%2Bto%2BSCVMM%2BR2%2Bserver%26start%3D10%26hl%3Den%26sa%3DN)

    The steps are:

    1) Run the utility dcomcnfg.exe, located in C: \ Windows \ System32.
    2)
    In "Console Root", "Component Services", "Computers", right click on "My Computer" and go to object properties.
    3)
    In the tab "COM Security", click "Edit Limits" in the "Access Permissions".
    4) Check all the checkbox to give access permission to the Domain User
    5) Restart the Domain User and try to add the Host to SCVMM R2 Server.

    Thanks,
    Vijaya
    • Proposto come risposta OxYI mercoledì 31 marzo 2010 15:35
    lunedì 15 marzo 2010 09:31
  • For anyone who comes across this issue the solution for my case was this:

    A previous attempt to add the host on the original server and build with the SCVMM installed before I had to rebuild that server had left the agent installed on the host server as you would expect.

    After manually removing the agent from the host server and retrying the job it succeeded without a hitch.

    Still check the DCOM permissions, firewall exceptions and patches but in my case these were already set as required.

    Hope that eases someones stress a little!

    martedì 7 settembre 2010 14:29
  •  

    Hi,

     

    I have the same problem. I have SCVMM 2008 R2 as a standalone installation on Windows Server 2008 R2 and the Hyper-V host which I am trying to add is also on Windows Server 2008 R2.

    The user credentials which I am using are DOMAIN Administrators and have complete activation permissions from DCOMCNFG.exe

     

    What should be the possible solution to this problem ?

    Will installing SP1 for Server 2008 R2 resolve my problem ?

    giovedì 5 gennaio 2012 14:30
  • Can somebody help ...

    martedì 21 febbraio 2012 18:13
  • Can somebody help ...


    I solved the problem by following step:

    On the target Hyper-V host,

    1) Run the utility dcomcnfg.exe, located in C: \ Windows \ System32.
    2)
    In "Console Root", "Component Services", "Computers", right click on "My Computer" and go to object properties.
    3)
    In the tab "COM Security", click "Edit Limits" in the "Access Permissions" and "Launch and Activation Permission".
    4) Check all the checkbox to give access permission to the Domain User
    5) Restart the Domain User and try to add the Host to SCVMM R2 Server.

    • Proposto come risposta Roy Chan giovedì 24 gennaio 2013 02:51
    giovedì 24 gennaio 2013 02:51
  • Has anyone found a fix for this? I've been troubleshooting this issue for 4 days now. I've unjoined/rejoined the host to the domain, deleted SCVMM certificate, given permissions (out the wahzoo) in COM/Access Permissions, all updates installed, firewall is off (I even tried turning it on and configuring program/port access), I've tried with 3 different domain accounts that are a member of the local Administrators group.

    The other day I managed to get the host added (don't ask me how) but then all the VM's were in status 'Host not responding' so I couldn't even manage them. So I removed it and now can't get the host added again. I'm using SCVMM 2008 R2 SP1 and the problem host is Server 2008 R2 SP1 x64.

    • Error (406)
      Access has been denied while contacting the server xxxxxxxx.domain.com.  

      Recommended Action
      1. Verify that the specified user account has administrative privileges on xxxxxxx.domain.com.
      2. Verify that DCOM access, launch, and activation permissions are enabled on xxxxxxx.domain.com for the Administrators group. Use dcomcnfg.exe to modify permissions, and then try the operation again.

    I was getting this error after I got the host added:

    • Error (2910)
      VMM does not have appropriate permissions to access the resource C:\Windows\system32\qmgr.dll on the xxxxxxxx.domain.com server.
       (Access is denied (0x80070005))

      Recommended Action
      Ensure that Virtual Machine Manager has the appropriate rights to perform this action.

    • Modificato bmorrison82 giovedì 14 febbraio 2013 20:23
    giovedì 14 febbraio 2013 20:22
  • The fix for me was discovered when I tried pinging both NETBIOS and FQDN server names, both ways. I discovered that when pinging FQDN of vmhostB from vmhostA, I got the IPv6 response back, but the IPv4 when pinging NETBIOS name - checked and saw that IPv6 was disabled on vmhostB, but enabled on vmhostA. Apparently this wasn't a problem when they were both on the same subnet, but when vmhostB was moved to a different subnet, this prevented re-adding it to SCVMM on vmhostA. After unchecking IPv6 on vmhostA's NIC properties, I had no errors in the "Add Host" process on vmhostA.
    lunedì 2 giugno 2014 12:43