none
The Service Principal Names (SPNs) that VMM requires were not correctly registered when the VMM management server

    问题

  • Dear all,

    After installing scvmm2012 I run the MBCA 2.0 and I got the following error:

    Category: Configuration
    
    Source: gvascvmm02.europe.loc
    
    Issue: The Service Principal Names (SPNs) that VMM requires were not correctly registered when the VMM management server was set up on the specified server. This is a known issue in System Center 2012 – Virtual Machine Manager.
    
    Impact: The VMM console may not be able to connect to the VMM management server and/or deploying a Hyper-V host to a bare-metal computer may not work.
    
    Resolution: Manually add the SPNs that are required by VMM by running the following commands as an administrator at an elevated command prompt:
    1. setspn -A SCVMM/yourmachine -U domain\account
    2. setspn -A SCVMM/yourmachine.fqdn.com -U domain\account

    I have done the following to solve it :

    setspn -A SCVMM/gvascvmm02 -U europe\gvascvmmservice2

    setspn -A SCVMM/gvascvmm02.europe.loc -U europe\gvascvmmservice2

    and error still there.

    i have also list all spn for that accounts :

    C:\Windows\system32>setspn -l gvascvmm02
    Registered ServicePrincipalNames for CN=GVASCVMM02,OU=Servers Prod,OU=GENEVA,DC=
    EUROPE,DC=loc:
            WSMAN/GVASCVMM02
            WSMAN/GVASCVMM02.EUROPE.loc
            TERMSRV/GVASCVMM02.EUROPE.loc
            TERMSRV/GVASCVMM02
            RestrictedKrbHost/GVASCVMM02
            HOST/GVASCVMM02
            RestrictedKrbHost/GVASCVMM02.EUROPE.loc
            HOST/GVASCVMM02.EUROPE.loc
    
    C:\Windows\system32>setspn -l gvascvmmservice2
    Registered ServicePrincipalNames for CN=gvascvmmservice2,OU=Services Accounts,OU
    =Users,OU=GENEVA,DC=EUROPE,DC=loc:
            gvascvmmservice2/gvascvmm02
            gvascvmmservice2/gvascvmm02.europe.loc
            SCVMM/GVASCVMM02
            SCVMM/GVASCVMM02.EUROPE.loc

    more info :

    scvmm server : gvascvmm02

    scvmm service account : gvascvmmservice2

    Please help , and info its wellcome !!!!!

    2012年9月27日 15:32

全部回复

  • Please check that post

    social.technet.microsoft.com/Forums/en-US/virtualmachingmgrsetup/thread/c6c93a10-06db-4222-b118-aa4ec1f9f8a2

    I would like to confirm what is the current situation? Have you resolved the problem?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Mohamed Fawzi | http://fawzi.wordpress.com

    2012年10月13日 11:18
  • I am experiencing the exact same issue. Running MBCA 2.0 shows errors with SPN. But I have run command manually and also checked manually that the SPN is correct. I cant find any documantation as to what the correct SPN settings are supposed to be so maybe there are more.
    2012年10月30日 17:30
  • Have you done the below both needs to be done as a domain admin?

    The Service Principal Name (SPN) could not be registered in Active Directory Domain Services (AD DS) for the VMM management server.

    1) Use setspn.exe to create SPN for vmmserver using following command "C:\Windows\system32\setspn.exe  -S SCVMM/hostname.domain accoutname".

    2) Add SPN values to following registry key "Software\Microsoft\Microsoft System Center Virtual Machine Manager Server\Setup\VmmServicePrincipalNames"

    .
    3) Run "C:\Program Files\Microsoft System Center 2012\Virtual Machine Manager\setup\ConfigureSCPTool.exe -install" to configure SCP.


    Kev :)

    2012年11月12日 8:45
  • I would like to confirm what is the current situation? Have you resolved the problem?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.

    Mohamed Fawzi | http://fawzi.wordpress.com

    2012年11月27日 0:17
  • Hi Kev,

    What should be the values that needs to be added in the registry

    Add SPN values to following registry key "Software\Microsoft\Microsoft System Center Virtual Machine Manager Server\Setup\VmmServicePrincipalNames"


    Thanks and Regards, Mukesh. This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2013年3月14日 5:53
  • Hi Mukesh

    This would be the SPN value for the VMM server which you can get by listing the SPN's in AD setspn -l (hostname)


    Kev :)

    2013年3月14日 10:35
  • Hi Kev,

    I am getting the following entries 

     HOST/SCVMM
     HOST/SCVMM.TEST.LAB
     SCVMM/SCVMM
     WSMAN/SCVMM
     WSMAN/SCVMM.TEST.LAB
     TERMSRV/SCVMM
     TERMSRV/SCVMM.TEST.LAB
     RestrictedKrbHost/SCVMM
     RestrictedKrbHost/SCVMM.TEST.LAB

    Which one of these should I add


    Thanks and Regards, Mukesh. This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2013年3月14日 12:24
  • I am not sure as I did this a while ago..

    I would un register the scvmm SPN then re register with:

     1) Use setspn.exe to create SPN for vmmserver using following command "C:\Windows\system32\setspn.exe  -S SCVMM/hostname.domain accoutname".

    The output you get from the register command above is the value that needs to go in the registry


    Kev :)

    2013年3月14日 15:23
  • You guys had any luck? I run all the necessary extra steps, my SPNs seem to be fine, but the Analyzer still complains.

    I don't want to reinstall SCVMM (which was actually what caused the whole fuss, since the original install worked fine).

    My problem now is App Controller, which won't work when SSO is enabled.

    Any definitive guide on how to fix this?

    J


    MCITP, MCSE, MCTS

    2013年9月19日 14:22