none
Autodiscover - mehrere Exchange 2010 Server

    Genel Tartışma

  • Guten Tag,

    ich habe schon andere Threads durchgelesen aber keine beanwortet leider genau meine Frage bzw. Problem.

    In unserer Organisation sind zwei Exchange 2010 Server: Exchange A1 und Exchange B1.  Wir haben auch mehrere Standorte und austellen. Es gibt einen Exchange Server der für Standort A zuständig ist und einen der für Standort B ist. Jedoch bekomme ich beim Outlook das Autodiscover am Standort A den Server B1, obwohl ich Extra im AutoDiscoverSiteScope angegeben habe welcher Server für welchen Standort sein soll.

    Bei Abfrage von Get-ClientAccessServer | ft name,*site* kommt folgendes:

    Name                                                        AutoDiscoverSiteScope
    ----                                                        ---------------------
    Exchange A1                                                       {Standort A}
    Exchange B1                                                       {Standort B}

    Trotzdem bekomme ich an Standort A als autodiscover den Exchange B1.


    31 Mayıs 2012 Perşembe 07:42

Tüm Yanıtlar

  • Guten Tag,

    aus remote Sicht eher schwierig zu beantworten ...

    Stimmen denn die Site-Links mit den entsprechenden Subnetzen im AD der diversen Standorte überein? Gibt es ein CAS-Array an den Standorten?

    Gruß

    Dominik


    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    31 Mayıs 2012 Perşembe 08:05
  • Hallo,

    die Subnetze wurden korrekt den Standorten zugewiesen. Nein, leider haben derzeit beide Server ein CAS Rolle, stört dies?

    Des weiteren sind die Exchange Server beide im gleichen Subnetz, stört dies evtl. auch?

    31 Mayıs 2012 Perşembe 08:21
  • Hi,

    bitte einmal für beide Server das Autodiscover ausgeben: Get-AutodiscoverVirtualDirectory | fl

    Und der SCP von beiden CAS-Servern wäre noch nützlich ... "You can view this SCP using Active Directory Sites and Services after you have enabled the “View Services Node” option:"

    CAS Rolle stört nicht ... Was meinst du genau, mit "im gleichen Subnetz"?

    Gruß

    Dominik


    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    31 Mayıs 2012 Perşembe 08:29
  • >Und der SCP von beiden CAS-Servern wäre noch nützlich ... "You can view this SCP using Active Directory Sites and Services after you have enabled the “View Services Node” option:"

    Oder über die Shell: get-clientaccessserver | fl autodiscoverserviceinternaluri


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    31 Mayıs 2012 Perşembe 08:36
  • Hallo,

    hier das Ergebnis von AutodiscoverVirtualDirectory

    RunspaceId                      : 3b0a407a-3393-4fe2-8cdf-40faa891f62d
    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication      : False
    WSSecurityAuthentication        : True
    LiveIdBasicAuthentication       : False
    BasicAuthentication             : True
    DigestAuthentication            : False
    WindowsAuthentication           : True
    MetabasePath                    : IIS://a1.domäne.local/W3SVC/1/ROOT/Autodiscover
    Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : A1
    InternalUrl                     : 
    ExternalUrl                     : 
    AdminDisplayName                : 
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=A1,CN=Servers,CN=Exchan
                                      ge Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Domäne,CN=
                                      Microsoft Exchange,CN=Services,CN=Configuration,DC=Domäne,DC=local
    Identity                        : A1\Autodiscover (Default Web Site)
    Guid                            : d292f198-fe31-4598-9ace-88772ecc6d44
    ObjectCategory                  : Domäne.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                     : 20.07.2011 10:24:19
    WhenCreated                     : 20.07.2011 10:24:19
    WhenChangedUTC                  : 20.07.2011 08:24:19
    WhenCreatedUTC                  : 20.07.2011 08:24:19
    OrganizationId                  : 
    OriginatingServer               : dc03.domäne.local
    IsValid                         : True
    
    
    RunspaceId                      : 3b0a407a-3393-4fe2-8cdf-40faa891f62d
    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
    LiveIdSpNegoAuthentication      : False
    WSSecurityAuthentication        : True
    LiveIdBasicAuthentication       : False
    BasicAuthentication             : True
    DigestAuthentication            : False
    WindowsAuthentication           : True
    MetabasePath                    : IIS://B1.Domäne.local/W3SVC/1/ROOT/Autodiscover
    Path                            : C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : B1
    InternalUrl                     : 
    ExternalUrl                     : 
    AdminDisplayName                : 
    ExchangeVersion                 : 0.10 (14.0.100.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=B1,CN=Servers,CN=Exchan
                                      ge Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Domäne,CN=
                                      Microsoft Exchange,CN=Services,CN=Configuration,DC=Domäne,DC=local
    Identity                        : B1\Autodiscover (Default Web Site)
    Guid                            : 9c8fa386-fd2c-4de1-a0ca-9b9b33653e11
    ObjectCategory                  : DOmäne.local/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}
    WhenChanged                     : 21.04.2012 11:40:43
    WhenCreated                     : 21.04.2012 11:40:43
    WhenChangedUTC                  : 21.04.2012 09:40:43
    WhenCreatedUTC                  : 21.04.2012 09:40:43
    OrganizationId                  : 
    OriginatingServer               : DC03.Domäne.local
    IsValid                         : True

    Und hier von dem SCP:

    AutoDiscoverServiceInternalUri : https://A1.domäne.local/Autodiscover/Autodiscover.xml
    
    AutoDiscoverServiceInternalUri : https://B1.domäne.local/Autodiscover/Autodiscover.xml



    Im gleichen Subnetz mein ich das beide Exchange Server z.b. im Netz 192.168.1.0/24 stehen.





    • Düzenleyen Maddin2803 31 Mayıs 2012 Perşembe 09:34
    31 Mayıs 2012 Perşembe 09:29
  • Sieht gut aus ...

    Set-ClientAccessServer -Identity "us-cas" -AutodiscoverServiceInternalURI "https://internal.contoso.com/autodiscover/autodiscover.xml" -AutodiscoverServiceSiteScope "us-contoso","europe-contoso"

    So ähnlich hast du es konfiguriert, richtig?

    http://technet.microsoft.com/de-de/library/aa997633(v=exchg.80).aspx

    Gruß

    Dominik


    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    31 Mayıs 2012 Perşembe 10:13
  • Hallo,

    bisher habe ich nichts gemacht außer A1 installiert,danach B1 und dann per Shell

    Set-ClientAccessServer -Identity A1 -AutodiscoverServiceSiteScope Standort A

    und

    Set-ClientAccessServer -Identity B1 -AutodiscoverServiceSiteScope Standort B

    31 Mayıs 2012 Perşembe 11:58
  • Hi,

    und das hier https://A1.domäne.local/Autodiscover/Autodiscover.xml ist auch ganz sicher die richtige Autodiscover-Adresse?

    Gruß

    Dominik


    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    31 Mayıs 2012 Perşembe 12:01
  • Hallo,

    ja hatte den namen A1 und domäne nur geändert, der rest ist so wie es bei mir im system steckt. und der domänen name und servername sind korrent.

    Kann ich das testen?

    Wenn ich die adresse aufrufe werde ich nach einem benutzername und kennwort gefragt, dort gebe ich meinen domänennamen ein und dann kommt:

    <Autodiscover><Response><Error Time="14:16:33.7011953" Id="1864219067"><ErrorCode>600</ErrorCode><Message>Ungültige Anforderung</Message><DebugData/></Error></Response></Autodiscover>

    aber bei beiden Servern kommt das gleiche. Und das Autodiscover scheint ja zu gehen nur lande ich auf dem falschen Server?

    31 Mayıs 2012 Perşembe 12:17
  • Hi,

    bitte setze für beide Server die Autodiscover-URL unter dem Punkt "InternalUrl                     : " und teste es erneut.

    Gruß

    Dominik



    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    31 Mayıs 2012 Perşembe 14:06
  • Ist denn das https://A1.domäne.local/Autodiscover/Autodiscover.xml  der korrekte Pfad? Oder wie finde ich den Korrekten Pfad heraus?
    01 Haziran 2012 Cuma 09:44
  • Ja, du hast dein virtuelles Autodiscover-Verzeichnis ja so konfiguriert.


    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    01 Haziran 2012 Cuma 10:09
  • Hallo Maddin2803,

    was meinst Du eigentlich genau mit "Trotzdem bekomme ich an Standort A als autodiscover den Exchange B1" ? Was hast Du Dir am Outlook Client genau angschaut und was stand da drin? Geht es hier wirklich darum, welcher Server Dir die Autodiscover Informationen liefert oder evtl. darum, dass Du falsche URLs vom Autodiscover Dienst bekommst?

    VG, Timo

    03 Haziran 2012 Pazar 07:46
    Moderatör
  • Hallo Timo Geuken,

    es geht mir darum das ich am Standort A eigentlich gern den autodiscover vom Server A bekommen würden und nicht vom Server B wo die Konten des Standortes A garnicht liegen.

    05 Haziran 2012 Salı 07:05
  • Hallo Maddin2803,

    woran siehst Du das? Ich kann Dir im Moment da noch nicht so ganz folgen.

    Viele Grüße

    Timo

    05 Haziran 2012 Salı 07:42
    Moderatör
  • Das merke ich daran das ich vom Server A am Standort A das Zertifikat auf den Rechner eingespielt ist. Die Rechner am Standort A haben das Zertifikat nicht von Server B und bekommen regelmässig die Meldung ob das akzeptiert wird und dort steht dann auch ein autodiscover pfad drin bei der Meldung und dieser zeigt auf Server B.

    Gruß

    05 Haziran 2012 Salı 12:26
  • Hast du die InternalURL gesetzt, wie in meinem letzten Beitrag oben beschrieben?

    NewCoTec GmbH MCITP: Enterprise Administrator 2008 MCITP: Enterprise Messaging Administrator 2010 MCTS: Windows 7, Configuring CCNA: Cisco Certified Network Associate

    11 Haziran 2012 Pazartesi 11:11