none
No permission to enable Sharepoint Server Publishing feature

    Soru

  • I have an issue when trying to activate Sharepoint Server Publishing feature, that a user get access denied. If the user is part of the Admins group which has full control this works fine. However, we only want this user to be able to have access to certain subsites and not the reach which the over arching Admin group has. So we have granted full control to the user in the subsites required. In doing this the user can enable and disable all site features except for enabling the Sharepoint Server Publishing. Anyone know what I have missed?

    Many Thanks.

    16 Temmuz 2012 Pazartesi 15:57

Yanıtlar

  • Hi all,

    I know this is old but figure it is worth posting a  resolution to the same issue since this was the root cause as to why my users could not activate the feature. Figure its worth a shot for some people.

    In my case, i am SCA and the user is an Owner (full control) of a few sites. He was having an issue activiting this feature because for some unknown reason he did not have access to the masterpage library at the top level site collection.

    <URL>_catalogs/masterpage/Forms/AllItems.aspx

    Minimum permission they would need is read acess to the masterpage library.

    Hope this helps

    -JGrey


    • Düzenleyen GreenGoblin 08 Nisan 2013 Pazartesi 17:51
    • Yanıt Olarak Öneren Gari T 11 Haziran 2013 Salı 15:00
    • Yanıt Olarak İşaretleyen Steven AndrewsEditor 11 Haziran 2013 Salı 15:07
    08 Nisan 2013 Pazartesi 17:51

Tüm Yanıtlar

  • I vaguely remember hearing that the Site Publishing feature can be problematic to activate.

    So to be clear, you're able to activate the feature as a Site Collection admin? Do the logs show any more details of the error?


    - cawood

     blog |  twitter

    16 Temmuz 2012 Pazartesi 19:00
  • Hi Scotta001,

    If I am understanding your question correctly, you have two groupings of users:

    *** Admins (or members of the Admins group)

    *** Standard users (Full Control)

    The second group should be able to activate publishing, not at the top site of the Site Collection, but at any of the sub sites beneath the Top Site.

    The Publishing functionality present in SharePoint relies on two Features, both of which must be activated for Publishing to work correctly:

    -- SharePoint Server Publishing Infrastructure - This Feature must be activated first for the Site Collection (Site in the Object Model) and is activated in Site Actions -> Site Settings -> Site Collection Administration -> Site Collection Features and is usually activated by a Site Collection Administrator

    -- SharePoint Server Publishing - This Feature is activated on a per Site (Web in the Object Model) level and completes Publishing by building a series of libraries, etc. for SharePoint to work with - this can be activated by a Site Owner (Full Control permissions)

    So, you should be able to activate the Pub Infrastructure and then allow your Site Owners to activate Publishing as desired - is this not the case? If not, what errors do you get?

    Hope this helps,


    Troy Lanphier -- MCT/MCSE/MCITP SharePoint Server 2010 Administration -- Author: Microsoft SharePoint Foundation 2010 Inside Out -- http://blog.sharepointcookbook.com

    16 Temmuz 2012 Pazartesi 19:29
  • Yes you are both correct, SCA's and the members of the admin group can activate the feature fine. It is only when you take the user out of the admin group and put them in to a group which has full control, or I have even given explicit permissions to that user but to no avail. I am not in the office now, but when I get back in the office I will see if there is anything enlightening in the logs and post what I find.
    16 Temmuz 2012 Pazartesi 20:16
  • OK, so have had a look through the logs and cannot find anything that matches up. It doesn't help that there is no correlation Id's on access denied messages either. Anything else anyone think it might be?

    17 Temmuz 2012 Salı 15:51
  • Any results with this problem? My situation is exactly the same as described here.
    26 Eylül 2012 Çarşamba 18:18
  • Hi all,

    I know this is old but figure it is worth posting a  resolution to the same issue since this was the root cause as to why my users could not activate the feature. Figure its worth a shot for some people.

    In my case, i am SCA and the user is an Owner (full control) of a few sites. He was having an issue activiting this feature because for some unknown reason he did not have access to the masterpage library at the top level site collection.

    <URL>_catalogs/masterpage/Forms/AllItems.aspx

    Minimum permission they would need is read acess to the masterpage library.

    Hope this helps

    -JGrey


    • Düzenleyen GreenGoblin 08 Nisan 2013 Pazartesi 17:51
    • Yanıt Olarak Öneren Gari T 11 Haziran 2013 Salı 15:00
    • Yanıt Olarak İşaretleyen Steven AndrewsEditor 11 Haziran 2013 Salı 15:07
    08 Nisan 2013 Pazartesi 17:51
  • Greengoblin Thanks, the same issue happened on mine as well. For some reason all the permission was taken from masterpage gallery library and giving a read permission solves the issue 

    Thanks 

    Tesfaye

    11 Haziran 2013 Salı 15:01