none
Outlook 2010 kann offline keine Termine/Aufgaben in Exchange 2010 eintragen

    Soru

  • Umgebung:

    Exchange 2010 SP2 RU2 auf W2K8R2.

    Es gibt ca 100 Postfächer. Die Benutzer arbeiten hauptsächlich mit Outlook 2007, Outlook 2010 oder OWA, einige wenige mit IMAP-Programmen. Seit >2 Jahren läuft alles ohne nennenswerte Probleme.

    Seit einiger Zeit hat ein Benutzer (und nur der eine!) folgendes Problem:

    Wenn Outlook 2010 Pro Plus (bei ihm auf W7 Pro 32bit) online mit Exchange verbunden ist (egal ob MAPI oder über http), kann er problemlos Mail/Termine/Kontakte/Aufgaben bearbeiten. Arbeiter er jedoch offline (Notebook, kein Internet), lassen sich keine Termine/Aufgaben speichern. Fehlermeldung: "Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus oder verbunden sein, um diesen Vorgang abzuschließen."

    Aber genau dazu gibt es doch den Cached Mode, damit man offline im Postfach arbeiten kann!? Wenn der Benutzer nun in Outlook extra "Offline arbeiten" anklickt, funktioniert das Erstellen von Terminen/Aufgabenauch offline, aber das ist ja nicht der Sinn der Sache und geht bei allen anderen auch ohne diese Aktion...

    Folgendes wurde versucht:

    - lokales Benutzerprofil gelöscht und neu vom Server gezogen (Roaming Profile) -> Fehler bleibt unverändert

    - Outlookprofil gelöscht und neu angelegt -> Fehler bleibt unverändert

    - Auf einem anderen PC ausprobiert -> Fehler tritt auch dort auf

    - Ein anderes Konto auf Ihrem PC probiert -> kein Fehler feststellbar.

    Es scheint also kein generelles Problem und auch nicht PC-spezifisch zu sein. Der nächste Schritt wäre sein Serverprofil zurückzusetzen und beim weiterem Misserfolg das Postfach neu zu erstellen.

    Bevor ich diesen Aufwand betreibe: Hat noch jemand eine andere Idee?

    Danke, Daniel

    29 Mayıs 2012 Salı 13:13

Yanıtlar

  • Auch auf dem Produktivrechner konnte das Problem mit einem OAB-Download beseitigt werden. Der Fall ist somit bei MS geschlossen.

    Zusammengefasst:

    Wenn man im Cached Mode ohne Serverzugriff keine Einträge in Kalender/Aufgaben/Kontakte erstellen kann, und die Fehlermeldung "Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus oder verbunden sein, um diesen Vorgang abzuschließen" erhält, hat der Client das Offlineadressbuch (noch) nicht korrekt heruntergeladen.

    Vorgehen:

    - Prüfen, ob der OAB-Download funktioniert. Falls nicht, OAB auf dem Server neu erstellen (Zuweisung DB und Verteilung nicht vergessen!)

    - Auf dem Client das Verzeichnis "\AppData\Local\Microsoft\Outlook\Offline Address Books" im Userprofil löschen.

    - Jetzt Outlook starten und etwas warten. Das OAB sollte einige Minuten nach "Alle Ordner aktuell" automatisch wieder im Userprofil erscheinen. Optional per "Senden&Empfangen -> Adressbuch herunterladen" manuell ausführen.

    Nun kann man auch ohne Serverzugriff wieder Termine erstellen...

    • Yanıt Olarak İşaretleyen Daniel-Hoegele 17 Ağustos 2012 Cuma 07:59
    17 Ağustos 2012 Cuma 07:59

Tüm Yanıtlar

  • Hallo,

    schau dir mal die Einstellungen Exchange-Kontos bzgl. "Verbindung automatisch prüfen" an: http://office.microsoft.com/de-at/outlook-help/aufforderung-zum-starten-von-ohne-herstellung-der-verbindung-zu-ihrem-microsoft-exchange-server-konto-HP010356473.aspx


    Guido Over MCITP Server Administrator 2008

    29 Mayıs 2012 Salı 14:14
  • Das ist bei dem User identisch zu allen anderen Usern eingestellt: "Verbindung automatisch prüfen".

    Mittlerweile habe ich auch das serverseitige Benutzerprofil temporär durch ein komplett jungfräuliches ersetzt, das Problem bleibt leider bestehen. Somit muss der Fehler wohl im Postfach auf dem Server zu suchen sein...

    29 Mayıs 2012 Salı 14:29
  • Hallo,

    sieht sehr danach aus,

    ich würde das vorschlagen.

    1. mails als PST exportiern.

    2. Postfach auf dem Exchange Löschen.

    3. wieder ein leeres erstellen.

    4. Outlook wieder zum Exchange einrichten mit dem leeren Postfach, jetzt wieder versuchen ob der Fehler wieder eintrifft.

    5. wenn jetzt keine Fehler mehr sind PST importieren.

    ich gleube das geht am schnelsten,

    Mfg

    Edmund


    Mit freundlichen Grüßen Edmund Jung System Engineer KUMAtronik GmbH 86153 Augsburg Tel: +49 (0)170 3325 843 edmund.jung@kumatronik.de http://www.kumatronik.de wenn Sie eine schnelle Hilfe benötigen können Sie gerne auf einen Tel. Service von mir zurückgreifen (mit Rechnung)

    29 Mayıs 2012 Salı 15:16
  • Hi Daniel,

    lass mal OCAT laufen und schaue ob da irgendwelche Fehler oder Warnings ausgegeben werden: http://blogs.technet.com/b/exchange/archive/2012/03/05/released-outlook-configuration-analyzer-tool-ocat.aspx

    Du könntest auch mal in das Eventlog auf dem Server schauen, ob da zu dem Zeitpunkt irgendwas interessantes auftaucht.

    Viele Grüße

    Timo

    29 Mayıs 2012 Salı 18:58
  • Hi,

    bevor der Export durchgeführt wird, sollte auch mal ein Repairrequest gestartet werden:
    http://technet.microsoft.com/de-de/library/ff625226.aspx

    Beim Neuerstellen unbedingt an den LegacyDN denken und eine x500-Adresse bei der neuen Mailbox setzen:
    http://www.msxfaq.net/server/legacyexchangedn.htm


    Viele Grüße
    Christian

    30 Mayıs 2012 Çarşamba 04:39
  • Hi Timo,

    >lass mal OCAT laufen und schaue ob da irgendwelche Fehler oder Warnings ausgegeben werden: >http://blogs.technet.com/b/exchange/archive/2012/03/05/released-outlook-configuration-analyzer-tool-ocat.aspx

    Danke für den Tipp, das Tool zeigt aber nur ein einziges Issue an: Das persönliche Onlinearchiv enthält zu viele Mails (6425) in "gesendete Objekte".

    >Du könntest auch mal in das Eventlog auf dem Server schauen, ob da zu dem Zeitpunkt irgendwas interessantes auftaucht.

    Das Problem tritt ja nur auf, wenn keine Verbindung zum Server besteht. Ergo wird serverseitig auch nichts zu sehen sein... ;)

    30 Mayıs 2012 Çarşamba 08:50
  • Hi,

    >bevor der Export durchgeführt wird, sollte auch mal ein Repairrequest gestartet werden:
    >http://technet.microsoft.com/de-de/library/ff625226.aspx

    findet keine Fehler

    >Beim Neuerstellen unbedingt an den LegacyDN denken und eine x500-Adresse bei der neuen Mailbox setzen:
    >http://www.msxfaq.net/server/legacyexchangedn.htm

    Danke!

    Kann ich eigentlich auch das Postfach in Exchange einfach nur trennen (statt trennen+löschen), ein neues PF für den User anlegen und testen und falls es keine Besserung bringt, einfach das alte PF wieder mit dem Konto verbinden? Oder verknüpft Exchange automatisch das getrennte Postfach, wenn ich eins zu einem bestehenden Konto hinzufüge? Das würde mir zumindest den Import der PST ersparen, was bei 10GB ne Menge Zeit ist....

    Wobei mir gerade einfällt, das ein getrenntes Onlinearchiv nicht wieder verknüpft werden kann, oder? Somit muss ich dieses wohl auf jeden Fall importieren....

    Daniel


    30 Mayıs 2012 Çarşamba 21:06
  •  >Du könntest auch mal in das Eventlog auf dem Server schauen, ob da zu dem Zeitpunkt irgendwas interessantes auftaucht.

    Das Problem tritt ja nur auf, wenn keine Verbindung zum Server besteht. Ergo wird serverseitig auch nichts zu sehen sein... ;)

    Da könntest Du wohl Recht haben. Sorry :-)

    Vielleicht dann aber das Eventlog auf dem Client.

    30 Mayıs 2012 Çarşamba 21:21
  • Hi,

    Wobei mir gerade einfällt, das ein getrenntes Onlinearchiv nicht wieder verknüpft werden kann, oder? Somit muss ich dieses wohl auf jeden Fall importieren....

    Das sollte mittlerweile auch klappen:
    Connect a Disconnected Personal (On-Premises) or Cloud-Based Archive
    http://technet.microsoft.com/en-us/library/ee633490.aspx


    Viele Grüße
    Christian

    01 Haziran 2012 Cuma 04:57
  • >Vielleicht dann aber das Eventlog auf dem Client.

    Nö, nur Outlook EventID 25 mit identischer Fehlermeldung, keine Details.


    01 Haziran 2012 Cuma 11:05
  • >Das sollte mittlerweile auch klappen:
    >Connect a Disconnected Personal (On-Premises) or Cloud-Based Archive
    >http://technet.microsoft.com/en-us/library/ee633490.aspx

    Super, das probiere ich am WE mal aus und gebe Feedback.

    Vielen Dank!

    01 Haziran 2012 Cuma 11:07
  • Hi Alex,

    ich hatte noch keine Zeit die Hinweise umzusetzen, daher noch kein Feedback. Ich setz mich voraussichtlich nächste Woche wieder dran, dann berichte ich natürlich vom Ergebnis...

    Gruß

    Daniel

    08 Haziran 2012 Cuma 12:45
  • Jetzt bin jetzt noch ratloser als vorher:

    Bislang ging ich davon aus, dass nur dieses eine Konto/Postfach betroffen ist, da sich niemand anderes über dieses Verhalten beschwert hat (hab zahlreiche Offlineuser) und ich es mit meinem eigenen Konto auch nicht nachvollziehen kann. Nun habe ich zum Testen des PST-Ex-/Imports und Wiederverbinden eines persönlichen Archis ein frisches Testkonto eingerichtet, und siehe da, auch dort tritt das Problem auf:

    - Neuen Benutzer im AD angelegt

    - Postfach eingerichtet

    - erstmalig am Notebook angemeldet (frisches Profil)

    - Outlook gestartet, Konto wird korrekt per Autodiscover eingerichtet

    - Termin angelegt (OK)

    - WLAN-HW deaktiviert

    - Termin offline angelegt (OK)

    - Outlook geschlosen

    - Outlook offline gestartet, Termin angelegt -> FEHLER

    Wenn die Verbindung zum Server also während der Nutzung von Outlook abbricht, stellt dies also kein Problem dar. Startet Outlook aber bereits ohne Serververbindung, lassen sich Termine nicht eintragen!?

    Normal ist das m.E. nicht...*Kopfkratz*

    10 Haziran 2012 Pazar 20:34
  • Hallo Daniel

    Wir haben bei uns genau die gleiche Problematik.
    Hast du den Fehler inzwischen gefunden?

    Gruss Patrik


    • Düzenleyen patrik-graf 27 Haziran 2012 Çarşamba 12:26
    27 Haziran 2012 Çarşamba 12:25
  • Nein, aber ich taste mich langsam ran. Leider habe ich nicht allzu viel Zeit, mich damit auseinanderzusetzen.

    Folgendes habe ich herausgefunden:

    Test 1: Melde ich mich als AD-User an und greife im Outlook offline auf das neu erstellte Testpostfach zu, kann ich das Problem wie oben angegeben (Beitrag 10.6.) nachvollziehen.

    Test 2: Melde ich mich als lokaler User an (kein AD Konto) und binde das Testkonto dort in Outlook ein, ist das Problem nicht nachvollziehbar.

    Test 3: Melde ich mich als lokaler User an (kein AD Konto) und binde das Konto des betroffenen Users in Outlook ein, kann ich das Problem wieder nachvollziehen.

    Es kann also sowohl am Postfach liegen (Test 3, dagegen spricht aber Test2), als auch an GPOs (Test 1, dagegen spricht aber Test 2).

    Kurzum: Ich bin nicht wirklich klüger uns muss weiter testen... :(

    27 Haziran 2012 Çarşamba 12:53
  • Habe das gleiche Problem, neues Laptop, Outlook 2010 neu installiert und offline keine Eintragungen in Kalender möglich. Werde aber am Ball bleiben und ggf. eine Lösung mitteilen.
    19 Temmuz 2012 Perşembe 08:09
  • Ich habs dazu am 3.7. einen Support Case bei Microsoft eröffnet. Der Techniker konnte das Problem in seiner eigenen Umgebung nachstellen, war sich aber nicht sicher, ob das nicht "by design" so sein muss (?!?).

    Ich denke Ihn anhand von technet und msxfaq-Artikeln vom Gegenteil überzeugt zu haben. Seither gab es aber noch kein weiteres Feedback.

    Sobald die das Problem gelöst haben, teile ich Euch die nötigen Schritte mit.

    Gruß

    Daniel

    19 Temmuz 2012 Perşembe 08:18
  • Manchmal ist es so einfach....

    Hier eine Lösung wie ihr zumindest mit einem Klick Termine und Aufgaben eingeben könnt welche sich dann auch bei der nächsten Verbinden zu Exchange aktualisieren.

    --> geht bei Office 2010 auf den Reiter "Senden und Empfangen" dann klinkt einmal auf "Offline arbeiten"

    Jetzt lassen sich alle Termine speichern.

    Hoffe es geht bei euch auch...

    Gruß Martin


    • Düzenleyen Eccomo 19 Temmuz 2012 Perşembe 09:02
    19 Temmuz 2012 Perşembe 09:02
  • Manchmal ist es so einfach....

    Hier eine Lösung wie ihr zumindest mit einem Klick Termine und Aufgaben eingeben könnt welche sich dann auch bei der nächsten Verbinden zu Exchange aktualisieren.

    --> geht bei Office 2010 auf den Reiter "Senden und Empfangen" dann klinkt einmal auf "Offline arbeiten"

    Jetzt lassen sich alle Termine speichern.

    Hoffe es geht bei euch auch...

    Gruß Martin


    Der Workaround stand schon in meinem ersten Beitrag, da hätteste nicht suchen müssen ;) Ein weiterer Workaround ist das Deaktivieren des Cache Mode.

    Eine akzeptable Dauerlösung ist das aber nicht und auf dem Großteil meiner mobilen Arbeitsstationen geht es auch ohne manuellen Offline-Mode, so wie es z.B. hier auch beschrieben ist:

    http://www.msxfaq.de/clients/cachedmode.htm

    "Neuen Kontakt, Termin etc. erstellen, ändern oder löschen - im Status getrennt - wird
    lokal abgelegt bis zur nächsten Replikation"

    Gruß

    Daniel

    19 Temmuz 2012 Perşembe 09:39
  • Hi Daniel,

    auf die Gefahr hin, dass ich das hier ueberlesen habe... aber ist der Client auch aktuell was Updates angeht?

    VG, Timo

    23 Temmuz 2012 Pazartesi 20:14
  • Hi Daniel,

    auf die Gefahr hin, dass ich das hier ueberlesen habe... aber ist der Client auch aktuell was Updates angeht?

    VG, Timo


    Ja, SP1 + alle Updates.
    23 Temmuz 2012 Pazartesi 20:33
  • Das ist schon etwas schraeg. Zumal Du nun auch scheinbar nicht mehr der Einzige hier bist. Dann bin ich mal gespannt was bei Deinem Call rauskommt.

    VG, Timo

    23 Temmuz 2012 Pazartesi 20:40
  • Habe das gleiche Problem, neues Laptop, Outlook 2010 neu installiert und offline keine Eintragungen in Kalender möglich. Werde aber am Ball bleiben und ggf. eine Lösung mitteilen.

    Bin dank MS Support einen Schritt weiter! Auf meinem Testsystem hing es mit dem Download des OAB zusammen:

    Das Erstellen von Kalendereinträgen (und Aufgaben/Kontakten) im Cached Mode Status "getrennt" funktioniert offensichtlich erst nach dem Download der OAB Liste. Wenn man also Outlook neu einrichtet und gleich wieder schließt, kann man danach ohne Netzwerk keine Einträge erstellen. Lädt man jedoch per "Senden&Empfangen" die OAB-Liste herunter, klappt auch das Eintragen im Status "getrennt" wieder.

    Dabei ist zu beachten, dass die Aussage "Alle Ordner aktuell" nicht bedeutet, das auch das OAB schon heruntergeladen wurde, was man durch einen Blick ins Userprofil schnell bestätigen kann. Auf diesen Trugschluß bin ich nämlich beim Testen reingefallen.

    Du kannst ja mal testen, ob das bei Dir auch das Problem beseitigt!?

    Warum das Problem aber auf dem Produktivrechner eines Kollegen auftrat, der bereits seit Monaten mit seinem Outlookprofil arbeitet (ergo das OAB haben müsste), ist mir noch unklar. Ich soll dort das OAB mal manuell aus dem Profilordner löschen, und es dann neu versuchen. Leider ist der Kollege derzeit im Urlaub, Feedback gibt es dazu erst nächste Woche.

    Bleibt nur noch die Frage, warum ich offline nicht mehr auf's OAB zugreifen kann (Fehler "Outlook muss verbunden sein"). Ich habe testhalber das OAB auf dem Server neu erstellt (neuer Name), den App Pool zurückgesetzt und die Verteilung neu eingerichtet. Der OAB Download funktiert auch ohne Fehler, der Offlinezugriff jedoch nicht...

    Schaut man sich die Eigenschaften des OAB an, wird als Pfad auch der Server statt die lokale Kopie im Profilordner angezeigt...

    Gruß

    Daniel

    • Yanıt Olarak İşaretleyen Daniel-Hoegele 17 Ağustos 2012 Cuma 07:51
    • Yanıt İşaretini Geri Alan Daniel-Hoegele 17 Ağustos 2012 Cuma 08:00
    30 Temmuz 2012 Pazartesi 13:07
  • Auch auf dem Produktivrechner konnte das Problem mit einem OAB-Download beseitigt werden. Der Fall ist somit bei MS geschlossen.

    Zusammengefasst:

    Wenn man im Cached Mode ohne Serverzugriff keine Einträge in Kalender/Aufgaben/Kontakte erstellen kann, und die Fehlermeldung "Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus oder verbunden sein, um diesen Vorgang abzuschließen" erhält, hat der Client das Offlineadressbuch (noch) nicht korrekt heruntergeladen.

    Vorgehen:

    - Prüfen, ob der OAB-Download funktioniert. Falls nicht, OAB auf dem Server neu erstellen (Zuweisung DB und Verteilung nicht vergessen!)

    - Auf dem Client das Verzeichnis "\AppData\Local\Microsoft\Outlook\Offline Address Books" im Userprofil löschen.

    - Jetzt Outlook starten und etwas warten. Das OAB sollte einige Minuten nach "Alle Ordner aktuell" automatisch wieder im Userprofil erscheinen. Optional per "Senden&Empfangen -> Adressbuch herunterladen" manuell ausführen.

    Nun kann man auch ohne Serverzugriff wieder Termine erstellen...

    • Yanıt Olarak İşaretleyen Daniel-Hoegele 17 Ağustos 2012 Cuma 07:59
    17 Ağustos 2012 Cuma 07:59