none
Windows Troubleshooter Not Working

    السؤال

  • Windows 7, clean install. I am getting the error when trying to use several of the troubleshooters: ie like the Windows Update or networking.
    "An error occured while troubleshooting: A problem is preventing the troubleshooter from starting."
    Any ideas on how to correct this? Is a service not started or something?
    19/ذو القعدة/1430 05:26 م

الإجابات

جميع الردود

  • Hi,

    Does this issue occur with all troubleshooters or just Windows Update and networking troubleshooter? Have you tried to launch troubleshooters from different location? You can launch troubleshooters either from Control Panel, Action Center or Related Topic in Help.  How about unchecking "Get the most up-to-date troubleshooters from the Windows Online Troubleshooting Service" and only use the local troubleshooter file? Moreover, based on my further research, please make sure there isn't any Group Policy setting blocking the launch of troubleshooters. I recommend you to check the following location in Local Group Policy Editor.

    Computer Configuration\Administrative Templates\System\Troubleshooting and Diagnostics\Scripted Diagnostics 

    Check these settings and make sure it isn't disabled:

    Troubleshooting: Allow users to access and run Troubleshooting Wizards

    Troubleshooting: Allow users to access online troubleshooting content on Microsoft servers from the Troubleshooting Control Panel (via the Windows Online Troubleshooting Service - WOTS)

    You may also check the related registries:

    HKLM\SOFTWARE\Policies\Microsoft\Windows\ScriptedDiagnostics!EnableDiagnostics

    HKLM\SOFTWARE\Policies\Microsoft\Windows\ScriptedDiagnosticsProvider\Policy!EnableQueryRemoteServer

    If the issue persists, I suspect that there might be corrupted files. I recommend you to perform a Startup Repair.

    For references:

    Built-in Troubleshooting Packs

    Best Regards
    Dale
    21/ذو القعدة/1430 08:29 ص
  • I get different error messages when I try to run different troubleshooters. This is one. The error code is different for different troubleshooters, but the same basic error message. In a message box.

    An error occured while troubleshooting:

    A problem is prventing the troubleshooter from starting.

    Package ID:    MaintenanceDiagnostics
    Path:                C:\Windows\diagnostics\scheduled\Maintenance
    Error Code:    0x8E5E0408
    Source:            Engine
    User:                 T61p\Administrator
    Context:          Elevated

    21/ذو القعدة/1430 06:46 م
  • Try using the windows troublshooter to find out why it doesn't work.
    21/ذو القعدة/1430 07:04 م
  • From the error report, I noticed that it is related to scheduled maintenance. I recommend you to turn on the computer maintenance under Troubleshooting settings. Moreover, please also check the following Group Policy setting:

    Computer Configuration\Administrative Templates\System\Troubleshooting and Diagnostics\Scheduled Maintenance

    Make sure that you didn't disable "Configure Scheduled Maintenance Behavior".

    Best Regards
    Dale
    22/ذو القعدة/1430 02:02 ص
  • This was ONLY an example. ALL the troubleshooter I have tried do not work but with different error codes for each module, networking, Windows update, sound, etc. It is like troubleshooter is disabled for ALL troubleshooting and/or is not there for ANY of them. Again, the error I posted only references one module. They ALL are not working!
    22/ذو القعدة/1430 01:32 م
  • Try to perform a  Startup Repair.

    Best Regards
    Dale
    • تم وضع علامة كإجابة بواسطة Dale QiaoModerator 28/ذو القعدة/1430 06:34 ص
    23/ذو القعدة/1430 02:56 ص
  • have the same problem, all troubleshooters not working, startup repair already done, tried to move \windows\diagnostics folder and do sfc /scannow, nothing works
    27/صفر/1431 07:55 ص
  • Same problem - I'm trying to repair my microphone and speakers since upgrading to Windows 7.  The system tells me my Audio Service is not running.  When I go to run the trouble shooter - from control panel, from application or elsewhere I get the following:

    A problem is preventing the troubleshooter from starting.

    Package ID:  AudioPlaybackDiagnostic
    Path: Unknown
    Error Code: 0x80070005
    Source: Engine
    User: Shelley-Laptop\Shelley
    Context: Elevated

    I'm unable to update device drivers, and my system shows a Base System Driver error.  I conducted a startup repair - no issues found.

    Not sure where to turn at this point.  I'm using a Dell Inspiron 1525, Windows 7 Professional - clean install - 32bit.
    02/ربيع الأول/1431 04:48 ص
  • Same problem for me, clean install of Windows 7, 64-bit, on DELL 1720 with new SSD, oh well, continue with Google to find answer
    08/جمادى الثانية/1431 10:02 ص
  • We had the same issue.  To resolve it, open IE and go to Tools -> Internet Options -> Advanced

    Uncheck the option - Check for server certificate revocation

    If this solves your problem then it suggest your PC's are unable to check the CRL for the certificate for some reason.  Usually a proxy/firewall issue.

    • تم الاقتراح كإجابة بواسطة Bret Gardner 24/ربيع الثاني/1432 03:17 م
    30/رمضان/1431 12:43 م
  • I had the same

    troubleshooting on the network -> IP conflict!

    08/صفر/1432 06:49 م
  • I was having the same issue on all windows 7 domain computers.  I found the section "Troubleshooting Pack Management" in this:

    http://technet.microsoft.com/en-us/library/ee424304(WS.10).aspx

    When I tried to run the PowerShell commands:

    Import-Module TroubleshootingPack

    $aero = Get-TroubleshootingPack $env:SystemRoot\Diagnostics\System\Aero

    Invoke-TroubleshootingPack -Pack $aero -Result C:\DiagResult -unattend

     I received this:

    Get-TroubleshootingPack : The revocation process could not continue - the certificate(s) could not be checked. (Exception from HRESULT: 0x800B010E)

     So in IE, tools, advanced tab in the settings section. under the security section,  I unchecked "check for publishers certificate revocation" and "check for server certificate revocation"

    I re-ran the above commands and they completed successfully.

    Low and behold, all of my troubleshooters are now working. No need for me to do a repair install!!!

    Now for me, this only pinpoints the true problem, I cannot access the CRL Distribution point of whatever certificate is being used for w7 troubleshooting.

    A few months back I moved my internal CA to a new DC (with a new name), so I suspect that there is a problem with my internal CRL. But I really don’t know for sure. Is the W7 troubleshooter(s) trying to access a public CRL and it's actually a firewall issue?

    Perhaps someone knows the answer to this part of the problem?

    24/ربيع الثاني/1432 08:01 م
  • On a computer that is currently reproducing the issue, what do you see for the State registry value?

    c:\>reg query "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing"

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
    State REG_DWORD 0x23c00

    And then if you run Rsop.msc on that machine, what IE-related policies are being pushed down to it?

    And if you do a "where gp*.dll" - check the version numbers of those files, both on a Windows 7 SP1 client that is reproducing the problem AND on a Windows Server 2008 R2 domain controller.

    Because it sounds similar to this issue resolved by hotfix 982606 where the State value is not written properly, but it sounds like you are already on versions of those files that would contain the fix.

    982606 The value of the "State" registry item is changed after a Group Policy preferences setting is applied in Windows Server 2008, in Windows Vista or in Windows Server 2008 R2
    http://support.microsoft.com/kb/982606

    10/شعبان/1432 02:10 م
  • Try to perform a  Startup Repair.

    Best Regards
    Dale

    Ok, I read your Posts Regarding Startup Repair. I Initiated that Procedure. in the Repair Window I got a Message that Stated "No Hard Disk Found, Can Not Continue", Funny as I have 3 x 1TB Hard Drives on my Computer which "seem" to be working Fine. I have a RAID Stripe on 2, and Use the 3rd for Backup.

    I went Back, and Stopped Windows Update, Cleaned out the Downloads Folder, Re-Started Windows Update, and Re-Installed the Fixit Program, however my Troubleshooters (ALL) still do not function. Tried Recovery again, went back to the Earliest Check Point, didn't work.

    Now What??

    30/ربيع الأول/1433 05:43 ص
  • How about, insteat of providing an automated respone, EXPLAIN HOW TO DO IT! How do you do a start up repair, that link gives no directions at ALL!!!!
    01/جمادى الأولى/1433 09:04 م
  • milew666

    How about, insteat of providing an automated respone, EXPLAIN HOW TO DO IT! How do you do a start up repair, that link gives no directions at ALL!!!!

    What and help us? That is against policy.

    milew666

     Please, these guys are reading a script, Unless they actually have a computer running at home with the same operating system and have had the same problem as we are having, there is no way they can actually provide what is needed.

    A step by step procedure, so we do not lose our harddrives, settings, programs, which run in the thousands, in fact many thousands of dollars.

    and customers? Gosh, one would think you figure Microsoft cares. As far as I know only God and CBS cares.

    Think., do you really think Microsoft is going to have 120.00 a hour system techs answering a forum?

    Use google.

    Try these http://www.ehow.com/how_7247933_do-startup-repair-windows-7.html

    http://www.sevenforums.com/tutorials/681-startup-repair.html


    • تم التحرير بواسطة Meows 16/جمادى الثانية/1433 09:22 م
    16/جمادى الثانية/1433 09:19 م
  • Hi guys, I found this solution on another channel.  I had this exact problem and it solved it for me.  Nothing else worked. I'm running Windows 7.

    "So I think this whole problem can be narrowed down to Cryptographic Services and whether it is on or not. It is currently set to Manualstartup. Do you know if this would work permanently if it was set to Automatic? I'm going to try it anyway."

    So bring up a command box, type in "services.msc" making sure you are running as administrator.  Scroll down the list that appears until you see Cryptographic Services and double click the bit where it says Manual and set it to Auto.  

    Worked perfectly for me.  Hope this helps.



    • تم الاقتراح كإجابة بواسطة TimLalahi 10/رجب/1433 12:00 ص
    09/رجب/1433 02:01 م
  • Hi guys, I found this solution on another channel.  I had this exact problem and it solved it for me.  Nothing else worked. I'm running Windows 7.

    "So I think this whole problem can be narrowed down to Cryptographic Services and whether it is on or not. It is currently set to Manualstartup. Do you know if this would work permanently if it was set to Automatic? I'm going to try it anyway."

    So bring up a command box, type in "services.msc" making sure you are running as administrator.  Scroll down the list that appears until you see Cryptographic Services and double click the bit where it says Manual and set it to Auto.  

    Worked perfectly for me.  Hope this helps.

    Apparently sometimes you have to restart your pc and F8 it sometimes to get to this list.  But the cmd box should work fine.


    • تم التحرير بواسطة TimLalahi 09/رجب/1433 02:04 م
    09/رجب/1433 02:03 م
  • Hay yall. Iam also having that problem but i get the same error code every time i try to run the TroubleShooter 0x80070057 ...I also noticed that under any of the properties i open it dont show any PREVIOUS VERSIONS any more?..  I ran sfc /scannow in cmp. it gets to 16% and says it found corrupt files but unable to fix....   And i also ran the start up repair but no luck so..    I NEED  HELP.,.,.

    22/رجب/1434 12:18 م