none
System Memory shortage

    Dotaz

  • Sorry if this has been addressed. I have looked through the forums and  found nothing yet.

    I checked a few features out throughout the evening and went to fire up my COD WAW game. I had ventrilo running. I got into a game and got out to check something on the net.The good ol' Low Memory message came on!

    Now I have 8 GB of RAM plus a 2 GB flash drive for ReadyBoost.  Checking my system info with my WEI score and Windows says I have 8 GB of RAM, checking Task Manager -> Performance Tab 3.3 GB. Checking even further under dxdiag the same amount showed for system memory and it gave my vid card (HD3870) 512MB more RAM.

    Any thoughts?

    Yes I am running the 64-bit version. Yes I checked each stick of RAM (2x2GB) individually. Unfortunately I can't say if it just started or if it was there from the install. 
    13. ledna 2009 5:45

Odpovědi

  • AHHHHHHHHH I see says the blind man!!!!! So I saw the resource monitor button and decided to click it ( I can't resist buttons!) well low and behold.......there is a memory tab! Selecting that revealed where 4.8GB of my RAM went. Its reserved for hardware!!!! Thats why it shows 3.3Gb in Task Manager, because thats what is reserved for programs. Come on Microsoft do i really need 4.8GB for hardware? I'm not controlling the Hubble telescope!

    • Označen jako odpověď TroyW76 14. ledna 2009 4:38
    14. ledna 2009 4:38

Všechny reakce

  •  Change Memory remap setting in BIOS. This parameter may have different names, look into motherboard or computer manual.
    13. ledna 2009 9:19
    Přispěvatel
  • LOL first thing I thought of...sorry I didn't include that. I actually turned it off and checked-no change. Re-enabled it-no change still.

    Oh also, I took the upgrade path from Vista Home Premium.
    13. ledna 2009 23:50
  • AHHHHHHHHH I see says the blind man!!!!! So I saw the resource monitor button and decided to click it ( I can't resist buttons!) well low and behold.......there is a memory tab! Selecting that revealed where 4.8GB of my RAM went. Its reserved for hardware!!!! Thats why it shows 3.3Gb in Task Manager, because thats what is reserved for programs. Come on Microsoft do i really need 4.8GB for hardware? I'm not controlling the Hubble telescope!

    • Označen jako odpověď TroyW76 14. ledna 2009 4:38
    14. ledna 2009 4:38
    • Upravený TroyW76 14. ledna 2009 4:56 Removed hyperlink to my alblum
    14. ledna 2009 4:54
  • TroyW76, I'm thinking the BIOS is to blame for this problem.  I've seen a few similar problems in the past where a BIOS release would cause stuff similar to this.  Try to see if there is a newer BIOS release for your system.  If not be sure to e-mail the tech support for your system with these issues.
    14. ledna 2009 14:32
  • Interesting... I have the same situation with my memory. No matter what, W7b 64bit only uses 3GB RAM, not unlike 32bit XP. System Information says I have 4 gigs of "Installed Phsical Memory" and "Total Physical Memory" of 2.5 gigs ( +512 on the graphics card). My "Total Virtual Memory" increased after I checked the "Maximum memory" box in System Configuration... again, kinda like 32bit XP. (And yes, the BIOS mem mapping settings are set for 4+ gigs and also report 4 gigs installed and working).  -curious
    15. ledna 2009 1:48
  • Nargg- I would normally agree. I do have the latest BIOS and had all the latest drivers (system and peripheals). Being this is a beta I wouldn't expect MSI to release drivers that are Win7 certified yet.

    I am running an MSI K9A2 Premium (which sucks, don't ever get) and an AMD 9850BE quad core and an ATI HD3870 with 8GB of G-Skill DDR2 PC8000 RAM.

    I am certain there is nothing wrong, as the motherboard AND Resource monitor BOTH report the same amount of "Total" RAM installed. I am thinking the new memory management in Win7 is to blame. As you can see in the picture above 4.8GB  is "Hardware Reserved." 

    I think if Microsoft is going to tweak the Resource Management, they need to implement  "Profiles" or some function to allow IT professionals (such as myself) to alter the amount that is reserved. It would allow system builders and retailers that have on-site repairs to help their customers adjust the performance to their needs.

    This is my gamimg rig and to come out of Call of Duty: World at War and see the low memory warning is a shock. I haven't seen that in about 3 years. since I left a helpdesk LOL!

    Being that I don't use alot of peripheals, except a keyboard, mouse, headset, and now a 640GB backup drive; i see no reason why I need 4.8GB reserved.

    Thanks for the post though Nargg. We need to post our thoughts as often as possible to avoid a Vista launch. 
    16. ledna 2009 22:52
  • 1dh1- did you run dxdiag yet? If so, did you notice that your graphics card now reports twice the physical amount of on-board RAM? I must say that when I play COD now the colors, picture and performance has improved! Another buddy of mine has the beta too and he says the same thing.
    16. ledna 2009 22:55
  • TroyW76 said:

    AHHHHHHHHH I see says the blind man!!!!! So I saw the resource monitor button and decided to click it ( I can't resist buttons!) well low and behold.......there is a memory tab! Selecting that revealed where 4.8GB of my RAM went. Its reserved for hardware!!!! Thats why it shows 3.3Gb in Task Manager, because thats what is reserved for programs. Come on Microsoft do i really need 4.8GB for hardware? I'm not controlling the Hubble telescope!





    hi you can release reserved  memory by  runing services and disable superfetch .

    good luck
    17. ledna 2009 2:18
  • Here is what disabling SuperFetch results to. It only frees up "Free" memory , does nothing for hardware. I trip up on semantics, if it says Hardware, I take it half of my RAM is sitting there waiting for more hardware to be used. If that is not the same thing, they need to change the name then. I know that turning off services can free up memory, but I'm worried about this hardware reserve. I ran Vista without a page file and was blazing fast, now if I try I get a low memory warning. I installed more RAM to not worry about stuff like that.

    If Microsoft makes statements that Win7 can run just fine on a 1Ghz proc, 2GB of RAM, 128MB video card and a 40GB hard drive, overkill as it may be, I should never have any negatives in terms of low memory.
    17. ledna 2009 7:50
  • I have an ECS A939 Mobo with 2gb running win 7 x64 and this is what I get:

    Hardware 3mb, In use 899mb, Modified 4mb, Standby 1141Mb, Free 1mb

    Available to programs  1142mb

    Used for cache 1145 mb

    Total 2045

    Total Installed 2048 mb

    I can't see you being able to make a useful diagnosis with the figures unless you know what they are really telling you. The fact that we get widely differing results is a cause for concern because you would think that they would be in proportion to the amount of memory we have.
    17. ledna 2009 12:01
  • Hi Troy, something doesn't seem right here and I too think it may be BIOS memory remap type issue - I know you say you've checked this - maybe there's a BIOS update needed or another option you've overlooked?

    Really clutching at straws, but are you certain it's 64bit version you've installed?  Did you clean install or was it an upgrade?

    For your info, on a clean install of Windows 7 64 bit my figures are;

    Hardware Reserved - 2mb
    In Use - 1708mb
    Modified - 21mb
    Standby - 6449mb
    Free - 12mb

    Available to programs - 6461mb
    Used for cache - 6469mb
    Total - 8190mb
    Installed - 8192mb

    I know that's not much help overall, but there's something not right as I'd expect your figures to be similar to mine - at least not such a huge discrepancy on the "Hardware Reserved".
    17. ledna 2009 13:27
  • Have same problem with Win 7 Pro x64 on HP NX9420. 4GB RAM installed and Windows is showing over 600MB as hardware reserved, so usable is something about 3,5GB. I don't have any memory remap option in BIOS. Hopefully will HP bring out a new Bios. For the time being will stay with XP 32bit.
    10. srpna 2009 21:06
  • On my machine with Win7 64bit and 8 gigs of ram, here is what I get....(running stock, no tweaks).

    [img]http://www.scapinosvpins.com/Usage.jpg[/img]
    Kurt
    11. srpna 2009 16:48
  • I have 2 systems running Win 7 x64. One is an HP laptop with Vista Home Prem w/4gig of ram. It was a total dog until I allowed Win 7 to do an "in place upgrade" to Win 7. Result was a MUCH more vigorous productivity. However, to get an even nicer operation, I added an 8gig Kingston flash drive; reformatting it to NTFS allowed the whole drive to be dedicated to ReadyBoost. It was worth the about $20 for the flash drive addition to the system cache, especially better than spending about $400 to upgrade to the system limit of 8gig of system ram (2x4gig).

    The 2nd system is a desktop with 8gig of system ram. With that one I am dual-booting it with XP Pro, but am now doing almost everything workwise on the Win 7 partition. I also have a Patriot XT 8gig flash drive formatted NTFS totally dedicated to ReadyBoost caching. It is GREAT for productivity. 

    On the HP laptop Win 7 still occasionally complains about some apps & drivers needing upgrades to 64bit, but it still works fine without them so far; about 2 months running on the laptop.

    I have had some blue screens on the desktop; I uninstalled eBoostr and it went away; I suspect it fought with ReadyBoost - they both do the same thing, except eBoostr Pro allowed control of individual apps usage of the cache.
    • Navržen jako odpověď CopierGuy 4. září 2009 1:53
    4. září 2009 1:53
  • I have a similar problem.. First of all I have a Samsung NP-R560 AS03TR.
    Specs:
    -Intel Core2 Duo T9400 @2.53GHz
    -4GB DDR3 RAM
    -Nvidia 9600M GT 512MB GDDR3

    When I bought the laptop it came with Vista 32-bit and I only had 30MB reserved for hardware.. I upgraded and now I have 1030mb reesrved for my hardware ?? 

    There just has to be a way to reduce this amount.. 
    29. listopadu 2009 1:50
  • Strangely I had this problem too. My laptop came with Win Vista Ultimate x86. I upgraded to Windows 7 Ultimate x86 and as far as I knew it was running all full physical memory which is 2GB, (2048 MB).

    My first Win 7 was a fresh install so I had formatted the drive, removing Vista, once 7 was installed I ran the Experience Test it showed me having the full 2GB of memory available.


    This time round I had done an upgrade because I couldn't be bothered backing up all my personal data this time. This might have been a factor in the memory change reported by Windows but I'm not sure.

    Basically after the upgrade from Vista to 7 it was showing only 1 GB was usable, that's what got me searching for the problem on google. I tried all the methods I could find, MSCONFIG changes, try Memory Remapping but my BIOS doesn't support it and so on.

    My lappy has on-board graphics too, at first I thought I was out of luck, even tho it only uses a small amount of shared memory I though I couldn't do anything about the Hardware allocated memory.

    I did notice that the BIOS itself only showed 1024 MB of memory installed and saw that other people noticed their PCs reporting this too. (strange)

    I decided to try a little Hardware tinkering. Here are the steps i did.

    1. Turned off the Laptop, unplugged power (so i didn't get any nasty shock)

    2. I Removed both RAM sticks just to see if their specs matched, which they did.

    3. I tested one at a time to make sure they both worked, put one in, powered up the laptop to the BIOS and it reported the RAM being 1GB intalled, turned it off again, swapped out the memory with the second stick, booted to the BIOS and it reported at 1GB, so both RAM sticks were working. Laptop was plugged in during the power ups.

    4. Put both sticks back in, screwed it back up and booted to the BIOS. It showed I now had the full 2GB installed. (thats better)

    5. Booted back into Windows 7, went to the system properties and now showed the full 2GB usable.

    6 Went to the Resource Monitor/Memory Tab and now shows all my memory installed with only 1MB used in Hardware Reserved instead of 1GB.


    Fixed!

     

    I'll keep an eye on it over the next week or so to see if the fix stays and doesn't revert back to the full gig used.


    Hope this helps someone

    23. dubna 2010 3:07