none
Solution to NAS Access with old NAS units

    Allgemeine Diskussion

  • There has been several issues with Vista and Windows 7 accessing older NAS boxes using network browsing.  Specifically, the older SAMBA version that some of these units use isn't compatible with the new network protocols.  Even configuring the suggested fixes don't fix it for many of these, including two that I have.

    The problem is really a browsing issue, but there is a simple work-around.  I just created a shortcut to a local folder, then in the properties of the folder, I put the top level share directory name, for instance for my Hawking HNAS1...

    \\HAWKING\share

    This shortcut has no trouble opening the box, and then I can browse within the NAS freely.

    Maybe people have discovered this, but from the amount of posts asking about the issue, I suspect the word isn't fully distributed. :-)

    MVP - Windows Desktop Experience
    Donnerstag, 4. Juni 2009 23:34

Alle Antworten

  • Hi John

    Noted.

    Thank You very much for posting the information. :)


    Ronnie Vernon MVP
    Freitag, 5. Juni 2009 23:04
  • Hopefully, it'll help some other poor soul that has one of these old units and wants to use it with Win7. :-)

    MVP - Windows Desktop Experience
    Freitag, 5. Juni 2009 23:19
  • There has been several issues with Vista and Windows 7 accessing older NAS boxes using network browsing.  Specifically, the older SAMBA version that some of these units use isn't compatible with the new network protocols.  Even configuring the suggested fixes don't fix it for many of these, including two that I have.

    The problem is really a browsing issue, but there is a simple work-around.  I just created a shortcut to a local folder, then in the properties of the folder, I put the top level share directory name, for instance for my Hawking HNAS1...

    \\HAWKING\share

    This shortcut has no trouble opening the box, and then I can browse within the NAS freely.

    Maybe people have discovered this, but from the amount of posts asking about the issue, I suspect the word isn't fully distributed. :-)

    MVP - Windows Desktop Experience
    Can you please provide step by step details on this. I can map my folders individually in Win7 but I get error 1208 if I try to view the drive.

    Mittwoch, 8. Juli 2009 17:35
  • Sure.

    Create a shortcut to a local folder on your machine, any folder.  Rename the shortcut whatever you'd like your link to the drive to be.  Open the properties of the shortcut and in the Target: field, type the network path to the root folder of the NAS.  In the case of my metalgear, that is PUBLIC, so my target line reads:

    \\Metalgear\PUBLIC

    Save this shortcut and you can use it to access the drive's root folder and navigate to all the folders on the drive.


    MVP - Windows Desktop Experience
    Mittwoch, 8. Juli 2009 17:54
  • Trying it now, thanks for the super fast reply.
    Mittwoch, 8. Juli 2009 17:56
  • No problem, happen to be sitting at the computer. :-)
    MVP - Windows Desktop Experience
    Mittwoch, 8. Juli 2009 17:58
  • I did as you said, after entering the target, \\storage\public, it changes the icon and then when I click the icon it produces a pop up box. It says, you may not have permission to use this network resource.... Network error 1208. If I change the target to, (examples,) \\stoarge\photos or \\storage\videos it still gives access to individual folder but the public link does not work?
    Mittwoch, 8. Juli 2009 18:11
  • That's odd, both of my NAS units responded to the technique I described.

    I have a second work-around that might do the trick for you.

    Create a secondary folder on that NAS, then put ALL of the other folders in that folder and link to the newly created folder.  This should still allow you access to all the data, there'll just be an extra folder in the path.

    Remember, I used PUBLIC because that was the name of the root folder on my NAS.

    MVP - Windows Desktop Experience
    Mittwoch, 8. Juli 2009 18:20
  • Thanks for assisting me. I have now successfully managed it, I did not have a root folder just all the separate folders on the drive. By putting them all into a folder called root- \\storage\root.
    Mittwoch, 8. Juli 2009 18:25
  • Great, glad it worked out.  Both of my old NAS units, and even the newer D-Link models, came standard with a "root" folder where everything was stored, so it just fell into place for me.  Essentially, I have the same thing you do, I just didn't have to add a root folder to get there. :-)
    MVP - Windows Desktop Experience
    Mittwoch, 8. Juli 2009 18:27
  • Hi,

    Just been looking at your posts, as I have the same problems, BUT my three NAS drives are all up to date and work well with Vista without any HACK's.

    Using windows 7 RC (build 7100).

    I have been looking for talk or news of what the NAS drive suppliers are doing to fix the problem, then I came across this ! (so its a BUG in windows 7 and we will have to wait for a proper fix).

    Thane.


    http://lists.samba.org/archive/samba-technical/2009-January/062827.html

    Hi!

    On Thu, Jan 15, 2009 at 11:10:55AM -0800, Joshua-M wrote:
    > I have a Samba 3 / OpenLDAP system working with 2000, XP/2003 and Vista
    > clients, but no go with 7, I will attach what information I have gathered.

    Jim Pinkerton asked me to post this message from Microsoft:

      Sincere apologies, but wanted to confirm that there is an issue with NT Domain support in
      Windows 7. We're trying to expeditiously track down exactly the issue(s), but the short of
      it is I wouldn't spend time trying to get this functionality to work. We'll get some sort
      of official notice out shortly (and I do mean shortly).

      Jim Pinkerton
      Microsoft

    Samstag, 8. August 2009 11:21
  • I got the same problem, but only happens with Ultimate RC on my notebook when trying to browse my Buffalo HG400LAN Linkstation. Ultimate RC on my desktop works fine with the NAS. I changed the level of authentication as recommended on another thread(Send LM and NTLM responses), turned off wireless networking, installed a new NAS browser from Buffalotech, and turned off the restricted acccess on the NAS, and that allowed me to see the NAS on the Network but still I can't Browse it. Could it be a notebook network driver bug?

    BTW, sometime ago I was able to browse my NAS from the notebook. Somehow this problem occurred after an update.
    Montag, 26. Oktober 2009 18:16
  • Hmm...  Jim's idea of "We'll get some sort of official notice out shortly (and I do mean shortly)." must be different than ours.  I have no problem with Vista or Windows 7 with my D-Link DNS-321 and DNS-323, so I can't be much more help.  I retired the two older boxes.

    MVP - Windows Desktop Experience
    Montag, 26. Oktober 2009 18:49
  • Love you long time - just saved me getting a headache :)
    Sonntag, 14. Februar 2010 20:58