none
Windows 7 - Herunterfahren sehr langsam (10+minuten)

    Allgemeine Diskussion

  • Bei Windows 7 Rechner - Einzelplatrechner ohne Serveranbindung

    OS Windows 7 Ultimate SP1 - Windows Update stand 12.06.2013

    Seit einige Zeit (30 Tage oder mehr) benötigt der Rechner mehr als 10 minuten herunterzufahren.

    Mit Hilfe der "Windows Perfomance Anaylser" könnte ich sehen, dass die Verzögerung bei der "PreShutdownNotification" passiert.

    <intervals>
    <interval duration="697" endTime="36501" startTime="35804" name="WaitForWinstationShutdown"/>
    <interval duration="611015" endTime="647697" startTime="36682" name="PreShutdownNotification"/>
    <interval duration="4768" endTime="658085" startTime="653317" name="NtShutdownSystem"/>
    <interval duration="-1" endTime="-1" startTime="0" name="ZeroHiberFile"/>
    <interval duration="2506" endTime="655890" startTime="653384" name="FlushVolumes"/>
    <interval duration="0" endTime="655890" startTime="655890" name="ZeroPageFile"/>
    <interval duration="1" endTime="656576" startTime="656576" name="IoShutdownSystem"/>
    <interval duration="-1" endTime="-1" startTime="0" name="WaitForProcesses"/>
    <interval duration="817" endTime="657394" startTime="656576" name="CmShutdownSystem"/>
    </intervals>

    Im Registryschlüssel:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    "PreshutdownOrder"

    sind die Standardwerte eingetragen: wuauserv; gpsvc; trusted installer
    Entferne ich die Werte, fährt der Rechner innerhalb eine Minute runter.

    Ich habe auch probiert mit jeweils nur einen Wert, ohne Erfolg - normal Herunterfahren geht nur wenn keine Werte da sind.

    Da diese Werte auf anderen Rechner auch genau so sind, und keine Probleme verursachen, verstehe ich nicht warum bei diesem Rechner es nicht funktioniert.

    Wenn jemand Rat weiss, wäre ich sehr dankbar.

    Donnerstag, 13. Juni 2013 14:09

Alle Antworten

  • Am 13.06.2013 schrieb Wanderer-Nomad:

    Seit einige Zeit (30 Tage oder mehr) benötigt der Rechner mehr als 10 minuten herunterzufahren.

    Werden evtl. immer wieder Updates installiert? Was findest Du im
    Eventlog zu diesem Zeitpunkt? Was wird angezeigt während des Shutdown?
    Lass dir ausführliche Meldungen anzeigen? Wird während dem Shutdown
    auf die HDD geschrieben? Deinstalliere doch mal den vorhandenen
    AV-Scanner und benutze auch das Removal Tool vom Hersteller.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Freitag, 14. Juni 2013 16:31
  • Hallo Winfried,

    Es sind in dem Zeitraum Updates installiert worden .. am 16.05. kamm ein ganzes Schwung wie ich sehen kann in Updates Verlauf, meiste aber mit Office zu tun. Da ich normalerweise den Rechner den Herunterfahren Befehl gebe und dann meistens das Zimmer verlasse, kann ich nicht genau sagen wann es mit dem langsames herunterfahren angefangen hat.

    Bei den Updates ist am 1.05 ein Update für Windows Update manager. Und komischer weise in dem PreshutdownOrder alle drei Dienste haben auch mit Windows Update zu tun. Könnte hier die Ursache liegen? Ich habe noch keine Möglichkeit gefunden dieses Update rückgängig zu machen, bzw. zu wiederholen. Dieses Update erscheint zwar in den Update Verlauf, aber nicht unter installierte Updates bei Programme und Funktionen.

    AV-Scanner habe ich komplett rausgeschmissen mit Removal Tool .. herunterfahren genauso langsam ohne AV-Scanner .. und anschliessend frisch installiert. Keine Änderung.

    Während dem Shutdowns zeigt sich das Bildschirm Herunterfahren... am Anfang tut sich die Festplatten Lampe noch blinken aber die letzte 10 minuten oder so leuchtet sie nur kurz vor der Rechner ausgeht auf.

    Im Ereignisanzeige ab 1.05. sehe ich keine Ereigniss die mit dem Shutdown zu tun haben. Einziges was sich wiederholt ist:

    Die Beschreibung für die Ereignis-ID "0" aus der Quelle "AdobeARMservice" wurde nicht gefunden. Entweder ist die Komponente, die dieses Ereignis auslöst, nicht auf dem lokalen Computer installiert, oder die Installation ist beschädigt. Sie können die Komponente auf dem lokalen Computer installieren oder reparieren.

    Falls das Ereignis auf einem anderen Computer aufgetreten ist, mussten die Anzeigeinformationen mit dem Ereignis gespeichert werden.

    Die folgenden Informationen wurden mit dem Ereignis gespeichert:

    Service started

    Grüße

    Montag, 17. Juni 2013 19:35
  • Am 13.06.2013 schrieb Wanderer-Nomad:

    Im Registryschlüssel:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    "PreshutdownOrder"

    sind die Standardwerte eingetragen: wuauserv; gpsvc; trusted installer
    Entferne ich die Werte, fährt der Rechner innerhalb eine Minute runter.

    Bei mir sind die Werte ohne ; eingetragen. Entferne doch bei dir die
    ;-Zeichen vollständig. Anschließend neu starten und wieder
    Herunterfahren. Geht das zweite Herunterfahren schneller?

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 17. Juni 2013 20:07
  • Entschuldige, den Zeichen ; habe ich reingemacht beim abschreiben, in Registry Eintrag sind die auch ohne ;

    Ich habe mittlerweile ein MS Fixit für Update Agent (http://support.microsoft.com/kb/971058/de) gefunden, durchlaufen lassen kein Unterschied. Den manuellen Fix durchgeführt keine Änderung.

    Liegt doch wohl an diese PreShutdownNotification.

    Dienstag, 18. Juni 2013 18:28
  • Hallo,

    Wenn es Probleme beim Shutdown gibt, dann solltest Du im Control Panel > All Control Panel Items > Performance Information and Tools > Advanced Tools unter Performance Issues ein paar Einträge finden, die mit dem Shutdown Prozess direkt verbunden sind.

    Wenn dort keine Einträge sind, dann such mal im Ereignisprotokoll unter Applications and Services Logs > Microsoft > Windows > Diagnostics-Performance > Operational. Die Einträge die hier mit 2** beginnen sind Einträge die mit dem Shutdown Delay etwas zu tun haben:

    Vielleicht helfen Dir diese Tipps weiter beim Troubleshooting.

    Gruss,

    Alex


    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 21. Juni 2013 08:48
  • Auch nichts zu sehen die EreignisId 200 zeigt auch nur an, dass die WindowsPreshutdownNotification sehr lange braucht. Unter der EreignisId 203 sind gelegentliche Einträge, keiner über 10 sec. Verzögerung und immer etwas anders.

    Montag, 24. Juni 2013 09:47
  • Du lässt nicht zufällig beim Abmelden aus Sicherheitsgründen die pagefile.sys löschen/leeren?

    http://support.microsoft.com/kb/314834/en



    Tschö
    Mark Heitbrink - MVP Windows Server - Group Policy
    Homepage: www.gruppenrichtlinien.de - deutsch
    GPO Tool: www.reg2xml.com - Registry Export File Converter

    Donnerstag, 27. Juni 2013 11:01
  • Nein, die Registry Wert für diesen Eintrag steht auf 0.

    Wenn ich den Wert auf 1 stelle, also sage dass die Pafefile.sys geleert werden soll, macht es beim Herunterfahren kein merkbaren Unterschied.

    Das kann nicht die Problemstelle sein, weil diese Verzögerung tritt nur mit der PreShutdownNotification auf.

    Sobald die drei Einträge oben stehen, bleibt er hängen beim Herunterfahren. Sind die Werte raus, fährt ganz normal runter.

    Sorry, war letzte Woche nur unterwegs und könnte nicht auf dem betroffenen Rechner die Werte nachschauen.

    Gruß

    Montag, 1. Juli 2013 15:40