none
Why does one portion of SP1 takes so long

    Frage

  • Environment: Win 7 Pro, 64-bit Core-i7, 8GB RAM

    Not taking chances I converted my system drive of Win 7 to a VM and ran SP1 in the VM just to see if there was any surprises. I gave the VM polenty of RAM and a couple of cores. Now I've installed this on a new HP quad core via WU and it took a bit over an hour. On my netbook it took 80 minutes. On a virgin VM it took a bit over 30 minutes.

    On my VM from my system? 3 hours!

    I can understand it being slow but this is long. But this chunk from the log file took just short of 2 hours:

    2011-03-20 17:23:05, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab1.cab
    2011-03-20 17:23:05, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 17:23:05, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 17:23:05, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 17:23:05, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 17:26:14, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 17:26:14, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 17:26:14, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab6.cab
    2011-03-20 17:26:14, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 17:26:14, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 17:26:14, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 17:26:14, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 17:41:27, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 17:41:27, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 17:41:27, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab0.cab
    2011-03-20 17:41:27, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 17:41:27, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 17:41:27, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 17:41:27, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:04:08, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:04:08, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 18:04:08, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab5.cab
    2011-03-20 18:04:08, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 18:04:08, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:04:08, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:04:08, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:25:40, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:25:40, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 18:25:41, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab2.cab
    2011-03-20 18:25:41, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 18:25:41, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:25:41, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:25:41, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:49:12, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:49:12, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 18:49:12, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab3.cab
    2011-03-20 18:49:12, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 18:49:12, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 18:49:12, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 18:49:12, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:36, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:36, Info                  DPX    Ended DPX phase: Resume and Download Job
    2011-03-20 19:06:36, Info                  CBS    Extracting all files from cabinet \\?\C:\c462e3ac169521d3ad22416726\f79c520b69880857774d06fb26797bf4\KB976933-LangsCab4.cab
    2011-03-20 19:06:36, Info                  DPX    Started DPX phase: Resume and Download Job
    2011-03-20 19:06:36, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:36, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:36, Info                  DPX    Started DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:58, Info                  DPX    Ended DPX phase: Apply Deltas Provided In File
    2011-03-20 19:06:58, Info                  DPX    Ended DPX phase: Resume and Download Job

    Is this normal? [pdidn't check the logs of the others] What's with the "lang" files? I have only English. No other languages.

     


    Montag, 21. März 2011 04:35

Alle Antworten

  • The extraction of the CABs takes very long if you use AntiVirus scanners which scans the CAB files. So disable your AntiVirus scanner during the intsllation. This should speedup the installation.

    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Montag, 21. März 2011 15:37
  • The AV was disabled. all services stopped and any processes were killed.

     

    Montag, 21. März 2011 20:59
  • You can try to run ProcessMonitor in background and look what happens during the time.
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Montag, 21. März 2011 21:29
  • Hi Edward,

     

    I am just writing to see how everything is going. Can you find any clues with using process monitor tool?

     

    If you have any updates or need any further assistance on this issue, please feel free to let us know. We are glad to be of assistance. :-)

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Mittwoch, 23. März 2011 02:27
  • Well, I haven't installed SP1 yet. Just waiting for a good time to install it.

     

    Mittwoch, 23. März 2011 04:38
  • It does seem l like SP1 takes a long time to install, even on a new, freshly imaged computer with 4GB of ram.....but about 30 minutes is the longest I have seen.

     

    Thank God for imaging....

    Mittwoch, 23. März 2011 17:19
  • Hell Edward,

    One thing to note, this looks like multiple language packs installed.  The more language packs installed on a machine, the longer the installation of SP1 will take.


    Thanks, Darrell Gorter This posting is provided "AS IS" with no warranties, and confers no rights. VAMT - Volume Activation Management Tool - Download link http://www.microsoft.com/downloads/details.aspx?FamilyID=ec7156d2-2864-49ee-bfcb-777b898ad582&displaylang=en
    Mittwoch, 23. März 2011 17:46
  • Just waiting for a good time to install it.

    ok, do this and capture the progress in background. Select that the logging goes directly into a file. Also look what Darrel wrote. How many language packs do you have?

    Run "C:\Windows\System32\lpksetup.exe" to remove the MUIs you don't use.

    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Mittwoch, 23. März 2011 20:16
  • Just a note that I have the Pro version - so no language packs installed.

    That said, SP1 is installed. 37 minutes from start to finish. 1 reboot. Didn't really resemble the Vm version in any way which had two reboots.

    I did remove my AV prior to the install.

    But I suspect part of the long install was because it was in a VM.

    One thing I have noticed is that the AUDIODG.EXE process has been running at arounde 6 to 8% since SP1 was installed. 


    • Als Antwort markiert Edward_b Freitag, 25. März 2011 03:36
    • Tag als Antwort aufgehoben Edward_b Freitag, 25. März 2011 04:26
    Freitag, 25. März 2011 03:36
  • When I tested it in a VM, it also only took 45min (2 Cores assigned with 2GB RAM). I think the AV tool was the cause.
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Freitag, 25. März 2011 14:46
  • When I tested it in a VM, it also only took 45min (2 Cores assigned with 2GB RAM). I think the AV tool was the cause.
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221


    Probably - even though I stopped the services and killed everything else. I had assigned 2 cores and 4GB of RAM.

    Of course there is still AUDIODG.EXE which is hovering between 9 & 10% constantly.

     

    Freitag, 25. März 2011 22:47
  • which VM do you use? Do you use the latest Integration components/VM addons?
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Samstag, 26. März 2011 13:16
  • Hi,

     

    Regarding your suspicion of audiodg.exe process, sometimes the audiodg.exe process would cause memory leak issue in Windows 7, as a test, try to install following hotfix before installing Windows 7 Service Pack 1:

     

    A memory leak issue occurs in the Audiodg.exe process when you play audio on a computer that is running Windows 7, Windows Server 2008 R2, Windows Vista or Windows Server 2008

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Montag, 28. März 2011 10:50
  • this hotfix is part of the Sp1 so it doesn't matter if you install it or not.
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Montag, 28. März 2011 12:51
  • I had that hotfix already installed prior to SP1. The CPU increase only happened after SP1.

    I guess someone didn't properly edit that KB. The symptoms don't mention SP1 but the prerequisites section does. Usually the mark it with "This probablem was first corrected in service pack 1." [or similar]

    audiodg.exe still hovering around 10%.

     

    Montag, 28. März 2011 23:51
  • Hi,

    please make a xperf trace [1] to diagnostic the higher CPU usage of audiodg.exe. Please upload the etl file to your SkyDrive [2] and post a link here.

    I'll take a look at it, maybe I can see more details.

    André

    [1] http://www.msfn.org/board/index.php?showtopic=140264
    [2] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Dienstag, 29. März 2011 13:34
  • Hi,

    please make a xperf trace [1] to diagnostic the higher CPU usage of audiodg.exe. Please upload the etl file to your SkyDrive [2] and post a link here.

    I'll take a look at it, maybe I can see more details.

    André

    [1] http://www.msfn.org/board/index.php?showtopic=140264
    [2] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221


    Hopefully this link works: http://cid-be3e9f9ec6c1601a.office.live.com/browse.aspx/Logs

    Thanks

     

    Dienstag, 29. März 2011 23:52
  • the function CAudioFormatConvert::ConvertInt24WideToFloat32 causes the permanent 6% CPU usage.

    Update the Creative SB X-Fi driver and disable the the audio enhancements in the soundoptions.


    "A programmer is just a tool which converts caffeine into code"

    I'm going to leave the forum on 31th March 2011 if I don't get a Feedback about the SPAM of 2 MVPs. So if you want an answer, be fast so that I can help you before I leave the Technet forum.
    Mittwoch, 30. März 2011 14:03
  • There are no new drivers from Creative Labs [as yet].

    I disabled each enhancement one at a time and no difference.

    Donnerstag, 31. März 2011 02:37
  • I have no idea, sorry. Ask this the MS/Creative support.
    "A programmer is just a tool which converts caffeine into code"

    I'm going to leave the forum on 31th March 2011 if I don't get a Feedback about the SPAM of 2 MVPs. So if you want an answer, be fast so that I can help you before I leave the Technet forum.
    Donnerstag, 31. März 2011 13:06
  • Hi,

    Make sure the checkbox "disable all enhancements" is ticked.

    Does uninstall and reinstall of the creative driver help?

    If there is no later driver, try downgrading the driver to a previous version [I have seen other reports of same issue with the creative X-Fi driver].

    Also, Check if windows has a Generic driver for the card instead of using the OEM driver.

     


    Sumesh P - Microsoft Online Community Support
    Montag, 4. April 2011 10:14
  • Enhancements were disabled at one point. At this point I won't bother uninstalling and reinstalling. 7%-10% isn't much.

    No recent drivers.

    No drivers with Windows.

    Montag, 4. April 2011 18:58
  • Okay.

    In case you decide to revisit the issue later, try an older driver as previous reports i have seen were associated with a X-Fi driver update and an older version might not have the issue. uninstall and reinstall of the driver also helps sometimes.

    Thanks

     


    Sumesh P - Microsoft Online Community Support
    Dienstag, 5. April 2011 13:46