none
SiS 900-Based PCI Fast Ethernet Adapter

    Frage

  • I tried windows 7 and there is no support for it, could not get it to work and go online.

    Motherboard, ASUS P4S800D-X socket 478

    Ethernet Adapter is integrated on motherboard

    ASUS and SiS does not have driver to download

    Ethernet Adapter works fine in MS Windows Vista Home Premium
    Mittwoch, 18. Februar 2009 02:37

Antworten

  •  

    Hi,

     

    After searching, I found the latest version of SiS 900 Lan Adapter may be 1.19. However, it is not for Windows 7.

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Just as a test, we can try to install this one with the compatible mode to see if it works.

     

    Since the issue is related to the hardware, it is also recommended that you contact SIS or ASUS to see if they have some proper solutions.

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Donnerstag, 19. Februar 2009 11:21
  • I tried the windows update approach without success. Also, I tried the 1.19 driver. No luck.

    Any other ideas? I'm stuck. thanks
    Dear Sir/Madam,

    Use your original driver from either PC or MB maker then do the following:
    1.) Boot up your PC
    2.) At W7 boot up press F8 then go to select Save mode with Netowrk support
    3.) Go to Device manager
    4.) Select delete your Network adapter
    5.) Refresh then re-install your Network adapter
    6.) Select manual install point to your either PC or MB maker's original network driver
    7.) After installation your are done! Re-Boot to W7 again then fly..... 

    • Als Antwort vorgeschlagen Yababy Donnerstag, 29. Oktober 2009 21:18
    • Als Antwort markiert Nicholas LiModerator Montag, 4. Januar 2010 04:14
    Donnerstag, 29. Oktober 2009 21:18

Alle Antworten

  • If you can download the ASUS chipset drivers to a file on the desktop, try rightclicking that to "Troubleshoot Compatibility. Vista compat. should work.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Mittwoch, 18. Februar 2009 14:14
  •  

    Hi,

     

    After searching, I found the latest version of SiS 900 Lan Adapter may be 1.19. However, it is not for Windows 7.

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Just as a test, we can try to install this one with the compatible mode to see if it works.

     

    Since the issue is related to the hardware, it is also recommended that you contact SIS or ASUS to see if they have some proper solutions.

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Donnerstag, 19. Februar 2009 11:21
  • I've just installed the Windows 7 RC1 build and had to do what I did with the beta, download the 1.19 driver package to my XP OS then logged into W7 and just dragged it over from XP to my W7 desktop, ran 'Setup' and it installed like a dream, Windows Update hunted out a better driver for me and I'm fully up and running.  I'm sure Microsoft will have a basic driver in the retail installation
    Samstag, 9. Mai 2009 08:52
  • While there is a newer driver in Windows Update, you can't reach it without an installed driver.  An alternative to the 1.19 driver is to use another machine to go to Windows Update Catalog (http://go.microsoft.com/fwlink/?LinkID=8973) and search for "SIS 900".  There you'll see the drivers listed 4 times (different languages and CPU architectures, but the description appears the same).  They're pretty small so add all 4 to your basket and download them.  Then look at the filenames to determine which driver you want - they're in .CAB files which you'll need to extract first (Window Explorer should be able to handle them).

    Copy the extracted drivers to a CD/USB Stick/Floppy etc. then transfer them to your Win7 machine.  Right-click on "Computer" and select Manage.  Go to the Device Manager and double click on the non-working network card.  Click Update Driver.  Choose to specify a location on your machine.  Point to the folder where you copied the drivers to.  They should now install and the network card should start working.

    Enjoy!

    Rob

    Dienstag, 21. Juli 2009 20:57
  • I tried the windows update approach without success. Also, I tried the 1.19 driver. No luck.

    Any other ideas? I'm stuck. thanks
    • Als Antwort vorgeschlagen Yababy Donnerstag, 29. Oktober 2009 21:12
    Mittwoch, 28. Oktober 2009 10:28
  • I tried the windows update approach without success. Also, I tried the 1.19 driver. No luck.

    Any other ideas? I'm stuck. thanks
    Dear Sir/Madam,

    Use your original driver from either PC or MB maker then do the following:
    1.) Boot up your PC
    2.) At W7 boot up press F8 then go to select Save mode with Netowrk support
    3.) Go to Device manager
    4.) Select delete your Network adapter
    5.) Refresh then re-install your Network adapter
    6.) Select manual install point to your either PC or MB maker's original network driver
    7.) After installation your are done! Re-Boot to W7 again then fly..... 

    • Als Antwort vorgeschlagen Yababy Donnerstag, 29. Oktober 2009 21:18
    • Als Antwort markiert Nicholas LiModerator Montag, 4. Januar 2010 04:14
    Donnerstag, 29. Oktober 2009 21:18
  • I tried windows 7 and there is no support for it, could not get it to work and go online.

    Motherboard, ASUS P4S800D-X socket 478

    Ethernet Adapter is integrated on motherboard

    ASUS and SiS does not have driver to download

    Ethernet Adapter works fine in MS Windows Vista Home Premium
    Stop looking for driver see yababy says. Install in SAVE mode for legacy driver.
    Samstag, 31. Oktober 2009 18:30
  • I tried the windows update approach without success. Also, I tried the 1.19 driver. No luck.

    Any other ideas? I'm stuck. thanks
    Stop looking for driver see yababy says. Install in SAVE mode for legacy driver.
    Samstag, 31. Oktober 2009 18:32
  • Rob,

    I downloaded the four files as you suggested.  (Actually there seems to be only two, each one being duplicated).  When I try and extract them using Winzip it complains that they are incomplete.  If I try and extract them in Windows Explorer, as you suggested, it simply a summons Winzip…

    I'd be very grateful for suggestions that would work on this machine which is actually running Windows 7.

    David
    Montag, 9. November 2009 16:49
  • I downloaded the winxp driver from here http://www.sis.com/download/
    unziped the files on the win7 box.  opened up the hardware manager, right clicked the unrecognized nic card, choose the winxps2 folder and clicked install
    and all is good
    Donnerstag, 12. November 2009 22:44
  • After a long search I found the SIS 900 Microsoft driver update for SiS 900-Based PCI Fast Ethernet Adapter at http://catalog.update.microsoft.com/v7/site/Search.aspx?q=SIS%20900 which is the official Microsoft's catalogue. I hope you can solve your problem.
    Mittwoch, 23. Dezember 2009 22:58
  • Yababy - thanks for the instructions, they solved the problem.  Per your instructions... I downloaded the XP driver from the SiS site and unzipped it into a folder on my Desktop.  I booted into SAFE mode with Networking and uninstalled the existing driver, then chose to Install a new Hardware device.  I didn't see the SiS in the list, so I chose an Intel Networking item from the list and browsed to the XP .info file in the folder on my Desktop.   That triggered the list to show the SiS Networking adapter and I installed it.  I rebooted the PC (into regular mode) and it completed the install and everything worked perfect.  Thanks for the step by step instructions.  Out of all of the suggestions I tried, this was the only one that worked for me.
    Sonntag, 3. Januar 2010 09:11
  • Yababy - thanks worked for me too.
    Dienstag, 5. Januar 2010 03:21
  • big respect to you yababy, I have been struggling to connect to the internet after installing windows 7 and I did just what you said and guess what??? I AM ONLINE. Many thanks
    Dienstag, 26. Januar 2010 19:31
  • BIG  THANKS yababy that works for me too... !!!
    I thought I had to buy a new network card..!  You are awesome!
    Donnerstag, 18. Februar 2010 08:48
  • Thx, NiceGuyUK.....this solved the last of my driver problems

    J

    Mittwoch, 28. April 2010 19:11
  • Fantastic!! It worked, as simple as you explained. I did my day !!!

    Samstag, 14. August 2010 02:29
  • Thanks Yababy - your HowTo did the trick on my ancient labtop (sis630/730 with sis900 netcard) - I've now got Windows 7 working with full network support!

    Cheers,

    Bo

    Donnerstag, 16. September 2010 08:54
  • I found the SiS 900-Based PIC adapter shows as Ethernet controller in device manager?

    When I followed Yababy instructions, I did not delete the network adapter as there is no option to do that. Instead I selected update driver and selected the version 1.16 that I downloaded from http://support.asus.com/Download.aspx?SLanguage=en&m=P4S800D-X&p=1&s=15 and moved to the computer by using an USB. Those are the modification to Yababy procedure I needed to make to install the driver.  

    Dienstag, 31. Mai 2011 19:08
  • I downloaded the XP package and installed those ... works fine ;-)
    Dienstag, 21. Juni 2011 10:52
  • ok this is how you do it:

    1. Google the name of the ethernet card name driver for xp

    2. It'll come up with a driver from a dell website, download it

    3. install it in safemode, it'll ask for a reboot, do it

    4. computer turns on BOOOM it works on windows 7

    5. run all the windows update CHYeAAAAAAAAAAAAAAAAaaaaaaaaaaaaa

    Freitag, 7. Oktober 2011 02:17
  • I tried the windows update approach without success. Also, I tried the 1.19 driver. No luck.

    Any other ideas? I'm stuck. thanks
    thank you really works!!!!!!!!!!!!!!! XD

    Montag, 21. November 2011 03:48