none
Computer Won't Stay Asleep (in sleep mode)

    Question

  • my computer keeps turning on after sleep mode

    any help would be great.

    I know its not the mouse because i turn my mouse off(its a battery mouse-laser).

    Saturday, January 24, 2009 3:29 PM

Answers

  • There are numerous people having problems with shutting down and/or sleep mode, but there aren't any fixes out yet except for disallowing hardware to wake up the computer from standby (for instance your network adapter).

    Frop said:

    Control Panel -> Device Manager -> Network adapters -> Right mouse click on your network adapter -> Properties -> Power Management (tab) -> Uncheck 'Allow this device to wake the computer'.

    You might have to repeat these steps for additional network adapters or possibly any other hardware which supports this Power Management function and might be responsible for waking up your system. Good luck!

    • Proposed as answer by Frop Monday, January 26, 2009 9:37 PM
    • Marked as answer by ae69ae Friday, January 30, 2009 3:35 PM
    Saturday, January 24, 2009 3:37 PM

All replies

  •  how do i add a picture in here?
    • Proposed as answer by Frop Saturday, January 24, 2009 3:36 PM
    • Unproposed as answer by ae69ae Saturday, January 24, 2009 3:37 PM
    • Unproposed as answer by ae69ae Saturday, January 24, 2009 3:40 PM
    Saturday, January 24, 2009 3:33 PM
  • There are numerous people having problems with shutting down and/or sleep mode, but there aren't any fixes out yet except for disallowing hardware to wake up the computer from standby (for instance your network adapter).

    Frop said:

    Control Panel -> Device Manager -> Network adapters -> Right mouse click on your network adapter -> Properties -> Power Management (tab) -> Uncheck 'Allow this device to wake the computer'.

    You might have to repeat these steps for additional network adapters or possibly any other hardware which supports this Power Management function and might be responsible for waking up your system. Good luck!

    • Proposed as answer by Frop Monday, January 26, 2009 9:37 PM
    • Marked as answer by ae69ae Friday, January 30, 2009 3:35 PM
    Saturday, January 24, 2009 3:37 PM
  • control panel / power opts / change plan settings / advanced opts

    under sleep / wake timers, select disabled

    • Proposed as answer by sheriff120 Saturday, November 09, 2013 10:53 PM
    Saturday, January 24, 2009 3:40 PM
  • ae69ae said:

     how do i add a picture in here?



    In the Reply screen in the lower let corner you will see a pencil and a icon that looks liek this:

    <>

    That is for HTML code.  Upload the picture to Imageshack or Photobucket and then get the HTML code.  Click that button and paste the code in there.  Then click the magnafying glass with the + symbol to make sure that the picture is present.  The click the pencil again to continue typing.

    Other than the suggested i would also suggest changing the power options to have your hard drives never turn off.  Something could be accessing your hard drives after they turn off which is forcing your PC to kick back on.


    ~Alex T.~
    ~Windows Desktop Experience MVP~
    Sunday, January 25, 2009 8:07 PM
  • So far setting my ethernet controller power management properties to not allow the device to wake computer, it has kept sleeping. I will keep testing it.
    • Proposed as answer by Rvrpilot Sunday, January 25, 2009 10:46 PM
    Sunday, January 25, 2009 10:45 PM
  •  Mine keeps waking up at 3:00 AM every other morning on the dot and it wakes me up due to a rather loud PSU fan.
    Monday, January 26, 2009 9:31 PM
  • pffbt said:

     Mine keeps waking up at 3:00 AM every other morning on the dot and it wakes me up due to a rather loud PSU fan.


    Just a hunch, but it might be the automatic schedule of the Disk Defragmenter. Start -> Search programs and files -> Disk Defragmenter -> Configure schedule... -> Uncheck 'Run on a schedule' -> Press OK.
    Monday, January 26, 2009 9:37 PM
  • It may also be Windows Update, which always woke my machine at 2am on the dot under Vista.
    Monday, January 26, 2009 10:44 PM
  • J Howland AU said:

    It may also be Windows Update, which always woke my machine at 2am on the dot under Vista.


    Agreed, I forgot for a second I also turn off Automatic Updates by default. :-p
    Monday, January 26, 2009 10:47 PM
  • Frop said:

    There are numerous people having problems with shutting down and/or sleep mode, but there aren't any fixes out yet except for disallowing hardware to wake up the computer from standby (for instance your network adapter).

    Frop said:

    Control Panel -> Device Manager -> Network adapters -> Right mouse click on your network adapter -> Properties -> Power Management (tab) -> Uncheck 'Allow this device to wake the computer'.

    You might have to repeat these steps for additional network adapters or possibly any other hardware which supports this Power Management function and might be responsible for waking up your system. Good luck!



    This seems to work but it still randomly turns on SOMEtimes, probably one full night, i wake up and its still sleeping, i go to school come back still sleeping, but after i use it and it "automatically"goes into sleep mode--it will wake up like a minute or two right after it goes into "sleep mode", it seems to stay asleep when i manually go to "start<Sleep".
    Friday, January 30, 2009 3:39 PM
  • You might also want to try disabling Automatic Updates and the scheduled Disk Defragmenter. One of the MFSTs posted another fix earlier on, you can use it to determine which other devices (apart from your network adapter) are also capable of waking up your system.

    Robinson Zhang - MSFT said:

     

    Hi,

     

    I suggest you take the following suggestions to troubleshoot the problem.

     

    1.       Open a command prompt and run the command

     

    powercfg -devicequery wake_armed

     

    The command will list all the devices which can wake up computer.

     

    2.       Try to disable each of these devices above one by one and test the problem until you find the culprit that is waking up the computer.

     

    powercfg -devicedisablewake "device name"

     

    3.       Once you find the one that is causing problems, you can re-enable the other devices.

     

    powercfg -deviceenablewake "device name"

    • Proposed as answer by tomchambliss Monday, February 02, 2009 4:47 PM
    Friday, January 30, 2009 4:27 PM
  • Unless Windows is adding something that doesn't show up listed It is not the Updates on my computer. Mine did go to sleep last night The powercfg answer listed did not work for my computer don't know why? tomchambliss@bellsouth.net

    Monday, February 02, 2009 4:51 PM
  • My PC wouldn't stay asleep; waking after a few minutes. I tried the suggestions posted here. It was turning off the defragmenter schedule that fixed it. Thanks!
    Friday, May 08, 2009 3:31 PM
  • Glad you fixed it. Mine went to sleep and wouldn't wake up!
    Fix for me was to turn off Hybernation.
    JS
    Friday, May 08, 2009 5:50 PM
  • my computer keeps turning on after sleep mode

    any help would be great.

    I know its not the mouse because i turn my mouse off(its a battery mouse-laser).


    I just got Windows 7 running about a week ago (as of this posting it is 6/3/09) on a homemade PC and I was having a similar problem with sleep mode. I'm using an ASUS X58 gene motherboard. I was also having a problem with a cooling fan and swapped it out. Oddly, I haven't seen a problem with the sleep mode ever since. I'm sure it is just a coincidence, but I can't explain why sleep mode is now working. The fan I replaced was a three wire power connection. I replaced it with a four wire pwm fan.
    Thursday, June 04, 2009 1:38 AM
  • Thanks for the advice.

    My system settings had changed when I installed a Sonos system.

    I am now experimenting with which power system works best
    Sunday, July 31, 2011 9:54 PM
  • I had that same problem and found that one of my keys was sticking on my keyboard, when I replaced my keyboard I dont have that restarting problem anymore, now how weird is that.
    Thursday, September 15, 2011 7:42 PM
  • As previously stated, simply typing in the search bar in the start menu "Change power-saving settings" and hitting enter will bring up the preferred plans. Whichever is selected, click the "Change plan settings" link to the right. After that, simply click the "Change advanced power settings". Click the + sign next to sleep. Then click the + next to "Allow wake timers". Click the setting and DISABLE it. This will solve any issues with the computer magically turning itself back on upon going to sleep mode.
    • Proposed as answer by mhill46 Wednesday, January 04, 2012 8:10 PM
    Wednesday, January 04, 2012 8:10 PM
  • Feb. 26, 2012   Frop:  The problem with the sleep mode has bothered me for weeks; your solution solved the problem immediately.  Thank you so much.  SantaFeJack
    Sunday, February 26, 2012 7:13 AM
  • Thanks so much Frop!  I've been reading and searching for over a month trying to figure out how to get my computer to stay in sleep mode and this works!!!  But, when I right clicked on Network adapters there wasn't a tab labeled Power Management.

    I had to click the little triangle just before Network adapters for it to open the drop down list and then I right clicked Realtek PCIe FE Family Controller and it had the Power Management tab and that's where I  un-checked the "Allow this device to wake the computer" and that worked!!!

    I'm so relieve I can put my computer into sleep mode and it stays asleep until I wake it up now.

    Thanks a million!!!

    Monday, April 23, 2012 3:28 PM
  • I had a battery back up on my computer, that ran not only all power though a surge protector but also the cable modem and Ethernet.

    When I shut down my computer it turns off anything else attached to it (ie the router etc. etc.) and in turn that must have sent a message to the computer that the network was lost or something, and it'd boot right back up lol.

    It was annoying to be honest and for some reason it only started recently, but your suggestion fixed it.

    So thank you for the good suggestion!


    n/a

    Friday, September 21, 2012 5:37 PM
  • after putting in sleep mode move your mouse and keyboard carefully to another room, the wireless is sensitive, I tried taking batteries out, but just moving them worked
    Tuesday, January 08, 2013 2:09 PM
  • i really not recommend to us "sleep mode" or any windows Os.

    i use windows vista!!. everytime that i put it to sleep , it's fuckd'up my computer. and yes i cancel it from let the HardDrive sleep.

    but still i wouldn't recommend to let it sleep it's better then shutdown it completely.!

    TODAY after the updates of fab 2013 of microsoft , i trid to set it 2 hours sleep and he seems that he never did. 

    if it was sleep i should know. but i dont trust microsoft settings in Vista . so or dont let it shoutdown it all or fully shutdown. (Ps i use 100% power us in my pc)


    Friday, February 15, 2013 3:48 PM
  • This is the likely culprit - be aware that if your computer is working ok and then starts not behaving itself it may be set correctly and an update might change it.  Don't ask me how but my machine was behaving itself, waking only when it received a magic packet from the network and after installing some updates it went into this "fault" state, waking almost immediately after going to sleep.  I tried changing settings and now have adjusted the network power management to allow the network adapter to wake the computer BUT making sure the check box "only allow a magic packet to wake the computer" is checked.

    Thanks to the brains trust on here for the great tips!

    Cheers

    Oz.

    Friday, August 09, 2013 6:55 AM
  • Thanks! You're the first person to propose a solution that works.
    Saturday, November 09, 2013 10:54 PM
  • This solution worked for me.  Yes!!

    Kudos to you.  I've had this problem for about a year and it has been wearing down my computer's performance.

    I am throwing multi-colored confetti upon you.  Champaigne all around.

    Yaay!


    Sunday, March 02, 2014 4:30 PM
  • Could be automatic update. Default setting is 3 AM (why I don't know) and I'd change the day to once a week, whatever day you choose, at the time you are least likely to use the computer, like dinner time, lunch hour, whatever. If it is the defragmenter, go to IOBIT.com and get smart defrag (free) which will work in the background whenever you are not actively using the machine, or when you choose to have it defragment. Jazzy little program. It will replace the windows defragmenting program if you choose at install.
    Monday, June 02, 2014 6:18 PM