none
BSOD in Windows 7 32bit Memory Dump

    Question

  • I have been having BSOD reboots every few hours today and am not sure why exactly.  I have been having problems in the recent past with an Nvidia 8800gs where the display driver would restart whenever I played flash on the internet.  I determined that it was a driver problem with that particular video card, so I have been running a 6800GS in its place for about a week.  The video driver restart problems are gone, but now my machine is rebooting with a BSOD error. 

    Event Viewer records a BugCheck 1001 Error: The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000000a (0x00000000, 0x00000002, 0x00000001, 0x82ad4634). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 012810-22885-01.

    Any help on this would be appreciated!

    Below is the minidump analysis:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck A, {0, 2, 1, 82ad4634}

    Probably caused by : ntkrpamp.exe ( nt!KeReleaseSemaphore+44 )

    Followup: MachineOwner
    ---------

    0: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    IRQL_NOT_LESS_OR_EQUAL (a)
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high.  This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arguments:
    Arg1: 00000000, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
    Arg4: 82ad4634, address which referenced memory

    Debugging Details:
    ------------------


    WRITE_ADDRESS: GetPointerFromAddress: unable to read from 82bb2718
    Unable to read MiSystemVaType memory at 82b92160
     00000000 

    CURRENT_IRQL:  2

    FAULTING_IP: 
    nt!KeReleaseSemaphore+44
    82ad4634 f00fba2807      lock bts dword ptr [eax],7

    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

    BUGCHECK_STR:  0xA

    PROCESS_NAME:  svchost.exe

    TRAP_FRAME:  9fd20ab4 -- (.trap 0xffffffff9fd20ab4)
    ErrCode = 00000002
    eax=00000000 ebx=82b73d20 ecx=88223802 edx=00000000 esi=00000000 edi=00000000
    eip=82ad4634 esp=9fd20b28 ebp=9fd20b38 iopl=0         nv up ei pl zr na pe nc
    cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
    nt!KeReleaseSemaphore+0x44:
    82ad4634 f00fba2807      lock bts dword ptr [eax],7   ds:0023:00000000=????????
    Resetting default scope

    LAST_CONTROL_TRANSFER:  from 82ad4634 to 82a907eb

    STACK_TEXT:  
    9fd20ab4 82ad4634 badb0d00 00000000 00000001 nt!KiTrap0E+0x2cf
    9fd20b38 82ab4909 00000000 00000000 00001000 nt!KeReleaseSemaphore+0x44
    9fd20b84 82ab4792 857827c0 8ba28711 85a9ab28 nt!ExpReleaseResourceForThreadLite+0x171
    9fd20b8c 8ba28711 85a9ab28 85a9aaf8 9fd20bb4 nt!ExReleaseResourceLite+0xf
    9fd20b9c 8ba28254 85a9aaf8 a5d11208 85a9aba0 Ntfs!NtfsReleaseFcb+0x6d
    9fd20bb4 8ba27e60 85a9aaf8 85a9aba0 85a9aaf8 Ntfs!NtfsReleaseAllResources+0x67
    9fd20bcc 8ba289ed 85a9aaf8 00000001 00000000 Ntfs!NtfsCleanupIrpContext+0x23
    9fd20bec 8bab4b38 85a9aaf8 00000000 00000000 Ntfs!NtfsExtendedCompleteRequestInternal+0x79
    9fd20c10 8baafaf3 85a9aaf8 a9b70444 8575f008 Ntfs!NtfsCompleteCreateRequest+0x8f
    9fd20cdc 8ba35210 85a9aaf8 8575f008 a5d11380 Ntfs!NtfsCommonCreate+0x14f0
    9fd20d1c 82aba10e a9b703dc 00000000 ffffffff Ntfs!NtfsCommonCreateCallout+0x20
    9fd20d1c 82aba205 a9b703dc 00000000 ffffffff nt!KiSwapKernelStackAndExit+0x15a
    a9b70340 00000000 00000000 00000000 00000000 nt!KiSwitchKernelStackAndCallout+0x31


    STACK_COMMAND:  kb

    FOLLOWUP_IP: 
    nt!KeReleaseSemaphore+44
    82ad4634 f00fba2807      lock bts dword ptr [eax],7

    SYMBOL_STACK_INDEX:  1

    SYMBOL_NAME:  nt!KeReleaseSemaphore+44

    FOLLOWUP_NAME:  MachineOwner

    MODULE_NAME: nt

    IMAGE_NAME:  ntkrpamp.exe

    DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bc007

    FAILURE_BUCKET_ID:  0xA_nt!KeReleaseSemaphore+44

    BUCKET_ID:  0xA_nt!KeReleaseSemaphore+44

    Followup: MachineOwner
    ---------

    Thursday, January 28, 2010 8:25 PM

Answers

  • I am gald to hear the issue disappeared after you remove the 533 RAM. As your memory is running two different sppeds, it's very normal the BSOD issue would occur. Generally, the BIOS would reduce the RAM frequency from 800 to 533 automatically, in your case, the current BIOS must fail to adjust it.

    I have a workaround you can try, please update the BIOS to the latest version first, reduce the RAM frequency to 533 in the BIOS, then plug the 533 RAM again. That should be able to fix your issue. If the BSOD issue still occur, it's better to using the 800 RAM only.

    Good luck!


    John
    Monday, February 01, 2010 2:17 AM

All replies

  • Have you try running memtest or memory diagnostic tool in windows?

    Friday, January 29, 2010 1:11 AM
    Answerer
  • Can you upload your Minidump log to your public folder in the SkyDrive? Please don't contain any personal information in it. And let us know your computer's model.

    At the same time, you can try the following suggestions to troubleshoot your issue.

    1. Run the Memory Diagnostics Tool to check memory. To run it, please open the Start menu,
    type mdsched in the Start search and press Enter, Select the Restart now and check for problems option.

    2. Update your BIOS.
    3. Test your machine in Clean boot mode. you can refer to KB929135.

    I hope this can help you.


    John
    Friday, January 29, 2010 5:57 AM
  • Thanks for both your replies.  Since I have posted this forum, I came to the conclusion that it might be a memory issue, so I investigated my memory setup and came to the realization that I was mistakenly running two different speeds of RAM (533 and 800).  I have since removed the 533 memory and and solely running the 800 and so far I have had no blue screens.  If I continue to have success with this environment, I will conclude that it was a hardware conflict between two different speeds of RAM.  Noting that both suggestions you have given me point to memory diagnostics also helps affirm this diagnosis.  It is odd, however, that I never experienced these problems with Windows XP or Vista.  It only became a problem once I implemented Windows 7.

    Thanks!
    Friday, January 29, 2010 6:08 AM
  • I am gald to hear the issue disappeared after you remove the 533 RAM. As your memory is running two different sppeds, it's very normal the BSOD issue would occur. Generally, the BIOS would reduce the RAM frequency from 800 to 533 automatically, in your case, the current BIOS must fail to adjust it.

    I have a workaround you can try, please update the BIOS to the latest version first, reduce the RAM frequency to 533 in the BIOS, then plug the 533 RAM again. That should be able to fix your issue. If the BSOD issue still occur, it's better to using the 800 RAM only.

    Good luck!


    John
    Monday, February 01, 2010 2:17 AM