none
BUG - Auto-Hide Taskbar Won't Un-hide

    Question

  • Using Windows 7 64-bit on a multiple monitor extended desktop:

    I've set my taskbar to auto-hide.

    I'm not sure which application is causing this to happen, but I've managed to get Windows to not display the task bar when I mouse over the bottom of the screen when the currently focused application is maximized. If I normalize the application, I can get the task bar to un-hide.  I had four apps open this morning when it happened again - Firefox, Thunderbird, Windows Explorer, and Visual Studio 2008.  I suspect that Visual Studio is somehow the culprit, but it's kind of difficult to quantify.

    Once the task bar decides that it doesn't have to un-hide itself, only a reboot fixes the issue.

    I saw this behavior in in the release candidate as well.

    Friday, August 14, 2009 11:44 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    To clarify if the issue is caused by any specific application, I would like to suggest that you run these applications using a 50/50 approach to quickly narrow down the exact cause. There may be related to signal application or conflicts among applications. To confirm this, please take the following steps:

     

    1. Run Firefox, Thunderbird, Windows Explorer and Visual Studio 2008 separately to see if the issue occurs.

     

    If the issue doesn't occur, please continue the step.

     

    2. Open two of these applications at the same time per test to see which combination causes this issue.

     

    If the issue doesn't occur neither, please continue the step.

     

    3. Run three of these applications at the same time per test to see which combination causes this issue.

     

    Meanwhile, I noticed that you use a multiple monitor, this can be a cause too. I'd like to suggest you disconnecting the external monitor and running the above four applications at the same time to see if the issue occurs.

    Best Regards.
    Dale Qiao

    Tuesday, August 18, 2009 6:47 AM
  • I don't see where the above is an answer. I have this same problem with Windows 7 RTM. I also run dual monitors and have the additional problem that many times after waking up, the right monitor no longer has a video signal. Restarting Explorer or rebooting are the only ways I have found to fix the taskbar problem. The taskbar will sit on top of any maximized window or any window, such as its own dialog, that is in its expanded space as they think they have the full screen and the taskbar has not properly communicated to them it think it owns that space. This is a bug!
    Sunday, September 20, 2009 4:17 PM
  • OK restarting FireFox also resolved the problem. So Explorer or FireFox? Who is at fault? How best troubleshoot this? Anyone else having issues?
    Tuesday, September 22, 2009 4:30 AM
  • This is no help. But this bug has been plaguing windows since XP.
    It might have been there for a longer time, but I started using the auto-hide feature at the time of XP.

    A fix would be lovely!
    Thursday, September 24, 2009 4:15 PM
  • Is your taskbar full and does over to the next another taskbar?  eg. have the arrows near the system tray icons.

    Try hovering near the Window "Orb" when trying to unhind the taskbar.  I noticed this as I use a netbook with the taskbar on the left and wont unhind when I have more programs that fit on the taskbar.  When I hover near the "Orb" it unhinds.

    I think this is a bug.
    Wednesday, September 30, 2009 12:33 AM

  • I have found how to reproduce this every time:

    1: Set your taskbar to autohide
    2: Unlock the taskbar (if locked)
    3: Drag the taskbar to the left side of the screen
    4: Open enough windows to overflow the taskbar (so it adds a previous/next arrow to display overflow open window icons)

    The taskbar will now only display the window previews when you mouse to un-hide the taskbar (assuming previews are enabled), *unless* you hover near the 'Start' icon. This is certainly a bug, as the preview screenshots appear, but not the taskbar itself.

    Monday, October 05, 2009 6:08 PM
  • Yes this is a very annoying bug.

    What is also poor is that when hidden the taskbar shows 1px, I guess so it can capture mouse over, however the pixels are coloured differently when an applications is active so you get this horrible 1px bar of differing colours accross the screen.

    Very poor indeed, I cannot believe both of these huge bugs got through QA.


    Tom.
    • Edited by tomdeloford Thursday, October 08, 2009 1:35 PM spelling
    Thursday, October 08, 2009 11:47 AM
  • Actually, I read this wrong! My taskbar won't HIDE! It's there all the time when it sticks! Like Now...can't get it to autohide mo matter what. Explorer in WIn7 is the buggiest I've seen in years! Even worse it often quits updating when you add, rename or delete a file - you have to hit F5 refresh to see the changes. But gee, the aero glass at least looks pretty even if it does make you click on the wrong window sometimes!
    • Edited by CodeSlinger Thursday, April 22, 2010 3:01 PM spelling
    Saturday, October 17, 2009 4:07 PM
  • while not 100% reproducible, the bug can occur with less effort than some of the other descriptions would imply.  for example, you do not need to drag the taskbar to the side of the screen for this to happen.  my taskbar is set to autohide and has never been moved from the default location (the bottom of the screen), and it still happens regularly.  also, i do not have firefox installed, so it's not firefox-specific.  the only application that consistently has this problem for me is an app i've written in c# with visual studio.  when it's maximized, i can never access the taskbar.  the problem happens with other applications as well (chrome, for one), but it doesn't seem to be consistent.  one potential clue is that whenever it breaks, you do not see the row of pixels associated with the taskbar on the bottom of the screen.  when the taskbar is correctly responding, you do see that single row of pixels at the bottom of the screen.  anyhow, i would be interested in hearing when this issue is resolved, as it's been annoying me since xp.

    EDIT:  i'm also running windows 7 on a laptop... so i'm only using a single monitor :)  the other descriptions mention dual monitors, but that is not necessary to recreate this bug.
    Tuesday, December 22, 2009 4:28 AM
  • I too am experiencing the taskbar-will-not-unhide-when-the-mouse-is-over-the-tray bug on W7 64-bit. My taskbar is nowhere near full and the reproducibility of this behavior does not depend on how many applications are running or the applications themselves. The taskbar is in the default location.
    Monday, January 11, 2010 5:23 PM
  • I have found 3 workarounds.

    1. Kill and restart Explorer via Task Manager.
    2. Kill and restart FireFox.
    3. Click on each and every window in the Taskbar, restoring it them minimizing it.

    Not sure who's fault this is but it sure is irritating...

    - Dave
    • Proposed as answer by Geezer_64 Monday, March 22, 2010 5:46 PM
    Monday, January 11, 2010 6:14 PM
  • I Had Windows Live Messanger chat actively running and I used the taskmanager in Windows 7 to kill it. The taskbar is now unfrozen. Just me or something else? Don't know but hey it worked.

    Alex

     

    Monday, March 22, 2010 5:50 PM
  • Sometimes, you don't have to kill anything. Just minimize everything until you can see it again.
    Tuesday, March 23, 2010 9:17 AM
  • I've never run any component of Windows Live. It still happens. 
    Tuesday, March 23, 2010 9:18 AM
  • I have had this same problem ever since I got my new notebook computer with Vista.  Taskbar won't unhide when Internet Explorer is in full screen mode.  A work around is to hit F11 to get out of full screen mode, then press the "Windows" key to bring up the taskbar.  You must then use the cursor to hide / unhide the taskbar two times (sometimes one time works).  When you press F11 again to return to full screen, the taskbar will hide /unhide like it is supposed to, but only until you open or close a new tab or a new window!  So what's the use?!

    Pressing the "Windows" key will also bring up the taskbar, so I have resigned myself to pressing this key whenever I need the taskbar.  What is extremely annoying to me is this problem did not exist in Windows 98.  (I know....I don't upgrade until I have to!)  Seems every time I do, there are unresolved issues.  I wish Microsoft would be as concerned about fixing problems with existing operating systems as they are about introducing new operating systems that have bugs that never get resolved, and are left unresolved until they no longer support that operating system.

    I guess making money selling new operating systems is more important than taking care of customers!!

     

    Wednesday, April 21, 2010 5:10 AM
  • That's pretty cheeky to mark your own response as the answer, when in point of fact, it WASN'T the answer.

    There appears to be no specific application that causess this. It happens with all too much frequency. So much so in fact that you should be able to duplicate the problem simply by using Wndows 7.

    It happens when you maximize a window. It's happened with VS2008, FireFox, IE8, Opera, Word, Excel, SqlServer 2005 Manager Express, my own applications, Windows Control Panel,  Windows Explorer, the Command prompt, MediaPortal, etc.  Do I really need to go on?  There doesn't appear to be a pattern (no specific appication can be blamed).

    It appears as if Windows simply loses the ability let me call up the task bar. The thin border that is normally on the screen when the taskbar is hidden is *gone*.  It's almost as if windows thinks the app has gone into full-screen mode (as oppossed to be maximized), yet the buttons that allow you to maximize/normalize/minimize are still showing in the titlebar.  When I originally reported this, I was running the same versions of the same software as I was with XP (also with a hidden task bar).

    As far as concurrency is concerned, it doesn't seem to matter if there's only one app running, or two, or three, or whatever, nor does it matter in what order I open applications.

    When is Microsoft going to stop dragging its feet and admit there's a problem with Windows itself? Look at all the people in this thread reporting the same issue.

    • Proposed as answer by EvanManrow Monday, July 01, 2013 1:26 PM
    Thursday, April 22, 2010 12:17 PM
  • I'm having the exact same problem, and it's a pain in the nuts (yep, you guessed it, I'm Australian). Really annoying trying to use Google Chrome, where all downloads appear at the bottom on the page, and it makes Facebook chat impossible. Any solution would be great, outside having to restart explorer every time it does this :/
    Tuesday, June 22, 2010 8:39 AM
  • I had the failure to unhide the taskbar problem.  I could unhide it by hitting the Windows key.  I cured it permanently by disabling Aero.  (unchecked "Enable desktop composition").

    As a bonus, I find non-Aero easier on the eyes.

     

    I still have the failure to unhide problem when the taskbar gets full and I'm given an alternate taskbar.  In this case I can unhide with the mouse if I go to either end of the taskbar.  (my taskbar is at the left side of the screen)

    Wednesday, June 23, 2010 3:59 AM
  • I did not wanted to disable aero, and killing the exporer isn't a good way too.

    Which seems to cure it temporarily is turn off auto-hide, restore windows, maximize them again and then turn back auto-hide. And this is a pain in the ____, because it is a very frequent bug.


    Sorry if my English is bad. ^_^
    Wednesday, July 21, 2010 6:08 PM
  • There are three issues that are reported in this thread:

    1. When the auto-hide options is selected, the taskbar is docked to the left, it is full with atleast 2 rows and the full side has the focus: In this case; putting the cursor on the icon area of the taskbar, the taskbar doesn't unhide.

    This does look like an issue. The workaround is to take the cursor on the start menu button or the notification area. Or press the Window Key. For more information check this:

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/a1cf1538-f211-4e6c-8fa7-ea6f7c981812

    2. When some applications are in full screen mode and the tasbar is auto-hidden, the taskbar can not be unhidden and either the application or the explorer has to be restarted. This is not a consistent repro and we have tried different scenarios to repro this unsuccesfully. If some one has more information / steps for this, it will be great.

    3. Issues with multi monitor: Windows 7 SP1 has taken some fixes for multi monitor and taskbar interaction scenario. Installing it (once it's available) should solve the problem.

    Thanks.

    Monday, November 08, 2010 7:03 PM
  • To repro #2 - Uisng Win7 x64, open a bunch of FireFox browser windows and then restart the computer. After restarting, FF will ask to restore sessions and say yes.

    The taskbar is now stuck visible and blocks the lower portion of full screen apps. You can either restart Explorer or minimize every FF window and maximize every FF window. Or maybe do the latter twice. No doubt a FF problem but MSFT should not let ill behaved software get away with bad behaviour. This is really irritating. And the only reason I use FF is because of AdBlock Plus software since IE does not support a reasonable addin architecture so there are few decent addins like Ad Block Plus.

    Sunday, January 16, 2011 5:34 PM
  • I am not using firefox, nor visual studio.

    I am using objectdock, on the bottom. My taskbar is on top.

    I am using taskbar autohide (yes we all must buy 16:9 displays only :().

    After any window maximized I am sometimes, 3-4times a week, unable to reach hided taskbar, on XP (some years ago - this times I had 4:3 display and no objectdock), on vistas, and now on W7-64bit, this occurs me for years. What helps to me? check and uncheck the autohide option.

    And yes, this very old bug goes through generations of windows... maybe none use this options for years in Microsoft corporation :).


     

     

     

     

    Friday, February 04, 2011 10:11 AM
  • Something I have recently four is this weird combination.

    I am running Win 7 64-bit and Internet Explorer 9 RC.  I also have my taskbar set to autohide.  Something peculiar started happening, whether I had any applications open or not.  If the taskbar was hidden and I cursored down over the taskbar, it would not appear.  Then I accidentally noticed that if my cursor was in just the right position, I would get the double-headed arrow like for re-sizing a window.  If I then left clicked the taskbar would reappear.  With the 64-bit machine when I downloaded the IE9 I received both a 32-bit and 64-bit version.  The 32 bit version is set as the default.


    Mark S. Gilliland
    • Proposed as answer by Marcus1953 Thursday, March 03, 2011 10:13 PM
    Monday, February 21, 2011 10:07 PM
  • Thanks for all your inputs. Here is what does seem to be a bug and is being looked into:

    1. Auto hide the taskbar.

    2. Launch IE or FF and put it in full screen mode (press F11).

    3. The taskbar cannot be unhidden by taking the mouse. This is by design. Because imagine someone had task bar on the top, and if moving the mouse on the top of IE, the taskbar was going to unhide, it will obscure the menu buttons on the top of IE.

    4. Now, change the mode of IE back from full screen (by pressing F11 again).

    5. The taskbar should now be unhidden by mouse, but it isn't. And that is an issue.

    But what doesn't seem to be an issue is that the only work around after step 5 is to reboot the system or restart explorer or restart firefox/ IE. There are many work arounds for this scenario:

    1. Just press the Windows button on your PC. It will bring back the taskbar. Or press Win + D and it will minimize all windows, and get access back to the taskbar.

    2. If your keyboard doesn't have the Winkey, then just minimize the IE / FF window. It will again bring back the taskbar.

    3. Alt-Tab and select any other window.

     

    Wednesday, March 02, 2011 10:45 PM
  • Under Taskbar properties, make sure under the Taskbar is set to be "on top of other windows".
    Monday, March 07, 2011 4:13 PM
  • I have this same issue, taskbar won't hide.

    After reading through these posting, I killed FF (with no other applications running) but no change.

    I clicked on the "show hidden icons" arrow on the right side of the taskbar and viewed the notes on each item in the dropdown looking for some backround app that may be an issue.

    When I left this area, the taskbar hid itself. I restarted FF and the taskbar still behaves ok.

     

    Wednesday, March 09, 2011 4:31 PM
  • On my system I discovered the following.

    When my screen saver comes on (I use YoWindow) and I restore the desktop, then 10 seconds later the taskbar will show itself and won't hide. This holds over a reboot.

    If I click on the "show hidden icons" arrow at the right side of the taskbar and then click on the desktop (to clear the drop down), the taskbar hides itself and now operates normally. (that is until the screen saver comes up again).

     

    Hope this helps.

     

     

    Wednesday, March 09, 2011 4:56 PM
  • My taksbar won't auto hide anymore either. But, i followed the PP steps and it works now. I think Billc is on to something (and thanks for posting because I can have my taskbar hidden again on my laptop).

    Tuesday, March 29, 2011 4:57 PM
  • That seems to be a way to fix it, I can kill process explorer.exe Restart it with task manager Then it will auto hide for an hour or two. Got stuck again, and its a bother to make a note of where all the windows explorer windows were pointed. Tried the f11 maximize app then un-maximize No autohide. Then click on an explorer window then autohide starts working again. It gets set to an unhidden state, which can be reset by killing explorer or doing the maximize window f11. Sorry maximizing by task bar doesnt seem to help. By the way I went to alert up arrow (this is windows 7 32 home premium) and went through alerts I don't care about, then closed em again. That might have some effect too.
    Wednesday, March 30, 2011 7:25 PM
  • This Windows 7 task bar autohide glitch can be easily dealt with
    I use Firefox and it is often the culprit
    Say you have 6 Firefox windows open>>>
    Put your mouse arrow over the task bar's preview window for Firefox window #1 and left click
    Do same to windows 2-6 until you find the culprit
    Often it is the Firefox downloads window
    Do this right and auto-hide will kick in

    Sometimes it is not Firefox but some other preview window
    It could be a Frontpage preview window or a folder preview window
    Go left click all your Internet Explorer preview windows until you find the culprit

    Today I had Windows Task Manager" open and it was to blame. So I left clicked my mouse over its little preview window and taskbar auto-hide kicked in

    I am a heavy Firefox user.
    So I usually re-boot it once a day
    On reboot I often have to left click the preview windows for task bar auto-hide to restore

    Wednesday, May 04, 2011 1:02 PM
  • This problem bugged me for the longest time, until I discovered that the problem disappears when you unlock the taskbar. Now it unhides even when apps are maximized, where it wouldn't before. The problem used to occur intermittently with maximized browsers and other apps, and seemingly all the time when using Adobe software. Now with the taskbar unlocked, the taskbar appears all the time. I have come to terms with the fact that I don't have a locked taskbar any more, indeed it hasn't caused me any problems so far.
    Friday, June 03, 2011 3:46 AM
  • I don't see where the above is an answer. I have this same problem with Windows 7 RTM. I also run dual monitors and have the additional problem that many times after waking up, the right monitor no longer has a video signal. Restarting Explorer or rebooting are the only ways I have found to fix the taskbar problem. The taskbar will sit on top of any maximized window or any window, such as its own dialog, that is in its expanded space as they think they have the full screen and the taskbar has not properly communicated to them it think it owns that space. This is a bug!

    I agree. It had to do with dual screens somehow here also: http://annoyances-resolved.blogspot.com/2011/04/vista-windows-7-taskbar-wont-hide.html 

    for Win 7 see also http://annoyances-resolved.blogspot.com/2012/03/taskbar-wont-auto-hide-on-windows-7.html

    • Proposed as answer by BuyX Saturday, March 03, 2012 1:52 PM
    Saturday, March 03, 2012 1:52 PM
  • No, the above links are for taskbars that won't hide.  My problem is it won't unhide.  At least it won't unhide with the mouse.  Hitting the Windows key will unhide it though.

    My problem happens with one monitor.  It also happens with the taskbar unlocked.  My permanent cure was to get rid of aero which I didn't like anyway.

    Sunday, March 04, 2012 8:31 PM
  • This problem bugged me for the longest time, until I discovered that the problem disappears when you unlock the taskbar. Now it unhides even when apps are maximized, where it wouldn't before. 

    I tried this, but it didn't work for me. Locked or unlocked, if an application decides to cover up that 1 pixel minimized taskbar at the bottom of the screen, I can't trigger it to reopen with my mouse.

    Firefox, Chrome, Photoshop, Eclipse does it... basically every app I use. The only workaround is to make sure all apps start un-maximized, then maximize them, then un-maximize them again before you close them. It's not worth the effort. Too bad because on a 1366x768 laptop, that extra space can be quite precious.

    The auto-hide feature has been broken like this since Windows XP. If they're not going to fix it, Microsoft might as well just take it out in Windows 8.

    Friday, April 06, 2012 4:46 PM
  • My taskbar worked fine XP.  It will unhide in Win7 if I disable aero, which I do.  Please don't remove auto-hide. 
     If you want to get rid of anything, get rid of aero.  Aero reminds me of a bad paint job where the surface beneath bleeds through.
    • Edited by FastSteve Saturday, April 07, 2012 12:19 AM
    Saturday, April 07, 2012 12:17 AM
  • I tried disabling Aero and everything else on this list, but that didn't do it. The problem seems to be that some programs leave a 1 pixel gap at the bottom so you can mouse over the hidden taskbar behind it, and some don't. It only seems to happen if the program (Chrome, Photoshop to name a few) starts maximized. So if you are careful to un-maximize applications before you exit them, you won't have the problem.

    But after trying for six months I can still never remember to do that. My screen is 1366x768 which is incredibly short, and the real estate that task bar takes up is valuable. I've tried moving it to the left and switching to large icons instead of text, but then I can't tell folders apart without their names showing. I used hidden taskbars since windows 98 but this bug (which has been around since Vista) makes them unusable.

    I'm not sure why Microsoft can't just fix it by keeping that 1 pixel hotspot OVER all programs instead of under them.

    Saturday, June 02, 2012 5:10 AM
  • Answer - As mentioned in another post I found that an application needed attention in my Taskbars Hidden Icons. When I closed the application it brought my Task bar back to normal. I am sure I will have to take action on it in the next reboot at least now I know what is causing this annoying problem.

    I knew this had to be the problem as it started after a new program and driver was installed.

    I hope this helps others.


    Respects, Magoo


    Friday, June 14, 2013 2:03 PM
  • That's pretty cheeky to mark your own response as the answer, when in point of fact, it WASN'T the answer.

    There appears to be no specific application that causess this. It happens with all too much frequency. So much so in fact that you should be able to duplicate the problem simply by using Wndows 7.

    ...

    When is Microsoft going to stop dragging its feet and admit there's a problem with Windows itself? Look at all the people in this thread reporting the same issue.

    What he said. I have never run Firefox on my W8 machine, I have never moved the taskbar to the side or top, and I have never run dual monitors. The taskbar gets "stuck" hidden multiple times a day, and it is infuriating. As others have discovered, the issue revolves around any application having an alert active.

    It is a bug. Fix it.

    "Disable the Action Center icon" is not a fix. It is a workaround that compromises one key security feature for one essential usability feature. There is literally no reason these features should be incompatible.

    Fix.

    It.


    • Edited by EvanManrow Monday, July 01, 2013 1:30 PM Word choice.
    Monday, July 01, 2013 1:29 PM
  • That's pretty cheeky to mark your own response as the answer, when in point of fact, it WASN'T the answer.

    There appears to be no specific application that causess this. It happens with all too much frequency. So much so in fact that you should be able to duplicate the problem simply by using Wndows 7.

    ...

    When is Microsoft going to stop dragging its feet and admit there's a problem with Windows itself? Look at all the people in this thread reporting the same issue.

    What he said. I have never run Firefox on my W8 machine, I have never moved the taskbar to the side or top, and I have never run dual monitors. The taskbar gets "stuck" hidden multiple times a day, and it is infuriating. As others have discovered, the issue revolves around any application having an alert active.

    It is a bug. Fix it.

    "Disable the Action Center icon" is not a fix. It is a workaround that compromises one key security feature for one essential usability feature. There is literally no reason these features should be incompatible.

    Fix.

    It.



    I get this all the time with Windows 8 64-Bit. The hidden messages issue should not stop the taskbar un-hiding! After reading this thread I now know I can use the windows key to 'fix' the issue (so I have to see Metro which is a bit annoying).
    Thursday, November 07, 2013 9:54 AM