none
"This network location can't be included because it is not indexed." - error when connecting to indexed location on Windows Server 2003

    Question

  • I am trying to link Windows 7 x86 RTM libraries to remote shares on a server and it's not working.

    The remote computer is running Windows Server 2003 x64 with Windows Desktop Search 4.0 installed, and the shares I want to use are indexed.

    When I try to include certain folders, I get the error : "This network location can't be included because it is not indexed"

    The server is setup like this:

    1. Windows Search Includes location "c:\data" and all subdirectories
    2. I have a share at c:\data called "\\server\data"
    3. I have a share on a subdirectory at c:\data\documents\pete called "\\server\pete".  These directories are indexed by the location set in step 1
    4. Connecting the client library at "\\server\data" works properly
    5. Connecting the client library to "\\server\pete" gives the error message "This network location can't be included because it is not indexed."

    I have tried to setup a new index location at c:\data\documents\pete but I get the same error.

    What gives?

    Pete
    Thursday, October 01, 2009 11:29 PM

Answers

  • I solved the problem.  There were issues with some of the files/folders on the server having the read-only flag set and they were not being indexed.  I issued an "attrib -r *.* /s" at the root directory and the indexing service kicked in and indexed everything.

    A helpful hint: if you need to see if a server folder is indexed in Windows 7, just navigate to it in the explorer.  A button titled "Include in library" will appear next to the Organize button if it is indexed.
    Pete
    • Marked as answer by Pete Claar Monday, October 05, 2009 5:46 PM
    Monday, October 05, 2009 5:45 PM

All replies

  • Bump.  Can anyone help?  Thanks in advance...
    Pete
    • Proposed as answer by big12rich Wednesday, May 08, 2013 3:08 PM
    • Unproposed as answer by big12rich Wednesday, May 08, 2013 3:08 PM
    Friday, October 02, 2009 6:40 PM
  • I solved the problem.  There were issues with some of the files/folders on the server having the read-only flag set and they were not being indexed.  I issued an "attrib -r *.* /s" at the root directory and the indexing service kicked in and indexed everything.

    A helpful hint: if you need to see if a server folder is indexed in Windows 7, just navigate to it in the explorer.  A button titled "Include in library" will appear next to the Organize button if it is indexed.
    Pete
    • Marked as answer by Pete Claar Monday, October 05, 2009 5:46 PM
    Monday, October 05, 2009 5:45 PM