none
Failed to Connect "Group Policy Client Service" Windows 7 x64

    Question

  • This error pops up everytime boot / start-up. I've tried everything, for the last month.  including http://support.microsoft.com/kb/2421599 In the "Resolution Section" did step by step, But did not work for me...

    Also http://blogs.technet.com/b/mempson/archive/2010/01/10/userenvlog-for-windows-vista-2008-win7.aspx  Didn't work either.  :(

    Is this a Winlogin problem? Or does have to do with other computers in my homegroup?

    But in Safe Mode & Safe Mode with Networking, this issue does Not appear / pop-up at start up. "Group Policy Client Service"

    ""HP Premium Remote Services"" tells me that in order to fix, I have to Re-Install Windows. And have been in contact today with Hp Premium Remote Services for over 7 hours with NO Resolution!!

    Hate to make a Recovery Partition on a New PC, in order to Re-Install Windows...

    This is a Brand New HP Pavilion HPE H8-1234 AMD Processor that I installed on 7/23/2012. Running windows 7 64-bit home premium, OS: Internet Explorer 9.

    Have a copy of Windows 7 Ultimate using Anytime Upgrade, My question is would that rectify the "Group Policy Client Service" error?

    Always run MalwareBytes Anti-Malware and Hitman Pro, in addition with Norton, on a regular basis. So that I know my system is clean...

    Any MS Engineers or Tech's have any ideas, suggestions OR help, How to Fix this issue,With-Out having to use: System Recovery/Restore. To factory condition...

    Would be Very Greatly Appreciated! HELP Me Pleeeze !!!!

    ***Because this issue Baogles my Mind! After all I'am only dealing with half a Brain, LOL- Due to Brain Tumor Surgery...
    • Edited by Vantaman Tuesday, November 06, 2012 11:24 AM
    Tuesday, November 06, 2012 11:11 AM

Answers

All replies

  • Hi,<o:p></o:p>

    <o:p> </o:p>


    You may refer to this.<o:p></o:p>

    http://www.pljdesigns.co.uk/blog/2010/09/13/how-to-fix-the-could-not-connect-to-group-policy-client-service-error/<o:p></o:p>


    Kim Zhou

    TechNet Community Support

    Wednesday, November 07, 2012 6:23 PM
  • I FOUND SOLUTION TO THIS PROBLEM!

    I had this issue on my laptop since November, and it really bugged me.  I sifted through the event log and found the pattern of events that preceded the issue, and, probably, caused it.

    In short, the pattern is as follows: Windows updates run automatically as scheduled, and when reboot is initiated after the updates are finished, the computer crashes (probably during reboot sequence).  When it boots up, it reports that the last shutdown was unexpected, and the issue begins to occur.

    I spent 2 days trying to dig out a solution from the Internet, to no avail, until I came across this page.  It doesn't say anything about this particular problem, but it gives more information about SVCHOST process that starts many services, including Group Policy Client.  It looks like during reboot a vital registry settings were lost during crash and Group Policy Client "doesn't know" how to start.  Let me explain:

    There are two places to look in the registry:

    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services this path should contain gpsvc key (a folder), which is responsible for service parameters and configuration.  I found that the key was intact, so, you do not touch anything here - just check that the key exists.
    2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SVCHOST This is the most important path you should look into, as it must contain the keys and values referred in the key #1.  Below are descriptions what must be present there.
    • There must be Multi-String value called GPSvcGroup. My laptop was missing it.  So, you should create multi-string value named GPSvcGroup and assign it value GPSvc.
    • Next, you must create a key (a folder) and name it GPSvcGroup - this key normally should be there, but, again, it was missin on my laptop.
    • Then open newly-created GPSvcGroup folder and create 2 DWORD values:
    1. First called AuthenticationCapabilities and you must give it a value of 0x00003020 (or 12320 in decimal)
    2. Second is called CoInitializeSecurityParam and it must have value of 1.

    Once you complete all steps above, reboot the computer and the problem will be fixed.

    I am so relieved I was able to fix it, and hope this will help others with the similar issue.

    Here is the link to the video walkthrough if you have any troubles understanding what has to be done: http://youtu.be/4m5KEmckWK4

    • Proposed as answer by SQL-ER Saturday, February 02, 2013 5:23 AM
    • Edited by SQL-ER Sunday, February 17, 2013 8:26 AM
    Saturday, February 02, 2013 5:23 AM
  • @SQL-ER - you Sir are an absolute legend!

    None of the other "fixes" I found dating back to the days of Windows Vista worked for me. I've had this issue on a new build PC with a fresh install of a retail copy of Windows 7 x64.  I do recall it crashing once when I was installing drivers and windows updates simultaneously to set up the machine. 

    System now works perfectly with no error message every time I boot up.  Thank you for posting this.

    Sunday, February 10, 2013 2:25 PM
  • @ SQL-ER Thanks much bro ! I have been trying to resolve this for months .. finally it got fixed

    Really a Big Thanks to you !

    Monday, February 11, 2013 10:35 AM
  • Glad it helped. I am damn proud I was able to nail it down ;-)

    • Edited by SQL-ER Sunday, February 17, 2013 8:46 AM
    Sunday, February 17, 2013 8:46 AM
  • Took me 2 days to get through the gut of Windows and to get it right ;-)  Glad it helped.
    • Edited by SQL-ER Sunday, February 17, 2013 8:48 AM
    Sunday, February 17, 2013 8:47 AM
  • @SQL-ER
    I recently did a new install on my Dell XPS 15 and started getting this error, All of the fixes that I came across did nothing, this however did it. Thanks so much! Keep doing what you are doing!

    • Edited by patkb92 Sunday, February 17, 2013 9:01 PM FIX
    Sunday, February 17, 2013 9:01 PM
  • It helped me too.

    Thank You so very much

    How'd you figure it out, would love to know.

    Tuesday, February 19, 2013 1:59 PM
  • It helped me too.

    Thank You so very much

    How'd you figure it out, would love to know.

    How did I find the solution? I had another laptop which was healthy, and Group Policy Client service was running fine there. When banging my head against the wall trying to fix the issue, I came across the link I posted in my original post. After reading it, it was sort of a light bulb thing - I figured out, that SVCHOST must have missing start-up parameters somewhere. I found from the linked article where those parameters should be. The rest was easy - I just looked what was the keys on a healthy PC and re-created them on the faulty one. The result is documented above ;-)

    Oh, yes, I also checked values on Win 7 Professional and Enterprise PCs, and confirmed that they are all the same.

    What strikes me most is that this issue was out there for at least 3 years (I tracked it back to Vista), and it is wide-spread (I had to post my solution to good dozen of threads in different forums), but no one at Microsoft got to the root cause of it, not mentioning posting a fix.
    • Edited by SQL-ER Monday, February 25, 2013 6:46 PM HTML cleanup
    Monday, February 25, 2013 6:45 PM
  • Thanks so much for sharing, SQL-ER!!  It worked perfectly!  :)  I was going to just give up, since I was only finding solutions that were waaay over my head...but this simple step-by-step sorted it out!  I appreciate it!
    Saturday, March 02, 2013 6:52 PM
  • Double amazing...

    Amazing that you figured it out and amazing that I, with my phobia of modifying the registry, did not mess it up, in spite of your excellent instructions.

    This was driving me nuts, thanks for saving my sanity.

    Saturday, March 16, 2013 3:59 AM
  • This is the funniest reply I got! Thanks! You made my day! :)
    Sunday, March 17, 2013 11:58 PM
  • Thank you SOOOOOOOOOOOOOOOOOO much.  Had this problem start yesterday on a brand new XPS8500 running Win 7 Pro (64) after a failed startup.  Tried other solutions online but nothing helped until this which did it perfectly.

    Thanks again!

    D

    Wednesday, April 10, 2013 3:23 PM
  • Seriously dude, you just won the Internet!!!!

    I'm so glad your post is the first I stumbled over. I found it at 3:30 and a very important customer was coming to pick up a very expensive new laptop at 4:00. This error message would not have gone down well at all.

    SQL-ER, if I knew where your local pub was I'd buy you a pint!

    Thanks again!

    Friday, April 19, 2013 2:42 PM
  • Thx, took me a while to find this solution. It works fine. I had the GPSvcGroup but the Multistring GPSvcGroup was missing. Once added the other users could login again.
    Saturday, April 27, 2013 4:05 PM
  • You sir absolutely ROCK!

    Thank you for this fix. Although I am the only user on my computer so group policy client didn't really affect any function of my rig it is nice to know that i do not have to see that annoying 'failed to connect' message every time I log on.

    Thanks again,

    Nico

    Sunday, May 05, 2013 7:46 PM
  • You are a legend, thanks
    Saturday, May 25, 2013 2:23 PM
  • How do you guys come up with this stuff? Being somewhat conversant with this (which means that when I have a problem, it's one that very few people have had before!), I've come to recognize potential solutions to problems, vs someone who is spouting off some hypothetical "solution."  These forums seem to be so full of these "solutions" that are such a waste of time. People blowing smoke drive me crazy! 

    I just skimmed the BleepingComputer page you mentioned, and it addresses one of the questions that has been in the back of my mind for a long time - the ubiquitous SVCHOST - just WHAT the hell is it actually doing? So I bookmarked it and will need to read it at length.

    At any rate I just got a laptop and had to gut it because it came with Windows 8. The 7 install went OK, but I had the problem to which you posted the solution, and just wanted to say thanks.  Thanks!

    Monday, May 27, 2013 5:18 PM
  • Hey Zlot,

    SVCHOST is designed to run bunch of core processes or services.  I guess, it's more secure this way.  Whatever is ran this way is protected on a very high level.  For example, all the controls for the Group Policy Services Client are grayed out - you can't fiddle with it even if you an admin.  But yes, read the article, it explains a lot. And, I posted how I came up with the solution - had one laptop with the problem and another without.  After reading the article and comparing the registry keys on both computers it became obvious what was missing.

    Hope this helps.

    Monday, May 27, 2013 7:44 PM
  • Thank you SQL-ER.  Worked a treat - Thank goodness people like you post this sort of help
    Thursday, July 18, 2013 1:24 PM
  • Thanks SQL-ER, great job, helped me too.

    For reference, I actually had two more errors that were both caused by the Group Services Client Service issue.

    1) Cannot start the Windows Firewall setting in Control Panel. I clicked on the link and nothing happened.

    2) Cannot change the network discovery and file- and printer sharing settings in the Network and Sharing Center.

    Just thought I post these two symtomps here so that people having those issues (like me) would find the root cause easier.

    Sunday, July 21, 2013 7:08 PM
  • Mic414, thanks for this feedback.  I knew about Windows Firewall cross-issue, but Network Discovery and File/Printer Sharing settings is something new!

    Much appreciated!


    • Edited by SQL-ER Wednesday, July 24, 2013 4:58 AM syntax error
    Wednesday, July 24, 2013 4:57 AM
  • As it seems that SQL-ER you are very goodat this and intelligent.

    I've got another troubling issue for you. I Followed your step-by-step instructions for the "Failure to Start Group Policy Service"  Was very easy to follow.

    But my Issue is that is still is not working, everytime I reboot the computer, it pops up in the corner. This is a fresh install of Windows 7 Pro x64 and it was completely fine until I proceeded with some windows updated after the install. Could that have possibly corrupted something? From my knowledge in the IT field, Which I am in just for the record, and I have never seen this issue.

    If you have any ideas please let me know,

    Thank you, Have a good day.

    Monday, July 29, 2013 2:10 PM
  • Thank you so much,

    I would have never found that myself, worked great !!!

    Thursday, August 01, 2013 12:14 AM
  • I take my hat off for you.....THANK you Sir/Madam...problem solved.
    Sunday, August 11, 2013 5:02 PM
  • A big thank you, great job.
    Friday, September 13, 2013 9:58 AM
  • This did not work for me. I have gone through it twice and watched the video. What do I do?
    Saturday, October 12, 2013 1:34 AM
  • Thank You SQL-ER!  I was battling this for months, and your solution worked perfectly!  I was just about to reinstall, but thought I'de look one more time for a solution!

    Thank You!

    Tuesday, October 15, 2013 5:10 PM
  • Had to post my sincere Thank You as well- I truly appreciate your time spent in finding a resolution to the issue- not a workaround. Plus I have to compliment you on your YouTube video production quality- you did an excellent job of presenting the step-by-step procedure with clarity and the video itself has a nice, polished professional feel to it.

    My hat is off to you for sharing this and your obvious expertise in communicating the information to the broadest range of users, regardless of their technical skill level. If they can read and/or watch, then follow the steps, they will succeed!

    Well done!

    Saturday, November 09, 2013 3:58 PM
  • Nice catch!

    Dave

    Monday, November 18, 2013 10:22 PM
  • Thanks!  This solution worked for me.
    Friday, November 22, 2013 8:06 PM
  • Thank you for your kind words, gcapp99!!!  :)
    Monday, November 25, 2013 8:41 PM
  • This works....! You are a rockstar..
    Thursday, December 19, 2013 6:05 AM
  • Epic thank you, worked like a charm!!
    Monday, December 30, 2013 6:21 AM
  • Make this a "sticky" on the internet somewhere..bailed my ass out..usually I obsess on this stuff for weeks at a time..thankfully found this post early in my search...Awesome dude!!
    Wednesday, January 08, 2014 10:39 PM
  • Cheers SQL-ER helped me out too - think the origins are actually a build issue for me but at least I know now what's missing...

    Thanks must also go to the work on the site you mentioned in the post too:

    http://www.bleepingcomputer.com/tutorials/list-services-running-under-svchostexe-process/#advanced


    Carl Barrett | Twitter: @Mosquat

    Monday, January 13, 2014 9:56 AM
  • Fantastic! 

    This fixed my problem 1st time

    Thanks!

    Monday, January 13, 2014 5:08 PM
  • Hello SQL-ER

    Your instructions say to create two Dword values. The Dword values are 32 bit. Should these be Gword values for a 64 bit system ?

    Edipus

    Monday, January 13, 2014 11:20 PM
  • No, the variable length has nothing to do with the "bittness" of OS. It HAS to be DWORD (i.e. 32 bit) 
    Saturday, January 18, 2014 2:56 AM
  • Thank you SO much for taking the time to figure this out AND post these very detailed instructions! Your fix worked perfectly for me, though I took a shortcut and exported and then imported the GPSvcGroup key from a good system to the bad one rather than making it from scratch.

    I had the exact same problem and your fix took care of the issue. During a reboot after a million updates on a brand new W7 x64 system, the restart seemed to get stuck, and  after 20 minutes I hit the kill switch and rebooted, which is what must have induced the issue. Perhaps I should have waited a whole hour before killing the system, but the HD indicator light was showing nothing but a lazy blink that's a side-effect of polling the optical drive.

    Yet another nasty, sucky problem from a grossly brittle operating system.

    Friday, February 21, 2014 3:21 AM
  • GREAT

    Just installed two laptops with win7-64  , and one had the problem ...

    Adding those missing ( why ? ) registry entries fully solved the problem

    THANKS SOOOO MUCH

    Friday, March 21, 2014 1:23 PM
  • Great solution, even worked on windows 8.1

    Thanks so much!

    Monday, April 28, 2014 8:29 PM
  • Yes, it works on Windows 8.1.  There might be some discrepancies in registry values.  Here is the video I set for Windows 8.1 specifically.

    http://youtu.be/ZUQNVhwVBpY


    • Edited by SQL-ER Thursday, May 01, 2014 5:49 PM
    Thursday, May 01, 2014 5:48 PM
  • Nice one, thank you! I no longer have multiple Windows boxes to compare, so this saved me a lot of hassle.

    I'd love to know what the origin of this broken Windows distribution is. My laptop is Toshiba in case anyone wants to compare notes.

    Cheers,
    Mark

    Monday, May 26, 2014 12:55 PM
  • Thank you, thank you, thank you!!!!  It worked and I know I wouldn't have found the solution in 10^6 years!

    All good things to you!!

    Friday, May 30, 2014 9:00 PM
  • Thanks to SQL-ER, this is "still" the quickest, easiest, best answer!

    As others here will attest - you can spend a lot of time trying to fix this problem

    Tuesday, June 17, 2014 7:40 PM
  • Very nice job finding it AND explaining how to fix it. My thanks to you!!
    Thursday, July 03, 2014 4:26 PM
  • Hi, I am having the same problem with windows client service failed??? I would be so grateful if you could give me some simple instructions, step by step how to correct this problem. I am not too computer savvy and am still learning lots of this computer stuff. I suspect I am "old school" to you. I remember when typewriters were "the thing!" Whatever you could do to help me would be most appreciated. I might need to add that recently I had a local computer repair shop, reinstall my windows 7. I had some kind of problem. The installed 4 disc. I never had this problem until is was fixed? Thank you so much for your time and please, no hurry for my problem. Maybe when you have some spare time, you might could help me out. Thank you so very much.
    Thursday, July 17, 2014 12:59 PM