none
Installing Windows on a GPT disk

    Question

  • Gigabyte Z68A-D3H-B3/Intel i7-2600K/Kingston 4GB*4/Hitachi 500GB HDD and Samsung 2TB.

    GPT: Hitachi 500 GB : 300MB(OEM),90MB(System),128MB(MSR),128GB(Primary- Windows 8),128GB(Primary)

    I have installed windows 8 on the fourth partition with 128 GB and I get error when I try Installing windows 7 professional 64 bit on fifth partition with 128 GB,

    Error when highlighting the partition : "Windows cannot be installed to this disk the selected disk is of the GPT Partition Style"

    Is it possible to push the installer further ??

    Wednesday, September 05, 2012 1:09 PM

Answers

  • Hi,

    Try to burn the ISO image to DVD and install from it. The installation from USB may not successful due to the hardware drivers.


    Tracy Cai

    TechNet Community Support

    • Marked as answer by windlover Monday, September 10, 2012 3:46 PM
    Monday, September 10, 2012 6:39 AM

All replies

  • Wednesday, September 05, 2012 3:54 PM
  • Hi,

    When you start an operating system from a GPT disk, the Extended Firmware Interface (EFI)-based BIOS is required.

    You may refer to the following links:

    Installing Windows 7 on UEFI based computer

    windows cannot be installed on this disk. The selected disk is of the GPT partition style

    Hope it helps.


    Tracy Cai

    TechNet Community Support

    Thursday, September 06, 2012 7:12 AM
  • Hi Tracy ,

    I did unplug my 2TB HDD as I have valuable data. This time I used only the 500GB HDD.

    When I install using MBR , it installs smooth, but when I use GPT I am not able to pass the install screen.

    1. Boot into UEFI: USB with windows 7

    2. At the installation screen pressed Shift+F10 to open command prompt

    3. Used Diskpart

    DISKPART > select disk 0

    DISKPART > clean

    DISKPART > convert gpt

    DISKPART > create partition efi size=100

    DISKPART > format fs=fat32 quick label=system

    DISKPART > create partition msr size=128

    DISKPART > create partition primary size=131072

    DISKPART > format fs=NTFS quick label=C

    DISKPART > assign letter=c

    DISKPART > exit

    exit

    And in the installation screen did an rescan to check the partitions and seems good. but when I highlight the Primary Partition to install i receive the same error.

    "Windows cannot be installed to this disk the selected disk is of the GPT Partition Style"

    But I am successful If I install windows 8


    • Edited by windlover Thursday, September 06, 2012 8:50 AM
    • Marked as answer by windlover Monday, September 10, 2012 3:46 PM
    • Unmarked as answer by windlover Monday, September 10, 2012 3:46 PM
    Thursday, September 06, 2012 8:39 AM
  • Hi,

    Try to burn the ISO image to DVD and install from it. The installation from USB may not successful due to the hardware drivers.


    Tracy Cai

    TechNet Community Support

    • Marked as answer by windlover Monday, September 10, 2012 3:46 PM
    Monday, September 10, 2012 6:39 AM
  • Hi Tracy,

     Hurray, it works like a charm, i never tried this with dvd. i guess was the issue installing from usb hdd. Points on the way.
     Now I have an other issue

     My 500GB Disk is GPT Disk 1

     My 2TB disk is MBR - Disk 0

     I added my 2TB disk and now my 500GB Disk changed its order from Disk 0 to Disk 1. From now on when I install the installation goes fine and when first reboot occurs it throws an error in Boot Manager

    Windows failed to start. A recent hardware or software changes might be the

    cause. To fix the problem

       1. Insert your windows installation disc and restart your computer.

       2. Choose your language settings and then click next

       3. Click "Repair your computer"

    If you do not have this disc, contact your system administrator or computer

    manufacturer for assistance,

    Status: 0xc0000225

    Info: An unexpected error has occured.

    regards



    • Marked as answer by windlover Monday, September 10, 2012 3:42 PM
    • Unmarked as answer by windlover Monday, September 10, 2012 3:46 PM
    • Edited by windlover Tuesday, September 11, 2012 10:26 AM
    Monday, September 10, 2012 3:39 PM
  • Everyone is making this more complex than it really is. At least for Windows Server 2012, just delete all the partitions on the drive and then create using "New". Windows Server 2012 setup will recognize a new drive and format it properly.

    Software Engineer

    Tuesday, June 25, 2013 4:53 PM
  • Nope - deleting the partitions doesn't fix it for me. Deleting the virtual disks on the RAID controller and creating a new one doesn't fix it either.
    Monday, July 01, 2013 5:09 PM
  • You could also try do this:

    Try and backup your files.

    Restart your system and run the windows OS you want to install and when it gets to the screen when it asks you which partition you want to install it to, delete the partitions you had on your hard disk and then click on "New".

    You should have a new partition there now. Windows also should be able to install on that new partition created. I did that and it worked for me.

    Monday, July 15, 2013 7:16 PM
  • What fixed it for me was initializing the virtual disk on the controller. Even a quick initialize was sufficient.
    Monday, July 15, 2013 7:18 PM
  • Had no problems with Gigabyte mobo but ASUS mobo required me to set "Boot Option Priorities" to 1.UEFI-ATAPI DVD, 2.UEFI-USB to curcumvent the GPT error when using USB thumb that contained the Autounattend.xml file for Windows 7 OPK (OEM Preinstallation Kit) installation.

    Friday, August 16, 2013 3:50 AM
  • try this http://www.eightforums.com/tutorials/15458-uefi-bootable-usb-flash-drive-create-windows.html . This way you cand keep all your files from other partitions:)
    Wednesday, May 21, 2014 11:01 AM