none
"Access Denied" to USB external hard disk

    Question

  • I have been using a USB external hard drive for a couple of years on two different computers, running Microsoft XP 32, Vista 64, and Vista 32.  Recently, after copying quite a bit of stuff to the external drive, Vista 32 has started telling me "access denied" when I try to access the USB drive, either from Explorer or from a command prompt.  Chkdsk did not find anything wrong with the drive, but utilities such as icacls don't help, I only get "access denied" with these.  The system seems to have no problem looking at the drive, but at the administrator level it is blocked.  A program called Process Monitor shows that svchost.exe has access to the drive, but EXPLORER.EXE always gets "access denied".  When svchost.exe accesses F: it then does a few things, such as CreateFile, QueryInformationVolume, SetBasicInformation, and FileSystemControl.

    Any ideas about this?
    Saturday, September 05, 2009 9:45 PM

All replies

  • I have a usb jump drive (flash drive, flash stick, whatever you want to call it) that's doing that same thing and it started all the sudden about a week or so ago... But it doesn't do it on all machines, it'll do it on both XP and Vista, but on some PCs of both OSs it will work fine... I've tried chkdsk and virus scans and all looks good...

    I haven't figured out why it does that yet or what changed, but I have found that if you go to windows explorer the drive is displayed as a folder rather than a drive and if you right click and say open it'll ask you for a program to open it with, but it greys out the option to use this program all the time... Then if you browse to explorer.exe it will open the drive and everything is normal until you close that window and then you start over...
    My guess is it's something with either the autorun.exe file on the jump drive or something else in the formatting, but it's also directly related to some sort of setting on the computer...

    Anyone figure it out yet??
    • Proposed as answer by Lloyd Ettinger Friday, September 18, 2009 6:53 PM
    Friday, September 18, 2009 6:47 PM
  • I figured it out... it's not autorun.exe as I stated, it's autorun.ini, but anyway, it doesn't belong there... just delete it and all works fine now...
    Friday, September 18, 2009 6:55 PM
  • I was having the exact "access denied" error on my Win7 64 bit system. 

    • Device Manager was good
    • Computer Management\Disk Management was good
    • Sometimes got luckly and would get access to it, but very rare

    Figured out that it was my ESET NOD32 Smart Security causing the problem.  To fix here is what I did:

    1. Open the NOD32 User Interface (should have icon in system tray in bottom right corner)
    2. Go to Advanced Setup (Setup | Advanced Setup in top right corner)
    3. Expand the following: Antivirus & Antispyware | Real-time file system protection
    4. Go to Advanced Setup
    5. On the right under Removable Media uncheck "Block removable media"

    After that I had immediate access to my USB drive.  If you don't have NOD32 you might have a similar option for blocking removable media in your antivirus software.

    • Proposed as answer by LoyalSoldier Sunday, April 10, 2011 7:37 AM
    Sunday, April 10, 2011 7:36 AM
  • In my instance, the problem was that the Customer received an old/retired work computer running windows XP. The software in place for me was Something called Lumination Endpoint Security. The software would allow a flash drive to install, but not open, even though Disk Management showed the partition as healthy. To manually disable the software check out the support article from the company.

    "

    Disabling the LES Client

    • Modify the following values found in:
      • HKLM\System\CurrentControlSet\Services

    scomc: Start = 4
    sk: Start = 4
    sk-ndis: Start = 4

    • IF PRESENT, delete the value 'sk' in:
      • HKLM\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F}\UpperFilters

    "

    Tuesday, September 17, 2013 8:47 PM