none
Docx file association is set up correctly but does not display Word icon when viewing in Explorer

    Question

  • Problem with MS Word as part of MS Office 2007 Professional Plus running on Windows 7.

    When I view a folder in Windows Explorer all docx files show up with a plain white icon, not a Word icon. I have done the following:

    Start > Control Panel > Default Programs > Associate a file type or protocol with a program.

    Then scrolled down the display and selected the docx extension - it already shows as Microsoft Office Word - clicked on Change Program, reset the program to WordPad, then back in the display clicked on the Change Program icon again. This tiime I reset it to Microsoft Office Word.

    However when I go back into Explorer the icon has not changed. Even if I close it down and restart it again. And even after a reboot.

     

    Also, I have checked the individual properties of the docs files, using Explorer, and they do say Open With Microsoft Word. So no problem there either.

    Any suggestions welcome as to how to change it so the icon displayed is Word not blank.

    Friday, June 11, 2010 10:34 AM

Answers

  • Hello Orchestrand - These icon issues are tricky to track down. I assume it’s only Word and no other icons. Has it been this way since installing Office or did it start recently? Graham was correct to try the Icon Cache steps. As a sanity check can you do the following steps to force a rebuilt of the cache-

    1.     Click - Change Display Settings
    2.     Click – Advanced Settings on the lower left
    3.     Click – List All Modes on the Adapter Tab of the Properties Sheet
    4.     Change to one of the modes with 16-bit listed next to it.
    5.     Click ok until you’re all the way out.

    The steps are only temporary to rebuild the cache.

    Also to rule out a corrupt Profile can you create a new user and logon as the new user?

    Change the resolution mode back after testing:)

    Thanks,

    Ron

    Friday, June 18, 2010 6:20 PM
    Moderator

All replies

  • Try repairing Office from Control Panel | Programs. Select Office 2010 and click Change.
    Simon Jones http://pcpro.co.uk
    Friday, June 11, 2010 11:07 AM
  •  

    Any suggestions welcome as to how to change it so the icon displayed is Word not blank.


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Friday, June 11, 2010 12:44 PM
  • Hi Simon

    Just tried that, rebooted afterwards and unfortunately no change.

     

    Friday, June 11, 2010 12:44 PM
  • Hi Graham

     

    Just had a look at this, thanks. The solution suggests deleting the file IconCache.db and creating a new file called the same. I've not created a db file before, can I just create a text file and rename it or do I have to use MS Access or something?

     

    Friday, June 11, 2010 1:13 PM
  • It should recreate it by itself:
     
    Close all folder windows that are currently open.

    Launch Task Manager using the CTRL+SHIFT+ESC key sequence, or by running taskmgr.exe.

    In the Process tab, right-click on the Explorer.exe process and select End Process.

    Click the End process button when asked for confirmation.

    From the File menu of Task Manager, select New Task (Run�?�)

    Type CMD.EXE, and click OK

    In the Command Prompt window, type the commands one by one and press ENTER after each command:

    CD /d %userprofile%\AppData\Local
    DEL IconCache.db /a
    EXIT

    In Task Manager, click File, select New Task (Run�?�)

    Type EXPLORER.EXE, and click OK.

     

    Hi Graham

     

    Just had a look at this, thanks. The solution suggests deleting the file IconCache.db and creating a new file called the same. I've not created a db file before, can I just create a text file and rename it or do I have to use MS Access or something?

     


    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Friday, June 11, 2010 1:22 PM
  • Thanks again for your suggestion. I did exactly as described above but unfortunately to no avail.
    Friday, June 11, 2010 3:26 PM
  • As I don't have Windows 7 to hand, I am fast running out of suggestions :( The only further suggestion I can think of would be to repair Office - from the Windows 7 add or remove programs applet.
     
    Thanks again for your suggestion. I did exactly as described above but unfortunately to no avail.

    Graham Mayor - Word MVP
    www.gmayor.com
    Posted via the Communities Bridge
    http://communitybridge.codeplex.com/
    Saturday, June 12, 2010 6:32 AM
  • Hi,

    If you have rebuilt icon cache but it still not works, I suggest you try to increase the cache's maximum size. Click Start->Run...and type regedit and press OK to open the Registry Editor.

    Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
    Create a new DWORD called Max Cached Icons and set its value to 2048.
    Restart your machine. Let us know if it helps.

    Monday, June 14, 2010 3:33 AM
  • Hi Jennifer

     

    Just tried this - tried MaxCachedIcons and Max Cached Icons - and unfortunately problem persists.

     

    Thanks anyway,

    O

    • Edited by orchestrand Tuesday, June 15, 2010 1:41 PM tried alternate
    Tuesday, June 15, 2010 9:30 AM
  • Hi Graham

     

    Already tried this as suggested by Simon Jones above. No change unfortunately.

    Thanks anyway,

    O

    Tuesday, June 15, 2010 9:37 AM
  • Hello Orchestrand,

    I've moved this forum to the Windows 7 forum for assistance from the Windows side.  It doesn't sound like a Word\Office issue.

    Thanks,

    Aaron

    Wednesday, June 16, 2010 3:04 PM
  • Hello Orchestrand,

    I'm researching your question and will post a response soon.

    Thanks,

    Ron

    Friday, June 18, 2010 4:15 PM
    Moderator
  • Hello Orchestrand - These icon issues are tricky to track down. I assume it’s only Word and no other icons. Has it been this way since installing Office or did it start recently? Graham was correct to try the Icon Cache steps. As a sanity check can you do the following steps to force a rebuilt of the cache-

    1.     Click - Change Display Settings
    2.     Click – Advanced Settings on the lower left
    3.     Click – List All Modes on the Adapter Tab of the Properties Sheet
    4.     Change to one of the modes with 16-bit listed next to it.
    5.     Click ok until you’re all the way out.

    The steps are only temporary to rebuild the cache.

    Also to rule out a corrupt Profile can you create a new user and logon as the new user?

    Change the resolution mode back after testing:)

    Thanks,

    Ron

    Friday, June 18, 2010 6:20 PM
    Moderator
  • Hi Ron

     

    Been away for a week so apologies for the delayed response.

    Tried the above.  Chaneg to Display Settings made no difference. However I created a second user went into Word, created a doc and sure enough the docx file created shows with the correct icon in Explorer.

    How would you suggest I repair the profile?

     

    O

    Friday, June 25, 2010 3:30 PM
  • I have the exact same problem!

    Did you get it solved somehow?

    • Proposed as answer by ankitanshu Wednesday, July 14, 2010 5:45 PM
    Monday, July 12, 2010 8:04 PM
  • I also faced similar issues with my MS Office 2007. Struggled a whole day with the same, and even tried repairing and finally re-installing MS Office.

    It was a Eureka feeling for me when next morning I tried this one. Very simple but worked for me.

    Right-click on DOCX file and then click on "Open With" --> "Choose Default Program". Select some other editor like MS Works Processor and associate these files with that application. The icons for all DOCX file will change.

    Now, close the file and again right-click on DOCX file and hen click on "Open With" --> "Choose Default Program". This time choose MS Word 2007. The things will come back to normal.

    • Proposed as answer by ankitanshu Wednesday, July 14, 2010 5:51 PM
    Wednesday, July 14, 2010 5:51 PM
  • Hi orchestrand,

    I have the same problem as you and after searching for a day for a definitive solution, i have found this one that works on another forum located here: http://www.sevenforums.com/tutorials/49819-icon-cache-rebuild.html

    The reason seems to be that icons stored have for some reason disappeared (inexplicably?). The solution is also stupidly simple after i've tried every suggestion in this thread.

    1) go to start menu and search for: cmd

    2) right click on cmd and choose "run as administrator" (--> this causes command line to change from C:\users\<account name> to change to: C:\windows\system32).

    3) turn off everything you are doing after saving your work because now you will be closing explorer.exe

    4) in the command line enter each command separately and with enter following each line

     

    • taskkill /IM explorer.exe /F
    • CD /d %userprofile%\AppData\Local
    • DEL IconCache.db /a
    • shutdown /r

     

    5) after the restart, everything should be back to normal.

     

    This is a complete fix for the problem and not a work around and I can verify that it worked for me. Good luck all.

    also, this is a repost, but i think we have the same problem

    Sunday, November 28, 2010 2:10 AM
  • I just started experiencing this problem today and I could kiss you right now because your solution worked perfectly! Sometimes the simplest solution is the best one obviously :DDDDDD
    Tuesday, November 15, 2011 1:29 PM
  • I also faced similar issues with my MS Office 2007. Struggled a whole day with the same, and even tried repairing and finally re-installing MS Office.

    It was a Eureka feeling for me when next morning I tried this one. Very simple but worked for me.

    Right-click on DOCX file and then click on "Open With" --> "Choose Default Program". Select some other editor like MS Works Processor and associate these files with that application. The icons for all DOCX file will change.

    Now, close the file and again right-click on DOCX file and hen click on "Open With" --> "Choose Default Program". This time choose MS Word 2007. The things will come back to normal.

    THIS WORKS! I was having the same problem then I tried this solution and it worked like magic
    Thursday, December 01, 2011 3:16 AM
  • Hi coefficients, an error is shown: "The process "explorer.exe " don't found"

    I have still the problem.

     

    Thank you

    Friday, December 16, 2011 1:19 PM
  • Ankitanshu - THANK YOU! You are a genius :D

    I was having the same problem and it was fixed right away after following your advice. Thankyouthankyou :)
    Wednesday, February 29, 2012 6:36 AM
  • To those who are still suffering from the problem, you must have noticed that when you right click on the desktop or windows explorer and point to New, there's no Microsoft Word Document option. First you need to correct this. Please follow the steps mentioned here in the answer by Tony :  http://answers.microsoft.com/en-us/windows/forum/windows_vista-files/right-click-menu-in-explorer-desktop-missing-new/f0244fe4-216b-459c-b48f-a3d0396b6b11?tm=1321295233864

    After following the above steps, right click on your .docx file, then Open With, then Choose default program and then click on Microsoft Word.

    After following the above two steps, I was not only able to bring the icon back but also add Microsoft Word option to the New functionality.

    • Proposed as answer by Ajitesh14 Friday, May 18, 2012 6:56 AM
    Friday, May 18, 2012 6:56 AM
  • Thanks Ankit, worked for me today !
    • Proposed as answer by techh3ad Saturday, July 14, 2012 10:05 PM
    • Unproposed as answer by techh3ad Saturday, July 14, 2012 10:05 PM
    Thursday, June 21, 2012 10:52 PM
  • I've seen this on many computers already, but this is related to the lawsuit that MS lost to I4i and it relates to DOCX or other files that have custom XML in the code. Look at it as MS being bitter about the lawsuit and now slapping I4i in the face by saying "we won't even recognize DOCX files anymore.
    Saturday, July 14, 2012 10:10 PM
  • Sorry, but that is completely wrong.

    The I4i patent case related to one small part of Word's functionality and only in the USA. Microsoft have not stopped recognising DOCX files. DOCX files are at the heart of Word 2007 and 2010 and will continue to be so in Word 2013.

    Using the Open With... command, rebuilding the icon cache or setting Max Cached Icons in the registry - all detailed elsewhere in this thread have all proven effective cures.


    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Sunday, July 15, 2012 8:11 AM
  • Thanks Ajitesh14, that did the job for me when everything else above failed!
    Wednesday, July 18, 2012 4:07 AM
  • I know about Windows XP and 7 would be having a similar way...

    1. My Computer(Computer in Win7)

    2. Tools option

    3. Folder options

    4. File Types Tab

    5. Select your extention(say eg:- DOCX)

    6. Advanced

    7. Change icon

    8. Select path and icon.Eg:- In my case - it is

    C:\WINDOWS\Installer\{90140000-0011-0000-0000-0000000FF1CE}\wordicon.exe

    (4th line,2nd icon)

    Monday, July 30, 2012 3:45 PM
  • AMEN. After several days of searching and trying all the recommendations above this one in this thread, the simple fix from WSWUVikings WORKED for me !! Hooray.
    Monday, August 20, 2012 7:09 PM
  • Guys, I solved this problem by following the steps below:

    1st thing you could do before installing Microsoft Office:

    You were supposed to remove Older/Related Versions and software of Microsoft Office.(This makes conflict after installing Microsoft Office)

    2nd

    Go to C:\Users\<your username here>\AppData\Local

    there should be an hidden file called IconCache,delete it.(To see this file,you must go to folder options and enable

    option to view hidden files.)

    IconChache file may be corrupted,delet it...Then restart computer the new fresh file of IconCache will be created with new fresh icons)

    If this didn't solve your problem,

    Then, run the Microsoft Office Diagnostics (it is found in start menu in programs in Microsoft Office folder)

    Follow the instructions to complete diagnostics.

    After diagnostics is done,

    (If your default .docx program is other than Microsoft Office)Select any .docx file type, right click and click properties.

    Then click change after right side of Opens With:

    Select Microsoft Office Word.

    (If your default .docx program is Microsoft Office):

    1)Select any .docx file type, right click and click properties.

    Then click change after right side of Opens With:

    Select Word Pad(or any other .docx supporting program)

    2)Again, folllow these steps here:

    Select any .docx file type, right click and click properties.

    Then click change after right side of Opens With:

    Select Microsoft Office Word again.

    That's all...This should solve your probelm

    Thanks

    Regards

    Asrar Bashir Sunge

    Saturday, June 29, 2013 6:57 PM
  • Cheers - this worked for me (ankitanshu's post above). :)

    Had exactly the same problem as described (also with the whole "displays fine for a different user"). I find the problem relates to installing OpenOffice.


    • Edited by MisterCrow Wednesday, August 14, 2013 2:28 PM
    Wednesday, August 14, 2013 2:27 PM
  • I tried everything else that seemed logical. The process above worked!

    Thanks!

    Friday, August 16, 2013 5:51 PM
  • I had this same issue ... I tried all the registry changes, Office repair option, and other suggestions offered by users on various help sites and spent several days playing with it.  In the end it seemed to be an issue with some updates.  I ended up completely uninstalling Office 2007 from my computer and reinstalling it from scratch.  This set the icons back to the way they were.  Since then I have not been installing any of the Office updates I receive.  I hope this helps.
    Wednesday, November 06, 2013 6:22 PM
  • In order to fix this problem, go to "Start", then click "Default Programs", then click "Associate a file type or protocol with a program", then locate the ".docx" file in the list and click on the file, then click on "Change Program", then click the program called "Microsoft Open XML Converter". This should totally fix the problem. I had this exact same problem and this method worked for me. I hope this helps!

    • Proposed as answer by Natural Ice Monday, June 16, 2014 2:11 AM
    • Edited by Natural Ice Monday, June 16, 2014 2:14 AM Updates
    Monday, June 16, 2014 2:10 AM