none
Western Digital Elements 1023 - Problem in Opening and Formatting

    Question

  • Hi All,

    I have a Western Digital Elements 1023 portable drive with 500 GB of memory. When I plug it in into my PC the Windows detected the external hard drive and successfully installed the drivers. However when trying to open the drive the windows explorer is Not Responding. I have tried checking it in Disk Management but still the same problem occur, the Disk Management window is Not Responding.

    Please help me with this guys.

    Thanks,

    Monday, February 10, 2014 5:21 PM

Answers

  • Hi,

    Do you get any error while open the hard drive?
    Have you tired to test the hard drive on another computer?

    Based on your description, it should be a driver issue. Please download and install the lastest USB driver from the motherboard manufacturer website.

    Also, in my opinion, it's better to make sure the power supply is enough before connecting it, and test in different USB ports.

    I also would like to suggest you contact Western Digital support for more information as Rick Dee mentioned.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support



    Tuesday, February 11, 2014 6:06 AM

All replies

  • Suggest you go to the Western Digital Community forum for assistance: http://community.wd.com/t5/WD-Portable-Drives/bd-p/BoardExample2

    I see lots of discussion over there related to your problem..

     

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, February 10, 2014 9:19 PM
  • Hi,

    Do you get any error while open the hard drive?
    Have you tired to test the hard drive on another computer?

    Based on your description, it should be a driver issue. Please download and install the lastest USB driver from the motherboard manufacturer website.

    Also, in my opinion, it's better to make sure the power supply is enough before connecting it, and test in different USB ports.

    I also would like to suggest you contact Western Digital support for more information as Rick Dee mentioned.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support



    Tuesday, February 11, 2014 6:06 AM