none
Disabling the "Close programs to prevent information loss" dialog in Vista

    Question

  • I am running Vista x64 with 4GB of RAM without a pagefile for better perfomance. Everytime my memory consumption goes over 75 percent I get a dialog box saying i need to close programs to prevent information loss. I am aware of the consequences of disabling that warning, but I would still like to know how to do so. I have searched everywhere and could not find any information at all.

    Thursday, August 14, 2008 8:06 AM

Answers

  •  

    I finally figured out how to get rid of the dialog box.

     

    The way to do this is to prevent the Diagnostics service from loading RADAR which consists of 2 DLL files, radardt.dll and radarrs.dll.

     

    I just took ownership of and deleted:

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\WDI\DiagnosticModules\{5EE64AFB-398D-4edb-AF71-3B830219ABF7}]

     

    and

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\WDI\DiagnosticModules\{45DE1EA9-10BC-4f96-9B21-4B6B83DBF476}]


    and


    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WDI\DiagnosticModules\{C0F51D84-11B9-4e74-B083-99F11BA2DB0A}]

    and rebooted.

    Now Windows isn't monitoring my virtual memory anymore!

    • Edited by MoralPanik Tuesday, January 13, 2009 7:57 AM
    Sunday, August 17, 2008 4:25 PM

All replies

  •  

    Hi,

     

    To do this, try the method below:

     

    Control Panel -> Problem Reports and Solutions -> Check settings -> Advanced settings. Choose “Off” under “For my programs, problem reporting is:” and click OK.

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Friday, August 15, 2008 4:04 AM
    Moderator
  •  

    I have already done that, and it does not solve the problem. All this setting does in my case is disable the "Send information to Microsoft" dialog when a program crashes. What I want to disable is the Low virtual memory warning dialog when free memory drops under 25 percent.

     

    (Or even better change the warning threshold value)

     

    Thanks anyway for your reply.

    Friday, August 15, 2008 5:58 AM
  •  

    Hi,

     

    To resolve the “Virtual memory is too low” issue, you can refer to the following articles:

     

    http://unlockforus.blogspot.com/2007/10/unlockme-low-memory-warning-on-windows.html

    http://www.troublefixers.com/fix-virtual-memory-too-low-warning-trouble-in-win-xp/

     

    If the issue persists after trying the suggestions in the articles above, I suggest trying to perform a check disk and disk defragmenter.

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Friday, August 15, 2008 6:37 AM
    Moderator
  •  

    Thanks for your response Tim, but that is not the answer I am looking for.

     

    I have chosen to completety disable the pagefile for several reasons, and I already know that I am getting this message because my system is "running out of memory" when I have too many programs open.

     

    But, is 1024mb free out of the 4gigs not enough for Windows to function properly? I dont think so, because i usually just press cancel on the dialog box, and successfuly continue firing up programs without any other errors until I get to 100% comsumption, at which point the whole system just crashes, a situation I make sure never happens, of course.

     

    The warning log entry in Event Viewer comes from "Microsoft-Resource-Exhaustion-Detector". Is there a way to tell Microsoft-Resource-Exhaustion-Detector not to warn me at all when the resources are low?

    Or only warn me when my I get down to 256mb or 128mb maybe, instead of 1024mb?

     

    I am thinking maybe I asked the question in the wrong forum; if so, could you please redirect me to the right place?

     

    Thanks again for your help,

    Mike

    Friday, August 15, 2008 7:05 AM
  •  

    Hi Mike,

     

    Have you tried to check disk and disk defragmenter?

     

    For more information about this message, please refer to the following article:

    http://aumha.org/win5/a/xpvm.htm

     

    I am afraid we do not have a way to specially disable this message. If you prefer to do so, you can try the following method. However, after doing so, all icons in the system try will disappear.

     

    1.    Locate the following registry key:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer

    2. Create a DWORD value called NoTrayItemsDisplay and set its value to 1.

     

    3.    Log off and log on your account.

     

    Hope it helps.

     

    Tim Quan - MSFT

     

     

    Friday, August 15, 2008 8:03 AM
    Moderator
  • As I mentioned in my first post, I am running Vista x64. What I am getting is a dialog box that suggests me to close some of my running programs or cancel. It is not the tray icon that bugs me, it is the dialog box that comes with it.

     

    I wish it were only the little yellow triangle in the tray, then I would not be looking so hard for a solution.

    Friday, August 15, 2008 8:22 AM
  •  

    Hi Mike,

     

    Thank you for the reply.

     

    Now I would like to confirm if you are trying to disable the dialog like “the program needs to be closed" when a program crashes or the dialog like “Virtual memory is too low”?

     

    I look forward to hearing from you.

     

    Tim Quan - MSFT

     

    Friday, August 15, 2008 10:23 AM
    Moderator
  • The dialog box says:

    __________________________________________________

    Close programs to prevent information

    loss.

     

    Your computer is low on memory. Save your files and

    close these programs:

     

    (Name of program(s))

                                             

                                                {Close program}    {Cancel}

     

    Windows will only close enough programs to restore needed

    memory.

    __________________________________________________

     

     

     

    This box pops up when I still have 1024mb of memory left in my case; so I press cancel and continue my work until it appears again and I press cancel again etc...

     

    PS. I was purposely running windows with the pagefile disabled.

     

    I have uploaded a screenshot of the dialog here http://rapidshare.com/files/137575511/warning.jpg.html

    Friday, August 15, 2008 5:38 PM
  •  

    I finally figured out how to get rid of the dialog box.

     

    The way to do this is to prevent the Diagnostics service from loading RADAR which consists of 2 DLL files, radardt.dll and radarrs.dll.

     

    I just took ownership of and deleted:

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\WDI\DiagnosticModules\{5EE64AFB-398D-4edb-AF71-3B830219ABF7}]

     

    and

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\WDI\DiagnosticModules\{45DE1EA9-10BC-4f96-9B21-4B6B83DBF476}]


    and


    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WDI\DiagnosticModules\{C0F51D84-11B9-4e74-B083-99F11BA2DB0A}]

    and rebooted.

    Now Windows isn't monitoring my virtual memory anymore!

    • Edited by MoralPanik Tuesday, January 13, 2009 7:57 AM
    Sunday, August 17, 2008 4:25 PM
  • Hi,

     

    Thank you for sharing your solution.

     

    Tim Quan - MSFT

     

    Monday, August 18, 2008 1:33 AM
    Moderator
  •  

    Tim,

     

    Do you mean to say you know of a way to disable that other dialog box?

    I'm talking about the "Close program" box which shows up when a program has crashed.

    Problem Reporting is off, and I would like the program to crash without Vista telling the user it did.

     

    Any help is appreciated. Thanks.

     

    Kjetil Larsen
    Monday, September 01, 2008 12:15 PM
  • Dear,

    I also would like to get of this dialog:

     

    The instruction "xxx" referenced memory at "xx"

    Click OK to terminate the program

    Click Cancel to debug the program

     

    I have an automated process and in this process, sometimes one of the programs crashes. This blocks the entire process, until somebody presses OK. Instead, the this dialog should not be presented and the process should continue. My logs files indicate later on what has happened and only that specific part needs to be restarted. Right now it is very frustrating: the process takes in total 12 hours, but after one hour it is already blocking. And I cannot look every hour on that computer. Anybody an idea how to do this? I'd REALLY appreciate a solution and I could not find any on the net.

    Wednesday, September 10, 2008 10:56 AM
  • MoralPanik's solution resolves the popup but its not the ideal solution,
    I want to have the popup, but just not at the default 80% of memory.
    If you have 8GB  or even 4GB  the remaining 20% (1,6GB, 800MB) allow a lot of programs to be loaded with no problems.
    Has anyone find out how too change the treshold?
    Friday, October 31, 2008 5:17 PM